Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: clubex on 2013/06/19, 14:35:09

Title: No audio devices detected ~(udev/modporbe failure)
Post by: clubex on 2013/06/19, 14:35:09
After yesterday's du (which included an upgraded kernel) and  rebooting the terminal hung at "waiting for dev to be fully populated..." until it eventually timed out. As the boot continued I saw a brief message something about udev and a modprobe failure. It went too fast for me to get any more data and I have no logs on that early part of the system initiation.

At the desktop the "do you want to permanently remove these devices" dialoge was displayed which indicated that no audio devices had been detected.

The above also happens with older kernels and it doesn't appear to be a hardware problem as the audio devices are all detected by an older version of siduction and also with a live CD.

Anyone have ideas how to get my audio devices detected and any explanation for the udev and the modprobe failure?

Code: [Select]

inxi -F
System:    Host: westfield Kernel: 3.9-6.towo.1-siduction-amd64 x86_64 (64 bit)
           Desktop: KDE 4.10.4 Distro: sidux 2008-04 Πόντος - kde-lite - (200812222256)
Machine:   Mobo: ASUSTeK model: M2N68-AM Plus version: Rev X.0x Bios: American Megatrends version: 1002 date: 11/19/2009
CPU:       Dual core AMD Athlon II X2 240 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm)
           Clock Speeds: 1: 2812.641 MHz 2: 2812.641 MHz
Graphics:  Card: NVIDIA GF119 [GeForce GT 520] X.Org: 1.12.4 driver: nvidia Resolution: 1680x1050@59.9hz
           GLX Renderer: GeForce GT 520/PCIe/SSE2 GLX Version: 4.3.0 NVIDIA 319.23
Audio:     Card-1: NVIDIA MCP61 High Definition Audio Sound: ALSA ver: k3.9-6.towo.1-siduction-amd64
           Card-2: NVIDIA GF119 HDMI Audio Controller
Network:   Card: NVIDIA MCP61 Ethernet driver: forcedeth
           IF: eth1 state: up speed: 100 Mbps duplex: full mac: e0:cb:4e:3a:d8:e4
Drives:    HDD Total Size: 250.1GB (48.2% used) 1: id: /dev/sda model: WDC_WD2500AAJB size: 250.1GB
Partition: ID: / size: 15G used: 12G (86%) fs: ext3 ID: /home size: 214G used: 101G (50%) fs: ext3
           ID: swap-1 size: 1.05GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 36.0C mobo: 32.0C
           Fan Speeds (in rpm): cpu: 3183 sys-1: 1510
Info:      Processes: 139 Uptime: 25 min Memory: 1048.6/3959.8MB Client: Shell inxi: 1.8.4
Title: No audio devices detected ~(udev/modporbe failure)
Post by: hsp on 2013/06/19, 16:07:07
apt-get purge oss-compat if installed and reboot helps

Title: No audio devices detected ~(udev/modporbe failure)
Post by: gcp on 2013/06/19, 16:15:24
I can confirm this problem described above.
Downgrading initramfs-tools and oss-compat does not help.

In my case, i added snd-hda-intel to /etc/modules and have sound again.

But the ~1min Boot-delay remains. "waiting for dev to be fully populated..."

I am running pure debian sid.

Edit: purging oss-compat solved the problem.
 :D
Title: No audio devices detected ~(udev/modporbe failure)
Post by: clubex on 2013/06/19, 16:51:02
Thanks hsp & gcp:
I tried both your suggestions and happily the audio devices have once again been detected and function correctly. Also the delay at waiting for dev is reduced to about 2 or 3 seconds.

Thanks once again to you both.

ps if a moderator thinks this topic is not an upgrade warning then please feel free to move it to the appropriate section of the forum.
Title: No audio devices detected ~(udev/modporbe failure)
Post by: dibl on 2013/06/19, 17:12:18
Strange -- after installing the new kernel 3.9-6.towo.1, and rebooting, the system came up with no sound, and no audio devices except the connected USB webcam.  aplay -l showed no sound card.  dmesg showed many many errors of all kinds.

So I rebooted to watch messages, and the second time the system came up perfectly with no errors, and sound is working perfectly.  dmesg shows no errors, and only a couple of old ACPI warnings that don't mean anything.

Poltergeist!
Title: No audio devices detected ~(udev/modporbe failure)
Post by: DeepDayze on 2013/06/22, 04:45:21
Found a bug report that could be related to the issue

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=660803
Title: No audio devices detected ~(udev/modporbe failure)
Post by: Smon on 2013/06/22, 11:42:15
Same problem here yesterday. I backup up everything in /etc/modprobe.d and then deleted all in there. Now it is working.
Title: No audio devices detected ~(udev/modporbe failure)
Post by: gilpier on 2013/06/22, 16:50:36
Smon, I follow your suggestion, and now it seems that everything is working. Is there some problem with empty /etc/modprobe.d ?

Thanks,

Gilbert
Title: No audio devices detected ~(udev/modporbe failure)
Post by: gilpier on 2013/06/22, 17:23:25
I restore everything inside /etc/modprobe.d and remove only alsa-base.conf.
Now it is working well. It seems that the problem is in module alsa-base.conf.
Title: fixed in package oss-compat
Post by: musca on 2013/06/25, 12:32:11
Issue is fixed with oss-compat 3 in debian unstable main.

cheers!
musca
Title: RE: fixed in package oss-compat
Post by: clubex on 2013/06/25, 14:06:11
Thanks musca
Title: RE: fixed in package oss-compat
Post by: michaa7 on 2013/06/25, 15:02:11
Are you sure it is solved?

During boot udev is now waiting (half a minute or more, was a fraction of a second before) for being populated. Then an error message appears which I can't read because the boot process is going on rapidly.

I don't know what might not work here and can't investigate further now (as I have to leave for some hours) but something seems still wrong with udev (fully updated half an hour ago).
Title: RE: fixed in package oss-compat
Post by: DeepDayze on 2013/06/25, 15:56:33
If you don't have any applications that only recognize OSS or you have a recent sound card you shouldn't need oss-compat, right?
Title: Re: RE: fixed in package oss-compat
Post by: dibl on 2013/06/25, 16:18:55
Quote from: "DeepDayze"
If you don't have any applications that only recognize OSS or you have a recent sound card you shouldn't need oss-compat, right?


Logically, that would seem correct, but do an rdepends on oss-compat and you will be surprised.  I removed it some time ago, but it's back -- obviously it gets pulled in by other packages.
Title: Re: RE: fixed in package oss-compat
Post by: DeepDayze on 2013/06/25, 16:57:24
Quote from: "dibl"
Quote from: "DeepDayze"
If you don't have any applications that only recognize OSS or you have a recent sound card you shouldn't need oss-compat, right?


Logically, that would seem correct, but do an rdepends on oss-compat and you will be surprised.  I removed it some time ago, but it's back -- obviously it gets pulled in by other packages.

I would think oss-compat should be a recommends not a dependency for such apps. Oss-compat is totally broken on my system as well
Title: Re: RE: fixed in package oss-compat
Post by: michaa7 on 2013/06/25, 20:40:27
No sound. It seems your salvation is my misfunction :-( .

The error message during boot says:
udev [473] /sbin/modprobe -b pci.000<very>

And no soundcard detected (my nifty mixer application didn't start).
Title: RE: Re: RE: fixed in package oss-compat
Post by: towo on 2013/06/25, 20:41:37
is oss-compat still installed?
Title: RE: Re: RE: fixed in package oss-compat
Post by: michaa7 on 2013/06/25, 20:50:11
Yes, oss-compat is installed. It was updatet to version 3, but downgrading it to version 2 (testing) does not solve the problem. Uninstalling it isn't a real option as my mixer application (wmmixer) and some other applications like notedit depend on it.

Any other option?

BTW: I now discoverd an other error message during boot stating something like 'alsa restore' failed and alsa coudn't find a soundcard :-(
Title: Re: RE: fixed in package oss-compat
Post by: Lanzi on 2013/06/25, 20:56:39
A simple dist-upgrade changes nothing here...
No sound and lots of "Audio hardware removeed - Audio Geräte wurden entfernt"

Should I try this (from gilpier)?

Quote

I restore everything inside /etc/modprobe.d and remove only alsa-base.conf.
Now it is working well. It seems that the problem is in module alsa-base.conf.

Title: solution: Re: RE: fixed in package oss-compat
Post by: michaa7 on 2013/06/25, 21:11:50
Saving away oss-compat.conf
Code: [Select]
# mv /etc/modprobe.d/oss-compat.conf /etc/modprobe.d/oss-compat.conf.saveis a workaround. In essence it's the same as uninstalling oss-compat, exept you do not loose some applications, but they won't work now.

So not a real solution but a temporary workaround as now the soundcard is found and works (unfortunatly here without my preferred mixer).


EDIT://
Here the solution is as follows:
- remove/save away /etc/modprobe.d/oss-compat.conf
- then install oss-compat 2
(apt-get install oss-compat/testing)

This will create a working oss-compat.conf which is different from the one created by version 3. Reinstalling the testing version without beforehand manually removing the oss-compat.conf created by version 3 didn't work here (see above)!

Now my oss-compat depending mixer is working again.
Title: solution: Re: RE: fixed in package oss-compat
Post by: Lanzi on 2013/06/25, 23:19:09
seems to work, even without mixer...
Thanks so far!
Title: Re: solution: Re: RE: fixed in package oss-compat
Post by: DeepDayze on 2013/06/26, 00:54:02
Quote from: "michaa7"
Saving away oss-compat.conf
Code: [Select]
# mv /etc/modprobe.d/oss-compat.conf /etc/modprobe.d/oss-compat.conf.saveis a workaround. In essence it's the same as uninstalling oss-compat, exept you do not loose some applications, but they won't work now.

So not a real solution but a temporary workaround as now the soundcard is found and works (unfortunatly here without my preferred mixer).


EDIT://
Here the solution is as follows:
- remove/save away /etc/modprobe.d/oss-compat.conf
- then install oss-compat 2
(apt-get install oss-compat/testing)

This will create a working oss-compat.conf which is different from the one created by version 3. Reinstalling the testing version without beforehand manually removing the oss-compat.conf created by version 3 didn't work here (see above)!

Now my oss-compat depending mixer is working again.


Ok then once we do that should we put oss-compat on hold to prevent oss-compat 3 from installing (at least till the issues with it are fixed)
Title: solution: Re: RE: fixed in package oss-compat
Post by: ralul on 2013/06/26, 00:54:41
My aptitude output shows me nothing worth to install oss-compat:
some old child games, some french text-to-speech etc
Title: Re: solution: Re: RE: fixed in package oss-compat
Post by: DeepDayze on 2013/06/26, 01:01:24
Quote from: "ralul"
My aptitude output shows me nothing worth to install oss-compat:
some old child games, some french text-to-speech etc


Yes,  but there are a few audio mixer apps that still depend on it. Hopefully some people could badger the apps' developers to change things so that oss-compat is just a recommends as its main use is to allow some old sound hardware and apps that are not alsa-aware to still work with latest alsa
Title: Re: solution: Re: RE: fixed in package oss-compat
Post by: michaa7 on 2013/06/26, 10:47:27
Quote from: "DeepDayze"
... Ok then once we do that should we put oss-compat on hold to prevent oss-compat 3 from installing (at least till the issues with it are fixed)


*I* do. But I'm not sure it's a solution for everyone (musca claimed oss-compat 3 to be the solution, which for me is the problem). But I am thinking about filing a bug report.

Quote from: "ralul"
My aptitude output shows me nothing worth to install oss-compat:
some old child games, some french text-to-speech etc


What about wmmixer under fluxbox or notedit?
Title: Alternatives for notedit
Post by: musca on 2013/06/26, 13:59:06
hello michaa7,
oss is deprecated and as you now see it is badly maintained.

notedit after a long discussion was removed from debian more than two years ago.
see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=560079
There are canorus and nted packaged in debian.

cheers!
musca
Title: Re: Alternatives for notedit
Post by: michaa7 on 2013/06/26, 14:11:20
Quote from: "musca"
hello michaa7,
oss is deprecated and as you now see it is badly maintained.

notedit after a long discussion was removed from debian more than two years ago.
see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=560079
There are canorus and nted packaged in debian.

cheers!
musca


Neither nted nor canorus is a full replacement of notedit and my wmmixer simply is the best (=small and handy) mixer in Debian.
So I need oss-compat (but wasn't aware of until yesterday ).

How is oss-compat 3 a solution for you if you don't need it?
Title: Re: Alternatives for notedit
Post by: musca on 2013/06/26, 14:44:43
I checked its changelog, and it closes bug #660803.
But indeed it is no solution, i admit.

musca
Title: RE: Re: Alternatives for notedit
Post by: DeepDayze on 2013/06/26, 16:28:58
Perhaps some one should open a new bug report referencing the old one and stating that the oss-compat 3 version still has issues that need further investigation
Title: RE: Re: Alternatives for notedit
Post by: dibl on 2013/06/28, 18:28:14
I thought of opening a new thread -- but this may be a related problem.  My main desktop system is now booting without the snd_hda_intel module loaded.  But I can modprobe it, then I have sound.  The only thing I can think of that might have caused this is, yesterday I upgraded the systemd packages, which were previously on hold.

Code: [Select]
don@imerabox:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
don@imerabox:~$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
05:00.1 Audio device: NVIDIA Corporation GF100 High Definition Audio Controller (rev a1)
don@imerabox:~$ lsmod | grep snd
snd_usb_audio          98706  1
snd_usbmidi_lib        15422  1 snd_usb_audio
snd_hwdep               5309  1 snd_usb_audio
snd_pcm_oss            30216  0
snd_mixer_oss          12246  1 snd_pcm_oss
snd_pcm                61237  2 snd_pcm_oss,snd_usb_audio
snd_page_alloc          6170  1 snd_pcm
snd_seq_oss            34021  1
snd_seq_midi_event      4532  1 snd_seq_oss
snd_rawmidi            15610  1 snd_usbmidi_lib
snd_seq                41713  2 snd_seq_midi_event,snd_seq_oss
snd_seq_device          4601  3 snd_seq,snd_rawmidi,snd_seq_oss
snd_timer              15473  2 snd_pcm,snd_seq
snd                    49520  13 snd_pcm_oss,snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_usbmidi_lib,snd_seq_oss,snd_seq_device,snd_mixer_oss
soundcore               4370  1 snd
usbcore               129729  9 uhci_hcd,snd_usb_audio,snd_usbmidi_lib,ehci_hcd,ehci_pci,gspca_main,usbhid,gspca_zc3xx,xhci_hcd
don@imerabox:~$ su
Password:
root@imerabox:/home/don# modprobe snd_hda_intel
root@imerabox:/home/don# aplay -l
**** List of PLAYBACK Hardware Devices ****
Invalid MIT-MAGIC-COOKIE-1 keyxcb_connection_has_error() returned true
card 0: Intel [HDA Intel], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
root@imerabox:/home/don#


dmesg does not show any detection of the audio chip during boot.

Are any of the other systemd systems having this issue?
Title: RE: Re: Alternatives for notedit
Post by: michaa7 on 2013/06/28, 19:05:12
see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=660803

I provided the info he asked me (he gave me a different email addresse so it does not show up in the mailing list). It really seems hda-intel related.
Title: RE: Re: Alternatives for notedit
Post by: dibl on 2013/06/28, 19:18:57
Thanks michaa7.
Title: RE: Re: Alternatives for notedit
Post by: michaa7 on 2013/06/28, 20:27:56
... but it seems there is more going on:
https://lkml.org/lkml/2013/6/28/460
Title: Re: RE: Re: Alternatives for notedit
Post by: dibl on 2013/06/28, 21:10:08
Quote from: "michaa7"
... but it seems there is more going on:
https://lkml.org/lkml/2013/6/28/460


Yep, that looks like my issue, exactly.  Looks like time to wait, and not to mess with configuration of anything.
Title: Re: RE: Re: Alternatives for notedit
Post by: Lanzi on 2013/07/01, 01:08:04
Waiting seems the best option.

on my system I got:

Code: [Select]

apt-get remove oss-compat -s

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  libwine-oss:i386 oss-compat
0 aktualisiert, 0 neu installiert, 2 zu entfernen und 14 nicht aktualisiert.
Remv libwine-oss:i386 [1.4.1-4]
Remv oss-compat [2]


Since I need wine, I think I have to wait. But no problem, sound is working.
Title: RE: Re: RE: Re: Alternatives for notedit
Post by: piper on 2013/07/01, 01:23:02
Yes, I too need wine.

My sound is also working, system, games, wine games, mythtv, etc.

For me, no need to remove if not broke ;)