Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: timc on 2013/07/03, 16:21:23

Title: 3.10 kernel - system freezes prior to login [Solved]
Post by: timc on 2013/07/03, 16:21:23
Since upgrading to kernel 3.10, when the Slim login screen is displayed, keyboard input is not accepted. Therefore, I cannot enter my username. I can enable the keyboard F Lock, but I cannot escape to a console with Ctrl-Alt-F1. I have to use the hardware reset button to reboot. The problem is repeatable, I have tried it at least four times.

It is a USB keyboard. I see no error messages during bootup.

If I boot to kernel 3.9.8, everything works, again.

Tim
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: timc on 2013/07/03, 21:13:06
I still need help with this, please.

Tim
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: towo on 2013/07/03, 21:22:24
I'm not able to reproduce your problem.
But, without further infos and relevant logfiles, no on will be able to help you.
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: timc on 2013/07/03, 22:50:41
More info:

I uninstalled 3.10 kernel and headers. I rebooted. I reinstalled them.

The first time I rebooted into the reinstalled 3.10, I was able to log in to the LXDE desktop, start a terminal, and run "free -m". But the next command I tried to enter, the keyboard was frozen, again.

I rebooted again, and things were just as before - I could not even type into the userid box of Slim. Then I rebooted into kernel 3.9-8, and everything is good.

I am still searching all the stuff in /var/log, but I still have not found anything that appears relevant. Maybe it is freezing so fast that nothing is being logged.

Tim
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: dibl on 2013/07/03, 23:17:31
LXDE/slim on a netbook is working fine with kernel 3.10 -- the problem must be in the USB or device ID domain.
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: timc on 2013/07/04, 00:18:22
dibl, thanks and, yes, I have verified that the problem is not with Slim or LXDE. I turned off Slim and booted to a text console. It still froze.

The fact remains that everything has been fine until the 3.10 kernel. 3.9-8 is still ok.

Thanks,
Tim

PS - I have edited the thread title to reflect that the problem is not Slim or LXDE
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: timc on 2013/07/04, 00:30:00
I find something about a firmware CYPRESS_uvd.bin and a CONFIG_EXTRA_FIRMWARE for the kernel build, but I have no idea what to do with them.

http://www.gossamer-threads.com/lists/linux/kernel/1730956

Tim
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: timc on 2013/07/04, 00:47:25
YES!

I watched the bootup messages very carefully. Very early in the messages, there is a message that says "cannot load CYPRESS_uvd.bin".

Is this something I can fix, or does the kernel need to be patched?

Tim

http://www.gossamer-threads.com/lists/linux/kernel/1741214?page=last

http://comments.gmane.org/gmane.linux.kernel/1519452
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: towo on 2013/07/04, 11:01:36
Download the firmware here:
http://people.freedesktop.org/~agd5f/radeon_ucode/
and put it to /lib/firmware/radeon/
Maybe it helps.
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: timc on 2013/07/04, 16:35:43
Thanks, towo, but now the symptoms are somewhat different and I get different error messages. The system still freezes. It is now as described in this report:

http://www.gossamer-threads.com/lists/linux/kernel/1741214

Tim

PS - I am adding CEDAR_rlc.bin, but it did not help the guy in the report.
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: timc on 2013/07/04, 20:12:27
towo, I have copied every firmware .bin file from http://people.freedesktop.org/~agd5f/radeon_ucode/ to my /lib/firmware/radeon

I no longer get any error messages during the boot process, and the boot now runs very fast. However, when the Slim login screen is displayed, the system is frozen.

Thank you for trying to help. I hope this problem will become resolved from upstream as time passes. In the meantime, I will continue to use kernel 3.9-8
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: timc on 2013/07/05, 23:09:26
A very small bit more of info:

I can successfully boot to runlevel 1 with kernel 3.10. I can login as root and run various commands. Of course, at that point, everything is ok and there are no problems to be found.

If I then "telinit 2 && exit", several more operations are done, then the system freezes, again.

Tim
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: belze on 2013/07/06, 00:26:50
i can't boot with 3.10
i use systemd
Code: [Select]
inxi -v 3
System:    Host: siductionbox Kernel: 3.9-8.towo-siduction-amd64 x86_64 (64 bit, gcc: 4.7.3)
           Desktop: KDE 4.10.4 (Qt 4.8.5) Distro: siduction 13.1.0 Firestarter - kde - (201305211844)
Machine:   System: Acer product: Aspire 4810T version: V2.35
           Mobo: Acer model: Aspire 4810T Bios: INSYDE version: V2.35 date: 04/13/2010
CPU:       Dual core Intel Core2 Duo CPU U9400 (-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 5585.98
           Clock Speeds: 1: 1401.00 MHz 2: 800.00 MHz
Graphics:  Card-1: Intel Mobile 4 Series Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: Advanced Micro Devices [AMD/ATI] RV710/M92 [Mobility Radeon HD 4330/4350/4550] bus-ID: 01:00.0
           X.Org: 1.12.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express GLX Version: 2.1 Mesa 9.1.3 Direct Rendering: Yes
Network:   Card-1: Intel WiFi Link 5100 driver: iwlwifi ver: in-tree: bus-ID: 03:00.0
           IF: wlan0 state: up mac: 00:22:fb:6b:e7:8c
           Card-2: Qualcomm Atheros AR8131 Gigabit Ethernet driver: atl1c ver: 1.0.1.1-NAPI port: 3000 bus-ID: 02:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:1f:16:ae:80:53
Drives:    HDD Total Size: 320.1GB (29.2% used) 1: model: Hitachi_HTS54503
Info:      Processes: 194 Uptime: 2:31 Memory: 2203.0/2947.7MB Runlevel: 5 Gcc sys: 4.8.1
           Client: Shell (bash 4.2.45) inxi: 1.9.11

i can only boot wuth previous kernels. Where can i found useful infos for you? i tried to look in /var/log and i did not found anything
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: timc on 2013/07/06, 15:09:59
Here's another link I found about the problem:

http://www.mail-archive.com/dri-devel@lists.freedesktop.org/msg39390.html

Tim
Title: RE: 3.10 kernel and Slim - no keyboard
Post by: timc on 2013/07/08, 14:49:04
This entire thread has been barking up the wrong tree.

On a hunch, I blacklisted module rt2800pci. Now things seem to be running well with kernel 3.10. Without wireless LAN, of course.

I will try to fix the wireless problem. If I need to, I will start a new thread on that,

Tim