Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: seasons on 2013/08/15, 15:45:13

Title: libwebkitgtk-1.0.0 (amd64)
Post by: seasons on 2013/08/15, 15:45:13
This morning, I found that the upgrade of libwebkitgtk-1.0-0 (to 2.0.4-2) depends on libglib2.0 >= 2.37.x, which is in experimental at the moment. Obviously, this causes issues if you want to upgrade.
Title: RE: libwebkitgtk-1.0.0 (amd64)
Post by: piper on 2013/08/15, 16:50:45
Code: [Select]
The following packages will be REMOVED:
  bluefish gvfs-backends libgoa-1.0-0 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 miro python-webkit zenity
The following packages will be upgraded:
  libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libvdpau1 libwebkitgtk-1.0-common libwebkitgtk-3.0-common x11-utils
6 upgraded, 0 newly installed, 8 to remove and 0 not upgraded.
Need to get 5,094 kB of archives.
After this operation, 50.7 MB disk space will be freed.

using -s
Code: [Select]
The following packages will be REMOVED:
  bluefish gvfs-backends libgoa-1.0-0 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 miro python-webkit zenity
The following packages will be upgraded:
  libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libvdpau1 libwebkitgtk-1.0-common libwebkitgtk-3.0-common x11-utils
6 upgraded, 0 newly installed, 8 to remove and 0 not upgraded.
Remv bluefish [2.2.4-2]
Remv gvfs-backends [1.16.3-1]
Remv libgoa-1.0-0 [3.8.2-1]
Remv miro [4.0.4-1]
Remv python-webkit [1.1.8-3]
Remv libwebkitgtk-1.0-0 [1.8.1-4]
Remv zenity [3.8.0-1]
Remv libwebkitgtk-3.0-0 [1.8.1-4]
Inst libvdpau1 [0.6-2] (0.7-1 Debian:unstable [amd64])
Inst libjavascriptcoregtk-1.0-0 [1.8.1-4] (2.0.4-2 Debian:unstable [amd64])
Inst libjavascriptcoregtk-3.0-0 [1.8.1-4] (2.0.4-2 Debian:unstable [amd64])
Inst libwebkitgtk-1.0-common [1.8.1-4] (2.0.4-2 Debian:unstable [all])
Inst libwebkitgtk-3.0-common [1.8.1-4] (2.0.4-2 Debian:unstable [all])
Inst x11-utils [7.7~1] (7.7+1 Debian:unstable [amd64])
Conf libvdpau1 (0.7-1 Debian:unstable [amd64])
Conf libjavascriptcoregtk-1.0-0 (2.0.4-2 Debian:unstable [amd64])
Conf libjavascriptcoregtk-3.0-0 (2.0.4-2 Debian:unstable [amd64])
Conf libwebkitgtk-1.0-common (2.0.4-2 Debian:unstable [all])
Conf libwebkitgtk-3.0-common (2.0.4-2 Debian:unstable [all])
Conf x11-utils (7.7+1 Debian:unstable [amd64])
Title: RE: libwebkitgtk-1.0.0 (amd64)
Post by: clubex on 2013/08/15, 22:56:19
It will also remove gimp and some other gimp related packages. At the moment I (and expect some others) can't allow that so I will have to wait for a fix.
Title: RE: libwebkitgtk-1.0.0 (amd64)
Post by: clubex on 2013/08/15, 23:10:07
...and 5 minutes after my above post a new apt-get update shows the removals no longer occur!
Title: Re: RE: libwebkitgtk-1.0.0 (amd64)
Post by: Santa on 2013/08/15, 23:27:18
Quote from: "clubex"
...and 5 minutes after my above post a new apt-get update shows the removals no longer occur!


Yep, I was about to say we have fixed this in fixes/.