Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: vilde on 2013/11/29, 12:19:12

Title: Spellchecking in smf
Post by: vilde on 2013/11/29, 12:19:12
The spell-checking in iceweasel and this forum is not working.  When I write here the spell is checked as the wrong spelled words will be underlined with red but when right-clicking on the mouse there is no spell-checker options at all. This is only happening in this forum, everywhere else it is working.
Title: Re: Spellchecking in smf
Post by: GoinEasy9 on 2013/11/29, 21:52:55
I also noticed that spell checking wasn't working.  Misspelled words get underlined, but, there's no way to see correct choices, no action on right click.
Title: Re: Spellchecking in smf
Post by: melmarker on 2013/11/30, 03:06:51
Hmm - have you tried other smf-forums?

(http://i.imgur.com/wYn0w59.jpg) (http://i.imgur.com/wYn0w59.jpg) - works with chromium
Title: Re: Spellchecking in smf
Post by: GoinEasy9 on 2013/11/30, 03:21:24
Interesting, it works on Chrome, but not Firefox/Iceweasel.  Same on my Fedora 19 install also.  Can there be a config somewhere that needs to be changed?
Title: Re: Spellchecking in smf
Post by: melmarker on 2013/11/30, 03:38:24
Aunty Google knows what to do - I've installed a few packages on the server, according to http://www.simplemachines.org/community/index.php?topic=469224.0

Until today i never used a spell checker in firefox so i had to install the english dictionary - but it seems to work now. The server packages in detail are:

Code: [Select]
The following NEW packages will be installed:
 aspell aspell-am aspell-ar aspell-bg aspell-bn aspell-br aspell-ca aspell-cs
 aspell-cy aspell-da aspell-de aspell-el aspell-en aspell-eo  aspell-es aspell-et
 aspell-fa aspell-fi aspell-fo aspell-fr aspell-ga aspell-gu aspell-he aspell-hi
 aspell-hr aspell-hu aspell-hy aspell-is  aspell-it aspell-kk aspell-kn aspell-ku
 aspell-lt aspell-lv aspell-ml aspell-mr aspell-nl aspell-no aspell-or aspell-pa
 aspell-pl aspell-pt  aspell-pt-br aspell-pt-pt aspell-ro aspell-ru aspell-sk
 aspell-sl aspell-sv aspell-ta aspell-te aspell-tl aspell-uk aspell-uz 
 dictionaries-common libaspell15 php5-pspell spellutils

(http://i.imgur.com/f5J9Xql.jpg) (http://i.imgur.com/f5J9Xql.jpg)

btw - this is my pimped firefox
Title: Re: Spellchecking in smf
Post by: vilde on 2013/11/30, 11:17:12
I don't think I'm a member of another smf forum so I can't check that.

After installing aspell, php5-pspell spellutils the spell-checking is still not working. If I right-click on a red underlined word I still not see any spell-check dialog in the pop up menu. If I right-click on an empty space beside the text there will be options to spell-check or not and to choose language.

There are also other issues with the right click menu and it's related to the spell-check problem.

Right-clicking in the empty space in the text frame sometimes but not always get the right menu up and this is the menu that always shall come up in a text frame.  Right-clicking on a word always get the wrong menu up.

The menus are in Swedish, but I think you will get the point anyway.
Title: Re: Spellchecking in smf
Post by: piper on 2013/12/01, 17:20:34
I have no problems with spell checking, works great

Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131201030203 CSet: 84a5a5800bd3

You could try and close iceweasel/firefox and in terminal do

Code: [Select]
iceweasel -P iceweasel -no-remote %u
or, if running firefox

Code: [Select]
firefox -P firefox -no-remote %u

The "-no-remote" clears up the multiple instance/already running problem.

The "-P iceweasel" will cause a profile dialog to popup upon first launching iceweasel/firefox.

At that point choose the option to create a new profile and see if spell checking works

The above output will also let you run multiple instance's of iceweasel/firefox
Title: Re: Spellchecking in smf
Post by: vilde on 2014/04/07, 23:50:36
I want to tell that after a clean installation,  with iceweasel-l10-sv-se installed and locales set to swedish my spellchecker is still not working as it shall in this forum, this is th only forum that it's not working in. It's behaving as I described before.

The spellcheck is sort of working but when right-clicking on a wrong-spelled word (red underlined) the wrong dialog comes up.