Siduction Forum

BUGS => Bugs 2013.2 RC1 (DE/EN) => Topic started by: pjnsmb on 2013/12/24, 07:50:48

Title: sidu-installer will not start -Xfce-amd64
Post by: pjnsmb on 2013/12/24, 07:50:48
Hallo


I have tried a usb stick, and a dvd burned with  'burniso' from the same iso with a correct md5sum .


The chromium web browser is working fine in live mode.


When I try to start the sidu-installer,on both methods, I get the same web page details showing :



Server: BaseHTTP/0.3 Python/2.7.6
Date: Tue, 24 Dec 2013 06:29:03 GMT
Content-Type: text/html
Connection: close


<html>
<head>
<title>Error response</title>
<head>
<body>
<h1>Error response</h1>
<p>Error code 500
<p>Message:

Server error in /autopart
Traceback (most recent call last):
  File "/usr/share/pywwetha/source/pywwetha.py", line 699, in do_it
    self.handleDjinn(method, config)
  File "/usr/share/pywwetha/source/pywwetha.py", line 671, in handleDjinn
    response = application.__call__(self._wsgiEnvironment, self.startResponse)
  File "/usr/share/pywwetha/djinn/wsgihandler.py", line 120, in __call__
    rc = self.handle(application, docRoot, startResponse)
  File "/usr/share/pywwetha/djinn/wsgihandler.py", line 94, in handle
    rc = handler.__call__(self._request)
  File "/usr/share/sidu-installer/installer/views.py", line 61, in autopart
    rc = handlePage(AutoPartPage(session), request, session)
  File "/usr/share/sidu-installer/isource/autopartpage.py", line 25, in __init__
    self._diskInfo = DiskInfoPage(self)
  File "/usr/share/sidu-installer/isource/diskinfopage.py", line 131, in __init__
    self.importPartitionInfo()
  File "/usr/share/sidu-installer/isource/diskinfopage.py", line 292, in importPartitionInfo
    info += date
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe1 in position 16: ordinal not in range(128)



</body>
</html>


I have tried using the desktop icon and from the applications menu with the same result.


Is it possible to progress with this error showing ?



Title: Re: sidu-installer will not start -Xfce-amd64
Post by: devil on 2013/12/24, 08:14:37
Does cli-installer work?
I never saw this output before, will send the traceback to the guy who last worked on the installer.


greetz
devil
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: melmarker on 2013/12/24, 08:54:44
try in the terminal

Code: [Select]
sidu-installer-control start
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: pjnsmb on 2013/12/24, 09:13:33
sorry for the delay guys


just been installing using the cli-installer method which has worked ok..............


never stop learning , it's the first time I have used this way  :)


thanks
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: vilde on 2013/12/25, 18:31:53
 Just confirming that I get the same error. Installing xfce to an old T60, the graphical installer makes the same fault as below, doesn't matter how you start it. cli-installer works as su.
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: melmarker on 2013/12/25, 18:41:03
another time: this may be happend with older machines - timing problems with the autostart i think - please try to start the installer with:

Code: [Select]
sidu-installer-control start

and please - give feedback, if it work
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: vilde on 2013/12/25, 21:31:17
another time: this may be happend with older machines - timing problems with the autostart i think - please try to start the installer with:

Code: [Select]
sidu-installer-control start

and please - give feedback, if it work

@melmarker,  That's what I meant with " doesn't matter how you start it" The above command will start the graphical installer exactly as clicking on the desktop-icon. After clicking "next" the first time I will come to terminal window with the same or similar message as pjnsmb. To be clear, I don't know about pjnsmb but the installer window start and it's after first click on "next" as the problem hit me.
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: melmarker on 2013/12/25, 21:45:47
ok - understood :)
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: vilde on 2013/12/25, 21:55:37
Just for checking i tried the same again on the T60 and on two other laptops, and I can't reproduce the bug, the installer just works now!!! I used the same usb-stick with xfce 32 bit and tried several times on the T60 and one time each on the two others! The only difference I can think of is that the battery charge was close to zero when I did the first faulty tests but AC power was on.
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: melmarker on 2013/12/25, 22:41:30
it can be a timing problem or some kind of black magic - can you check please the Language Settings on these computers - it may be, that this can help us.
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: vilde on 2013/12/25, 22:48:21
it can be a timing problem or some kind of black magic - can you check please the Language Settings on these computers - it may be, that this can help us.
How do you mean that I shall try?
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: melmarker on 2013/12/25, 23:01:25
Quote
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe1 in position 16: ordinal not in range(128)
it may be, that two of your computers have different language settings than the third - knowing that would help a lot - we are currently searching for one or two f***ing letters, umlauts or such things - which are displayed or handled correct with other language sets - maybe a historical overcome or simply a typo :)
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: vilde on 2013/12/25, 23:14:49
First, the problem has gone also on the T60 where I had the problem. Where is the language setting in the computer?

Language setting is only in the os on the usb-stick or the hard-disk?

I used the default language us-english and swedish keyboard when the fault ocured. 

Sorry for the spelling but spell-checking is still not working for me on this forum, (another thrad about that)
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: unklarer on 2013/12/26, 10:40:41
Entschuldigt bitte, wenn ich hier auf deutsch schreibe!

Ich habe exakt den hier beschriebenen Fehler beim Versuch der LXDEx86_64 Installation.
Auch der Aufruf des Installer mit dem Befehl von melmarker im Terminal hat dieses Ergebnis.

Der Computer (Desktop) stammt ursprünglich aus England und die Bios-Spracheinstellung ist ENGLISCH.
Weitere Sprachen wären japanisch / chinesisch (?). Das Bios ist ein Ami-Bios mit Build-Date 02/23/09
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: melmarker on 2013/12/26, 11:52:02
Es sind keine Entschuldigungen notwendig, Informationen sind in jeder Sprache gewünsch - ok, in kisuaheli, japanisch, burmesisch vielleicht nicht so eingängig - aber wichtig. Für den Rest gibt es den google Translator. Danke, ich hoffe, es hilft, diesen heisenbug einzugrenzen.
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: hamatoma on 2014/01/01, 12:20:10
The reason of the error is a character set problem. Some info of the disk (e.g. partition label...) contains at least one non ASCII char, which cannot changed to UNICODE.
Therefore this error occurs on some systems, on other not.
This error will be repaired.


Dieser Fehler kommt dadurch, dass mindestens ein Nicht-ASCII-Zeichen in der Diskinfo (z.B. Partitions-Label) vorkommt, und dieses nicht nach UNICODE konvertiert werden kann.
Daher tritt der Fehler in manchen Systemen auf, in anderen nicht.

Title: Re: sidu-installer will not start -Xfce-amd64
Post by: unklarer on 2014/01/01, 18:42:50
@hamatoma
Thanks for the info.
What can I do to correct the mistake?
(In the meantime, he is being treated in 3 places here in the forum)

Danke für die Info.
Was kann ich zur Behebung des Fehler tun?
(In der Zwischenzeit wird er an 3 Stellen hier im Forum behandelt)
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: devil on 2014/01/01, 19:59:17
If this affects you, you can only use cli-installer or wait for a fixed iso (gonna be some days)


greetz
devil
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: melmarker on 2014/01/01, 22:24:16
@unklarer and @all: Don't use f***ing umlauts in any label or name until this issue is fixed - this hint applies to all languages with characters other then ascii
Title: Re: sidu-installer will not start -Xfce-amd64
Post by: hamatoma on 2014/01/02, 16:24:24
The error is corrected in version 2014.01.01

Code: [Select]
apt-get update ; apt-get install sidu-installer

Command to ensure the version:
Code: [Select]
apt-cache policy sidu-installer