Siduction Forum

BUGS => Bugs 2013.2 (DE/EN) => Topic started by: sunrat on 2014/01/11, 06:15:15

Title: network-manager
Post by: sunrat on 2014/01/11, 06:15:15
Not sure if this is a bug or just my faulty methodology.
I have Atheros wireless, so installed firmware-atheros from a USB drive and configured network in the live session with network-manager. Then updated sidu-installer and installed.
After installation and re-entering pass key to n-m, I was online with Iceweasel. Dropped to RL3 to do dist-upgrade and no connection. I reconfigured with Ceni and purged n-m (don't need it, static desktop) and installed Knemo for monitoring. Connection OK now.
Is network-manager supposed to configure global network or does it just work for user space as I experienced? If I configured with Ceni first, would n-m still work?

ps. December installed 4 days ago now and running beautifully after a few personal tweaks. Best OS I have used! Thanks.
Title: Re: network-manager
Post by: ayla on 2014/01/11, 08:02:57
Hi,

you may use nmcli if you need a network connection in runlevel 3. See
Code: [Select]
man nmcli.

You may use ceni or networkmanager, you can't use both at the same time.

To do a dist-upgrade you may download only first, then go to runlevel 3 and d-u. Following steps:

open root terminal:

Quote
apt-get upgrade update
apt-get dist-upgrade -d
init 3 # or whatever the systemd command now is...
then on runlevel 3
Code: [Select]
apt-get dist-upgrade
normally you dont need a network connection on runlevel 3 then.

Maybe related:
http://chili.siduction.org/issues/1459 (http://chili.siduction.org/issues/1459)

greets
ayla[/code]
Title: Re: network-manager
Post by: sunrat on 2014/01/11, 09:20:57
Maybe related:
http://chili.siduction.org/issues/1459 (http://chili.siduction.org/issues/1459)
Yes.
I am happy now anyway without network-manager but not happy without runlevel 3 networking.
Definitely a bug.
I will use the method of download then switch to RL3 to dist-upgrade for now.

Thanks ayla.
Title: Re: network-manager
Post by: sunrat on 2014/01/11, 13:04:14
I just read your post again. The first line here should be "update" not "upgrade".
Title: Re: network-manager
Post by: ayla on 2014/01/11, 13:09:58
you're right of course.

Code: [Select]
apt-get update
apt-get dist-upgrade -d
init 3 # or whatever the systemd command now is..
apt-get dist-upgrade

Edited original post.
Title: Re: network-manager
Post by: sunrat on 2014/01/11, 14:48:07
 :)
Removed quote from my previous post to avoid confusion.
Title: Re: network-manager
Post by: unklarer on 2014/01/12, 12:23:12
Dieses Verhalten habe ich bei "december 2013.2 rqt" installiert
am 10.01.2014 um 22.07 Uhr auch.

Die "december 2013.2 lxde" installiert am 03.01.2014 um 10.53 Uhr hat das nicht.

Bei beiden Installationen wurde vorher

Code: [Select]
apt-get install sidu-base && sidu-installer
gemacht.
Die netzwerk Verbindung ist weg, wenn in die init 3 Umgebung
gewechselt wird. (systemctl isolate multi-user.target)

Erst nach einem Neustart ist sie wieder ok.
Im Moment helfe ich mir mit der Option -d.

Google-Translate:
This behavior I "2013.2 december rqt" installed aton 10.01.2014 at 22.07 clock also.

The "december 2013.2 lxde" installed on 03.01.2014 at 10.53 clock does not.

In both installations was previously

Code: [Select]
apt-get install sidu-base && sidu-installer
made.
The network connection is gone when in init 3 Environmentis changed. (systemctl isolate multi-user.target)

Only after a restart it is ok again.
At the moment I'm helping me with the  -d option.
Title: Re: network-manager
Post by: dibl on 2014/01/12, 13:39:52

The network connection is gone when in init 3 Environmentis changed. (systemctl isolate multi-user.target)


Try


Code: [Select]
systemctl stop lightdm



Quote
Only after a restart it is ok again.


Try


Code: [Select]
ifup eth0

(or wlan0, etc.)


I have also seen this issue with a KDE/KDM system.
Title: Re: network-manager
Post by: unklarer on 2014/01/12, 20:32:52

Hello dibl,


thanks for your tips.
It works.


Nevertheless, it is not answered, why lxde slim used and there are
no problems.
Razor uses lightdm and it does not work with the d-u.   ???
Title: Re: network-manager
Post by: dibl on 2014/01/12, 23:38:53
My LXDE installation is an older one (Riders or Desperado) and slim is used on that one.  We know that LXDE and Razor QT will be merged in the future, and Razor QT has been using lightdm.  The siduction devs have indicated that lightdm is the display manager of choice for the future, as KDM is being slowly abandoned (and bloated), so the movement is towards lightdm on all non-gnome flavors, I believe.


I do not know whether the random disconnection of networking under "systemctl isolate multi-user.target" is because my siduction installations were originally with sysvinit, or not.  But I have checked the remaining processes after issuing "systemctl stop xxxdm" and there are no user or X server processes remaining -- it seems a safe way to do the d-u and I have been using it for quite a few months now with no issues. 
Title: Re: network-manager
Post by: sunrat on 2014/01/14, 10:25:17
Try

Code: [Select]
systemctl stop lightdm

This seems to work well. Thanks.
Title: Re: network-manager
Post by: MaxStone on 2014/10/28, 10:28:31
Hi guys,

I noted a strange behavior, when I switch to "init 3" , only the eth0 go down, while wlan0 remain up.

this happens in more than 1 laptop with Razor-qt (now lxqt ).

Why?

Regards

Massimo
Title: Re: network-manager
Post by: hendrikL on 2014/10/28, 10:53:57
hi.
@MaxStone

Quote
I noted a strange behavior, when I switch to "init 3" , only the eth0 go down, while wlan0 remain up


which connection was/is up while you change to the multi-user-target (init 3)?
Is wlan0 up and eth0 down?
Is there a switch configured to automaticly switch between eth0/wlan0, aka if networkcable connected; then eth0 up; if not; eth0 down and wlan0 up?.


And why should a aktiv connection go down if someone switch to init 3?
The network should be up also in int 3!
For example, you make a dist-upgrade in init 3, and have apt-listbugs/changes enabled, if the network is down you will get an error message,
and for shure there are more scenarios where you need an online connection in int 3.


greetz hendrikL
Title: Re: network-manager
Post by: MaxStone on 2014/10/28, 12:16:21
Hi hendrikL,

I have perfomed more tests and I see that the behavior is this:

-if the laptop is using eth0 (no wlan0 in use), the command init 3, put down the interface eth0. 
-if the laptop is using wlan0 (no eth0), the command init 3, leave the wlan0 up and running without any problem.

I have 2 laptop and both work in this way

regards
Massimo

Title: Re: network-manager
Post by: hendrikL on 2014/10/29, 11:09:39
mh,
at the moment i have no time to test this.

Do you use systemd as init system?
If you dont know, or wait, provide us the output of
Code: [Select]
inxi -xI
If you use systemd, you can search for ifup@eth0.service and ifup@wlan0.service.
First in grafical.target (init5) then after switching to multi-user.target (init 3), then after ifup eth0 (in init 3).

good luck

edit: do you use NM for to connect to the world?
Or, how did you set up your network?

edit part 2:
First: an ifup@eth0.service does not exist on my system, so i gues also not on yours!
An ifup@wlan0.service exist, this could be a left over.
When i had the same trouble with wlan0 i wrote myself an ifup@wlan0.service, because i was tiered about
to type every time ifup wlan0 when switching to rl 3.

Well, ok,  i have tested it, wlan0 down, eth0 up, switched to multi-user.target (init 3), eth0 still working.

So we need more informations from you.
We lost our world wide funtional crystal ball, so i/we can't debug your problem.


btw. i do not use NM.
Title: Re: network-manager
Post by: MaxStone on 2014/10/29, 23:01:10
Code: [Select]
root@sidbox1:~# inxi -xI
Info:      Processes: 153 Uptime: 2:19 Memory: 496.2/3895.1MB Init: systemd runlevel: 5 Gcc sys: 4.9.1
           Client: Shell (bash 4.3.301) inxi: 2.2.15



I remenber that I configure my networks interfaces first time with CENI (ETH0 dhcp and WLAN0 in roam-mode)

this is all my service on systemd

Code: [Select]
root@sidbox1:~# find /etc/ -name *service
/etc/systemd/system/sysinit.target.wants/lvm2-monitor.service
/etc/systemd/system/sysinit.target.wants/resolvconf.service
/etc/systemd/system/getty.target.wants/getty@tty1.service
/etc/systemd/system/dbus-org.freedesktop.Avahi.service
/etc/systemd/system/syslog.service
/etc/systemd/system/bluetooth.target.wants/bluetooth.service
/etc/systemd/system/multi-user.target.wants/ModemManager.service
/etc/systemd/system/multi-user.target.wants/ssh.service
/etc/systemd/system/multi-user.target.wants/inetd.service
/etc/systemd/system/multi-user.target.wants/avahi-daemon.service
/etc/systemd/system/multi-user.target.wants/dns-clean.service
/etc/systemd/system/multi-user.target.wants/anacron.service
/etc/systemd/system/multi-user.target.wants/pywwetha.service
/etc/systemd/system/multi-user.target.wants/cron.service
/etc/systemd/system/multi-user.target.wants/redsocks.service
/etc/systemd/system/multi-user.target.wants/sidu-base.service
/etc/systemd/system/multi-user.target.wants/pppd-dns.service
/etc/systemd/system/multi-user.target.wants/rsyslog.service
/etc/systemd/system/multi-user.target.wants/lm-sensors.service
/etc/systemd/system/dbus-org.freedesktop.ModemManager1.service
/etc/systemd/system/printer.target.wants/cups.service
/etc/systemd/system/local-fs.target.wants/lvm2-activation-early.service
/etc/systemd/system/local-fs.target.wants/lvm2-activation.service
/etc/systemd/system/dbus-org.bluez.service
/etc/systemd/system/display-manager.service
/etc/systemd/system/sshd.service
/etc/avahi/services/udisks.service
root@sidbox1:~#


And this my interfaces conf file:

Code: [Select]
root@sidbox1:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp

allow-auto wlan0
iface wlan0 inet manual
        wpa-roam /etc/wpa_supplicant/wpa-roam.conf

allow-hotplug eth1
iface eth1 inet dhcp

iface default inet dhcp




tell me what other info you need.

Regards
and thanks for your kindly reply

Massimo
Title: Re: network-manager
Post by: absolut on 2014/10/29, 23:41:09
if i am not mistaken, the /etc/network/interfaces file, when using network-manager, should contain only the loopback interface... at least, this is the case on all my computers with network-manager handling all the network devices:

Code: [Select]
# The loopback network interface
auto lo
iface lo inet loopback

and note the /etc/systemd/system/dbus-org.freedesktop.NetworkManager.service line in the following:
Code: [Select]
host:# find /etc/ -name *.service
/etc/systemd/system/display-manager.service
/etc/systemd/system/sshd.service
/etc/systemd/system/dbus-org.freedesktop.ModemManager1.service
/etc/systemd/system/dbus-org.freedesktop.Avahi.service
/etc/systemd/system/dbus-org.freedesktop.nm-dispatcher.service
/etc/systemd/system/multi-user.target.wants/pppd-dns.service
/etc/systemd/system/multi-user.target.wants/ssh.service
/etc/systemd/system/multi-user.target.wants/NetworkManager.service
/etc/systemd/system/multi-user.target.wants/dns-clean.service
/etc/systemd/system/multi-user.target.wants/anacron.service
/etc/systemd/system/multi-user.target.wants/cron.service
/etc/systemd/system/multi-user.target.wants/cups-browsed.service
/etc/systemd/system/multi-user.target.wants/vnstat.service
/etc/systemd/system/multi-user.target.wants/smartd.service
/etc/systemd/system/multi-user.target.wants/avahi-daemon.service
/etc/systemd/system/multi-user.target.wants/sidu-base.service
/etc/systemd/system/multi-user.target.wants/ModemManager.service
/etc/systemd/system/multi-user.target.wants/lm-sensors.service
/etc/systemd/system/multi-user.target.wants/pywwetha.service
/etc/systemd/system/printer.target.wants/cups.service
/etc/systemd/system/getty.target.wants/getty@tty1.service
/etc/systemd/system/dbus-org.freedesktop.NetworkManager.service
/etc/systemd/system/sysinit.target.wants/resolvconf.service
/etc/avahi/services/udisks.service
Title: Re: network-manager
Post by: MaxStone on 2014/10/30, 14:31:08
I apologise with all, after your kindly reply I think that I posted this problem not in the correct thread.

my laptop was installes  using razor-qt version .iso, who by default not use network-manager I think at this point


the system have only ceni installed
Code: [Select]

massimo@sidbox1:~$ sudo su -
root@sidbox1:~# dpkg -l | grep ceni
ii  ceni                                                      2014.10.12                             all          Curses interface to /etc/network/interfaces
root@sidbox1:~# dpkg -l | grep network-manager
root@sidbox1:~#


Now please tell me if I need to open another discussion on this behavior.

Regards
Massimo