Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: terroreek on 2014/09/25, 05:35:37

Title: (sovled) Warning X breakage
Post by: terroreek on 2014/09/25, 05:35:37
Hi all,

heads up I just performed the updates from today, please see below it looks like Wayland is being pushed, down, this maybe because of a gnome 3.14 thing but lightdm refuses to start.  Still looking into it but heads up.

Code: [Select]
The following NEW packages will be installed:
  libblas-common libprocps4 xwayland
The following packages have been kept back:
  freerdp-x11 libfreerdp-plugins-standard
The following packages will be upgraded:
  adwaita-icon-theme aisleriot apache2-bin baobab bash bind9-host
  cheese-common cups-pdf curl dconf-cli dconf-editor dconf-gsettings-backend
  dconf-service dconf-tools dictionaries-common distro-defaults dnsutils eog
  ethtool evince evince-common file-roller four-in-a-row gcalctool gcr gedit
  gedit-common gir1.2-caribou-1.0 gir1.2-clutter-1.0 gir1.2-evince-3.0
  gir1.2-freedesktop gir1.2-gck-1 gir1.2-gcr-3 gir1.2-gdesktopenums-3.0
  gir1.2-glib-2.0 gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0
  gir1.2-grilo-0.2 gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0
  gir1.2-gtk-3.0 gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0
  gir1.2-gweather-3.0 gir1.2-mutter-3.0 gir1.2-nautilus-3.0
  gir1.2-networkmanager-1.0 gir1.2-peas-1.0 gir1.2-soup-2.4 git git-man
  glib-networking glib-networking-common glib-networking-services
  gnome-backgrounds gnome-bluetooth gnome-calculator gnome-control-center
  gnome-control-center-data gnome-desktop3-data gnome-dictionary gnome-keyring
  gnome-logs gnome-mines gnome-nibbles gnome-online-accounts
  gnome-power-manager gnome-robots gnome-screenshot gnome-session
  gnome-session-bin gnome-session-common gnome-settings-daemon gnome-shell
  gnome-shell-common gnome-system-monitor gnome-themes-standard
  gnome-themes-standard-data gnome-tweak-tool gnome-user-guide
  gnome-user-share google-chrome-unstable grilo-plugins-0.2
  gsettings-desktop-schemas gstreamer1.0-libav gstreamer1.0-plugins-bad
  gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x gucharmap
  gvfs gvfs-backends gvfs-bin gvfs-common gvfs-daemons gvfs-fuse gvfs-libs
  ifupdown inxi krb5-locales krb5-multidev libapparmor1 libavcodec56
  libavcodec56:i386 libavfilter5 libavformat56 libavresample2
  libavresample2:i386 libavutil54 libavutil54:i386 libbind9-90 libblas3
  libcap2 libcap2:i386 libcap2-bin libcaribou-common libcaribou0
  libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcheese-gtk23 libcheese7
  libclutter-1.0-0 libclutter-gtk-1.0-0 libcurl3 libcurl3-gnutls
  libcurl4-gnutls-dev libdconf1 libdns100 libevdocument3-4 libevview3-3
  libgail-3-0 libgck-1-0 libgcr-3-1 libgcr-3-common libgcr-base-3-1
  libgcr-ui-3-1 libgdata-common libgdata19 libgdict-1.0-6 libgdict-common
  libgegl-0.2-0 libgeocode-glib0 libgirepository-1.0-1 libglib2.0-0
  libglib2.0-0:i386 libglib2.0-bin libglib2.0-data libglib2.0-dev
  libglibmm-2.4-1c2a libgnome-bluetooth13 libgnome-desktop-3-10 libgoa-1.0-0b
  libgoa-1.0-common libgoa-backend-1.0-1 libgpgme11 libgrilo-0.2-1
  libgssapi-krb5-2 libgssapi-krb5-2:i386 libgssrpc4
  libgstreamer-plugins-bad1.0-0 libgstreamer-plugins-base1.0-0
  libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtkmm-3.0-1
  libgtksourceview-3.0-1 libgtksourceview-3.0-common libgucharmap-2-90-7
  libgweather-3-6 libgweather-common libisc95 libisccc90 libisccfg90
  libk5crypto3 libk5crypto3:i386 libkadm5clnt-mit9 libkadm5srv-mit9 libkdb5-7
  libkrb5-3 libkrb5-3:i386 libkrb5-dev libkrb5support0 libkrb5support0:i386
  liblwres90 libmediaart-1.0-0 libmutter0e libnautilus-extension1a
  libnm-glib-vpn1 libnm-glib4 libnm-util2 libntrack-qt4-1 libntrack0 libnuma1
  libpackagekit-glib2-18 libpam-gnome-keyring libpcsclite1 libpcsclite1:i386
  libpeas-1.0-0 libpeas-common libphonon4 libpipeline1 libpostproc53
  libprotobuf9 libslang2 libslang2-dev libsoup-gnome2.4-1 libsoup2.4-1
  libswitch-perl libswresample1 libswresample1:i386 libswscale3
  libtotem-plparser18 libtotem0 libtracker-control-1.0-0
  libtracker-sparql-1.0-0 libvlc5 libvlccore8 libwayland-client0
  libwayland-client0:i386 libwayland-cursor0 libwayland-dev libwayland-server0
  libwayland-server0:i386 libxenstore3.0 libyelp0 man-db mutter-common
  nautilus nautilus-data network-manager ntrack-module-libnl-0 phonon
  printer-driver-cups-pdf procps python-gi python-gi-cairo python-gobject
  python3-gi python3-gi-cairo seahorse totem totem-common tracker tracker-gui
  vino vlc vlc-data vlc-nox vlc-plugin-pulse xserver-common xserver-xorg-core
  xterm xvfb yelp yelp-xsl zenity zenity-common
Title: Re: Warning X breakage
Post by: terroreek on 2014/09/25, 08:23:49
Ok, I was able to successfully update my laptop, which has an intel gpu.  I think the problem is with nvidia cards/drivers. 
Title: Re: Warning X breakage
Post by: slaughterer on 2014/09/25, 21:07:22
No problem here!I am with intels gpu.
Title: Re: Warning X breakage
Post by: towo on 2014/09/25, 21:11:40
This seems only affect gnome, here is all good with nvidia and binary blob.
Code: [Select]
~
towo:Defiant> inxi -SG
System:    Host: Defiant Kernel: 3.17-rc6-siduction-amd64 x86_64 (64 bit) Desktop: Xfce 4.11.8
           Distro: siduction 13.2.0 December - xfce - (201312310323)
Graphics:  Card: NVIDIA GM107 [GeForce GTX 750 Ti]
           Display Server: X.Org 1.16.1 driver: nvidia Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 750 Ti/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 343.22
Title: Re: Warning X breakage
Post by: terroreek on 2014/09/25, 22:12:15
just to elaborate, I can't even switch between virtual terminals.
Title: Re: Warning X breakage
Post by: terroreek on 2014/09/28, 16:17:46
Hi ok with some help with the siduction team, I was able to figure out the problem I was actually having was with systemd/journald.  Looks like if I booted into rescue mode and started up siduction to multi-user.target, virtual console (ttys) would keep restarting and I would see the error "systemd-journald[xxxx]: Received request to flush runtime journal from PID 1" flashed on the top.

I am not sure what the root cause was, but the latest systemd/journald updates did fix the issue.