Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: musca on 2014/10/20, 19:17:24

Title: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: musca on 2014/10/20, 19:17:24
Hello,

after latest dist-upgrade my KDE was unusable, because the window-manager kwin did not start. Windows had no decorations and i could not even switch input focus. So i rebootet in multi-user.target (append "3" in grub menu).

I found this in my .xsession-errors
win: error while loading shared libraries: libEGL.so.1: cannot open shared object file: No such file or directory
ksmserver(5833) KSMServer::wmProcessChange: Window manager "kwin" failed to launch


The new nvidia-driver 340.46-2 only recommends libegl1-nvidia
apt-get changelog nvidia-driver
 * nvidia-driver: Recommend libegl1-nvidia and suggest libgles[12]-nvidia.


Solution: after an install everything was okay again
Code: [Select]
apt-get install libegl1-nvidia libgles2-nvidia
[ Edit: for new installs the nvidia-driver misses the nouveau blacklist and fails to update the glx alternative!
See my next posting in this thread. ]
 
Thanks towo` for your nice recommendations in the siduction-irc support channel.

Cheers, and have fun with siduction!
musca

Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE
Post by: mork on 2014/10/20, 20:12:16
Hi,
this appears not to be a KDE/KWin only issue as my installation with Cinnamon/Mutter has been hit as well...

thanks for the solution!
...fantastic support!
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE
Post by: dibl on 2014/10/20, 20:51:02
Thanks musca -- great tip!
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: musca on 2014/10/20, 22:17:03
Hello,

even more annoyance!
For new installs the nvidia-driver misses the nouveau blacklist and fails to update the glx alternative!

so for a successful install you need two more steps:
Code: [Select]
apt-get install nvidia-driver libegl1-nvidia libgles[12]-nvidia nvidia-settings
echo -e "\n#manually inserted because nvidia-driver lost the nouveau blacklist\nblacklist nouveau\n" >>  /etc/modprobe.d/nvidia.conf
update-alternatives --config glx
There are 2 choices for the alternative glx (providing /usr/lib/glx).

  Selection    Path                    Priority   Status
------------------------------------------------------------
  0            /usr/lib/nvidia          100       auto mode
* 1            /usr/lib/mesa-diverted   5         manual mode
  2            /usr/lib/nvidia          100       manual mode

Press enter to keep the current choice (*), or type selection number: 0
update-alternatives: using /usr/lib/nvidia to provide /usr/lib/glx (glx) in auto mode
root@sidbox:~#


greetings
musca
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: clubex on 2014/10/20, 23:38:30
Thanks musca for your quick and thorough explanation.
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: Penyelam on 2014/10/21, 17:10:26
I have the same or a at least a similar problem after system update.
The graphical login screen appeared, but after entering login data just a command window openend in the left upper corner.
I run all the commands mentioned above.
Now when I login as user nothing happens.
When logging in as root, the command window appears as before.

One of the install commands told me I've to configure the NVIDIA driver in xorg.conf but this file does't exist.

Please help
Manfred
Title: Re: [not-solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: gcp on 2014/10/21, 18:30:52
Nothing of the above worked for me.
Im getting:

kwin: error while loading shared libraries: libEGL.so.1: cannot open shared object file: No such file or directory
So i got angry and made a link:
ln -s /usr/lib/x86_64-linux-gnu/nvidia/current/libEGL.so.1 /usr/lib/libEGL.so.1
kwin starts now and all seems working.
I will delete the link at better times...
My driver is Nvidia 343.22-0.siduction.1 on x65 multiarch.
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: musca on 2014/10/21, 22:26:39
Hello Peneylam,

the config is in our manual  http://manual.siduction.org/gpu#nvidia or just copy this to your root-shell:
mkdir /etc/X11/xorg.conf.d ; echo -e 'Section "Device"\n\tIdentifier "MyGPU"\n\tDriver "nvidia"\nEndSection\n' > /etc/X11/xorg.conf.d/20-nvidia.conf

It is normal that no /etc/X11/xorg.conf exists. You are allowed to create one (only if needed) and Xorg will respect it. Same goes for conf-snippets in the subdir /etc/X11/xorg.conf.d/ .

greetings
musca
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: vayu on 2014/10/22, 01:01:12
so for a successful install you need two more steps:
Code: [Select]
apt-get install nvidia-driver libegl1-nvidia libgles[12]-nvidia nvidia-settings
echo -e "\n#manually inserted because nvidia-driver lost the nouveau blacklist\nblacklist nouveau\n" >>  /etc/modprobe.d/nvidia.conf
update-alternatives --config glx
greetings
musca

Thanks, I had no nvidia after du, this got me back in. 
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: melmarker on 2014/10/22, 02:58:06
i have similar issues with kwin and the legacy 304xx - but no time to figure this out, so i using openbox and compton right now :D
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: Penyelam on 2014/10/22, 11:12:20
Hi Musca,
I really appreciate your quick response.
But unfortunately after creating the
/etc/X11/xorg.conf.d/20-nvidia.conf

nothing changed.
I still get the graphical login screen,
but after entering my credentials nothing happens.


Kind regards
Manfred

Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: gcp on 2014/10/22, 19:05:23
the update to glx-alternative-nvidia (0.5.1) should fix the problem.
see:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=766169
the problem is solved now for me.

Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: melmarker on 2014/10/22, 22:45:29
for me too - seems to be solved
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: musca on 2014/10/23, 01:14:43
Hello all,

there is a complete new nvidia 340.46-3 which solved all three issues (libEGL.so.1, blacklist and glx-alternative).
I think we can cosider this thread closed.

greetings
musca
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: Penyelam on 2014/10/23, 11:55:16
Hi guys,
I really appreciate your effort and time you spend to support normal user like me.
But I'm truly sorry,  I've still trouble, please see attachments.
Yesterday I did a mistake in the file name of the "20-nvidia-conf".
Now I don't get a graphic screen.

I followed all instructions but nothing helped.
The only what I haven't done was installing the "nvidia-173xx-driver" beause I don't know the number,
of my "GeForce GT520". How can I find that?
Do you think I have a change to fix that issue or shall I reinstall my system from scratch? 

Regards
Manfred
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: musca on 2014/10/23, 12:22:30
Hello Peneylam,

the numbers are Versionnumbers of the driver. The 173xx driver supports the ancient Geforce 5000 series and Xorg 1.12. Don't install it! Your GT520 will work well with the recent nvidia-driver 340.46-3.


I suggest you use the nouveau driver to get your system up and then seek help in our irc channel.
Code: [Select]
mv /etc/X11/xorg.conf.d/* /home/$USER
apt-get purge $(dpkg -l | awk '/nvidia/ {print $2}')
This commands move the 20-nvidia.conf away and remove about 12 to 16 packages. Please read carefully what it does remove.
You should not remove your whole desktop. Please reboot afterwards.

(The following command works in textmode and in graphical mode!) Please login as user and start:
Code: [Select]
siduction-irc
You will find us there and can easily fix your problem with our experienced support.

greetings
musca
Title: Re: [solved] nvidia-driver 340.46-2 breaks KDE (and more)
Post by: Penyelam on 2014/10/24, 08:16:11
Hi Musca,
many  thanks for your excellent help yesterday at the irc.

I recreated my user account and copied .kde/share, .local and Desktop back.
Some apps like gmail were left and needed to install again, but this was easy doing.
So everything works fine now.

Kind regards
Manfred