Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: musca on 2014/10/21, 23:43:04

Title: [solved] serious bug in dpkg
Post by: musca on 2014/10/21, 23:43:04
Hello,

beware of this serious bug http://bugs.debian.org/766242 (http://bugs.debian.org/766242)
and better do not upgrade to dpkg 1.17.19 at the moment.

Hold your dpkg version with this command:
Code: [Select]
apt-mark hold dpkg
greetings
musca
Title: Re: DU-Warning: serious bug in dpkg
Post by: musca on 2014/10/22, 10:28:19
Hello,

a fix is on the way. The maintainer will do some testing and extend the test suite to catch such issues in the future.

We are lucky in this case, because dpkg is still able to downgrade itself.
root@sidbox:~# dpkg -i /var/cache/apt/archives/dpkg_1.17.18_amd64.deb
dpkg: warning: downgrading dpkg from 1.17.19 to 1.17.18
(Reading database ... 167715 files and directories currently installed.)
Preparing to unpack .../dpkg_1.17.18_amd64.deb ...
Unpacking dpkg (1.17.18) over (1.17.19) ...
Setting up dpkg (1.17.18) ...
Processing triggers for siduction-dynamic-dms (2014.08.13) ...
Processing triggers for man-db (2.7.0.2-2) ...

Don't forget to "apt-mark hold dpkg"  before you take the next steps and proceed with the usual dist-upgrade.

greetings
musca
Title: Re: DU-Warning: serious bug in dpkg
Post by: hendrikL on 2014/10/22, 11:04:33
If you cleaned the cache with "apt-get clean", do following
Code: [Select]
wget -c http://ftp.de.debian.org/debian/pool/main/d/dpkg/dpkg_1.17.18_amd64.deb && dpkg -i dpkg_1.17.18_amd64.deb && apt-mark hold dpkg

EDIT: Does not work, because it is not at that location anymore, look some post later.
Title: Re: DU-Warning: serious bug in dpkg
Post by: clubex on 2014/10/22, 13:37:14
I missed the above post also unfortunately I did an apt-get clean.
hendrikL: I tried your code with the following result
Code: [Select]
wget -c http://ftp.de.debian.org/debian/pool/main/d/dpkg/dpkg_1.17.18_amd64.deb && dpkg -i dpkg_1.17.18_amd64.deb && apt-mark hold dpkg
--2014-10-22 12:16:12--  http://ftp.de.debian.org/debian/pool/main/d/dpkg/dpkg_1.17.18_amd64.deb
Resolving ftp.de.debian.org (ftp.de.debian.org)... 141.76.2.4
Connecting to ftp.de.debian.org (ftp.de.debian.org)|141.76.2.4|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2014-10-22 12:16:12 ERROR 404: Not Found.

No obvious typos so I'm stuck with dpkg_1.17.18_amd64.

Any suggestions?
Title: Re: DU-Warning: serious bug in dpkg
Post by: convbsd on 2014/10/22, 13:51:04
clubex you can download dpkg-1.17.18 from debian snapshots.
http://snapshot.debian.org/archive/debian/20141021T164213Z/pool/main/d/dpkg/dpkg_1.17.18_amd64.deb.
Title: Re: DU-Warning: serious bug in dpkg
Post by: hendrikL on 2014/10/22, 14:01:10
Unfortunately it is removed, not really nice.
But ok, as convbsd wrote, take it from debian snapshots.

for x64
Code: [Select]
wget -c http://snapshot.debian.org/archive/debian/20141021T164213Z/pool/main/d/dpkg/dpkg_1.17.18_amd64.deb. && dpkg -i dpkg_1.17.18_amd64.deb && apt-mark hold dpkg
for i386
Code: [Select]
wget -c http://snapshot.debian.org/archive/debian/20141021T164213Z/pool/main/d/dpkg/dpkg_1.17.18_i386.deb. && dpkg -i dpkg_1.17.18_i386.deb && apt-mark hold dpkg
Title: Re: DU-Warning: serious bug in dpkg
Post by: clubex on 2014/10/22, 14:57:32
Many thanks hendrikL and convbsd that did it.
Title: Re: DU-Warning: serious bug in dpkg
Post by: hefee on 2014/10/22, 15:48:34
Unfortunately it is removed, not really nice.
But ok, as convbsd wrote, take it from debian snapshots.
Well all mirrors are synced and only the newest version is availabe from them. If you want an older version you always have to use snapshots. It worked for you because to took an mirror, that wasn't sync at that time you tried it.
Title: Re: DU-Warning: serious bug in dpkg
Post by: hendrikL on 2014/10/23, 08:23:23
@hefee
Thank you for clarification, i forgot about that  8)

There is a fixed version of dpkg uploaded.

Code: [Select]
LANG=C apt-cache policy dpkg
dpkg:
  Installed: 1.17.18
  Candidate: 1.17.20
  Version table:
     1.17.20 0
        500 http://ftp.nl.debian.org/debian/ sid/main amd64 Packages
        500 http://debian.morphium.info/debian/ unstable/main amd64 Packages

So if you marked dpkg  to hold, please do following before the next dist-upgrade

Code: [Select]
apt-mark unhold dpkg
To see what is marked hold, you can use
Code: [Select]
apt-mark showhold
I think we can close this issue and mark it as solved.
Title: Re: [solved] serious bug in dpkg
Post by: musca on 2014/10/23, 11:15:19
Hello hendrikL,

yes, i can confirm your successful testing, thanks!  I marked the thread as [solved].

greetings
musca