Siduction Forum

BUGS => Bugs 2014.1 (DE/EN) => Topic started by: Pip on 2015/02/04, 13:46:47

Title: KDE dark colour schemes mangled
Post by: Pip on 2015/02/04, 13:46:47
If I set a dark colour scheme in System Settings -> Application Appearance, it can seem to take, but the dark colours will then vanish in various places - the icons in System Settings all have light surrounds - or not be set - the menu bar, search and transfers sections in qbittorrent.
I can get some of the darkness back by going in to the System Settings -> Application Appearance and changing from Oxygen to Plastique, then back to Oxygen again before applying the change.
This has happened on three different machines and with existing and new accounts.
Is this a bug somewhere, or is there some extra step I have to take to resolve this?
Thanks for any help. I really would like to be able to move across to a distro with a name like siduction, but I can't afford to move over my work machine yet until I can get this sorted out.
Title: Re: KDE dark colour schemes mangled
Post by: der_bud on 2015/02/04, 15:11:18
Hi Pip,
I can confirm this beviour on a Indiansummer KDE system while not having it in earlier releases of siduction KDE. I tried hard to find diffs in the settings, without success. Changing to Plastique and back to Oxygen only helped here until the next reboot.
There was a user in irc who somehow worked around it, I'll later try to find that in the logs. So the devs have heard about it, but as far as I've seen there is no bugreport yet. Perhaps now we have a thread  for this ;) and collect more info from users, I will open one in our issue tracker.
Title: Re: KDE dark colour schemes mangled
Post by: Pip on 2015/02/04, 15:17:46
Yes, it was a fresh installation each time from Indiansummer. Thanks for letting me know it's not just me doing something odd. I couldn't find any other reference to it in the forums, so wasn't sure.
Re-applying the current skin works a bit but not for long. The System Settings goes back to having dark surrounds on the icons unless you close it and open it again, at which point the light backgrounds are back in place.
That's been tried with a number of dark themes.
Title: Re: KDE dark colour schemes mangled
Post by: der_bud on 2015/02/04, 15:50:34
It was absolut who posted that same in irc three weeks ago. He added three srceenshots, the first [1] showing "white squares" in systemsettings, the second [2] showing a tab with white background where it should be gray and the third [3] with correct colors after applying the settings (which did not survive reboots)
 [1]  http://ibin.co/1nSxe6o0YeAg
 [2]  http://ibin.co/1nXF79hFiFHY
 [3]  http://ibin.co/1nXFOKMOKqxo

He posted a solution that worked for him: "this is awesome, i've got that fixed. installed qt4-qtconfig and ran qtconfig-qt4... set the gui style to oxygen. save reboot and it sticks. since oxygen is what i wanted, for me the issue is sorted out."
Odd is that in other installs where everything is okay no qtconfig-stuff is or was ever installed. ???

I just opened a bug report for this,  #1746 KDE Indiansummer colors or style borked (http://bugs.siduction.org/issues/1746) .

Title: Re: KDE dark colour schemes mangled
Post by: melmarker on 2015/02/04, 17:50:16
we accept patches :)
Title: Re: KDE dark colour schemes mangled
Post by: Pip on 2015/02/04, 18:26:40
I tried the qt4-qtconfig installation/configuration and that seemed to work! Excellent!
As to why...
Thanks for this.
Title: Re: KDE dark colour schemes mangled
Post by: sunrat on 2015/03/01, 01:38:08
Sorry, started a new thread. Similar issue but not a 2014.1 bug.