Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: Millie on 2015/03/04, 15:45:04

Title: [fixed] Chromium won't start after upgrade
Post by: Millie on 2015/03/04, 15:45:04
I upgraded my LXDE this morning, and afterword, Chromium won't start at all.

I tried from the terminal and got:
Code: [Select]
[0304/073715:FATAL:isolate_holder.cc(70)] Couldn't mmap v8 natives data file
Aborted

Upgraded the following packages:
chromium (40.0.2214.111-1) to 41.0.2272.76-1
gtk2-engines-pixbuf (2.24.25-2) to 2.24.25-3
libgtk2.0-0 (2.24.25-2) to 2.24.25-3
libgtk2.0-common (2.24.25-2) to 2.24.25-3
linux-headers-siduction-686 (3.19-2) to 3.19-3
linux-image-siduction-686 (3.19-2) to 3.19-3
Title: Re: Chromium won't start after upgrade
Post by: dibl on 2015/03/04, 16:39:03
Google tells me that error has been seen before (https://code.google.com/p/chromium/issues/detail?id=437136).


Not an official siduction recommendation, but FYI I switched from chromium to SRWare Iron (http://www.srware.net/en/software_srware_iron.php) some months ago and it is working great.  But enabling pepperflash is a special kubuki dance that you have to do.  Those instructions are here (http://ag8.alltagsgrauen.info/tying-the-knot-between-pepper-flash-and-srware-iron).
Title: Re: Chromium won't start after upgrade
Post by: Millie on 2015/03/04, 21:19:51
Thanks for the info, dibl. It looks like this problem has been around for a while now.

But enabling pepperflash is a special kubuki dance that you have to do.
I don't think I want to put on all that makeup just to install pepperflash. ;D    
(http://s19.postimg.org/9zizfy8gz/k2_200.jpg) (http://s19.postimg.org/9zizfy8gz/k2_200.jpg)

I've used Iron on Linux in the past, but I can't remember why I stopped using it. I think I'll take this opportunity and try out the Linux version of Slimjet.
Title: Re: Chromium won't start after upgrade
Post by: seasons on 2015/03/05, 06:00:42
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=779717
Title: Re: Chromium won't start after upgrade
Post by: seasons on 2015/03/05, 06:26:10
I also had Google Chrome installed, so I copied two files from Chrome (natives_blob.bin and snapshot_blob.bin) to /usr/lib/chromium and now it starts.

I don't know exactly what those files are for and whether they could/should be included with chromium
https://chromium.googlesource.com/chromium/src/+/dd97f2b5ff8cbdab0bb9c0fec87d07f2fe2a3b50%5E!/#F0.
Title: Re: Chromium won't start after upgrade
Post by: Millie on 2015/03/05, 15:24:08
Well, for now I'm going to avoid upgrading Chromium on my Xfce. I did  install Slimjet on my LXDE and it runs great. Flash is supported without any extra effort. It is, however, based on 40, so I'll have to wait and see what happens when it's updated to base 41.
Title: Re: Chromium won't start after upgrade
Post by: dibl on 2015/03/05, 17:05:16
Iron seems to lag Chrome development a bit -- it is presently at Ver. 39.0.2100.  And of course there's no package in Debian, although they do package a .deb for downloading from their site.
Title: Re: Chromium won't start after upgrade
Post by: melmarker on 2015/03/05, 18:22:21
hmm - this is sid, a bugreport for it is there, with a possible fix - so just wait and/or use chromium from testing should be sufficient.  Hey, it's sid, things break from time to time, but nothing to see here, move along :D

EDIT: FTBFS (fail to build from source) after 1h build time on a decent buildmachine - bug in debian packaging, the sources are ok - so i lost the interest to fix this.
Title: Re: Chromium won't start after upgrade
Post by: Millie on 2015/03/06, 00:08:04
Iron seems to lag Chrome development a bit -- it is presently at Ver. 39.0.2100.  And of course there's no package in Debian, although they do package a .deb for downloading from their site.

I did go look at the Iron website, but found they don't support 32bit for Linux any more, and I run 32bit.

This is on their "New Iron-Version: 39.0.2100.0 Stable for Linux" page posted back in January:
"We create no 32-Bit Versions due to the marginal usage. The downloads link to an older version."

So that means at best 38 for Linux 32bit. Debian stable is still 37 and probably not going to change until Jessie goes stable.
Title: Re: Chromium won't start after upgrade
Post by: melmarker on 2015/03/06, 00:16:07
Suggestion: Wait for a fixed build - use chromium from testing until available :)
Title: Re: Chromium won't start after upgrade
Post by: musca on 2015/03/06, 13:03:03
Hello,

fixed chromium 41.0.2272.76-2 is in incoming and will enter the debian repo with next sync (around 16:30h UTC, i think).

greetings
musca
Title: Re: Chromium won't start after upgrade
Post by: ajavibp on 2015/03/06, 17:05:32
It's finally fixed!  ;D
Title: Re: Chromium won't start after upgrade
Post by: melmarker on 2015/03/06, 17:43:33
HURRA! Das Internet geht wieder 8)
Title: Re: Chromium won't start after upgrade
Post by: dibl on 2015/03/06, 19:29:07
HURRA! Das Internet geht wieder 8)


Wie wunderbar!  Das Internet hat die chromium-software repariert!   :o
Title: Re: Chromium won't start after upgrade
Post by: Millie on 2015/03/06, 20:03:52
Thanks musca! :)  I just installed and it runs perfectly.