Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: wodga on 2015/12/06, 21:35:19

Title: alles englisch nach d-u
Post by: wodga on 2015/12/06, 21:35:19
nach einem d-u sind sämtliche Anwendungen auf englisch. Wie kann ich die locales auf deutsch umstellen?
Title: Re: alles englisch nach d-u
Post by: jure on 2015/12/06, 22:41:16
hast du mal
Code: [Select]
dpkg-reconfigure locales probiert ....
Title: Re: alles englisch nach d-u
Post by: wodga on 2015/12/07, 15:36:12
hab ich probiert. Hat nichts bewirkt
Title: Re: alles englisch nach d-u
Post by: musca on 2015/12/07, 16:12:06
Hallo wodga,

was gibt der Befehl "locale" aus?
Title: Re: alles englisch nach d-u
Post by: piper on 2015/12/07, 16:32:58
Code: [Select]
dpkg-reconfigure locales && dpkg-reconfigure console-setup && dpkg-reconfigure keyboard-configuration
Title: Re: alles englisch nach d-u
Post by: wodga on 2015/12/08, 21:56:17
@musca locale:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nds_DE.UTF-8
LANGUAGE=de
LC_CTYPE="nds_DE.UTF-8"
LC_NUMERIC="nds_DE.UTF-8"
LC_TIME="nds_DE.UTF-8"
LC_COLLATE="nds_DE.UTF-8"
LC_MONETARY="nds_DE.UTF-8"
LC_MESSAGES="nds_DE.UTF-8"
LC_PAPER="nds_DE.UTF-8"
LC_NAME="nds_DE.UTF-8"
LC_ADDRESS="nds_DE.UTF-8"
LC_TELEPHONE="nds_DE.UTF-8"
LC_MEASUREMENT="nds_DE.UTF-8"
LC_IDENTIFICATION="nds_DE.UTF-8"
LC_ALL=
Title: Re: alles englisch nach d-u
Post by: wodga on 2015/12/08, 22:10:16
@piper: Keine Änderung
Title: Re: alles englisch nach d-u
Post by: dibl on 2015/12/08, 23:17:31
No guarantee ...


Keine Garantie ..



An init 3:


Code: [Select]
# apt-get purge locales

Code: [Select]
# apt-get update && apt-get install locales

Code: [Select]
# dpkg-reconfigure locales

Use the spacebar to select/unselect languages.


Benutzen Sie die Leertaste, um vorzuwählen
Title: Re: alles englisch nach d-u
Post by: sunrat on 2015/12/09, 00:07:12
Possibly related? https://bugs.kde.org/show_bug.cgi?id=340982

Sorry, no German.
Entschuldigung, keine Deutsch.
Title: Re: alles englisch nach d-u
Post by: der_bud on 2015/12/09, 15:32:37
...
LANG=nds_DE.UTF-8
LANGUAGE=de
...
I realized recently that in some dropdown lists if you want to select german by typing 'de', the cursor jumps to nde_DE. But be aware that nds is Niedersachsen, do you really want Platt ;) ? Probably that's not fully translated yet. Reconfigure again and assure that you really select de_DE.UTF-8, then try again.
Title: Re: alles englisch nach d-u
Post by: wodga on 2015/12/09, 15:36:44
no, no I selected:             
Title: Re: alles englisch nach d-u
Post by: der_bud on 2015/12/10, 09:18:49
Then something went wrong or did not get applied, please compare your output from the post above:
@musca locale:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nds_DE.UTF-8
LANGUAGE=de
LC_CTYPE="nds_DE.UTF-8"
LC_NUMERIC="nds_DE.UTF-8"
LC_TIME="nds_DE.UTF-8"
LC_COLLATE="nds_DE.UTF-8"
LC_MONETARY="nds_DE.UTF-8"
LC_MESSAGES="nds_DE.UTF-8"
LC_PAPER="nds_DE.UTF-8"
LC_NAME="nds_DE.UTF-8"
LC_ADDRESS="nds_DE.UTF-8"
LC_TELEPHONE="nds_DE.UTF-8"
LC_MEASUREMENT="nds_DE.UTF-8"
LC_IDENTIFICATION="nds_DE.UTF-8"
LC_ALL=

versus mine

Code: [Select]
LANG=de_DE.UTF-8
LANGUAGE=de
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
Note the difference, nds_DE and de_DE.
Title: Re: alles englisch nach d-u
Post by: wodga on 2015/12/11, 14:00:06
with a little help, in the irc I got now locale:
LANG=de_DE.UTF-8
LANGUAGE=de
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

what solved the problem was locale-gen "de_DE.UTF-8"