Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: devil on 2016/01/19, 09:24:10

Title: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: devil on 2016/01/19, 09:24:10
Please do not install init-system-helpers from todays upgrade, it prevents your machine to boot afterwards with:  Target filesystem doesn't have requested /sbin/init


Bitte nicht init-system-helpers aus dem heutigen Upgrade installieren. Der Rechner verweigert danach das Booten mit: Target filesystem doesn't have requested /sbin/init


Mehr dazu, sobald Infos verfügbar sind.


greetz
devil
Title: Re: Warning: Init-system-helpers breaks boot
Post by: devil on 2016/01/19, 14:50:25
After some more debugging I found initramfs-tools the culprit and init-system-helpers was completely innocent :)
If you locked yourself out already and have older kernels installed, you should be able to boot one of those. If not, chrooting into the system and installing initramfs-tools in version 0.120 also fixes the issue.


Nach weitrem Debugging stellte sich heraus, dass  initramfs-tools schuld ist. init-system-helpers ist völlig unschuldig.
Wenn ihr euch bereits ausgesperrt habt, hilft es, einen älteren Kernel zu booten. Wenn nicht, hilft nur ein Chroot ins System und das Downgrade von initramfs auf 0.120.


greetz
devil
Title: Re: Warning: Init-system-helpers breaks boot
Post by: manilg on 2016/01/19, 18:18:48
Das ist aber nicht so einfach:

Code: [Select]
dpkg -i initramfs-tools_0.120+nmu1_all.deb
(Lese Datenbank ... 315654 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von initramfs-tools_0.120+nmu1_all.deb ...
Entpacken von initramfs-tools (0.120+nmu1) über (0.120+nmu1) ...
Ersetzt durch Dateien in installiertem Paket initramfs-tools-core (0.121) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von initramfs-tools:
 initramfs-tools-core (0.121) beschädigt initramfs-tools (<< 0.121~) und ist installiert.
  Zu konfigurierende Version von initramfs-tools auf dem System ist 0.120+nmu1.

dpkg: Fehler beim Bearbeiten des Paketes initramfs-tools (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Trigger für siduction-dynamic-dms (2016.01.04.3) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 initramfs-tools

und

Code: [Select]
apt-get purge initramfs-tools
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  initramfs-tools* linux-image-4.3.0-towo.3-siduction-amd64* linux-image-4.3.1-towo.1-siduction-amd64*
  linux-image-4.3.2-towo.1-siduction-amd64* linux-image-4.3.3-towo.1-siduction-amd64* linux-image-4.4.0-towo.1-siduction-amd64*
  linux-image-siduction-amd64*

Gruss

manilg
Title: Re: Warning: Init-system-helpers breaks boot
Post by: towo on 2016/01/19, 18:23:39
man man man,


apt install initramfs-tools=0.120+nmu1
Title: Re: Warning: Init-system-helpers breaks boot
Post by: manilg on 2016/01/19, 18:27:20
Code: [Select]
apt install initramfs-tools=0.120+nmu1
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 initramfs-tools-core : Beschädigt: initramfs-tools (< 0.121~) aber 0.120+nmu1 soll installiert werden
                        Beschädigt: initramfs-tools:i386 (< 0.121~)
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).
root@charon:/home/ma/Downloads# apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
The following additional packages will be installed:
  initramfs-tools
Die folgenden Pakete werden aktualisiert (Upgrade):
  initramfs-tools
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 17 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 62,1 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 252 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] y
Lese Changelogs... Fertig
(Lese Datenbank ... 315654 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../initramfs-tools_0.121_all.deb ...
Entpacken von initramfs-tools (0.121) über (0.120) ...
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Trigger für siduction-dynamic-dms (2016.01.04.3) werden verarbeitet ...
initramfs-tools (0.121) wird eingerichtet ...
update-initramfs: deferring update (trigger activated)
Trigger für initramfs-tools (0.121) werden verarbeitet ...
update-initramfs: Generating /boot/initrd.img-4.4.0-towo.1-siduction-amd64
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
W: mdadm: no arrays defined in configuration file.


Beim nochmaligen Versuch hatś geklappt:

Code: [Select]

apt install initramfs-tools=0.120+nmu1
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  initramfs-tools-core
Die folgenden Pakete werden durch eine ÄLTERE VERSION ERSETZT (Downgrade):
  initramfs-tools
0 aktualisiert, 0 neu installiert, 1 durch eine ältere Version ersetzt, 1 zu entfernen und 17 nicht aktualisiert.
Es müssen noch 0 B von 95,5 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 72,7 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] y
dpkg: initramfs-tools-core: Abhängigkeitsprobleme, wird aber wie gefordert dennoch entfernt:
 initramfs-tools hängt ab von initramfs-tools-core (= 0.121).

apt-cache policy initramfs-tools
initramfs-tools:
  Installiert:           0.120+nmu1
  Installationskandidat: 0.121
  Versionstabelle:
     0.121 500
        500 http://http.debian.net/debian unstable/main amd64 Packages
        500 http://http.debian.net/debian unstable/main i386 Packages
 *** 0.120+nmu1 500
        500 http://ftp.spline.de/pub/siduction/extra unstable/main amd64 Packages
        500 http://ftp.spline.de/pub/siduction/extra unstable/main i386 Packages
        100 /var/lib/dpkg/status


Gruss

manilg
Title: Re: Warning: Init-system-helpers breaks boot
Post by: gnasch on 2016/01/19, 19:32:03
Verhaltensaenderung:

https://lists.debian.org/debian-kernel/2015/12/msg00077.html (https://lists.debian.org/debian-kernel/2015/12/msg00077.html)

Gruss, gnasch
Title: Re: Warning: Init-system-helpers breaks boot
Post by: devil on 2016/01/19, 19:50:11
Das klappt aber nicht, da bei allen Betroffenen die ich gesehen habe, busybox installiert war.


greetz
devil
Title: Re: Warning: Init-system-helpers breaks boot
Post by: sedonix on 2016/01/19, 20:27:19
Since I update everytime I sit down at my computer, I get to enjoy the latest problems if I guess wrong. :) Towo's solution worked for me on kernel 4.4.0-towo.1-siduction-amd64.
Title: Re: Warning: Init-system-helpers breaks boot
Post by: mylo on 2016/01/20, 00:54:12
.... Towo's solution worked for me on kernel 4.4.0-towo.1-siduction-amd64.
+1
thanks towo, yes worked perfect on kernel .1, rebooting after in .2 without any problems!
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: seasons on 2016/01/20, 01:46:16
Bullshit!

 (The ignorant American wonders how to express that in German.)
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: linearJim on 2016/01/20, 07:49:14
hi
i got lost with posts in german, so i can someone clarify..
Code: [Select]
└──┤ apt-cache policy initramfs-tools
initramfs-tools:
  Installed: 0.120+nmu1
  Candidate: 0.121
  Version table:
     0.121 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://httpredir.debian.org/debian unstable/main i386 Packages
 *** 0.120+nmu1 500
        500 http://ftp.spline.de/pub/siduction/extra unstable/main amd64 Packages
        500 http://ftp.spline.de/pub/siduction/extra unstable/main i386 Packages
        100 /var/lib/dpkg/status
     0.120 500
        500 http://httpredir.debian.org/debian testing/main amd64 Packages
        500 http://httpredir.debian.org/debian testing/main i386 Packages

if i understand correctly i need to pin initramfs-tool in this version 0.120+nmu1?
the problem is upgrading initramfs-tools without having busybox installed?
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: der_bud on 2016/01/20, 08:17:03
Yes, hold initramfs-tools for now
Code: [Select]
apt-mark hold initramfs-tools until further notice. If/what the installed version of busybox has to do with it is not very clear to me atm, but waiting with dist-upgrades or at least holding initramfs is the way to go, initramfs-tool 0.122 are in the making.
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: linearJim on 2016/01/20, 08:30:58
thank you der_bud!
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: seasons on 2016/01/20, 12:07:09
I got it fixed. (Thank you, towo!)
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: drb on 2016/01/20, 22:03:52
Yes, hold initramfs-tools for now
Code: [Select]
apt-mark hold initramfs-tools until further notice. If/what the installed version of busybox has to do with it is not very clear to me atm, but waiting with dist-upgrades or at least holding initramfs is the way to go, initramfs-tool 0.122 are in the making.

Is that the correct way to hold a package these days? Rather than echo .............set-selections?
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: towo on 2016/01/20, 22:05:10
Quote
Is that the correct way to hold a package these days? Rather than echo .............set-selections?
It is, and it's easyer than echo hold ... set-selections
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: drb on 2016/01/20, 22:05:49
Thanks! It is!
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: seasons on 2016/01/21, 15:27:32
So initramfs-tools 0.122 is available now. I guess it is safe to unhold it and upgrade? I would like some confirmation from someone who's already done it if possible. Thanks.

P.S. new version of Pepper Flash (20.0.0.286) available
Code: [Select]
update-pepperflashplugin-nonfree --install --unverified

EDIT: fixed copy/paste error in command
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: pjnsmb on 2016/01/21, 16:07:53
I have updated to initramfs-tools 0.122 without any problems showing after a reboot a couple of times .............


thanks for the pepper flash update - had to delete the first update- though  ;)



Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: vilde on 2016/01/21, 16:30:40
I have updated to initramfs-tools 0.122 without any problems showing after a reboot a couple of times .............


thanks for the pepper flash update - had to delete the first update- though  ;)

Confirm that it's working here also :)
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: mylo on 2016/01/21, 22:24:03
I have updated to initramfs-tools 0.122 without any problems showing after a reboot a couple of times .............

thanks for the pepper flash update - had to delete the first update- though  ;)
a thankful +1
Title: Re: Warning: Init-system-helpers breaks boot/ Really it was initramfs-tools
Post by: blaze on 2016/01/22, 11:49:12
Ok here too.