Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: vilde on 2016/04/13, 20:02:33

Title: php and php 7.0 was removed
Post by: vilde on 2016/04/13, 20:02:33
D-u today removed  php and php7.o for me, I let it go without knowing what it's for. Now my fonts are really ugly in terminal and also firefox looks a little wrong. Is this because of php gone?

Title: Re: php and php 7.0 was removed
Post by: melmarker on 2016/04/13, 20:38:35
in short: no
long version: it seems that your droid fonts are gone too - i would suggest to install the noto fonts and configure the desktop to use them
Title: Re: php and php 7.0 was removed
Post by: vilde on 2016/04/13, 21:54:23
Found out that it looks the same bad on another computer, (xfce 64 bit on both) the other computer was also dist-upgraded today without any (for me) vissible removed packages. Doesn't help to change font's, looking like this in terminal,looks ok in other applications
Title: Re: php and php 7.0 was removed
Post by: melmarker on 2016/04/13, 23:49:57
solution is simple - change the terminal font and make sure that the noto fonts are installed
Title: Re: php and php 7.0 was removed
Post by: vilde on 2016/04/14, 00:10:40
solution is simple - change the terminal font and make sure that the noto fonts are installed
I did that before I made the screenshot, everything fonts-noto* is installed. It doesn't matter which font I choose in terminal, it looks the same uggly, the fonts changes but  it's the same faulty spaces and lacks of spaces between the letters.
Title: Re: php and php 7.0 was removed
Post by: melmarker on 2016/04/14, 01:47:18
one has to change the font in the terminal settings
Title: Re: php and php 7.0 was removed
Post by: reinob on 2016/04/14, 09:50:11
D-u today removed  php and php7.o for me, I let it go without knowing what it's for. Now my fonts are really ugly in terminal and also firefox looks a little wrong. Is this because of php gone?

A couple of days ago while upgrading my _user_ setting for DPI (xfce4) was also reset. I had to set it back to what it was (96, in my case) and then everything was OK.

From your screenshot it could be that (check it just in case) and/or your font rendering settings have (also?) been reset. Check aliasing and hinting.

EDIT: Reading again and seen your screenshot again, it seems you just have a bad font. Try the same font with another terminal (e.g. lxterminal) and see if you have the same. Some terminals are really crappy at displaying Unicode.
Title: Re: php and php 7.0 was removed
Post by: vilde on 2016/04/14, 10:43:49
one has to change the font in the terminal settings
That's what I did and it looks the same ugly with every font.

It's only in the xfce terminal I have this problem, I mentioned some problems in firefox from the beginning but that was the dpi settings.

In the picture below you can see that some characters have wrong space around them like l i and j, @ and % will have no space at all.

And again i doesn't help to change font in xfce terminal