Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: devil on 2016/07/04, 18:29:55

Title: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: devil on 2016/07/04, 18:29:55
As of today, the transitions to a new kdepim 16.04.2-1 have started. The process was initiated by this bugreport (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=827755 ) over the weekend and accepted by the release team as of today. It will take days, maybe weeks to get all the packages into unstable in the right order. As debian-kde-qt-maintainer Lisandro writes (http://perezmeyer.blogspot.de/2016/07/upcoming-kdepim-changes-in-unstable.html), this can wreak havok for kdepim users until the transitions are completed.


If you rely on a working kmail or other components of kdepim, you should hold back on dist-upgrades until the transitions are completed. We will keep you posted. Other components of KDE or siduction should™ not be affected.


--


Seit heute finden eine (bzw mehrere) Transition(s) für kdepim 16.04.2-1 statt. Dabei werden die Pakete für ein neues KDEPim in der richtigen Reihenfolge hochgeladen. Das kann  insgesamt Tage/Wochen dauern. Die Transitions wurden am Wochenende durch einen Bugreport  (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=827755 )beantragt, dem heute seitens des Releaee-Teams stattgegeben wurde. Wie Debian-KDE-Qt-Maintainer Lisandro schreibt (http://perezmeyer.blogspot.de/2016/07/upcoming-kdepim-changes-in-unstable.html), ist dabei Vorsicht geboten.


Wer also auf ein funktionierendes Kmail oder andere KDEPim-Komponenten angewiesen ist, sollte sich bis zum Abschluss der Transitions mit Dist-Upgrades zurückhalten. Wir halten euch auf dem Laufenden. Andere Komponenten von KDE oder siduction sollten™ nicht betroffen sein.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/07/05, 18:13:50
Hi Community,

die ersten Komponenten von KDE-PIM in der Version 16.04.2 sind heute in SID angekommen. Bitte Vorsicht wer auf ein funktionierendes kontact/kmail/kaddressbook usw. angewiesen ist.

---

the first component of the KDE PIM in version 16.04.2 arrived today in SID. Please be careful when d-u, who kontact on a functioning / kmail / kaddressbook so instructed is.

Code: [Select]
# apt-show-versions -u|grep 16.04.2
akonadi-backend-sqlite:amd64/unstable 1.13.0-8 upgradeable to 4:16.04.2-2
akonadi-server:amd64/unstable 1.13.0-8 upgradeable to 4:16.04.2-2
kde-runtime:amd64/unstable 4:16.04.2-1 upgradeable to 4:16.04.2-2
kde-runtime-data:all/unstable 4:16.04.2-1 upgradeable to 4:16.04.2-2
plasma-scriptengine-javascript:amd64/unstable 4:16.04.2-1 upgradeable to 4:16.04.2-2
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/07/08, 11:52:11
Immer noch keine gute Idee einen d-u durchzuführen.

---

Still not a good idea a d-u perform.

Code: [Select]
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden ENTFERNT:
  kdepim-kresources libeventviews4 libkolab0v5 libksieveui4 libmessagelist4 libnoteshared4
Die folgenden NEUEN Pakete werden installiert:
  accountwizard kdepimlibs-data kf5-kdepim-apps-libs-data kf5-kdepimlibs-kio-plugins kf5-messagelib-data libgrantlee-textdocument5 libkf5akonadiagentbase5 libkf5akonadicalendar5
  libkf5akonadicontact5 libkf5akonadicore-bin libkf5akonadicore5 libkf5akonadimime5 libkf5akonadinotes5 libkf5akonadiprivate5 libkf5akonadisearchdebug5 libkf5akonadisearchpim5
  libkf5akonadiwidgets5 libkf5alarmcalendar5 libkf5blog5 libkf5calendarcore5 libkf5calendarsupport-data libkf5calendarsupport5 libkf5calendarutils5 libkf5composereditorng5
  libkf5contacts-data libkf5contacts5 libkf5eventviews-data libkf5eventviews5 libkf5followupreminder5 libkf5gapi-data libkf5gapiblogger5 libkf5gapicalendar5 libkf5gapicontacts5
  libkf5gapicore5 libkf5gapitasks5 libkf5gpgmepp-pthread5 libkf5grantleetheme-plugins libkf5grantleetheme5 libkf5gravatar5 libkf5holidays-data libkf5holidays5 libkf5identitymanagement5
  libkf5imap5 libkf5incidenceeditor-bin libkf5incidenceeditor5 libkf5kaddressbookgrantlee5 libkf5kdepimdbusinterfaces5 libkf5kdgantt2-5 libkf5kiogui5 libkf5kmanagesieve5
  libkf5kontactinterface-data libkf5kontactinterface5 libkf5ksieve-data libkf5ksieve5 libkf5ksieveui5 libkf5ldap5 libkf5libkdepim-data libkf5libkdepim-plugins libkf5libkdepim5
  libkf5libkleo5 libkf5mailcommon-plugins libkf5mailcommon5 libkf5mailimporter5 libkf5mailtransport-data libkf5mailtransport5 libkf5mbox5 libkf5messagecomposer5 libkf5messagecore5
  libkf5messagelist5 libkf5messageviewer5 libkf5mime5 libkf5pimcommon-plugins libkf5pimcommon5 libkf5pimtextedit5 libkf5qgpgme5 libkf5sendlater5 libkf5syndication5 libkf5templateparser5
  libkolab1 libqt5xmlpatterns5 libwebrtc-audio-processing1
Die folgenden Pakete werden aktualisiert (Upgrade):
  akonadi-backend-sqlite akonadi-server akonadiconsole akregator apt apt-transport-https apt-utils blogilo cdrdao cpp-6 cups cups-bsd cups-client cups-common cups-core-drivers cups-daemon
  cups-ppdc cups-server-common dash desktop-file-utils dkms dpkg dpkg-dev fonts-mplus foomatic-db gcc-6 gcc-6-base glances grep hostname kaddressbook kalarm kde-l10n-de kde-runtime
  kde-runtime-data kdepim kdepim-doc kdepim-runtime kjots kleopatra kmail knode knotes konsolekalendar kontact korganizer ktimetracker libapt-inst2.0 libapt-pkg5.0 libasan3
  libatk-wrapper-java libatk-wrapper-java-jni libatomic1 libaudit-common libaudit1 libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libcalendarsupport4 libcap-ng0 libcc1-0 libcilkrts5
  libcups2 libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1 libdpkg-perl libebml4v5 liberror-perl libgcc-6-dev libgcc1 libgdata-common libgdata22 libgfortran3 libgimp2.0 libgomp1
  libgssdp-1.0-3 libgupnp-1.0-4 libhtml-parser-perl libincidenceeditorsng4 libitm1 libkdepim4 libkdepimdbusinterfaces4 libkdgantt2-0 libkleo4 libkpgp4 liblist-moreutils-perl liblsan0
  libmailcommon4 libmailimporter4 libmatroska6v5 libmbim-glib4 libmbim-proxy libmessagecomposer4 libmessagecore4 libmessageviewer4 libmoo-perl libmpx2 libncurses5 libncursesw5
  libnghttp2-14 libnss-myhostname libopusfile0 libpam-systemd libperl5.22 libpimcommon4 libpulse-mainloop-glib0 libpulse0 libpulsedsp libpython3.5 libpython3.5-minimal libpython3.5-stdlib
  libqmi-glib5 libqmi-proxy libquadmath0 libsendlater4 libslang2 libsmbclient libstdc++6 libsystemd0 libtalloc2 libtemplateparser4 libtinfo5 libtsan0 libubsan0 libudev1 libwbclient0
  libwebp5 libwebpdemux1 libwebpmux1 libwpd-0.10-10 libwpg-0.3-3 libwps-0.4-4 linux-libc-dev locales multiarch-support nano ncurses-base ncurses-bin network-manager-openvpn
  openprinting-ppds openvpn perl perl-base perl-modules-5.22 plasma-scriptengine-javascript postfix pulseaudio pulseaudio-module-gconf pulseaudio-module-x11 pulseaudio-module-zeroconf
  pulseaudio-utils python-talloc python3.5 python3.5-minimal rkhunter samba-common samba-libs sddm sshfs sudo systemd systemd-sysv tzdata udev
168 aktualisiert, 81 neu installiert, 6 zu entfernen und 0 nicht aktualisiert.
Es müssen 233 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 42,5 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] n
Abbruch.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: drb on 2016/07/09, 10:34:28
Are any/all of those 'removed' files replaced by new installations?
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: finotti on 2016/07/09, 12:38:42
It seems like it.  I don't see a replacement for kdepim-kresourse and I am not sure about the one for libnoteshared4, but the rest seem to be replaced: libeventviews4 by libkf5eventviews5, libkolab0v5 by libkolab1, libksieveui4 by libkf5ksieveui5, libmessagelist4 by libkf5messagelist5 and libnoteshared4 maybe by libkf5akonadinotes5.

But, I'm not an expert.  So, maybe we should wait for some to chime in.

Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: devil on 2016/07/09, 14:17:51
So far the packages to remove are o.k. to let go.


greetz
devil
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: drb on 2016/07/09, 14:26:00
Thanks!
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Lanzi on 2016/07/11, 11:20:17
So here it wants to deinstall

Code: [Select]
kdepim-kresources libeventviews4 libkolab0v5 libksieveui4 libmessagelist4 libnoteshared4

should I let it go?
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: der_bud on 2016/07/11, 11:47:05
...     should I let it go?   
Probably no one can tell you that from your partial output with only the removals, you might want to give us the whole one with new packages, too. For example, in bluelupo's output libeventviews4 gets removed, and libkf5eventviews5 comes new, there it is a good guess that the latter replaces the former. Investigate your apt output for similar patterns and decide.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/07/12, 12:06:33
Hi Community,

heute habe ich einen d-u auf einem meiner KDE Systeme durchgeführt (letzter d-u war am 4.7.2016). Der d-u lief ohne Fehler durch aber beim Start von kontact (kdepim) kommt folgende Fehlermeldung:
Code: [Select]
Im E-Mail-Programm ist ein schwerwiegender Fehler aufgetreten. Das Programm wird
beendet. Die Fehlermeldung lautet: Fehler beim Einholen der Ressourcen-Sammlung.

Danach wird kontact geschlossen, d.h. in diesem Zustand ist kdepim nicht nutzbar.

---

Today I have a d-u on one of my KDE performed Systems (updated d-u was on 07.04.2016). The d-u ran without fault through but when you start kontact (kdepim) comes the following error message:

(translated error message)
Code: [Select]
In email client a fatal error has occurred. The program is terminated. The error message is:
Error obtaining the resource collection.

Thereafter kontact closed, i.e. in this state is not usable kdepim.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: horo on 2016/07/12, 15:44:16
Hi bluelupo,

Looks like your above error correlates with your removed packages
Code: [Select]
Die folgenden Pakete werden ENTFERNT:
  kdepim-kresources ...

Thx for trying - we should wait...

Ciao, Martin
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: melmarker on 2016/07/12, 17:10:19
or drop kdepim at al - one should have a closer look to the dependencies - some devs consider qtwebkit as insecure and obsolete - qtwebengine isn't in debian and will not be in a certain amount of time. So we can distribute insecure or outdated software or simply drop it. Case solved 8)

BTW: This is not KDE nor KDEPIM bashing - i have replaced Midori in LXDE and Qupzilla in LXQt because of exactly these reasons.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/07/12, 20:15:10
Hi Community,
u.a. sind nachfolgende Fehlermeldungen bei einem Restart von akonadi im Log zu sehen.

Code: [Select]
$ akonadictl restart
[...]
akonadicore_log: Failed to request resource "akonadi_maildir_resource_0" : "Fehler beim Einholen der Ressourcen-Sammlung."
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Fehler beim Einholen der Ressourcen-Sammlung."
akonadicore_log: Failed to request resource "akonadi_maildir_resource_0" : "Fehler beim Einholen der Ressourcen-Sammlung."
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Fehler beim Einholen der Ressourcen-Sammlung."
log_maildispatcher: Failed to get outbox folder. Retrying in:  15000

Auch ein "akonadictl fsck" mit nachfolgenden "akonadictl vakuum" hat nichts zur Fehlerbehebung beigetragen.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: piper on 2016/07/13, 01:11:48
Did you delete

Code: [Select]
~/.local/share/akonadi/file-lost+found
after   akonadictl fsck and akonadictl vacuum

fsck should be first, then vacum, I don't have any of this installed (pim) and search disabled. I build without it, The information on the order it is done,  I got from #debian-qt-kde and took notes on it just in case it helps someone else
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/07/13, 09:05:23
Hi piper,

Here's what I've done (in this order):

Code: [Select]
$ akonadictl fsck
$ akonadictl vacuum # Could not be executed because the Akonadi backend (SQLlite) does not support according to error message
$ rm ~/.local/share/akonadi/file-lost+found/*

After a restart of akonadi carried out, but did not eliminate the problem.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: devil on 2016/07/13, 22:51:59
The transition to a new kdepim is still in full swing. IMHO it makes no sense to talk about things not working correctly right now. 'We should rather wait, until the transition is over, as Lisandro recommended in his above statement.


greetz
devil
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/07/15, 12:47:47
Stand der Transitionen von akonadi, kdepim und kdepimlibs
---
Prior transitions of akonadi, kdepim and kdepimlibs


https://release.debian.org/transitions/html/auto-akonadi.html
https://release.debian.org/transitions/html/auto-kdepim.html
https://release.debian.org/transitions/html/auto-kdepimlibs.html
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: mylo on 2016/07/20, 21:51:33
Hi bluelupo,

thanks for the links, these contain many informations. Sorry, but I cannot find out from these data, whether a
Code: [Select]
d-u is secure regarding plasma (whatever this is or brings me to) /pim or not.

For the users here, maybe it would be helpful, when one of the experts type down their opinion to the grade of safety and completeness of this complex story...so recommend or advice a discard on a d-u in relation to the transition state.

No one awaits here a safety guarantee, but to let all the nice users here in this nice community with a
Code: [Select]
d-u -s showing up some hundreds of packs without any advice is not good for the future of a distri.

Just my opinion.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: devil on 2016/07/20, 23:19:59
//expert mode// Transition is over. D-U to your hearts content//epert mode off //
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: mylo on 2016/07/20, 23:43:47
thanks devil, that is a statement I can forward with.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: dibl on 2016/07/20, 23:47:38
No one awaits here a safety guarantee ...


Safety guarantee = Debian Stable.


Adventure + Character-building = Debian sid.


 ;D
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: mylo on 2016/07/20, 23:56:39
the d-u went perfectly through, so thanks to all maintainers and contributors from my side
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: drooghead on 2016/07/21, 05:25:10
The dist-upgrade works well although I did have to install kdepim-addons to restore the header in the message pane of kmail.
Thanks to all those involved. 
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: manilg on 2016/07/21, 09:53:46
Code: [Select]
The dist-upgrade works well although I did have to install
kdepim-addons to restore the header in the message pane of kmail.

I can´t confirm this.

Code: [Select]
kmail
Pass a valid window to KWallet::Wallet::openWallet().
org.kde.akonadi.ETM: GEN true false false
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM:
org.kde.akonadi.ETM: GEN true false true
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM: GEN true false true
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM: GEN true false true
org.kde.akonadi.ETM: collection: QVector()
"Tag 'a' is not defined in message {<__kuit_internal_top__>KMail has many powerful features that are described in th...}."
"Tag 'br' is not defined in message {<__kuit_internal_top__>Thank you,[br /]The KMail Team</__kuit_internal_top__>}."
org.kde.akonadi.ETM: Subtree:  479 QSet(479)
org.kde.akonadi.ETM: Subtree:  397 QSet(500, 397, 498, 499)
org.kde.akonadi.ETM: Fetch job took  170 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 5
org.kde.akonadi.ETM: first fetched collection: "WEB.DE Freemail (manilg)"
org.kde.akonadi.ETM: Fetch job took  174 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 1
org.kde.akonadi.ETM: first fetched collection: "akonadi_maildir_resource_0"
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Could not create collection inbox, resourceId: 38"
log_mailcommon: "Im E-Mail-Programm ist ein schwerwiegender Fehler aufgetreten. Das Programm wird beendet.\nDie Fehlermeldung lautet:\nCould not create collection inbox, resourceId: 38"
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Could not create collection outbox, resourceId: 38"
log_mailcommon: "Im E-Mail-Programm ist ein schwerwiegender Fehler aufgetreten. Das Programm wird beendet.\nDie Fehlermeldung lautet:\nCould not create collection outbox, resourceId: 38"
akonadicore_log: Failed CollectionCreateJob. "Could not create collection outbox, resourceId: 38"
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Could not create collection sent-mail, resourceId: 38"
log_mailcommon: "Im E-Mail-Programm ist ein schwerwiegender Fehler aufgetreten. Das Programm wird beendet.\nDie Fehlermeldung lautet:\nCould not create collection sent-mail, resourceId: 38"
akonadicore_log: Failed CollectionCreateJob. "Could not create collection sent-mail, resourceId: 38"
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Could not create collection drafts, resourceId: 38"
log_mailcommon: "Im E-Mail-Programm ist ein schwerwiegender Fehler aufgetreten. Das Programm wird beendet.\nDie Fehlermeldung lautet:\nCould not create collection drafts, resourceId: 38"
akonadicore_log: Failed CollectionCreateJob. "Could not create collection drafts, resourceId: 38"
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Could not create collection trash, resourceId: 38"
log_mailcommon: "Im E-Mail-Programm ist ein schwerwiegender Fehler aufgetreten. Das Programm wird beendet.\nDie Fehlermeldung lautet:\nCould not create collection trash, resourceId: 38"
akonadicore_log: Failed CollectionCreateJob. "Could not create collection trash, resourceId: 38"
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Could not create collection templates, resourceId: 38"
log_mailcommon: "Im E-Mail-Programm ist ein schwerwiegender Fehler aufgetreten. Das Programm wird beendet.\nDie Fehlermeldung lautet:\nCould not create collection templates, resourceId: 38"
akonadicore_log: Failed CollectionCreateJob. "Could not create collection templates, resourceId: 38"
org.kde.akonadi.ETM: Fetch job took  307 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 0
org.kde.akonadi.ETM: Fetch job took  308 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 0
org.kde.akonadi.ETM: Fetch job took  308 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 0
QObject::connect: No such signal QObject::aboutToClose()
*** KMail got signal 11 (Exiting)
*** Dead letters dumped.
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kmail path = /usr/bin pid = 4029
KCrash: Arguments: /usr/bin/kmail
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
Invalid write to eventfd: Ungültiger Dateideskriptor
Code should not be reached at pulsecore/fdsem.c:199, function pa_fdsem_post(). Aborting.

kdepim-kresoursses is  not installable.

manilg
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/07/21, 11:17:21
Hi community,

Ich kann leider eine erfolgreiche Transition von kdepim auch nicht bestätigen. Immer noch nicht funktioniert eine Anbindung eines Adressbuches via Owncloud. Das Adressbuch selbst wird zwar eingebunden, aber die Kontakte im Adressbuch sind nicht zu sehen. Eine erfolgreiche Transition sieht für mich anders aus.

Ich würde den Fehler gerne bei Debian als Bugreport melden, aber bei welchen Programm-Paket ist der am besten aufgehoben? kdepim, kaddressbook, kmail, kontact oder wo sonst?

---

Unfortunately, I can successfully transition from kdepim not confirm. Still does not work, a connection of an address book via ownCloud. The address itself is indeed involved, but the contacts in the address book can not be seen. A successful transition looks to me differently.

I'd like to report errors in Debian as bug report, but in which program package is the best place?
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: vayu on 2016/07/21, 17:39:53
Edited to say never mind my question. I deleted everything kdepim and can now du.  I must have had conflicts from kdenext...
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/07/21, 20:44:47
Hier mein Bugreport zur CardDAV Ressource (KDEpim/Akonadi):
https://bugs.kde.org/show_bug.cgi?id=365959


EDIT: und hier mein Bugreport bei Debian https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=832048
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/07/21, 22:14:45
After upgrade, I get a "Failed to fetch the resource collection" when I try to start kontact or kmail. The early parts of my google search have shown me this message occurring back in 2011, so I'm still looking for something relevant. I've installed kde-l10n-uk as kdepim-kresources showed that it had been replaced with such packages.
I'll let you know if I find anything.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/07/21, 23:44:58
Now tried it on three boxes with the same result. Two of them didn't have e-mail accounts drawn up, as far as I recall.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/07/22, 00:21:15
Added kdepim-addons, but no change.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/07/22, 07:56:54
 From the command line, starting kontact produces the following
Code: [Select]
The kwalletd service has been registered
log_messagelist: Saved theme loading failed
log_messagelist: Saved theme loading failed
log_messagelist: Saved theme loading failed
QDBusConnection: name 'org.kde.kwalletd5' had owner '' but we thought it was ':1.86'
org.kde.akonadi.ETM: GEN true false false
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM:
org.kde.akonadi.ETM: GEN true false true
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM: GEN true false true
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM: GEN true false true
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM: Fetch job took  273 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 0
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Failed to fetch the resource collection."
log_mailcommon: "The Email program encountered a fatal error and will terminate now.\nThe error was:\nFailed to fetch the resource collection."
org.kde.akonadi.ETM: Fetch job took  320 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 0
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Failed to fetch the resource collection."
log_mailcommon: "The Email program encountered a fatal error and will terminate now.\nThe error was:\nFailed to fetch the resource collection."
akonadicore_log: Failed to request resource "akonadi_mixedmaildir_resource_1" : "Failed to fetch the resource collection."
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Failed to fetch the resource collection."
log_mailcommon: "The Email program encountered a fatal error and will terminate now.\nThe error was:\nFailed to fetch the resource collection."
akonadicore_log: Failed to request resource "akonadi_mixedmaildir_resource_1" : "Failed to fetch the resource collection."
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Failed to fetch the resource collection."
log_mailcommon: "The Email program encountered a fatal error and will terminate now.\nThe error was:\nFailed to fetch the resource collection."
akonadicore_log: Failed to request resource "akonadi_mixedmaildir_resource_1" : "Failed to fetch the resource collection."                                                     
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Failed to fetch the resource collection."                                                                     
log_mailcommon: "The Email program encountered a fatal error and will terminate now.\nThe error was:\nFailed to fetch the resource collection."                                 
akonadicore_log: Failed to request resource "akonadi_mixedmaildir_resource_1" : "Failed to fetch the resource collection."                                                     
akonadicore_log: Failed SpecialCollectionsRequestJob::slotResult "Failed to fetch the resource collection."                                                                     
log_mailcommon: "The Email program encountered a fatal error and will terminate now.\nThe error was:\nFailed to fetch the resource collection."                                 
akonadicore_log: Failed to request resource "akonadi_mixedmaildir_resource_1" : "Failed to fetch the resource collection."                                                     
org.kde.akonadi.ETM: Subtree:  1 QSet(150, 151, 1)                                     
org.kde.akonadi.ETM: Fetch job took  403 msec                                           
org.kde.akonadi.ETM: was collection fetch job: collections: 3                           
org.kde.akonadi.ETM: first fetched collection: "Search"                                 
org.kde.akonadi.ETM: Subtree:  1 QSet(150, 151, 1)                                     
org.kde.akonadi.ETM: Fetch job took  404 msec                                           
org.kde.akonadi.ETM: was collection fetch job: collections: 3                           
org.kde.akonadi.ETM: first fetched collection: "Search"                                 
org.kde.akonadi.ETM: Fetch job took  402 msec                                           
org.kde.akonadi.ETM: was collection fetch job: collections: 0 
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/07/22, 08:05:09
Hi Pip,
please opens up a bug report in KDE with your error description.

https://bugs.kde.org/
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/07/22, 21:01:23
Will do. I was just trying to check first to make sure it wasn't just my set ups or that I'd missed something obvious.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: orinoco on 2016/07/22, 21:30:32
Hello,


I can confirm the error.


* KMail window opens
* KWallet pops up
* Account assistant pops up
* Error pops up: Failes to fetch the resource collection


I hope my email-files are still availlable...
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/07/22, 22:43:21
I've opened a bug under akonadi. But I won't pick up notifications about it quickly since I don't have mail.
Creating a new user domain (wiping their home directory) allowed me to start Kontact, so it's some interaction with the user settings.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/07/23, 12:49:32
Hi Pip,
can you give us a link to the bug report?
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/07/23, 13:25:56
https://bugs.kde.org/show_bug.cgi?id=365991


I've tried removing all entries in .local/share/akonadi with no effect, so that's not where things are going wrong.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: devil on 2016/07/24, 09:36:03
I can confirm that on a fresh install without integrating an old home directory everything works relatively smooth. On an older install removing everything under .local/share/akonadi is not enougn- Unfortunately at the moment I have no time for further experimentation, but I would suggest to do a
Code: [Select]
mlocate akonadi and see what else there is to remove. Also purging everything kdepim related followed by a new install might get you somewhere.


greetz
devil
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/07/24, 14:05:38
On one machine (testing), akonadiconnectionrc is the culprit.
If the Data UnixPath entry is hashed out, kontact starts.
UnixPath=/tmp/akonadi-xxxxxxx/akonadiserver.socket

I'll get back later if there's any progress with the main box.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/07/24, 14:45:40
No, I probably won't have progress with that: if I disconnect Kontact from Akonadi by taking away the reference to the socket, it's unlikely I'll get anything good happening. It just seemed ok on the test box since there was no account. I'll have to raise an account there and seem what comes of it.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: orinoco on 2016/07/24, 16:23:39
I'm lost. Is it a kmail or an akonadi problem?


Now I'm preparing a new home-folder and located my emails in ~./.local/share/local-mail. I will create a new user und I hope it is enough to put the content of the old mail-folder to the new one?!?!


Is there a different (working) migration path for the email-folders? Please no re-install.

Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/07/24, 20:35:53
It's kmail interfacing with akonadi, I think. It's the akonadi logs that are reporting the lack of resource.
I haven't made any further progress - or, to put it another way, I haven't done any more work on it - so narrowing it down further is going to have to wait a bit. You'll probably see the same thing on your system if you take out the UnixPath (after suitable backups) and try to start kontact. My suspicion is that it will appear to work in that your kontact will appear, but it won't be populated.
Just a suspicion, though.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: davidb on 2016/08/01, 10:20:45
I still can't do a du:

Code: [Select]
$ LANG=C apt-get dist-upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 akonadi-server : Breaks: akonadiconsole (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
                  Breaks: kmail (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
                  Breaks: korganizer (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
 libkf5calendarsupport-data : Breaks: korganizer (<= 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
 libkf5ksieve-data : Breaks: kmail (<= 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
 libkf5libkdepim-data : Breaks: kaddressbook (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: der_bud on 2016/08/01, 10:59:52
...
Code: [Select]
...
 akonadi-server : Breaks: akonadiconsole (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed ...

Thats odd, because 4:16.04.3-1 is in Debian and 4:4.14.10-siduction1.7 not available here. Do you have an old install still with deprecated kdenext repo active? Please post output of
Code: [Select]
inxi -r
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: davidb on 2016/08/01, 11:15:57
Code: [Select]
$ LANG=C sudo inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/debian.list
           deb http://http.debian.net/debian/ unstable main contrib non-free                                                                                                               
           deb http://http.debian.net/debian/ experimental main                                                                                                                           
           deb-src http://http.debian.net/debian/ unstable main contrib non-free                                                                                                           
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list                                                                                                         
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main                                                                                                             
           Active apt sources in file: /etc/apt/sources.list.d/mono-xamarin.list                                                                                                           
           deb http://download.mono-project.com/repo/debian wheezy main                                                                                                                   
           Active apt sources in file: /etc/apt/sources.list.d/siduction.list                                                                                                             
           deb http://packages.siduction.org/base unstable main contrib non-free                                                                                                           
           deb http://packages.siduction.org/extra unstable main contrib non-free                                                                                                         
           deb http://packages.siduction.org/fixes unstable main contrib non-free
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: piper on 2016/08/01, 11:26:48
comment out (#)

Code: [Select]
deb http://packages.siduction.org/base unstable main contrib non-free
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main  
deb http://download.mono-project.com/repo/debian wheezy main

apt clean  (if you enabled it)

apt update && apt dist-upgrade

 
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: davidb on 2016/08/01, 14:26:28
This results in the same conflict.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: der_bud on 2016/08/01, 16:34:37
Ok, then please output of
Code: [Select]
apt-cache policy akonadiconsole
apt-cache policy kontact

(Seems some strange dependencies to old packages, probably some of the "but $foo is to be installed" ones will have to be removed and/or then reinstalled with explicit version number...)
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Taliesin on 2016/08/02, 10:40:03
Hi folks, I'm getting the same dist-upgrade problems as davidb.

Code: [Select]
apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 akonadi-server : Breaks: akonadiconsole (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
                  Breaks: kmail (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
                  Breaks: korganizer (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
 libkf5calendarsupport-data : Breaks: korganizer (<= 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
 libkf5libkdepim-data : Breaks: kaddressbook (< 4:16.04) but 4:4.14.10-siduction1.7 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

But...

Code: [Select]
apt-cache policy akonadi-server
akonadi-server:
  Installed: 1.13.0-8
  Candidate: 4:16.04.3-1
  Version table:
     4:16.04.3-1 500
        500 http://ftp.au.debian.org/debian unstable/main amd64 Packages
 *** 1.13.0-8 100
        100 /var/lib/dpkg/status
apt-cache policy akonadiconsole
akonadiconsole:
  Installed: 4:4.14.10-siduction1.7
  Candidate: 4:16.04.3-1
  Version table:
     4:16.04.3-1 500
        500 http://ftp.au.debian.org/debian unstable/main amd64 Packages
 *** 4:4.14.10-siduction1.7 100
        100 /var/lib/dpkg/status
root@sidvicious:/home/dave# apt-cache policy kmail
kmail:
  Installed: 4:4.14.10-siduction1.7
  Candidate: 4:16.04.3-1
  Version table:
     4:16.04.3-1 500
        500 http://ftp.au.debian.org/debian unstable/main amd64 Packages
 *** 4:4.14.10-siduction1.7 100
        100 /var/lib/dpkg/status
root@sidvicious:/home/dave# apt-cache policy korganizer
korganizer:
  Installed: 4:4.14.10-siduction1.7
  Candidate: 4:16.04.3-1
  Version table:
     4:16.04.3-1 500
        500 http://ftp.au.debian.org/debian unstable/main amd64 Packages
 *** 4:4.14.10-siduction1.7 100
        100 /var/lib/dpkg/status

So it seems while the upgradable packages are available, it wants to pull down older versions.

Oh and the following,

Code: [Select]
apt-cache policy kontact
kontact:
  Installed: 4:4.14.10-siduction1.7
  Candidate: 4:16.04.3-1
  Version table:
     4:16.04.3-1 500
        500 http://ftp.au.debian.org/debian unstable/main amd64 Packages
 *** 4:4.14.10-siduction1.7 100
        100 /var/lib/dpkg/status
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: davidb on 2016/08/02, 11:29:53
Yep, same as Tallesin.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: davidb on 2016/08/02, 18:07:46
Code: [Select]
sudo apt-mark hold akonadi-server libkf5calendarsupport-data libkf5ksieve-data libkf5libkdepim-data
Makes it possible to du again, but a solution would be very nice. Maybe it will resolve automaticly after some time...
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: der_bud on 2016/08/02, 21:17:28
Hi, sorry to say that, but it will not heal itself. You both seem to have leftovers from kdenext repo, which is no longer available. The packages are on your system now and not upgradable because of dependency issues ( /me no apt guru, perhaps someone else can can explain better).

So manual work is needed. You should delete the packages mentioned in the error messages and take note (!) of what apt does and which other packages are removed with the commands you issue (pipe output to a text file or such). Then reinstall those packages, I don't know if it is necessary to force the version in some cases. You should as well search your system for other suspect packages, meaning those with 'siduction' or 'really' in the package version string.

All this is not for granted, so have a backup. If unsure, come to IRC where might be better experts than me, prepare to work and chat in text mode and know how to use a paste service ;).
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Taliesin on 2016/08/03, 01:39:06
Hi der_bud.

thanks for the information.

Interesting to note that remnants of kdenext may well be the cause of the problem.

I'm more than happy to fire up a console and do things manually, in fact I prefer it that way.

Unfortunately I'm more familiar with how to 'force upgrade' and 'forcibly remove' individual packages of specific versions using RPM from my Fedora / Redhat days of long past.

Any one have any tips on how to do so using apt / apt-get.

I'll post the results of successes for the assistance of others.

Likewise the results of 'failures' for the purpose of further assistance if needed.

Cheers.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: hendrikL on 2016/08/03, 08:26:18
Maybe you are able to find some background information and a solution here:

http://forum.siduction.org/index.php?topic=5943.0
http://forum.siduction.org/index.php?topic=6072.msg50017#msg50017
http://forum.siduction.org/index.php?topic=5943.msg49417#msg49417

and please if nothing works -> irc.oftc.net #siduction
remember most members there are from Europa, okay piper not ;)

Okay, for sure, you can ask here too, if you run in trouble with removing the leftovers.

greetz. 
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Taliesin on 2016/08/03, 12:16:20
Hi all,

fixed and successfully dist-upgraded.

It was a 'simple' process of uninstalling the 'outdated' kdepim and associated packages, using

Code: [Select]
apt-get remove --purge "name of package"Once done, then I simply did an update / dist-upgrade.

Reinstalled the kdepim packages.

All good now.

Here I was thinking I'd have to chase down individual dependencies....

My thanks to all who have offered advice.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/08/04, 09:19:18
Eine Antwort zu meinen KDE-Bugreport (https://bugs.kde.org/show_bug.cgi?id=365959) bzgl. dem nicht angezeigten Adressbuch (via Owncloud).
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: davidb on 2016/08/06, 12:56:11
My thanks to all who have offered advice.


Yes, that worked. Thank you!
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: bluelupo on 2016/08/06, 13:16:06
Hi Taliesin,

do you have a possibility to include an addressbook of a resource ownCloud? This does not work for me.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: orinoco on 2016/08/06, 21:11:59
Hello,


a few days ago I installed PaintItBlack from scratch on a spare machine to follow devils recommendation. I'm sad to say, I got the same error message "Failed to fetch resource collection" after starting kmail.


Totally clueless. How did you got kontact/kmail to work properly?

Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/08/07, 00:13:11
Personally, I haven't. Tried a few things, but most clues seem to refer back to 2011 and they don't seem to apply any more.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: ayla on 2016/08/07, 09:53:55
Hi orinoco,

I got kmail running without an error message by following an advice from this thread:

https://forum.kde.org/viewtopic.php?f=215&t=120777

I startet akonadiconsole, opened the first tab (agents) and removed the "locale folder" agent. After reboot kmail startet but I could not send or receive emails. Kmail shows it works on it but didn't finished the job.
 I was trying around then a while, deleting kmail and kdepim, reinstalled, deleted the email acount profile (pop) 4 to 5 times, set it up anew, rebooted a few times....

And after all hope was gone I suddenly had a working kmail back with all my old emails but adresses were gone (Typing and get a choice of former used adresses).

For me that does not seem that kmail has getting anything near of more stable now but it does its job (sending/receiving emails) here again.

hth and good luck
ayla

Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/08/09, 21:18:35
To quote my KDE Bug report:

A way around: I took out the KMail Mail Folder agent and put in a Maildir agent pointing to the same place. At first glance, that seems to get around the problem, though there are still things to tidy up.

So, this might be the root of the problem. I'll have to actually run it for a while to find out, and it has (small issue) added a local mail directory that I've no interest in, but at least Kontact starts now with the mail and accounts in place.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/08/09, 21:20:24
No, scratch that: the directory structure is in place and some new mails are there, but not the old ones.
Still have to work on this.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/08/09, 21:22:45
It claims to be busy with syncing the folder, but it's staying stubbornly at 0%.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/08/09, 22:17:46
I'm getting mixed results: I've got old mail again - adding Local Folders in KMail settings, adding a KMail mail folder, removing the Maildir agent, sacrificing a chicken - and akonadi seems to be picking up new mail, but it's not putting it in the mail folder so I can't see it. It also downloads new mail, then gets stuck saving the downloaded messages.
That'll do for the night, I think. I'll go break something else now.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/09/22, 21:30:53
Eventually got a working system by switching to MariaDB instead of SQLITE3. I really wanted to keep the default, but it just didn't work.
It took a while to rebuild, but it is working now. Remember to install libqt5sql5-mysql if you do go this route.
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: ubahn1 on 2016/09/23, 14:32:37
Hi all,

fixed and successfully dist-upgraded.

It was a 'simple' process of uninstalling the 'outdated' kdepim and associated packages, using

Code: [Select]
apt-get remove --purge "name of package"
  • akonadiconsole
  • kmail
  • korganizer
  • kaddressbook
  • kontact
Once done, then I simply did an update / dist-upgrade.

Reinstalled the kdepim packages.

All good now.

Here I was thinking I'd have to chase down individual dependencies....

My thanks to all who have offered advice.


I did this, but it didn't work:

# apt install kalarm


Reading package lists... 100%
Reading package lists... Done

Building dependency tree       
Reading state information... Done

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kalarm : Depends: libkf5akonadicontact5 (>= 15.07.90) but it is not going to be installed
          Depends: libkf5akonadimime5 (>= 15.07.90) but it is not going to be installed
          Depends: libkf5libkdepim-plugins but it is not going to be installed
          Depends: libkf5libkdepim5 (>= 16.04) but it is not going to be installed
          Depends: libkf5mailtransport5 but it is not going to be installed
          Depends: libkf5pimcommon-plugins but it is not going to be installed
          Depends: libkf5pimcommon5 (>= 4:16.04) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Can anybody direct me to what I could do next, or do I just have to wait, and it will come right eventually?

Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: Pip on 2016/09/23, 22:38:52
The info would indicate the packages have been held. Have you tried explicitly installing them as well?
Title: Re: WARNING: KDEPim 16.04.2-1 Transitions started
Post by: ubahn1 on 2016/09/24, 23:44:12
I tried that initially, but it didn't work (I don't remember why).
But then I tried to solve the problem by installing the package kdepim-addons. This was just a guess. I figured that that wouldn't cause too much damage.
This is what happened:
Code: [Select]
# apt install kdepim-addons

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  kdepimlibs-data kf5-kdepim-apps-libs-data kf5-messagelib-data libkf5akonadicalendar5 libkf5akonadicontact5 libkf5akonadimime5 libkf5calendarsupport-data libkf5calendarsupport5
  libkf5eventviews-data libkf5eventviews5 libkf5followupreminder5 libkf5gpgmepp-pthread5 libkf5grantleetheme-plugins libkf5grantleetheme5 libkf5gravatar5 libkf5incidenceeditor-bin
  libkf5incidenceeditor5 libkf5kaddressbookgrantlee5 libkf5kdepimdbusinterfaces5 libkf5kdgantt2-5 libkf5libkdepim-plugins libkf5libkdepim5 libkf5libkleo5 libkf5mailcommon-plugins
  libkf5mailcommon5 libkf5mailimporter5 libkf5mailtransport5 libkf5mbox5 libkf5messagecomposer5 libkf5messagecore5 libkf5messageviewer5 libkf5pimcommon-plugins libkf5pimcommon5
  libkf5qgpgme5 libkf5sendlater5 libkf5templateparser5 libkf5tnef5 libkf5webkit5
Recommended packages:
  kde-config-mailtransport
The following packages will be REMOVED:
  kdepimlibs-kio-plugins libakonadi-calendar4 libakonadi-contact4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4 libkabc4 libkalarmcal2 libkcal4 libkgapi2-2 libkholidays4 libkolab0v5
  libkresources4 libktnef4 libmailtransport4
The following NEW packages will be installed:
  kdepim-addons kdepimlibs-data kf5-kdepim-apps-libs-data kf5-messagelib-data libkf5akonadicalendar5 libkf5akonadicontact5 libkf5akonadimime5 libkf5calendarsupport-data
  libkf5calendarsupport5 libkf5eventviews-data libkf5eventviews5 libkf5followupreminder5 libkf5gpgmepp-pthread5 libkf5grantleetheme-plugins libkf5grantleetheme5 libkf5gravatar5
  libkf5incidenceeditor-bin libkf5incidenceeditor5 libkf5kaddressbookgrantlee5 libkf5kdepimdbusinterfaces5 libkf5kdgantt2-5 libkf5libkdepim-plugins libkf5libkdepim5 libkf5libkleo5
  libkf5mailcommon-plugins libkf5mailcommon5 libkf5mailimporter5 libkf5mailtransport5 libkf5mbox5 libkf5messagecomposer5 libkf5messagecore5 libkf5messageviewer5 libkf5pimcommon-plugins
  libkf5pimcommon5 libkf5qgpgme5 libkf5sendlater5 libkf5templateparser5 libkf5tnef5 libkf5webkit5
0 upgraded, 39 newly installed, 15 to remove and 0 not upgraded.
Need to get 9,537 kB of archives.
After this operation, 11.3 MB of additional disk space will be used.
Do you want to continue? [Y/n]


So I went ahead, and afterwards kalarm installed without problems.
Then I also had to install the package "plasma-workspace" because of this:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=822061


So, it appears that all is well now.

EDIT: Set code tags (Moderator: bluelupo)