Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: absolut on 2016/08/17, 23:25:15

Title: [solved]apt dist-upgrade wants to remove pulseaudio-module-udev and systemd-shim
Post by: absolut on 2016/08/17, 23:25:15
last dist-upgrade was about 6 weeks ago (before summer vacations).

apt now wants to remove pulseaudio-module-udev and systemd-shim

i understand that pulseaudio-module-udev is now gone from the debian repos...

can anybody point me to how to find out why exactly systemd-shim is listed to be removed?

thanks in advance,
absolut

Code: [Select]
apt full-upgrade -dy
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  pulseaudio-module-udev systemd-shim
The following NEW packages will be installed:
  g++-6 gfortran-6 keyutils libboost-serialization1.61.0 libebur128-1 libgfortran-6-dev libicu57:i386 libip4tc0 libip6tc0 libiptc0 liblouis10 liblouisutdml7 libmagic-mgc libmnl0 libnetfilter-conntrack3 libprocps6 libpsl5 librtaudio5a
  libstdc++-6-dev libva-drm1:i386 libva-x11-1:i386 libvdpau1:i386 libwebp6:i386 libwebpdemux2 libwebpmux2:i386 linux-headers-4.7.1-towo.1-siduction-amd64 linux-image-4.7.1-towo.1-siduction-amd64 python3-apt
The following packages have been kept back:
  konq-plugins
The following packages will be upgraded:
  alsa-utils apt-listchanges ark base-passwd bind9-host binutils breeze breeze-cursor-theme bsdutils calibre-bin console-setup console-setup-linux cpp cpp-5 cpp-6 cups cups-browsed cups-bsd cups-client cups-common cups-core-drivers
  cups-daemon cups-filters cups-filters-core-drivers cups-ppdc cups-server-common curl darktable dbus dbus-x11 debhelper debian-goodies dh-python dh-strip-nondeterminism dirmngr dnsutils dolphin4 dpkg-dev encfs feh ffmpeg fig2dev file
  findutils fontconfig fontconfig-config fonts-dejavu fonts-dejavu-core fonts-dejavu-extra fonts-ebgaramond fonts-ebgaramond-extra fonts-noto-hinted fonts-opensymbol g++ g++-5 gcc gcc-5 gcc-5-base gcc-5-base:i386 gcc-6 gcc-6-base
  gcc-6-base:i386 gfortran gfortran-5 ghostscript ghostscript-x gimp gimp-data gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-gtk-3.0 git git-man gitk gnupg gnupg-agent gnupg2 gpgsm gpgv gtk-update-icon-cache gtk2-engines-pixbuf
  guile-2.0-libs gvfs gvfs-backends gvfs-bin gvfs-common gvfs-daemons gvfs-libs htop icedove init init-system-helpers initscripts insserv intel-microcode iotop iproute2 iptables iso-codes k3b k3b-data k3b-i18n kde-baseapps
  kde-baseapps-bin kde-baseapps-data kde-plasma-desktop kde-runtime kde-runtime-data kde-style-breeze kde-style-breeze-qt4 kde-style-oxygen-qt4 kdelibs-bin kdelibs5-data kdelibs5-plugins kdenlive kdenlive-data kdepasswd kdoctools
  keyboard-configuration kfind kipi-plugins-common konqueror konversation konversation-data ksysguard ksysguard-data ksysguardd ktimetracker kwin-common kwin-data kwin-style-breeze kwin-x11 libapt-inst2.0 libarchive-zip-perl
  libarchive13 libasan2 libasan3 libasound2 libasound2:i386 libasound2-data libassuan0 libatk-bridge2.0-0 libatomic1 libaudio2 libaudio2:i386 libaudit-common libaudit1 libavcodec57 libavcodec57:i386 libavdevice57 libavfilter6
  libavformat57 libavresample3 libavresample3:i386 libavutil55 libavutil55:i386 libbasicusageenvironment1 libbind9-140 libblas-common libblas-dev libblas3 libblkid1 libbluetooth3 libc-bin libc-dev-bin libc-l10n libc6 libc6:i386
  libc6-dev libcc1-0 libcdr-0.1-1 libcilkrts5 libclass-method-modifiers-perl libclucene-contribs1v5 libclucene-core1v5 libcups2 libcups2:i386 libcupscgi1 libcupsfilters1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3 libcurl3-gnutls
  libcurses-perl libdb5.3 libdb5.3:i386 libdbus-1-3 libdbus-1-3:i386 libdbus-1-dev libdebconfclient0 libdlrestrictions1 libdns-export162 libdns162 libdpkg-perl libdrm-amdgpu1 libdrm-amdgpu1:i386 libdrm-intel1 libdrm-intel1:i386
  libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386 libdv4 libe-book-0.1-1 libelf1 libelf1:i386 liberror-perl libfdisk1 libfile-stripnondeterminism-perl libfontconfig1 libfontconfig1:i386
  libfontembed1 libgail18 libgcc-5-dev libgcc-6-dev libgcc1 libgcc1:i386 libgcrypt20 libgcrypt20:i386 libgd3 libgd3:i386 libgfortran-5-dev libgfortran3 libgimp2.0 libgirepository-1.0-1 libglib2.0-0 libglib2.0-0:i386 libgoa-1.0-0b
  libgoa-1.0-common libgomp1 libgomp1:i386 libgpg-error0 libgpg-error0:i386 libgpgme++2v5 libgraphicsmagick-q16-3 libgroupsock8 libgs9 libgs9-common libgssapi-krb5-2 libgssapi-krb5-2:i386 libgtk-3-0 libgtk-3-bin libgtk-3-common
  libgtk2.0-0 libgtk2.0-common libgtkglext1 libharfbuzz-icu0 libharfbuzz0b libhpmud0 libibverbs1 libical2 libid3tag0 libidn11 libidn11:i386 libinput-bin libinput10 libio-socket-ssl-perl libisc-export160 libisc160 libisccc140
  libisccfg140 libitm1 libjack-jackd2-0 libjack-jackd2-0:i386 libjavascriptcoregtk-4.0-18 libjpeg-progs libjpeg9 libjs-iscroll libjs-sphinxdoc libjson-glib-1.0-0 libjson-glib-1.0-common libk3b6 libk3b6-extracodecs libk5crypto3
  libk5crypto3:i386 libkabc4 libkcalcore4 libkcmutils4 libkde3support4 libkdeclarative5 libkdecorations2-5v5 libkdecorations2private5v5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkf5archive5
  libkf5gpgmepp5 libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkldap4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common libkonq5-templates
  libkonq5abi1 libkonqsidebarplugin4a libkparts4 libkpathsea6 libkprintutils4 libkpty4 libkrb5-3 libkrb5-3:i386 libkrb5support0 libkrb5support0:i386 libkresources4 libkrosscore4 libksba8 libktexteditor4 libkwalletbackend5-5
  libkwin4-effect-builtins1 libkwineffects8 libkwinglutils8 libkwinxrenderutils8 libkxmlrpcclient4 liblapack-dev liblapack3 liblightdm-gobject-1-0 liblightdm-qt-3-0 liblist-moreutils-perl liblivemedia52 libllvm3.8 libllvm3.8:i386
  liblouis-bin liblouis-data liblouisutdml-bin liblouisutdml-data liblsan0 libltdl7 libltdl7:i386 liblua5.2-0 liblwres141 libmagic1 libmlt++3 libmlt6 libmm-glib0 libmms0 libmount1 libmpx0 libmpx2 libmspub-0.1-1 libmwaw-0.3-3
  libneon27-gnutls libnepomuk4 libnepomukquery4a libnepomukutils4 libnet-ssleay-perl libnghttp2-14 libnm-glib-vpn1 libnm-glib4 libnm-util2 libnm0 libnspr4 libnss3 libopenexr22 libopenjp2-7 libopenjp2-7:i386 liborcus-0.11-0 libp11-kit0
  libp11-kit0:i386 libpam-systemd libpcre16-3 libpcre3 libpcre3:i386 libpcre3-dev libpcre32-3 libpcrecpp0v5 libpcsclite1 libperl5.22 libphonon4 libphonon4qt5-4 libplasma3 libpng16-16 libpng16-16:i386 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libpostproc54 libpsm-infinipath1 libptexenc1 libpulse-mainloop-glib0 libpulse0 libpulse0:i386 libpulsedsp libpython2.7 libpython2.7-minimal libpython2.7-stdlib libpython3.5
  libpython3.5-minimal libpython3.5-stdlib libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5quickwidgets5 libqt5sql5 libqt5sql5-sqlite libqt5test5
  libqt5webkit5 libqt5widgets5 libqt5xml5 libqtglib-2.0-0 libqtwebkit4 libqtwebkit4:i386 libquadmath0 libraw15 librevenge-0.0-0 libsane-hpaio libsdl-image1.2 libsearchclient0v5 libservlet3.1-java libsigc++-2.0-0v5 libsmartcols1
  libsolid4 libsqlite3-0 libsqlite3-0:i386 libssh2-1 libstdc++-5-dev libstdc++6 libstdc++6:i386 libstreamanalyzer0v5 libstreams0v5 libstrigihtmlgui0v5 libstrigiqtdbusclient0 libswresample2 libswresample2:i386 libswscale4 libsynctex1
  libsyndication4 libsystemd0 libsystemd0:i386 libtasn1-6 libtasn1-6:i386 libtcl8.6 libtexlua52 libtexluajit2 libthreadweaver4 libtiff5 libtiff5:i386 libtk8.6 libtool libtsan0 libubsan0 libudev1 libudev1:i386 libusageenvironment3
  libuuid1 libuuid1:i386 libva-drm1 libva-glx1 libva-x11-1 libva1 libva1:i386 libvisio-0.1-1 libvlc5 libvpx3 libvpx3:i386 libwebkit2gtk-4.0-37 libwildmidi-config libwps-0.4-4 libxcb-composite0 libxcb-damage0 libxcb-dpms0 libxcb-dri2-0
  libxcb-dri2-0:i386 libxcb-dri3-0 libxcb-dri3-0:i386 libxcb-glx0 libxcb-glx0:i386 libxcb-present0 libxcb-present0:i386 libxcb-randr0 libxcb-randr0:i386 libxcb-record0 libxcb-render0 libxcb-render0:i386 libxcb-shape0
  libxcb-shape0:i386 libxcb-shm0 libxcb-shm0:i386 libxcb-sync1 libxcb-sync1:i386 libxcb-xfixes0 libxcb-xfixes0:i386 libxcb-xinerama0 libxcb-xkb1 libxcb-xv0 libxcb1 libxcb1:i386 libxml-libxml-perl libxml2 libxml2:i386 libxml2-utils
  libxslt1.1 libxslt1.1:i386 libxtables11 libzvbi-common libzvbi0 libzvbi0:i386 lightdm linux-headers-siduction-amd64 linux-image-siduction-amd64 linux-libc-dev locales manpages manpages-de melt milou mobile-broadband-provider-info
  most mount mpi-default-bin multiarch-support mysql-common nano network-manager nfs-common openssh-client openssh-server openssh-sftp-server oxygen-icon-theme oxygen-sounds p7zip p7zip-full paintitblack-grub-theme
  paintitblack-wallpapers paraview perl perl-base perl-modules-5.22 phonon phonon4qt5 plasma-integration plasma-scriptengine-javascript policykit-1 printer-driver-escpr printer-driver-hpcups procps pulseaudio pulseaudio-utils
  python-apt python-apt-common python-backports-abc python-backports.ssl-match-hostname python-cffi-backend python-cryptography python-cssselect python-debianbts python-enum34 python-glade2 python-gobject-2 python-gtk2 python-imaging
  python-libxml2 python-lz4 python-mpi4py python-msgpack python-openssl python-pandas python-pandas-lib python-pexpect python-pil python-pkg-resources python-pyparsing python-pyqt5 python-pyqt5.qtsvg python-pyqt5.qtwebkit
  python-routes python-setuptools python-sip python-tornado python-twisted python-twisted-bin python-twisted-core python-zope.interface python2.7 python2.7-minimal python3-pexpect python3-pil python3-pkg-resources python3.5
  python3.5-minimal qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings qml-module-qtquick-controls-styles-breeze qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qtwebkit qt5-image-formats-plugins scdaemon
  siduction-scripts smartmontools ssft startpar strigi-client strigi-daemon systemd systemd-sysv sysv-rc sysvinit-utils tar tcl8.6 texlive-base texlive-binaries texlive-extra-utils texlive-latex-base texlive-latex-recommended tk8.6
  transfig udev usb-modeswitch-data util-linux wget wpasupplicant x11-common xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-all youtube-dl
638 upgraded, 28 newly installed, 2 to remove and 1 not upgraded.
Need to get 0 B/735 MB of archives.
After this operation, 204 MB of additional disk space will be used.
Download complete and in download only mode
Title: Re: apt dist-upgrade wants to remove pulseaudio-module-udev and systemd-shim
Post by: melmarker on 2016/08/17, 23:41:30
 systemd-sysv : Kollidiert mit: systemd-shim but 10-2 is to be installed
---
halt andersrum
Title: Re: apt dist-upgrade wants to remove pulseaudio-module-udev and systemd-shim
Post by: absolut on 2016/08/18, 00:48:48
hi melmarker,

thanks for the response. can you also share how you got it? and which package should be preserved shim or sysv?

since i moved to systemd with siduction upgrade path, there might still be some legacy packages around. :-S

thanks
absolut
Title: Re: apt dist-upgrade wants to remove pulseaudio-module-udev and systemd-shim
Post by: melmarker on 2016/08/18, 01:00:20
i'v looked in systemd and found no conflict - so i tried to install systemd-shim and s-sysv was the conflicting package :)

And that make sense - one can't have both - one could go with sysv - in that case the shim is needed - or one could go with systemds - in that case it is clever to have the sysv compat layer :)
Title: Re: apt dist-upgrade wants to remove pulseaudio-module-udev and systemd-shim
Post by: absolut on 2016/08/18, 21:54:46
okay, thanks for the feedback.

ran dist-upgrade, and left both packages go. smooth sailing so far.

best
absolut