Siduction Forum

Siduction Forum => Free Speech / Freie Rede => Topic started by: bluelupo on 2016/09/21, 15:02:36

Title: Strategie von Debian bzgl. KDEpim
Post by: bluelupo on 2016/09/21, 15:02:36
Hi Community,

ich bin wie ihr wisst ein eingefleischter und langjähriger KDE-Nutzer und melde selbstverständlich Fehler bei Debian und KDE. Seit geraumer Zeit bin ich aber vom Zustand des KDEpim in Debian Unstable enttäuscht.

Die KDE-Baseapps sind schon in Version 16.08.0 in SID, warum nicht das KDEpim-Paket? Ich kann mir vorstellen das viele gemeldete Fehler schon aufgrund der Versionsunterschiede auftreten. Die KDEpim Version (mit seinen Einzelkomponenten) 16.04.3 ist in SID seit 17. Juli.

Code: [Select]
Package: kdepim
Version: 4:16.04.3-1
Installed-Size: 253
Maintainer: Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Architecture: all
Depends: accountwizard (>= 4:16.04.3-1), akonadiconsole (>= 4:16.04.3-1), akregator (>= 4:16.04.3-1), blogilo (>= 4:16.04.3-1), kaddressbook (>= 4:16.04.3-1), kalarm (>= 4:16.04.3-1), kdepim-runtime, kleopatra, kmail (>= 4:16.04.3-1), knotes (>= 4:16.04.3-1), konsolekalendar (>= 4:16.04.3-1), kontact (>= 4:16.04.3-1), korganizer (>= 4:16.04.3-1)
Recommends: kdepim-doc, kdepim-addons

Kann mir jemand erklären warum diese Versionsunterschiede innerhalb des KDE-Desktops immer so auseinander laufen?

In der Praxis sieht es für mich so aus das ich oftmals für "alte" Versionen in Debian Unstable aufgetretene Fehler reporte, die vermutlich in einer aktuellen Version schon längst behoben sind.

Steht da eine bestimmte Strategie in Debian dahinter das dieser Zustand so ist wie sich für mich gerade darstellt?


---Translated in EN---


Hi Community,

I am, as you know, a long-time KDE users and reporting course error in Debian and KDE. For some time now but I am disappointed with the state of the kdepim in Debian Unstable.

The KDE Base apps are already in version 16.08.0 in SID, why not the kdepim package? I can imagine that many reported errors already occur due to the differences between versions. The kdepim version (with its individual components) 16.04.3's SID since 17 of July.

Can anyone explain why this version differences always run so apart within the KDE desktop me?

In practice, it looks to me like I reporte often encountered for "old" versions in Debian Unstable errors that are supposedly already fixed in the latest version.

Is there a certain strategy in Debian behind the this state so as to represent for me now?
Title: Re: Strategie von Debian bzgl. KDEpim
Post by: dibl on 2016/09/21, 23:30:18
Since KDE 4 was released, I have seen many many reports of problems with KDE PIM.  For that reason, I have never attempted to use it, but rather have stayed with my ancient AOL web mail and smart phone for contacts and phone numbers.  Seems I have saved myself some grief.
Title: Re: Strategie von Debian bzgl. KDEpim
Post by: piper on 2016/09/22, 10:03:01
I feel your pain bluelupo   :(

I actually have no use for KDE PIM period and all my builds come without it.

KDE PIM is currently split to over 40 modules,
which to me, = 40 modules of bloat.

But,  one man's bloat equals another man's treasure   :)

https://kdesrc-build.kde.org/
https://quickgit.kde.org/