Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: devil on 2016/11/23, 07:39:44

Title: [solved] Warnig: No dist-upgrade
Post by: devil on 2016/11/23, 07:39:44
Be careful today. x11-common is broken: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=%23845398 (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=%23845398)
Should be fixed soon.
Title: Re: Warnig: No dist-upgrade
Post by: devil on 2016/11/23, 14:51:18
Problem solved, x11-common  all 1:7.7+18 shoulbe be in with nexr sync.
Title: Re: Warnig: No dist-upgrade
Post by: Geier0815 on 2016/11/23, 17:56:18
But instead it has broken other packages?
Quote
Die folgenden Pakete werden ENTFERNT:
  iptables nvidia-legacy-340xx-driver xorg xserver-xorg xserver-xorg-input-all
  xserver-xorg-input-evdev xserver-xorg-input-libinput
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xserver-xorg-input-wacom
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-nouveau
  xserver-xorg-video-nvidia-legacy-340xx xserver-xorg-video-radeon
  xserver-xorg-video-vesa xserver-xorg-video-vmware
Or is this another problem?
Title: Re: Warnig: No dist-upgrade
Post by: devil on 2016/11/23, 18:19:24
It is not the problem of a broken x11-common package. It might be, that some part of X11 is still missing or it might be fallout of the libc6-update on multiarch machines. I cannot find any clues right now
Title: Re: Warnig: No dist-upgrade
Post by: Maik on 2016/11/23, 18:48:51
Hier zickt nach Upgrade xserver-xorg-core rum, will xserver-xorg & CO entfernen

Quote
Die folgenden Pakete werden ENTFERNT:
  nodm nvidia-driver xorg xserver-xorg xserver-xorg-input-evdev xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-video-fbdev xserver-xorg-video-nouveau xserver-xorg-video-nvidia
Die folgenden NEUEN Pakete werden installiert:
  libxfont2
Die folgenden Pakete werden aktualisiert (Upgrade):
  xserver-xorg-core
1 aktualisiert, 1 neu installiert, 10 zu entfernen und 0 nicht aktualisiert.
---
xserver-xorg:
  Installiert:           1:7.7+18
  Installationskandidat: 1:7.7+18
  Versionstabelle:
 *** 1:7.7+18 990
        990 http://http.debian.net/debian sid/main amd64 Packages
        100 http://incoming.debian.org/debian-buildd buildd-unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     1:7.7+16 600
        600 http://http.debian.net/debian stretch/main amd64 Packages
     1:7.7+7 500
        500 http://http.debian.net/debian jessie/main amd64 Packages
xserver-xorg-core:
  Installiert:           2:1.18.4-2
  Installationskandidat: 2:1.19.0-1
  Versionstabelle:
     2:1.19.0-1 990
        990 http://http.debian.net/debian sid/main amd64 Packages
        100 http://incoming.debian.org/debian-buildd buildd-unstable/main amd64 Packages
 *** 2:1.18.4-2 600
        600 http://http.debian.net/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     2:1.16.4-1 500
        500 http://http.debian.net/debian jessie/main amd64 Packages
Title: Re: Warnig: No dist-upgrade
Post by: seasons on 2016/11/24, 13:36:29
https://release.debian.org/transitions/html/xserver1.19.html
Title: Re: Warnig: No dist-upgrade
Post by: Maik on 2016/11/24, 16:27:40
Be careful today. x11-common is broken: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=%23845398
Should be fixed soon.

Thanks  ::)
Title: Re: Warnig: No dist-upgrade
Post by: KrunchTime on 2016/11/25, 00:26:27
Got the following a few moments ago when attempting to dist-upgrade:
Code: [Select]

The following packages were automatically installed and are no longer required:
  exuberant-ctags geany-plugin-addons geany-plugin-autoclose
  geany-plugin-automark geany-plugin-codenav geany-plugin-ctags
  geany-plugin-debugger geany-plugin-defineformat geany-plugin-devhelp
  geany-plugin-doc geany-plugin-extrasel geany-plugin-gendoc
  geany-plugin-geniuspaste geany-plugin-git-changebar geany-plugin-insertnum
  geany-plugin-latex geany-plugin-lineoperations geany-plugin-lipsum
  geany-plugin-lua geany-plugin-macro geany-plugin-miniscript
  geany-plugin-multiterm geany-plugin-numberedbookmarks geany-plugin-overview
  geany-plugin-pairtaghighlighter geany-plugin-pg geany-plugin-pohelper
  geany-plugin-prettyprinter geany-plugin-prj geany-plugin-projectorganizer
  geany-plugin-sendmail geany-plugin-shiftcolumn geany-plugin-spellcheck
  geany-plugin-tableconvert geany-plugin-treebrowser
  geany-plugin-updatechecker geany-plugin-vc geany-plugin-webhelper
  geany-plugin-xmlsnippets intltool-debian libarchive-zip-perl libc-dev-bin
  libctpl2 libfile-stripnondeterminism-perl libgit2-24 libgtkspell0
  libhttp-parser2.1 libip6tc0 libiptc0 libxatracker2 libxfont2 libxvmc1
  linux-libc-dev po-debconf x11-apps x11-session-utils xbitmaps xfonts-100dpi
  xfonts-75dpi xfonts-base xfonts-scalable xinit xserver-common
  xserver-xorg-core
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  build-essential debhelper dh-autoreconf dh-make dh-strip-nondeterminism
  equivs g++ g++-6 geany-plugin-py geany-plugins gufw iptables libc6-dev
  libexpat1-dev libpython2.7-dev libstdc++-6-dev libtool ufw xorg xpra
  xserver-xorg xserver-xorg-input-all xserver-xorg-input-evdev
  xserver-xorg-input-libinput xserver-xorg-input-mouse
  xserver-xorg-input-synaptics xserver-xorg-input-vmmouse
  xserver-xorg-input-void xserver-xorg-input-wacom xserver-xorg-video-all
  xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-cirrus
  xserver-xorg-video-dummy xserver-xorg-video-fbdev xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-savage
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware
The following NEW packages will be installed:
  libldap-common libxfont2
The following packages have been kept back:
  libc6 libc6-dbg
The following packages will be upgraded:
  binutils clamtk console-setup console-setup-linux cpp devscripts dirmngr
  fonts-lyx gcc gir1.2-gtk-3.0 gnupg gnupg-agent gnupg-l10n gnupg2 gpa gpgsm
  gpgv gstreamer1.0-plugins-good gstreamer1.0-pulseaudio gtk-update-icon-cache
  imagemagick imagemagick-6-common imagemagick-6.q16 keyboard-configuration
  libbcmail-java libbcpkix-java libbcprov-java libc-bin libc-dev-bin libc-l10n
  libcgi-fast-perl libdebconfclient0 libedit2 libedit2:i386 libgcj-bc
  libgcj-common libglib2.0-0 libglib2.0-data libgpgme11 libgtk-3-0
  libgtk-3-bin libgtk-3-common libhtml-parser-perl libip4tc0 libip6tc0
  libiptc0 libldap-2.4-2 libldap-2.4-2:i386 liblockfile-bin liblockfile1
  libmagickcore-6.q16-2 libmagickcore-6.q16-2-extra libmagickwand-6.q16-2
  libmwaw-0.3-3 libparams-validationcompiler-perl libpath-tiny-perl libprocps6
  libpython2.7 libpython2.7-minimal libpython2.7-stdlib libpython3.5
  libpython3.5-minimal libpython3.5-stdlib libruby2.3 libshine3 libshine3:i386
  libssl1.1 libustr-1.0-1 libvlc-bin libvlc5 libvlccore8 libxfont1 locales
  multiarch-support ntp ntpdate openssl procps python-xapian python2.7
  python2.7-minimal python3.5 python3.5-minimal rsyslog ruby-atk
  ruby-gdk-pixbuf2 ruby-gio2 ruby-glib2 ruby-gobject-introspection ruby-gtk2
  ruby-pango ruby2.3 scrot stunnel4 vivaldi-stable vlc vlc-bin vlc-data
  vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba
  vlc-plugin-skins2 vlc-plugin-video-output vlc-plugin-video-splitter
  vlc-plugin-visualization vpnc x11-common xfonts-utils xserver-common
  xserver-xorg-core
112 upgraded, 2 newly installed, 49 to remove and 2 not upgraded.
Need to get 131 MB of archives.
After this operation, 116 MB disk space will be freed.
So, I cherry-picked and installed most of the upgrades, which went fine.  Those upgrades that would have resulted in removed packages, I opted not to upgrade.  Rebooted and LightDM now will not start and
Code: [Select]
startx would not work, so I have no GUI, which means I can't dist-upgrade at all because network-manager will only work in a GUI.   :'(

Lesson learned; next time I encounter something like this I will just wait or at least check here before proceeding.

Note:  I run the BunsenLabs distro tracking Debian Unstable.
Title: Re: Warnig: No dist-upgrade
Post by: melmarker on 2016/11/25, 00:42:28
lesson 2: Learn about ceni or in case of bunsen maybe ifupdown
Title: Re: Warnig: No dist-upgrade
Post by: seasons on 2016/11/25, 05:18:52
Lesson learned; next time I encounter something like this I will just wait or at least check here before proceeding.
Be very careful with transitions, especially critical stuff like xserver.

Quote
Learn about ceni or in case of bunsen maybe ifupdown
Yeah, I use good old ifupdown and simple tect file configuration. It allowed me to get rid of network manager and systemd's networking module (and shaves a few seconds off boot).
Title: Re: Warnig: No dist-upgrade
Post by: Carnophage on 2016/11/25, 08:21:54
There is always nmcli too https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Networking_Guide/sec-Using_the_NetworkManager_Command_Line_Tool_nmcli.html
Title: Re: Warnig: No dist-upgrade
Post by: KrunchTime on 2016/11/25, 09:27:43
Okay, I stand corrected.  I do have network access in tty1 mode, so I am still able to perform system updates.  Some over in the BunsenLabs forums also pointed out ifupdown, ceni, and nmcli.
Title: Re: Warnig: No dist-upgrade
Post by: zash1958 on 2016/11/25, 11:00:36
For me:

Code: [Select]
Die folgenden Pakete werden ENTFERNT:
  build-essential debhelper dh-autoreconf dh-strip-nondeterminism g++ g++-5 g++-6 iptables libblkid-dev libc6-dev libexpat1-dev libpython-dev
  libpython2.7-dev libstdc++-5-dev libstdc++-6-dev libtool python-dev python2.7-dev uuid-dev virtualbox-guest-source virtualbox-guest-x11
Die folgenden NEUEN Pakete werden installiert:
  libaccounts-glib0 libaccounts-qt5-1 libboost-regex1.62.0 libkaccounts1 libkf5purpose-bin libkf5purpose5 libldap-common libsignon-qt5-1 libuv1
  libxfont2 linux-image-4.8.10-towo.1-siduction-amd64 nodejs nodejs-legacy qml-module-org-kde-purpose
Die folgenden Pakete sind zurückgehalten worden:
  libc6 libc6-i386
Die folgenden Pakete werden aktualisiert (Upgrade):
  accountwizard akonadi-backend-mysql akonadi-backend-sqlite akonadi-server akonadiconsole akregator ark aspell-en binutils blogilo bluedevil breeze
  breeze-cursor-theme console-setup console-setup-linux cpp cpp-6 dirmngr dolphin dolphin4 dragonplayer filelight firefox firefox-l10n-de
  fonts-freefont-ttf gcc gcc-6 gcc-6-base gcc-6-base:i386 gnupg gnupg-agent gnupg2 gpgsm gpgv gstreamer1.0-plugins-good gstreamer1.0-pulseaudio
  gtk-update-icon-cache gwenview imagemagick imagemagick-6-common imagemagick-6.q16 imagemagick-common juk kactivitymanagerd kaddressbook kalarm kamera
  kate kate5-data kcalc kcolorchooser kde-baseapps kde-baseapps-bin kde-baseapps-data kde-cli-tools kde-cli-tools-data kde-config-cddb
  kde-config-gtk-style kde-config-gtk-style-preview kde-config-screenlocker kde-config-sddm kde-config-touchpad kde-runtime kde-runtime-data
  kde-spectacle kde-style-breeze kde-style-breeze-qt4 kdegraphics-thumbnailers kdelibs-bin kdelibs5-data kdelibs5-plugins kdepasswd kdepim kdepim-doc
  kdeplasma-addons-data kdf kdoctools keyboard-configuration kfind kgamma5 kgpg khelpcenter khotkeys khotkeys-data kinfocenter kio-audiocd kmail
  kmenuedit knotes kolourpaint4 konq-plugins konqueror konqueror-nsplugins konsole konsole-kpart konsolekalendar kontact korganizer kpackagetool5 krdc
  kremotecontrol krfb kscreen ksnapshot ksshaskpass ksysguard ksysguard-data ksysguardd ksystemlog kwalletmanager kwin-addons kwin-common kwin-data
  kwin-style-breeze kwin-x11 kwrite kwrited libasan3 libastro1 libatomic1 libc-bin libc-dev-bin libc-l10n libcc1-0 libcilkrts5 libdebconfclient0
  libdolphinvcs5 libedit2 libgail-3-0 libgcc-6-dev libgcc1 libgcc1:i386 libgcj-common libgcj17 libgfortran3 libglib2.0-0 libglib2.0-0:i386
  libglib2.0-bin libglib2.0-data libgomp1 libgpgme11 libgtk-3-0 libgtk-3-bin libgtk-3-common libhtml-parser-perl libimage-magick-perl
  libimage-magick-q16-perl libio-socket-ssl-perl libip4tc0 libip6tc0 libiptc0 libitm1 libkasten3controllers3 libkasten3core3 libkasten3gui3
  libkasten3okteta1controllers1 libkasten3okteta1core1 libkasten3okteta1gui1 libkcddb4 libkcmutils4 libkde3support4 libkdeclarative5
  libkdecorations2-5v5 libkdecorations2private5v5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkf5akonadiagentbase5
  libkf5akonadicore-bin libkf5akonadicore5 libkf5akonadiprivate5 libkf5akonadiwidgets5 libkf5package-data libkf5package5 libkf5screen-bin libkf5screen7
  libkf5sysguard-bin libkf5sysguard-data libkfile4 libkfontinst5 libkfontinstui5 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
  libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common libkonq5-templates libkonq5abi1 libkonqsidebarplugin4a libkparts4
  libkprintutils4 libkpty4 libkrosscore4 libkrossui4 libkscreenlocker5 libksgrd7 libksignalplotter7 libktexteditor4 libkwin4-effect-builtins1
  libkwineffects9 libkwinglutils9 libkwinxrenderutils9 libkworkspace5-5 libldap-2.4-2 liblsan0 libmagick++-6.q16-6v6 libmagickcore-6.q16-2
  libmagickwand-6.q16-2 libmarblewidget-qt5-25 libmpx2 libmwaw-0.3-3 libnepomuk4 libnepomukquery4a libnepomukutils4 libnetcdf11 libnss-myhostname
  libokteta2core2 libokteta2gui2 libpam-systemd libplasma-geolocation-interface5 libplasma3 libpowerdevilcore2 libpowerdevilui5 libprocesscore7
  libprocessui7 libprocps6 libprotobuf10 libpython2.7 libpython2.7-minimal libpython2.7-stdlib libpython3.5 libpython3.5-minimal libpython3.5-stdlib
  libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5sql5 libqt5sql5-mysql libqt5sql5-sqlite
  libqt5test5 libqt5widgets5 libqt5xml5 libqtwebkit4 libquadmath0 libruby2.3 libshine3 libsndio6.1 libsolid4 libssl1.1 libstdc++6 libstdc++6:i386
  libsystemd0 libsystemd0:i386 libtaskmanager6 libthreadweaver4 libtsan0 libubsan0 libudev1 libudev1:i386 libustr-1.0-1 libvlc-bin libvlc5 libvlccore8
  libweather-ion7 libxfont1 linux-image-siduction-amd64 locales man-db manpages-de marble-data milou mkvtoolnix mplayer mpv multiarch-support okteta
  openssl oxygen-sounds perlmagick plasma-dataengines-addons plasma-desktop plasma-desktop-data plasma-integration plasma-nm plasma-pa
  plasma-runners-addons plasma-scriptengine-javascript plasma-wallpapers-addons plasma-widgets-addons plasma-workspace polkit-kde-1 polkit-kde-agent-1
  powerdevil powerdevil-data print-manager procps python-django python-django-common python-pip python-pip-whl python2.7 python2.7-minimal python3.5
  python3.5-minimal qml-module-qtquick-controls-styles-breeze ruby2.3 scrot sddm-theme-breeze smplayer systemd systemd-sysv systemsettings tzdata udev
  vim vim-common vim-runtime virtualbox virtualbox-dkms virtualbox-ext-pack virtualbox-guest-additions-iso virtualbox-guest-dkms virtualbox-guest-utils
  virtualbox-qt vlc vlc-bin vlc-data vlc-l10n vlc-nox vlc-plugin-base vlc-plugin-qt vlc-plugin-video-output vokoscreen vpnc x11-common xfonts-utils
  xserver-common xserver-xephyr xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-libinput
  xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-legacy xserver-xorg-video-ati xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-mga xserver-xorg-video-nouveau xserver-xorg-video-radeon xserver-xorg-video-vesa xserver-xorg-video-vmware
  xxd zim
369 aktualisiert, 14 neu installiert, 21 zu entfernen und 2 nicht aktualisiert.
Es müssen 456 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 19,5 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]


There is more than X11 bugged ?
Title: Re: Warnig: No dist-upgrade
Post by: devil on 2016/11/25, 11:18:46
Virtualbox also has problems. What irritates me in your output is build-essential debhelper dh-autoreconf dh-strip-nondeterminism. Have not seen these blocked elsewhere.
Title: Re: Warnig: No dist-upgrade
Post by: vilde on 2016/11/25, 12:19:13
I checked the output of a d-u on my xfce 64 bit system. "Only" two packages  to be removed,
Code: [Select]
iptables xserver-xorg-input-vmmouse
Title: Re: Warnig: No dist-upgrade
Post by: HarzG on 2016/11/25, 13:18:06
Quote from: devil
What irritates me in your output is build-essential debhelper dh-autoreconf dh-strip-nondeterminism. Have not seen these blocked elsewhere.
Ist bei mir auch so. For me also blocked/removed.
Code: [Select]
apt dist-upgrade -d
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  build-essential debhelper dh-autoreconf dh-strip-nondeterminism g++ g++-5 g++-6 libc6-dev libstdc++-5-dev libstdc++-6-dev
  libtool nvidia-legacy-304xx-driver virtualbox-guest-source virtualbox-guest-x11 xserver-xorg-video-intel
  xserver-xorg-video-nvidia-legacy-304xx
The following NEW packages will be installed:
  libxfont2
The following packages have been kept back:
  libc6
The following packages will be upgraded:
  libc-dev-bin libprotobuf10 virtualbox-guest-dkms virtualbox-guest-utils xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-libinput xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-wacom
  xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev xserver-xorg-video-mga xserver-xorg-video-nouveau
  xserver-xorg-video-radeon xserver-xorg-video-vesa xserver-xorg-video-vmware
18 upgraded, 1 newly installed, 16 to remove and 1 not upgraded.
Need to get 7466 kB of archives.
After this operation, 131 MB disk space will be freed.
Do you want to continue? [Y/n]
Title: Re: Warnig: No dist-upgrade
Post by: seasons on 2016/11/25, 15:02:47
What irritates me in your output is build-essential debhelper dh-autoreconf dh-strip-nondeterminism. Have not seen these blocked elsewhere.

They also get removed on my system. I believe it's because of the libc multiarch issue:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845512
Title: Re: Warnig: No dist-upgrade
Post by: CCarpenter on 2016/11/26, 01:11:33
Big thanks for the warning, devil & team!
Title: Re: Warnig: No dist-upgrade
Post by: zash1958 on 2016/11/26, 15:15:10
es werden weniger Pakete die entfernt werden sollen ;-)

Code: [Select]
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden ENTFERNT:
  iptables virtualbox-guest-x11

Title: Re: Warnig: No dist-upgrade
Post by: towo on 2016/11/26, 15:19:57
Code: [Select]
apt install iptables libxtables12 libxtables11-
Title: Re: Warnig: No dist-upgrade
Post by: zash1958 on 2016/11/26, 17:05:17
Done :-)

Aber mit dem aktuellen Kernel 4.8.10 läuft der Nvidia Treiber "NVIDIA-Linux-x86_64-375.20" nicht. Kein GUI
Mit dem Kernel 4.8.9 tut alles wie gewünscht.

Kernel 4.8.10:
Code: [Select]
[   128.566] (II) LoadModule: "glx"
[   128.566] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   128.569] (II) Module glx: vendor="NVIDIA Corporation"
[   128.569]    compiled for 4.0.2, module version = 1.0.0
[   128.569]    Module class: X.Org Server Extension
[   128.569] (II) NVIDIA GLX Module  367.57  Mon Oct  3 20:28:17 PDT 2016
[   128.569] (II) LoadModule: "nvidia"
[   128.569] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   128.569] (II) Module nvidia: vendor="NVIDIA Corporation"
[   128.569]    compiled for 4.0.2, module version = 1.0.0
[   128.569]    Module class: X.Org Video Driver
[   128.569] ================ WARNING WARNING WARNING WARNING ================
[   128.569] This server has a video driver ABI version of 23.0 that is not
supported by this NVIDIA driver.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[   128.569] =================================================================
[   128.569] (EE) NVIDIA: Use the -ignoreABI option to override this check.
[   128.569] (II) UnloadModule: "nvidia"
[   128.569] (II) Unloading nvidia
[   128.570] (EE) Failed to load module "nvidia" (module requirement mismatch, 0)
[   128.570] (EE) No drivers available.
[   128.570] (EE)
Fatal server error:
[   128.570] (EE) no screens found(EE)
[   128.570] (EE)


Title: Re: Warnig: No dist-upgrade
Post by: towo on 2016/11/26, 17:08:41
1. 375.20 gibt in Debian nicht!
2. "läuft nicht" sagt genau Nichts!

3. 375.20 läuft sogar mit 4.9-rcX, also werde genauer, oder lass es.
Title: Re: Warnig: No dist-upgrade
Post by: zash1958 on 2016/11/26, 17:16:54
warum immer so grimmig?

Kernel 4.8.10 zusammen mit dem beschriebenen NVidia Treiber startet halt keinen Xserver und wirft die beigefügte Fehlermeldung
Kernel 4.8.9 funktioniert dagegen tadellos ????

Ich habe doch sogar das Logfile des vergeblichen Starts des Xservers beigefügt?

Wir hatten diese Diskussionen doch schonmal in ähnlicher Form. Damals war der Grund, dass bei einem Dist-Upgrade der Standard gcc von der Version 5 auf die Version 6 umgestellt wurde. Auch damals stand immer latent der Vorwurf des "Unmöglich/Unfähig" im Raum :-(

Muss doch BITTE wirklich nicht sein.....

NVIDIA-Linux-x86_64-375.20 habe ich gerade vor einer halben Stunde von der Nvidia Webseite heruntergeladen. Wieso soll es DEN dort nicht geben????

http://www.nvidia.de/download/driverResults.aspx/111627/de

Title: Re: Warnig: No dist-upgrade
Post by: axt on 2016/11/26, 17:31:19
"auf nvidia.com" ≠ "in Debian"
Title: Re: Warnig: No dist-upgrade
Post by: towo on 2016/11/26, 17:41:59
Schonmal in die Fehlermeldung geschaut?


Quote
[   128.569] (II) NVIDIA GLX Module  367.57  Mon Oct  3 20:28:17 PDT 2016


Das ist nicht 375.20!

Und das hat auch Nix mit dem Kernel zu tun, sondern einfach nur, dass 367.57 mit Xserver 1.19 nicht kann!
Title: Re: Warnig: No dist-upgrade
Post by: zash1958 on 2016/11/26, 18:18:13
Habe den Kernel 4.8.10, die Kernel-Header dafür, den NVIDIA-Treiber 375.20 nochmals geladen.
Dann den symbolischen Link "/usr/lib/i386-linux-gnu/libEGL.so" gelöscht (der wird vom Nvidia Installer immer angemault)


Dann den Nvidia Installer nochmals laufen lassen.......
 

Jetzt tut es!

Kernel 4.8.10 startet und der Xserver tut auch !


Title: Re: Warnig: No dist-upgrade
Post by: cas on 2016/11/27, 00:22:05
Jetzt tut es!

schön, aber du hast den thread gekapert
Title: Re: Warnig: No dist-upgrade
Post by: cas on 2016/11/27, 00:29:13
Code: [Select]
apt install iptables libxtables12 libxtables11-

danke, aber es ist seltsam, dass man hier selbst tätig werden muss. sollte das nicht automatisch geschehen? ist das ein fehler von debian?

aber auch nach obigem befehl heißt es bei mir
Code: [Select]
Die folgenden Pakete werden ENTFERNT:
  virtualbox-guest-x11 xserver-xorg-input-vmmouse xserver-xorg-video-intel

gruß, c
Title: Re: Warnig: No dist-upgrade
Post by: vilde on 2016/11/27, 00:41:35
May I ask, is it ok to d-u now or? I still will get "iptables xserver-xorg-input-vmmouse" removed. So shall I wait or shall I d-u and then do as towo wrote?
Code: [Select]
apt install iptables libxtables12 libxtables11-
What about xserver-xorg-input-vmmouse?
Title: Re: Warnig: No dist-upgrade
Post by: towo on 2016/11/27, 00:55:24
Quote
What about xserver-xorg-input-vmmouse?
What about?
Ever read the description of that package?
You have running siduction in vmware, vbox or qemu? No? Then you won't need that package.
Title: Re: Warnig: No dist-upgrade
Post by: vilde on 2016/11/27, 09:53:43
Quote
What about xserver-xorg-input-vmmouse?
What about?
Ever read the description of that package?
You have running siduction in vmware, vbox or qemu? No? Then you won't need that package.
Sorry, I know it's not like that but for some reason I always think that all packages delivered with the iso is necessary. On the other side I always take away all virtualbox guest packages after installation.

But, my main question as this topic still say "no dist-upgrade" and not marked solved, is it ok to d-u now?
Title: Re: Warnig: No dist-upgrade
Post by: blaze on 2016/11/27, 10:20:22
Patience is a virtue. Or is there some new package that you really need? Check transition page for xorg and decide.

https://release.debian.org/transitions/html/xserver1.19.html
Title: Re: Warnig: No dist-upgrade
Post by: drb on 2016/11/27, 11:00:31
Not slved here yet :

Code: [Select]
The following packages will be REMOVED:                                                                                                                                                                                                       
   xserver-xorg-input-vmmouse (1:13.1.0-1+b1)                                                                                                                                                                                                 
   xserver-xorg-video-intel (2:2.99.918+git20160426-1)
Title: Re: Warnig: No dist-upgrade
Post by: vilde on 2016/11/27, 12:04:20
I'm in no hurry. It was towos post about reinstalilng some packages and a lot o german (that I don't understand) text before that made me wondering. I wait for it to clear up. Thanks.
Title: Re: Warnig: No dist-upgrade
Post by: seasons on 2016/11/27, 16:42:08
But, my main question as this topic still say "no dist-upgrade" and not marked solved, is it ok to d-u now?

The libc multiarch issue has been cleared and the libxtables/libtesseract issue has cleared.

DO NOT dist-upgrade if:
1) You use binary/proprietary nvidia driver (including legacy versions)
2) You use virtualbox
3) You need vmmouse package as towo discussed
4) You are using intel i945 graphics or older (i.e. you need xserver-xorg-video-intel package)

Otherwise, you are probably okay (no guarantees though).
Title: Re: Warnig: No dist-upgrade
Post by: Carnophage on 2016/11/28, 11:23:44
As for intel package, please double check that You are not using something newer then the package in unstable.
I'm not sure why and how but I also had .918 package while .917 is in unstable. Reinstalling xserver-video-intel to the version from unstable by hand solved that one for me.
Title: Re: Warnig: No dist-upgrade
Post by: dibl on 2016/11/28, 11:41:20
Hmmmmmmmm.  Thanks @Carnophage.


Code: [Select]
root@hp-350g:/# apt policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installed: 2:2.99.918+git20160426-1
  Candidate: 2:2.99.918+git20160426-1
  Version table:
 *** 2:2.99.918+git20160426-1 100
        100 /var/lib/dpkg/status
     2:2.99.917+git20161105-1+b1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages


root@hp-350g:/# inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/debian.list
           deb http://httpredir.debian.org/debian/ unstable main contrib non-free
           Active apt sources in file: /etc/apt/sources.list.d/siduction.list
           deb http://mirror.lug.udel.edu/pub/siduction/extra unstable main contrib non-free
           deb http://mirror.lug.udel.edu/pub/siduction/fixes unstable main contrib non-free


I don't know how this happened, either.
Title: Re: Warnig: No dist-upgrade
Post by: der_bud on 2016/11/28, 12:37:08
Quote from: Carnophage
... I'm not sure why and how but I also had .918 package while .917 is in unstable. Reinstalling xserver-video-intel to the version from unstable by hand solved that one for me....
Quote from: dibl
... I don't know how this happened, either.

musca and horo elaborated on that some weeks ago: intel graphics factsheet (https://forum.siduction.org/index.php?topic=6317.msg52007#msg52007) , first there came a .918 into debian repos, then intel withdraw that and debian stepped down again to .917

Title: Re: Warnig: No dist-upgrade
Post by: towo on 2016/11/28, 12:37:54
Let this package go and install the one from debian.
Your 218-package was a build of me from git, where it was mistagged as 218.
Title: Re: Warnig: No dist-upgrade
Post by: dibl on 2016/11/28, 14:13:26
It was easily replaced and d-u goes through completely on that laptop.  The multi-arch desktop with Nvidia graphics is still waiting.
Title: Re: Warnig: No dist-upgrade
Post by: Taliesin on 2016/11/29, 02:48:02
The last I checked, Nvidia drivers are now good to go, 12:47 UTC +11 or AEDST.

Still waiting on the following.

Code: [Select]
The following packages will be REMOVED:
  iptables xserver-xorg-input-vmmouse

In the meantime the list of packages to be upgraded is growing.....
Title: Re: Warnig: No dist-upgrade
Post by: Taliesin on 2016/11/29, 02:50:46
@Towo,

everytime I see your signature, I have this urge to flick the bug off of my screen.
Title: Re: Warnig: No dist-upgrade
Post by: terroreek on 2016/11/29, 03:27:28
I performed a dist-upgrade, looks like following package was removed

Code: [Select]
libegl1-nvidia
trying to re-install, apt wants to remove libegl1-glvnd-nvidia

Code: [Select]
The following packages will be REMOVED:
  libegl1-glvnd-nvidia
The following NEW packages will be installed:
  libegl1-nvidia

Is is safe to assume the libegl1-glvnd-nvidia replaces the libegl1-nvidia package???
Title: Re: Warnig: No dist-upgrade
Post by: pjnsmb on 2016/11/29, 05:28:05
from apt show libegl1-nvidia




Package: libegl1-nvidia
Version: 375.20-1.1
Priority: extra
Section: non-free/oldlibs
Source: nvidia-graphics-drivers
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 216 kB
Depends: nvidia-alternative (= 375.20-1.1)
Conflicts: libegl1-glvnd-nvidia
Replaces: libegl1-glvnd-nvidia

Title: Re: Warnig: No dist-upgrade
Post by: jure on 2016/11/29, 08:44:57
....
Still waiting on the following.

Code: [Select]
The following packages will be REMOVED:
  iptables xserver-xorg-input-vmmouse

In the meantime the list of packages to be upgraded is growing.....

there is no more xserver-xorg-input-vmmouse in sid

https://tracker.debian.org/pkg/xserver-xorg-input-vmmouse (https://tracker.debian.org/pkg/xserver-xorg-input-vmmouse)

because > https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=831420 (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=831420)

and here it was no problem to reinstall  iptables, after the du
Code: [Select]
apt policy iptables
iptables:
  Installiert:           1.6.0+snapshot20161117-4
  Installationskandidat: 1.6.0+snapshot20161117-4
  Versionstabelle:
 *** 1.6.0+snapshot20161117-4 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status


Title: Re: Warnig: No dist-upgrade
Post by: Taliesin on 2016/11/29, 09:04:39
Danke schon
Title: Re: Warnig: No dist-upgrade
Post by: piper on 2016/11/29, 10:10:54
On my box  (YMMV)

Code: [Select]
root /home/piper # apt update && apt full-upgrade -d
Hit:1 http://deb.debian.org/debian unstable InRelease
Hit:2 http://deb.debian.org/debian testing InRelease                                                                                       
Hit:3 http://deb.debian.org/debian experimental InRelease
Hit:4 https://liquorix.net/siduction/extra unstable InRelease
Hit:5 http://www.deb-multimedia.org sid InRelease
Hit:6 https://liquorix.net/siduction/fixes unstable InRelease
Hit:7 https://dl.winehq.org/wine-builds/debian sid InRelease
Hit:8 http://packages.siduction.org/extra experimental InRelease
Hit:9 http://packages.siduction.org/user experimental InRelease
Hit:10 http://packages.siduction.org/user unstable InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Title: Re: Warnig: No dist-upgrade
Post by: terroreek on 2016/11/29, 14:41:50
from apt show libegl1-nvidia




Package: libegl1-nvidia
Version: 375.20-1.1
Priority: extra
Section: non-free/oldlibs
Source: nvidia-graphics-drivers
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 216 kB
Depends: nvidia-alternative (= 375.20-1.1)
Conflicts: libegl1-glvnd-nvidia
Replaces: libegl1-glvnd-nvidia



I think I am even more confused as to which package I should be installing now.

Code: [Select]
Package: libegl1-glvnd-nvidia
Version: 375.20-1.1
Priority: optional
Section: non-free/libs
Source: nvidia-graphics-drivers
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 271 kB
Depends: nvidia-alternative (= 375.20-1.1), glvnd-nvidia-abi-361.45, libc6 (>= 2.2.5), libgldispatch0 | libgldispatch0-nvidia
 (>= 375.20)
Conflicts: libegl1-nvidia
Replaces: libegl1-nvidia
Homepage: http://www.nvidia.com
Download-Size: 193 kB
APT-Manual-Installed: no
APT-Sources: http://packages.siduction.org/fixes unstable/non-free amd64 Packages
Description: NVIDIA binary EGL GLVND stub library
 EGL provides a platform-agnostic mechanism for creating rendering surfaces
 for use with other graphics libraries, such as OpenGL|ES.
 .
 This package contains the (binary) GLVND libEGL.so.1 stub library provided by
 NVIDIA which dispatches to vendor implementations (libEGL_*.so.0) via GLVND.


and

Code: [Select]
Package: libegl1-nvidia
Version: 375.20-1.1
Priority: extra
Section: non-free/oldlibs
Source: nvidia-graphics-drivers
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 216 kB
Depends: nvidia-alternative (= 375.20-1.1)
Conflicts: libegl1-glvnd-nvidia
Replaces: libegl1-glvnd-nvidia
Homepage: http://www.nvidia.com
Download-Size: 173 kB
APT-Sources: http://packages.siduction.org/fixes unstable/non-free amd64 Packages
Description: NVIDIA binary EGL library (transitional)
 EGL provides a platform-agnostic mechanism for creating rendering surfaces
 for use with other graphics libraries, such as OpenGL|ES.
 .
 This package contains the driver specific binary EGL implementation by NVIDIA
 as a non-glvnd alternative.

Both look like they are identical to each other but libegl1-glvnd-nvidia uses the Open GL Vendor Neutral driver.

I think libegl1-glvnd-nvidia is the right package, silly question anyone know why one would rather the libegl1-nvidia package??  Would it provide better performance?
Title: Re: Warnig: No dist-upgrade
Post by: pjnsmb on 2016/11/29, 14:54:05

@terroreek

Is is safe to assume the libegl1-glvnd-nvidia replaces the libegl1-nvidia package???


you have them the wrong way round !


look at my post :



from apt show libegl1-nvidia



Package: libegl1-nvidia
Version: 375.20-1.1


Conflicts: libegl1-glvnd-nvidia
Replaces: libegl1-glvnd-nvidia
Title: Re: Warnig: No dist-upgrade
Post by: terroreek on 2016/11/30, 03:13:04
@pjnsmb I did see your post, did you happen to look at mine??

Both packages conflict and replace the other.  I happened to look into it further and it looks like this glvnd is newer, but the option to install the legacy non-glvnd libraries are there because certain applications with incompatibilities with the glvnd binaries from Nvidia. 

Here are some resources I found.

https://devtalk.nvidia.com/default/topic/915640/unix-graphics-announcements-and-news/multiple-glx-client-libraries-in-the-nvidia-linux-driver-installer-package/ (https://devtalk.nvidia.com/default/topic/915640/unix-graphics-announcements-and-news/multiple-glx-client-libraries-in-the-nvidia-linux-driver-installer-package/)

https://www.reddit.com/r/archlinux/comments/44zqau/nvidia_36128_and_glvnd_with_steam_games/ (https://www.reddit.com/r/archlinux/comments/44zqau/nvidia_36128_and_glvnd_with_steam_games/)

Looks like I'll fire up steam and see if my games work or not. -edit- games seem to work still.
Title: Re: Warnig: No dist-upgrade
Post by: paxmark2 on 2016/11/30, 03:33:11
After a wait my full-upgrade was dull in lxqt.  My apt full-upgrades on two testing machines with lxqt was dull also.  Intel atom - aspire one with Sparky linux and intel i3 with vanilla debian.  Really appreciate the info.  I wasn't sure if xorg 1.18 was going to go to testing.  Silly me.
Title: Re: Warnig: No dist-upgrade
Post by: KrunchTime on 2016/11/30, 09:55:53
It has been 2 or more weeks since I last updated Bunsen Labs tracking Unstable on my laptop, so this morning I opted to cherry pick...again.  After my mishap on my desktop, I did some research into apt-get and discovered a very useful option:
Code: [Select]
--no-remove
Usage example:
Code: [Select]
sudo apt-get install --no-remove pkgname
So, after over 2 hours I went from the following:
Code: [Select]
The following packages were automatically installed and are no longer required:
  gir1.2-javascriptcoregtk-4.0 gir1.2-soup-2.4 gir1.2-webkit2-4.0 libadns1
  libidl-2-0 libip6tc0 libiptc0 libllvm3.8 libllvm3.8:i386 liborbit2
  liborc-0.4-0:i386 libschroedinger-1.0-0 libschroedinger-1.0-0:i386
  libspeechd2 libssl1.0.2:i386 libudev1:i386 python-gconf python-gnome2
  python-pyorbit
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  gufw iptables ufw xserver-xorg-input-vmmouse xserver-xorg-video-sisusb
The following NEW packages will be installed:
  gir1.2-gconf-2.0 gir1.2-keybinder-3.0 gir1.2-notify-0.7 libkeybinder-3.0-0
  libldap-common libllvm3.9 libllvm3.9:i386 liblz4-1:i386 libminizip1 libre2-3
  libsensors4:i386 libssl1.1:i386 libxfont2 python-psutil
The following packages will be upgraded:
  apt apt-listchanges apt-transport-https apt-utils base-files bash binutils
  bunsen-os-release bunsen-python-apt-template chromium clamtk console-setup
  console-setup-linux cpio cpp cpp-6 dbus dbus-user-session dbus-x11
  debianutils devscripts dirmngr dpkg dpkg-dev exim4 exim4-base exim4-config
  exim4-daemon-light ffmpeg fonts-freefont-ttf fonts-lyx fonts-noto-mono
  fonts-opensymbol g++ g++-6 gcc gcc-6 gcc-6-base gcc-6-base:i386 gdebi
  gdebi-core geany geany-common geany-plugin-addons geany-plugin-autoclose
  geany-plugin-automark geany-plugin-codenav geany-plugin-commander
  geany-plugin-ctags geany-plugin-debugger geany-plugin-defineformat
  geany-plugin-devhelp geany-plugin-doc geany-plugin-extrasel
  geany-plugin-gendoc geany-plugin-geniuspaste geany-plugin-git-changebar
  geany-plugin-insertnum geany-plugin-latex geany-plugin-lineoperations
  geany-plugin-lipsum geany-plugin-lua geany-plugin-macro
  geany-plugin-markdown geany-plugin-miniscript geany-plugin-multiterm
  geany-plugin-numberedbookmarks geany-plugin-overview
  geany-plugin-pairtaghighlighter geany-plugin-pg geany-plugin-pohelper
  geany-plugin-prettyprinter geany-plugin-prj geany-plugin-projectorganizer
  geany-plugin-py geany-plugin-scope geany-plugin-sendmail
  geany-plugin-shiftcolumn geany-plugin-spellcheck geany-plugin-tableconvert
  geany-plugin-treebrowser geany-plugin-updatechecker geany-plugin-vc
  geany-plugin-webhelper geany-plugin-xmlsnippets geany-plugins
  geany-plugins-common ghostscript ghostscript-x gir1.2-gtk-3.0 gnupg
  gnupg-agent gnupg-l10n gnupg2 gpa gpgsm gpgv greybird-gtk-theme
  gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x
  gtk-update-icon-cache imagemagick imagemagick-6-common imagemagick-6.q16
  imagemagick-common iso-codes jq keyboard-configuration libapt-inst2.0
  libapt-pkg5.0 libasan3 libassuan0 libatomic1 libavcodec57 libavcodec57:i386
  libavdevice57 libavfilter6 libavformat57 libavresample3 libavresample3:i386
  libavutil55 libavutil55:i386 libbasicusageenvironment1 libbluray1 libc-bin
  libc-dev-bin libc-l10n libc6 libc6:i386 libc6-dbg libc6-dev libcc1-0
  libcgi-fast-perl libcilkrts5 libconfig9 libdatetime-locale-perl
  libdatetime-perl libdatetime-timezone-perl libdbus-1-3 libdbus-1-3:i386
  libdebconfclient0 libdpkg-perl libdrm-amdgpu1 libdrm-amdgpu1:i386
  libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386
  libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386 libedit2
  libedit2:i386 libegl1-mesa libfont-afm-perl libgbm1 libgcc-6-dev libgcc1
  libgcc1:i386 libgfortran3 libgl1-mesa-dri libgl1-mesa-dri:i386
  libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386
  libgles1-mesa libgles2-mesa libglib2.0-0 libglib2.0-data libgnutls-openssl27
  libgnutls30 libgnutls30:i386 libgomp1 libgomp1:i386 libgpg-error0
  libgpg-error0:i386 libgpgme11 libgphoto2-6 libgphoto2-l10n libgphoto2-port12
  libgraphite2-3 libgroupsock8 libgs9 libgs9-common
  libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin
  libgtk-3-common libhtml-parser-perl libhtml-tagset-perl libicu57
  libicu57:i386 libinput-bin libinput10 libio-socket-ssl-perl libip4tc0
  libip6tc0 libiptc0 libitm1 libjansson4 libjson-xs-perl libldap-2.4-2
  libldap-2.4-2:i386 liblivemedia57 liblockfile-bin liblockfile1 liblsan0
  liblua5.1-0 libmagickcore-6.q16-2 libmagickcore-6.q16-2-extra
  libmagickwand-6.q16-2 libmarkdown2 libmm-glib0 libmpx2 libmwaw-0.3-3
  libneon27-gnutls libnghttp2-14 libnm-glib-vpn1 libnm-glib4 libnm-util2
  libnm0 libnpth0 libosmesa6 libosmesa6:i386 libpam-systemd
  libparams-validationcompiler-perl libpath-tiny-perl libpci3 libperl5.24
  libpng16-16 libpng16-16:i386 libpostproc54 libprocps6 libprotobuf10
  libproxy-tools libproxy1v5 libpsl5 libpython2.7 libpython2.7-dev
  libpython2.7-minimal libpython2.7-stdlib libpython3.5 libpython3.5-minimal
  libpython3.5-stdlib libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5
  libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5sql5
  libqt5sql5-sqlite libqt5test5 libqt5widgets5 libqt5xml5 libquadmath0
  libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-base
  libreoffice-base-core libreoffice-base-drivers libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-en-us
  libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder-bin
  libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer libruby2.3 libsasl2-2
  libsasl2-2:i386 libsasl2-modules libsasl2-modules:i386 libsasl2-modules-db
  libsasl2-modules-db:i386 libseccomp2 libservlet3.1-java libshine3
  libshine3:i386 libsndio6.1 libsndio6.1:i386 libspecio-perl libspeechd2
  libssl1.1 libstdc++-6-dev libstdc++6 libstdc++6:i386 libswresample2
  libswresample2:i386 libswscale4 libsystemd0 libsystemd0:i386 libtiff-tools
  libtiff5 libtiff5:i386 libtsan0 libubsan0 libudev1 libudev1:i386
  libudisks2-0 libusageenvironment3 libustr-1.0-1 libva-drm1 libva-drm1:i386
  libva-wayland1 libva-x11-1 libva-x11-1:i386 libva1 libva1:i386 libvlc-bin
  libvlc5 libvlccore8 libwayland-egl1-mesa libxatracker2 libxfont1
  libxtables11 libzvbi-common libzvbi0 libzvbi0:i386 licensecheck
  lightdm-gtk-greeter linux-image-4.8.0-1-amd64 locales login lsb-base
  lsb-release man-db mesa-vdpau-drivers mesa-vdpau-drivers:i386 modemmanager
  mpv multiarch-support network-manager nitrogen ntp openssl p7zip p7zip-full
  passwd pciutils perl perl-base perl-modules-5.24 procps python-gconf
  python-gnome2 python-pyorbit python-sqlalchemy python-sqlalchemy-ext
  python-tz python2.7 python2.7-minimal python3-uno python3.5
  python3.5-minimal qt5-gtk-platformtheme rsyslog ruby-atk ruby-gdk-pixbuf2
  ruby-gio2 ruby-glib2 ruby-gobject-introspection ruby-gtk2 ruby-pango ruby2.3
  scrot systemd systemd-sysv terminator tzdata udev udisks2 uno-libs3 ure
  user-setup va-driver-all va-driver-all:i386 vlc vlc-bin vlc-data vlc-l10n
  vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-skins2
  vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization
  vpnc w3m x11-common xfce4-panel xfonts-utils xorg xserver-common
  xserver-xorg xserver-xorg-core xserver-xorg-input-all
  xserver-xorg-input-evdev xserver-xorg-input-libinput
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-void xserver-xorg-input-wacom xserver-xorg-video-all
  xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-cirrus
  xserver-xorg-video-dummy xserver-xorg-video-fbdev xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-tdfx
  xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware
440 upgraded, 14 newly installed, 5 to remove and 0 not upgraded.
Need to get 486 MB of archives.
After this operation, 113 MB of additional disk space will be used.
to this:
Code: [Select]
The following packages were automatically installed and are no longer required:
  libip6tc0 libiptc0
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  gufw iptables ufw xserver-xorg-input-vmmouse xserver-xorg-video-sisusb
The following packages will be upgraded:
  dpkg libip4tc0 libip6tc0 libiptc0 libxtables11 xserver-xorg-core
  xserver-xorg-input-evdev xserver-xorg-input-libinput
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-void xserver-xorg-input-wacom xserver-xorg-video-amdgpu
  xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-dummy
  xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-mach64
  xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-tdfx
  xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware
30 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
Need to get 8,130 kB/10.2 MB of archives.
After this operation, 5,714 kB disk space will be freed.
;D
Title: Re: Warnig: No dist-upgrade
Post by: piper on 2016/11/30, 10:10:12
Code: [Select]
apt-get install --no-remove pkgname
Sooner or later, that will bite you in the ass
Title: Re: Warnig: No dist-upgrade
Post by: KrunchTime on 2016/11/30, 10:46:06
In what way?  When I used it earlier today, if there were packages that were going to be removed, nothing happened, which is exactly what I wanted.  This would have saved me from having all of my xserver-xorg-video-xxx packages being removed on my desktop.
Title: Re: Warnig: No dist-upgrade
Post by: tmhind2 on 2016/11/30, 10:56:23
You may be right this time about not removing packages, but Piper is only giving you a warning to be careful.  :)
Title: Re: Warnig: No dist-upgrade
Post by: seasons on 2016/11/30, 15:12:45
In what way?  When I used it earlier today, if there were packages that were going to be removed, nothing happened, which is exactly what I wanted.

I think piper is referring to cherry-picking upgrades (especially using apt-get install) in general. If you want to use the '--no-remove' option with 'dist-upgrade' as extra security, I can't see how that would cause issues.
Title: Re: Warnig: No dist-upgrade
Post by: blaze on 2016/11/30, 15:19:51
After dist-upgrade, and reinstall of xorg (despite some bug warning from apt) things are working again.

This is only a  base install with Openbox though. :)
Title: Re: Warnig: No dist-upgrade
Post by: KrunchTime on 2016/11/30, 22:53:34
@seasons:  Interesting...I didn't think of using the --no-remove option with dist-upgrade.  I'll hold off trying that in the future until I get more clarification about the cons of using the option.

Edit:  dist-upgrade with the --no-remove option will not work if there are packages to be removed.

On another note, I could have saved myself a lot of time earlier this morning by just marking the packages to be removed for hold.  I did that on my desktop a few minutes ago and successfully dist-upgraded.  Of course, you have to remember to unhold the packages afterwards and if there are a number of packages to be removed, it may be better to just wait.
Title: Re: Warnig: No dist-upgrade
Post by: seasons on 2016/12/01, 00:26:39
Edit:  dist-upgrade with the --no-remove option will not work if there are packages to be removed.

I thought that's what you wanted? That will prevent you from accidentally saying yes to a d-u with package removals.

Quote
On another note, I could have saved myself a lot of time earlier this morning by just marking the packages to be removed for hold.  I did that on my desktop a few minutes ago and successfully dist-upgraded.  Of course, you have to remember to unhold the packages afterwards and if there are a number of packages to be removed

I don't see how that's ultimately different than cherry-picking packages to upgrade except that it's faster (and will break your system faster if you don't know what you're doing).

Quote
it may be better to just wait
Hallelujah! Another one has seen the light!
Seriously, if you're unsure about removals, ask here. Sometimes, you can safely let things go. Sometimes, you have to let something go and reinstall it to work around a bug (like the recent iptables bug).
Title: Re: Warnig: No dist-upgrade
Post by: KrunchTime on 2016/12/01, 00:54:47
I thought that's what you wanted? That will prevent you from accidentally saying yes to a d-u with package removals.
That will prevent you from doing anything.  When performing a normal dist-upgrade, you are prompted with something like "Do you want to continue?", which is sufficient for preventing something you don't want to happen.  You just enter "n" and press the <ENTER> key.

Quote
I don't see how that's ultimately different than cherry-picking packages to upgrade except that it's faster (and will break your system faster if you don't know what you're doing).
saved myself a lot of time = faster  ;)   Also, cherry picking can break your system as well if you're not careful, as happened to me recently on my desktop; still no GUI.  :'(

Quote
Hallelujah! Another one has seen the light!
Seriously, if you're unsure about removals, ask here. Sometimes, you can safely let things go. Sometimes, you have to let something go and reinstall it to work around a bug (like the recent iptables bug).
It would be nice to learn how to determine when to let things get removed.
Title: Re: Warnig: No dist-upgrade
Post by: seasons on 2016/12/01, 04:18:52
When performing a normal dist-upgrade, you are prompted with something like "Do you want to continue?", which is sufficient for preventing something you don't want to happen.  You just enter "n" and press the <ENTER> key.

I know. When you talked about removing all of the xserver video packages on your desktop, I thought you accidentally or unknowingly said 'Y' to the prompt ( '--no-remove' would have prevented that).

But I guess you tried to cherry pick and got burned? I can't tell what exactly you did or why you have no GUI on your desktop.
Title: Re: Warnig: No dist-upgrade
Post by: KrunchTime on 2016/12/01, 06:49:53
Yes, I cherry picked and got burned.  I don't think there is a prompt regarding automatic removals when you manually install an upgrade.  I manually upgraded xserver-xorg-core, resulting in the removal of all xserver-xorg-video-xxx packages, hence my current lack of a GUI.  I guess I could always pull from Testing, but I think I've done enough damage and so will sit and wait.

Edit:  apt history log or it didn't happen:
Code: [Select]
Start-Date: 2016-11-24  17:47:13
Commandline: apt-get install xserver-xorg-core
Requested-By: xxx
Install: libxfont2:amd64 (1:2.0.1-2, automatic)
Upgrade: xserver-xorg-core:amd64 (2:1.18.4-2, 2:1.19.0-2)
Remove: xserver-xorg-input-all:amd64 (1:7.7+16), xserver-xorg-video-dummy:amd64 (1:0.3.7-1+b5), xserver-xorg-input-synaptics:amd64 (1.9.0-1), xserver-xorg:amd64 (1:7.7+16), xserver-xorg-video-r128:amd64 (6.10.1-2), xserver-xorg-video-qxl:amd64 (0.1.4-3+b1), xserver-xorg-video-vesa:amd64 (1:2.3.4-1+b1), xserver-xorg-video-nouveau:amd64 (1:1.0.13-1), xserver-xorg-video-amdgpu:amd64 (1.2.0-1), xserver-xorg-video-cirrus:amd64 (1:1.5.3-1+b1), xserver-xorg-input-void:amd64 (1:1.4.1-1+b1), xserver-xorg-video-trident:amd64 (1:1.3.7-2), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1+b4), xserver-xorg-input-libinput:amd64 (0.22.0-1), xserver-xorg-video-savage:amd64 (1:2.3.8-2), xserver-xorg-input-wacom:amd64 (0.33.0-1), xserver-xorg-input-vmmouse:amd64 (1:13.1.0-1+b1), xserver-xorg-video-mach64:amd64 (6.9.5-1+b1), xserver-xorg-video-sisusb:amd64 (1:0.9.6-2+b4), xserver-xorg-video-intel:amd64 (2:2.99.917+git20161105-1), xserver-xorg-video-tdfx:amd64 (1:1.4.6-2), xserver-xorg-video-vmware:amd64 (1:13.2.1-1), xserver-xorg-input-evdev:amd64 (1:2.10.4-1), xserver-xorg-video-all:amd64 (1:7.7+16), xserver-xorg-video-ati:amd64 (1:7.8.0-1), xorg:amd64 (1:7.7+16), xpra:amd64 (0.17.6+dfsg-1), xserver-xorg-video-radeon:amd64 (1:7.8.0-1), xserver-xorg-video-neomagic:amd64 (1:1.2.9-1+b1), xserver-xorg-input-mouse:amd64 (1:1.9.2-1), xserver-xorg-video-mga:amd64 (1:1.6.4-2)
End-Date: 2016-11-24  17:47:50
Title: Re: Warnig: No dist-upgrade
Post by: dibl on 2016/12/01, 12:03:30
Quote from: KrunchTime
.... hence my current lack of a GUI.


Inasmuch as my three (very different hardware) siduction systems have been updated and running trouble-free for two or three days, I'll go out on a limb and suggest that your GUI problem may not be directly related to an ongoing transition in the X11 realm. You might want to examine the dependency and version relationships between your xserver packages that are fighting each other, with only the sid repo enabled -- or maybe just rip out all X11 packages and reinstall them from sid.


Here on an Intel GPU:


Code: [Select]
root@hp-350g:/# apt policy xserver-xorg xserver-xorg-core xserver-xorg-video-intel
xserver-xorg:
  Installed: 1:7.7+18
  Candidate: 1:7.7+18
  Version table:
 *** 1:7.7+18 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
xserver-xorg-core:
  Installed: 2:1.19.0-2
  Candidate: 2:1.19.0-2
  Version table:
 *** 2:1.19.0-2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
xserver-xorg-video-intel:
  Installed: 2:2.99.917+git20161105-1+b1
  Candidate: 2:2.99.917+git20161105-1+b1
  Version table:
 *** 2:2.99.917+git20161105-1+b1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Title: Re: Warnig: No dist-upgrade
Post by: devil on 2016/12/01, 12:39:01
Dibl,


I would confirm your verdict and see you sitting on a quite comfortable branch there. :)
Title: Re: Warnig: No dist-upgrade
Post by: piper on 2016/12/01, 23:54:51
Code: [Select]
apt upgrade --with-new-pkgs
Is the better choice than using

Code: [Select]
apt-get install --no-remove pkgname
Packages that want to be removed will be held back until safe to du again.

Or, KISS  just wait it out ...
 
I haven't used  apt-get, apt- anything in like forever  :)
Title: Re: Warnig: No dist-upgrade
Post by: KrunchTime on 2016/12/02, 01:26:03
@dibl:  I only upgraded xserver-xorg-core, and that resulted in most/all of the xserver-xorg-video-xxx packages being removed.  After rebooting, I'm getting errors that Light Display Manager will not start and to reference a systemd log (can't remember name).  In any case, since most/all of the xserver-xorg-video-xxx packages were removed, I'm fairly confident that is the issue.


I did uninstall, and attempted to re-install, xserver-xorg-core, but no xserver-xorg-video-xxx packages were being brought in with it.


@piper:  I've not seen the use of just apt to install or update a system.  I'll have to check into the difference between that and apt-get.  I've always used apt-get when using Debian Unstable and aptitude when using Debian Stable.
Title: Re: Warnig: No dist-upgrade
Post by: melmarker on 2016/12/02, 02:26:36
one should really get familar with apt - the advantage in apt is that nobody has to type apt-get upgrade --with-new-pkgs anymore - a) typing so much sucks a lot b) the chance is high that one forget about the new packages part because one otherwise would use dist-upgrade. And missing new packages within an upgrade is a not so clever move 8)
Title: Re: Warnig: No dist-upgrade
Post by: KrunchTime on 2016/12/02, 08:53:40
Code: [Select]
apt upgrade --with-new-pkgs
Is the better choice than using

Code: [Select]
apt-get install --no-remove pkgname
Packages that want to be removed will be held back until safe to du again.

Or, KISS  just wait it out ...
 
I haven't used  apt-get, apt- anything in like forever  :)
I'm not seeing the --with-new-pkgs option for apt.  I've played around with apt this morning...interesting.  I like the coloring of text and the status indicators.  However, based on some research I did prior to using it, some say that it doesn't always handle dependency issues well.


one should really get familar with apt - the advantage in apt is that nobody has to type apt-get upgrade --with-new-pkgs anymore - a) typing so much sucks a lot b) the chance is high that one forget about the new packages part because one otherwise would use dist-upgrade. And missing new packages within an upgrade is a not so clever move 8)
Never knew about the --with-new-pkgs option...face plant...so much to learn.


Well, the reason I came here is to report that I now have GUI again on Unstable on my desktop.  After researching the packages that were removed, I realized that re-installing xserver-xorg would bring in all of the xserver-xorg-video-xxx packages.  However, it didn't bring in all of the xserver-xorg-input-xxx packages that were automatically removed previously, so I manually installed the missing ones.  Tap-to-click working again on my Logitech T650 touchpad.  ;D
Title: Re: Warnig: No dist-upgrade
Post by: melmarker on 2016/12/03, 00:27:08
sid can and will be hard some times - esp. before or within transitions and/or near freezes - have a look at the state of Qt - in sid is a snapshot to met the date of the transition freeze - the finished Qt will be in when it is released, but without transition - so the chance is high that there can and will be regressions in such situations - so there is a lot to learn and to practice for all of us.

The only difference might be the impact of false or not so clever moves - depending on the knowledge. But it is true that some knowledge and constant practicing might helps a lot. What leads to a new install some years ago is now a "Oh fine - something not  to boring to play with ..."
Title: Re: Warnig: No dist-upgrade
Post by: KrunchTime on 2016/12/04, 06:14:09
Big thank you to devil for the initial warning, to towo for the iptables workaround, and to piper and melmarker for enlightening me about apt.
Title: Re: Warnig: No dist-upgrade
Post by: harley-peter on 2016/12/09, 09:43:15
Here the xorg-nvidia-legacy packages want to be removed:

Code: [Select]
Die folgenden Pakete werden ENTFERNT:
  iptables nvidia-legacy-340xx-driver xserver-xorg-input-vmmouse xserver-xorg-video-intel xserver-xorg-video-nvidia-legacy-340xx xserver-xorg-video-sisusb

Can I reinstall the packages after an du like the package iptables (thank's towo) or do they not work or must I wait some other days?
Title: Re: Warnig: No dist-upgrade
Post by: devil on 2016/12/09, 09:59:25
This has been resolved more than a week ago.
Code: [Select]
apt install iptables libxtables12 libxtables11-xserver-xorg-input-vmmouse is not in the repo anymore, Intel driver is not necessary anymore in debian.
Title: Re: Warnig: No dist-upgrade
Post by: harley-peter on 2016/12/09, 10:23:41
Hi devil,
the iptables package is not the problem but nvidia-legacy-340xx-driver and xserver-xorg-video-nvidia-legacy-340xx and maybe xserver-xorg-video-sisusb
Title: Re: Warnig: No dist-upgrade
Post by: Geier0815 on 2016/12/09, 10:43:32
Have a look at the transition site of xserver (https://release.debian.org/transitions/html/xserver1.19.html). Is this answering your question? No, it will not work to let it go and try to reinstall.
Title: Re: Warnig: No dist-upgrade
Post by: devil on 2016/12/09, 10:46:04
Looking at
Code: [Select]
apt shpw xserver-xorg-video-sisusb would have told you that you most probably don't need that. About the Nvidia stuff I have no clue, I resorted to intel-only graphic chips a couple years ago and gave up following the closed source stuff.
Title: Re: Warnig: No dist-upgrade
Post by: harley-peter on 2016/12/09, 10:54:49
@devil:
danke, da hätte ich auch selbst drauf kommen können.  ???

@geier0815:
Thank you for the link. I think it is better to wait yet.  :(
Title: Re: Warnig: No dist-upgrade
Post by: dsat on 2016/12/09, 12:32:02
Hi,

I am running a pure debian sid and since days d-u wants to remove nvidia-driver and xserver-xorg-video-nvidia. Yesterday I let it go and found myself on a console on reboot. I opened experimental in the sources list and installed nvidia-driver and xserver-xorg-video-nvidia from experimental. That worked for me.

Regards dsat
Title: Re: Warnig: No dist-upgrade
Post by: seasons on 2016/12/09, 13:45:54
@dsat: If you had just waited another day or two, you wouldn't have needed to install anything from experimental: https://packages.qa.debian.org/n/nvidia-graphics-drivers/news/20161208T165034Z.html

@harley-peter: Debian is waiting on Nvidia to update their proprietary legacy drivers:

Nvidia 340.xx bug:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845640

Nvidia 304.xx bug:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845639
Title: Re: Warnig: No dist-upgrade
Post by: OppaErich on 2016/12/09, 16:20:25
Seems the wait is over
Code: [Select]
root@oppa-hex-ssd:~# apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  nvidia-egl-common nvidia-egl-icd
The following packages will be upgraded:
  gir1.2-clutter-gst-3.0 gstreamer1.0-clutter-3.0 libclutter-gst-3.0-0 libegl-nvidia0 libegl1-glvnd-nvidia libfdt1 libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgldispatch0-nvidia libinput-bin libinput10
  libjs-angularjs liblirc-client0 liblircclient0 libmozjs-24-0 libmozjs185-1.0 libnvidia-eglcore libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1 libpng16-16 libpng16-16:i386 libservlet3.1-java
  libsmbclient libtomcat8-java libwbclient0 nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-kernel-dkms nvidia-kernel-support nvidia-legacy-check nvidia-vdpau-driver
  preview-latex-style samba-common samba-libs xserver-xorg-video-nvidia
38 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 49.7 MB of archives.
After this operation, 424 kB of additional disk space will be used.
Does this glue the GPU to the bus ? My GPU has a habit of falling off it.  :-\
Title: Re: Warnig: No dist-upgrade
Post by: terroreek on 2016/12/10, 00:36:30
Hmm ... I just upgraded this what my dist-upgrade looks like

Code: [Select]
The following NEW packages will be installed:
  libgnutls-dane0 libunbound2 linux-headers-4.8.12-towo.2-siduction-amd64 linux-image-4.8.12-towo.2-siduction-amd64
  nvidia-egl-common nvidia-egl-icd
The following packages will be upgraded:
  conky conky-all coreutils crda cryptsetup cryptsetup-bin cups-browsed cups-filters cups-filters-core-drivers
  exfat-utils ffmpeg gir1.2-clutter-gst-3.0 glances grep gstreamer1.0-clutter-3.0 guile-2.0-libs iso-codes libaprutil1
  libaprutil1-dbd-sqlite3 libaprutil1-ldap libav-tools libavcodec-extra libavcodec-extra57 libavdevice57 libavfilter6
  libavformat57 libavresample3 libavutil55 libclutter-gst-3.0-0 libcryptsetup4 libcupsfilters1 libegl-nvidia0
  libegl1-glvnd-nvidia libfontembed1 libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgldispatch0-nvidia libgles-nvidia1
  libgles-nvidia2 libgles1-glvnd-nvidia libgles1-nvidia libgles2-glvnd-nvidia libgles2-nvidia libgnutls-openssl27
  libgnutls28-dev libgnutls30 libgnutls30:i386 libgnutlsxx28 libgraphicsmagick-q16-3 libinput-bin libinput10
  libjs-angularjs liblcms2-2 liblcms2-2:i386 liblcms2-utils liblirc-client0 liblircclient0 libmozjs-24-0
  libmozjs185-1.0 libnvidia-eglcore libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1 libopenconnect5
  libparted-fs-resize0 libparted2 libpcsclite1 libpcsclite1:i386 libpkcs11-helper1 libpng-dev libpng16-16
  libpng16-16:i386 libpostproc54 libsmbclient libswresample2 libswscale4 libtiff5 libtiff5:i386 libwayland-bin
  libwayland-client0 libwayland-client0:i386 libwayland-cursor0 libwayland-cursor0:i386 libwayland-dev
  libwayland-server0 libwayland-server0:i386 libwbclient0 libwnck-common libwnck22 libxkbcommon-dev libxkbcommon-x11-0
  libxkbcommon0 libxkbcommon0:i386 libxrandr-dev libxrandr2 libxrandr2:i386 links linux-headers-siduction-amd64
  linux-image-siduction-amd64 network-manager-openconnect network-manager-openconnect-gnome nvidia-alternative
  nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-kernel-dkms nvidia-kernel-support nvidia-legacy-check
  nvidia-smi nvidia-vdpau-driver nvidia-xconfig openconnect parted python-samba samba samba-common samba-common-bin
  samba-dsdb-modules samba-libs xserver-xorg-video-nvidia zlib1g zlib1g:i386 zlib1g-dev

Gnome is barfing after the upgrade. 
Title: Re: Warnig: No dist-upgrade
Post by: CCarpenter on 2016/12/10, 02:33:13
apt full-upgrade worked fine here ...
Title: Re: Warnig: No dist-upgrade
Post by: OppaErich on 2016/12/10, 11:58:58
Yeah, I knew this - why did I upgrade anyway ? Black screen and a working mouse pointer is all I get from this.  ::)
Title: Re: Warnig: No dist-upgrade
Post by: devil on 2016/12/10, 13:52:05
Paste the output of
Code: [Select]
dpkg -l | grep xorg
Title: Re: Warnig: No dist-upgrade
Post by: OppaErich on 2016/12/10, 14:35:14
Hmm, there were no removals. I'll boot and join irc...
Title: Re: Warnig: No dist-upgrade
Post by: DuckHunting on 2016/12/10, 18:21:07
Yeah, I knew this - why did I upgrade anyway ? Black screen and a working mouse pointer is all I get from this.  ::)

Just wanted to say that Oppa Erich is not alone: I seem to have the same issues with a NVIDIA GPU as Oppa Erich. Mine is a GTX 970. Some time ago, with a kernel and/or nvidia-driver upgrade, I lost my sddm login screen, getting only a black screen. Nouveau was not working either with the 4K resolution of my Dell and produced flickering screens with 1024*768 goodness. At least, I got a working konsole.

Be it as it may, with the recent update of the kernel and the nvidia-driver, I directly boot into a black screen with no way out. The display goes into standby. Boot into recovery produces the same result, even with older kernels.

Nvidia-driver is from debian sid, kernel is standard siduction.

So, in case of a boot into darkness, is there any alternative to a new install? If not, could you please let me know when the new release will be available?

Thank you and kind regards
Duck Hunting
Title: Re: Warnig: No dist-upgrade
Post by: OppaErich on 2016/12/10, 18:37:26
It seems it's not nvidia this time. I can't find any errors about it, the modules are loaded and I get the graphical mouse pointer and can move it around. I have to [Alt][Ctrl][F2] to get to a console. I do see "unrecoverable" errors about libclutter in journal and libclutter was updated too. looks like this a Gnome issue this time.
Title: Re: Warnig: No dist-upgrade
Post by: devil on 2016/12/10, 19:57:58
you want to look into https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=847542 or  https://twitter.com/cryptosteve/status/806528682248568832 to see if one of them helps
Title: Re: Warnig: No dist-upgrade
Post by: terroreek on 2016/12/11, 04:56:48
thanks @devil

Looks like libmozjs-24-0 was updated and gnome is working fine again.  Version 24.2.0-5 confirmed working.
Title: Re: Warnig: No dist-upgrade
Post by: OppaErich on 2016/12/11, 11:02:48
Yeah, same here. Gnome up again.


Thanks devil
Title: Re: Warning: No dist-upgrade
Post by: musca on 2016/12/11, 14:40:35
Hello,
I'm happily closing the thread as it has reached the chinese lucky number of 88 replies.

Please feel free to open a new thread.

greetings
musca