Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: hsp on 2018/12/23, 10:11:17

Title: (gelöst) tvbrowser läuft nicht mit systemd 240
Post by: hsp on 2018/12/23, 10:11:17
Alle die Tvbrowser benutzen sollten erstmal auf systemd-240 beim d-u verzichten. Ne Lösung dafür habe ich allerding nicht :)

Code: [Select]
Starting TV-Browser...
Java exec found in PATH. Verifying...
Suitable java version found [java = 1.8.0_191]
Configuring environment...
Loading TV-Browser:
java -Xms16m -Xmx512m -XX:+IgnoreUnrecognizedVMOptions --add-modules=ALL-SYSTEM -Djava.library.path="/usr/share/tvbrowser" -Dpropertiesfile=linux.properties -jar tvbrowser.jar ''
library initialization failed - unable to allocate file descriptor table - out of memory./tvbrowser.sh: Zeile 127:  1965 Abgebrochen             ${JAVA_PROGRAM_DIR}java -Xms16m -Xmx512m -XX:+IgnoreUnrecognizedVMOptions --add-modules=ALL-SYSTEM -Djava.library.path="${PROGRAM_DIR}" -Dpropertiesfile=linux.properties -jar tvbrowser.jar "$@"
TV-Browser TERMINATED.

...
Title: Re: tvbrowser läuft nicht mit systemd 240
Post by: jure on 2018/12/23, 10:16:08
mit TV Browser 4.01 und systemd-240-1 habe ich hier kein Problem

Quote
Version: 4.0.1
Plattform: Linux 4.19.11-towo.2-siduction-amd64
System: amd64

Java-Version: 10.0.2 OpenJDK 64-Bit Server VM Oracle Corporation /usr/lib/jvm/java-10-openjdk-amd64
Title: Re: tvbrowser läuft nicht mit systemd 240
Post by: hsp on 2018/12/23, 10:23:02
Du hast auch das nicht mehr existierende 10.0.2 was auch nicht mehr im repo ist. Obsoletes Paket.
Nimm mal java 8 wie es eigentlich sein soll, was auch der Dev empfiehlt. Mit java 11 geht er erst recht nicht, das ist aber ein anderes Problem
Title: Re: tvbrowser läuft nicht mit systemd 240
Post by: towo on 2018/12/23, 10:32:40
Nicht nur tvbrowser, ebenso jamaica/hibiscus starten mit gleicher Fehlermeldung nicht.
Title: Re: tvbrowser läuft nicht mit systemd 240
Post by: jure on 2018/12/23, 12:15:52
auch jamaica/hibiscus läuft hier ohne Probleme

Quote
Software-Version: 2.8.6
HBCI4Java-Version: 3.0.22-SNAPSHOT
Datenbank-Version: 65
Build: 369 [Datum 20181101]

Quote
Version: 2.8.2
SWT-Version: 4626 / gtk
Java-Version: 10.0.2 / Linux amd64
Build: 450 [Datum 20180917]
Title: Re: tvbrowser läuft nicht mit systemd 240
Post by: hsp on 2018/12/23, 12:21:04
@jure
Jetzt nochmal, du benutzt noch eine nicht mehr existierende Javaverison, java 10 gibt es nicht mehr, schon sehr lange. Auch nicht mehr im Debianrepo. Du hast da noch ein völlig veraltetes Paket drauf. Stable version ist 8 und 11. Du solltest dein System mal aufräumen und alten Ballast entfernen.
...

/edit
es sind alle java-programme betroffen
Title: Re: tvbrowser läuft nicht mit systemd 240
Post by: jure on 2018/12/23, 12:26:56
ich habe auch

openjdk-8-jre
openjdk-11-jre

aber mit openjdk-10-jre laufen die progs eben ....
Title: Re: tvbrowser läuft nicht mit systemd 240
Post by: hsp on 2018/12/23, 12:33:31
Irgendwann ist dein System nur noch alter Ballast, dann behalte java 10. Irgendwann klingelts oder so...
Title: Re: tvbrowser läuft nicht mit systemd 240
Post by: hsp on 2018/12/27, 17:20:30
solved, gelöst ==> systemd 240-2