Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: pit on 2018/12/23, 12:45:49

Title: Systemd 240 breaks java (solved)
Post by: pit on 2018/12/23, 12:45:49
Don't upgrade systemd to version 240.
If you already did: Downgrade to 239 ...

Code: [Select]
sudo apt install libnss-myhostname=239-5.6 libnss-mymachines=239-5.6 libnss-systemd=239-5.6 libpam-systemd=239-5.6 libsystemd0=239-5.6 libudev-dev=239-5.6 libudev1=239-5.6 systemd=239-5.6 systemd-container=239-5.6 systemd-coredump=239-5.6 systemd-sysv=239-5.6 udev=239-5.6... and set those packages on hold
Title: Re: Systemd 240 breaks java
Post by: Penyelam on 2018/12/23, 15:07:02
@pit, thanks a lot, that helped.

Is it really recommended to set those packages on hold or isn't it better just be patient and wait with the next DU?
Title: Re: Systemd 240 breaks java
Post by: hsp on 2018/12/23, 16:31:31
https://forum.siduction.org/index.php?topic=7509.msg6118
Title: Re: Systemd 240 breaks java
Post by: finotti on 2018/12/23, 19:02:44
Don't upgrade systemd to version 240.
If you alreade did: Downgrade to 239 ...

Code: [Select]
sudo apt install libnss-myhostname=239-5.6 libnss-mymachines=239-5.6 libnss-systemd=239-5.6 libpam-systemd=239-5.6 libsystemd0=239-5.6 libudev-dev=239-5.6 libudev1=239-5.6 systemd=239-5.6 systemd-container=239-5.6 systemd-coredump=239-5.6 systemd-sysv=239-5.6 udev=239-5.6... and set those packages on hold

It does not work for me:
Code: [Select]
# apt -s install libnss-myhostname=239-5.6 libnss-mymachines=239-5.6 libnss-systemd=239-5.6 libpam-systemd=239-5.6 libsystemd0=239-5.6 libudev-dev=239-5.6 libudev1=239-5.6 systemd=239-5.6 systemd-container=239-5.6 systemd-coredump=239-5.6 systemd-sysv=239-5.6 udev=239-5.6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '239-5.6' for 'libnss-myhostname' was not found
E: Version '239-5.6' for 'libnss-mymachines' was not found
E: Version '239-5.6' for 'libnss-systemd' was not found
E: Version '239-5.6' for 'libpam-systemd' was not found
E: Version '239-5.6' for 'libsystemd0' was not found
E: Version '239-5.6' for 'libudev-dev' was not found
E: Version '239-5.6' for 'libudev1' was not found
E: Version '239-5.6' for 'systemd' was not found
E: Version '239-5.6' for 'systemd-container' was not found
E: Version '239-5.6' for 'systemd-coredump' was not found
E: Version '239-5.6' for 'systemd-sysv' was not found
E: Version '239-5.6' for 'udev' was not found
I do have testing repository enabled...  Is there anything else that needs to be done?
Title: Re: Systemd 240 breaks java
Post by: jure on 2018/12/23, 19:10:44
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917173
Title: Re: Systemd 240 breaks java
Post by: pit on 2018/12/23, 22:08:01
@finotti
Try activating the fixes repository
Code: [Select]
deb      https://packages.siduction.org/fixes unstable main contrib non-freeNow ...
Code: [Select]
sudo apt install libnss-myhostname=239-5.6 libnss-mymachines=239-5.6 libnss-systemd=239-5.6 libpam-systemd=239-5.6 libsystemd0=239-5.6 libudev-dev=239-5.6 libudev1=239-5.6 systemd=239-5.6 systemd-container=239-5.6 systemd-coredump=239-5.6 systemd-sysv=239-5.6 udev=239-5.6... should work.
Title: Re: Systemd 240 breaks java
Post by: towo on 2018/12/23, 23:01:57
There is no need for downgrading anything. Use the Fix from the linked bugreport.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917167#37
Title: Re: Systemd 240 breaks java
Post by: DeepDayze on 2018/12/23, 23:14:19
The workaround in the bug report works for me and plasma starts fine, albeit a touch slower.
Title: Re: Systemd 240 breaks java
Post by: pit on 2018/12/23, 23:31:24
I can confirm that. Thx towo!
Title: Re: Systemd 240 breaks java (solved)
Post by: DeepDayze on 2018/12/23, 23:47:16
So Java apps work again with that fix? There was another thread about Java-based apps failing  because of this issue.
Title: Re: Systemd 240 breaks java (solved)
Post by: towo on 2018/12/24, 11:01:03
Sure, even java works again with that fix.