Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: df8oe on 2018/12/24, 09:58:52

Title: KDE does not start full
Post by: df8oe on 2018/12/24, 09:58:52
Yesterday everything was working fine - today kde/plasma starts without loading desktop background picture and missing taskbar. So I cannot start any application "via mouse / gui". I waited more than 20 minutes - no taskbar appears. Fortunately I have left open two console windows at last session which are open now so that I get access to applications via command line  ;) .


I tried downgrading systemd and dependent packages to 239 - but that does not change anything. I tried "kwin --replace &" - that restarts kwin fine but no taskbar at all. I tried rebooting - without success. I can access other PCs running Siduction and will check if behaviour is identical on all of them.


How for hell can I restart taskbar (except kwin --replace &) ?? There is nothing critical in dmesg and Xorg logs - where can I take a look? Is it possible to start a kde/plasma session without loading settings from last session?


I proudly present the first unusable Siduction I got within ~5 years. This is a very good result for a system which bases on "unstable". Millions of Windows users have unusable systems in a much smaller timespan - and I think it can be fixed without new installation.  ;D


Best regards
df8oe
Title: Re: KDE does not start full
Post by: unklarer on 2018/12/24, 10:39:57
Because we're on sarcasm right now...   ;D

I will abolish plasma next year, because I'm just fed up with this crap and I'm concentrating on LXDE and Fluxbox. You know what you have.
Title: Re: KDE does not start full
Post by: df8oe on 2018/12/24, 11:13:41
@unklarer:
You can do that of course - it is your decision. But not mine.


In the meantime I have investigated more:
- the issue is not related to a malsetting in users home directory. It also appears at a clean home directory (created new user)
- when I observe kde starting up I can see desktop background image appears for a few seconds (as usual) but then vanishes.
- after kde started up completely there are windows of the applications which were active during last shutdown. I can switch virtual desktops via "screen corners function". If i click on desktop left or right nothing happens (no menu appears).


Other machines with the same software state do not show the issue. A possible important difference is that this machine does have nvidia graphics card (with nvidia drivers activated) and other machines do not have nvidia card...


Best regards
df8oe
Title: Re: KDE does not start full
Post by: df8oe on 2018/12/24, 13:00:28
Update:


I started plasmashell using strace and found that plasmashell crashed with segfault hen loading print-manager. I cannot undestand why (print-manager was not updated yesterday). When I purge print-manager everything works fine again. Reinstalling print-manager brings up a working systemsettings-module - but only as long as I do not restart system. When restarting issue comes up again. It is definitely bound to cups and print-manager. And does not appear on any other machine.


Suspected...


Best regards
df8oe
Title: Re: KDE does not start full
Post by: piper on 2018/12/24, 13:27:10
You can try the 415.25 nvidia drivers (experimental), I have no problems with them :)

Can you try this

You can go back to 240 systemd and/or the other shit that was downgraded with it

You can make a file called systemd.conf in

Code: [Select]
/etc/security/limits.d
and edit systemd.conf to look like

Code: [Select]
* hard nofile 524288
save/close/reboot

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917167#37