Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: axt on 2018/12/27, 04:22:03

Title: qt5-Transition
Post by: axt on 2018/12/27, 04:22:03
Die Transition von qt5 5.11.2 auf .3 will mir gerade das halbe System hinwegraffen - also Obacht!

Look out! A qt5 transition is currently running. Very few packages have been adapted so far.

Title: Re: qt5-Transition
Post by: tranquil on 2018/12/27, 07:20:33
Thank you for the heads up...ouch!

Code: [Select]
The following packages were automatically installed and are no longer required:
  kwayland-data libdbusmenu-qt5-2 libkf5auth-data libkf5auth5 libkf5configgui5
  libkf5configwidgets-data libkf5configwidgets5 libkf5crash5 libkf5guiaddons5
  libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5 libkf5idletime5
  libkf5notifications-data libkf5service-bin libkf5service-data libkf5service5
  libkf5wallet-data libkf5waylandclient5 libphonon4qt5-4 libpolkit-qt5-1-1
  libqt5help5 libqt5quick5 libqt5quickwidgets5 libqt5webengine-data phonon4qt5
  phonon4qt5-backend-vlc python3-dbus.mainloop.pyqt5 python3-sip xsane
  xsane-common
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  falkon hplip-gui kwayland-integration libkf5notifications5 libkf5wallet-bin
  libkf5wallet5 libkwalletbackend5-5 libqt5designer5 libqt5positioning5
  libqt5sensors5 libqt5texttospeech5 libqt5waylandclient5 libqt5waylandcompositor5
  libqt5webchannel5 libqt5webenginecore5 libqt5webenginewidgets5 libqt5webkit5
  phantomjs python3-pyqt5 qtwayland5
The following NEW packages will be installed:
  libntfs-3g883
The following packages will be upgraded:
  apt-file exim4-base exim4-config exim4-daemon-light gir1.2-gtksource-3.0
  libel-api-java libgoa-1.0-0b libgoa-1.0-common libgraphene-1.0-0 libgspell-1-1
  libgspell-1-common libgssdp-1.0-3 libgtksourceview-3.0-1
  libgtksourceview-3.0-common libgtkspell3-3-0 libgucharmap-2-90-7 libgupnp-1.0-4
  libhdf5-103 libhdf5-cpp-103 libhdf5-openmpi-103 libpanel-applet3
  libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5
  libqt5opengl5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5quickwidgets5
  libqt5sql5 libqt5sql5-sqlite libqt5svg5 libqt5test5 libqt5widgets5
  libqt5x11extras5 libqt5xml5 libsqlite3-0 ntfs-3g python-numpy
  qt5-gtk-platformtheme sqlite3 task-english task-laptop tasksel tasksel-data
47 upgraded, 1 newly installed, 20 to remove and 0 not upgraded.
Need to get 23.2 MB/23.2 MB of archives.
After this operation, 207 MB disk space will be freed.
Update:  placing qt5-gtk-platformtheme temporarily on hold removes all of the above mess.  Now this is more like it!
Code: [Select]
The following NEW packages will be installed:
  libntfs-3g883
The following packages have been kept back:
  libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5
  libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5quickwidgets5 libqt5sql5
  libqt5sql5-sqlite libqt5svg5 libqt5test5 libqt5widgets5 libqt5x11extras5
  libqt5xml5 qt5-gtk-platformtheme
The following packages will be upgraded:
  apt-file exim4-base exim4-config exim4-daemon-light gir1.2-gtksource-3.0
  libel-api-java libgoa-1.0-0b libgoa-1.0-common libgraphene-1.0-0 libgspell-1-1
  libgspell-1-common libgssdp-1.0-3 libgtksourceview-3.0-1
  libgtksourceview-3.0-common libgtkspell3-3-0 libgucharmap-2-90-7 libgupnp-1.0-4
  libhdf5-103 libhdf5-cpp-103 libhdf5-openmpi-103 libpanel-applet3
  libqt5concurrent5 libsqlite3-0 ntfs-3g python-numpy sqlite3 task-english
  task-laptop tasksel tasksel-data
30 upgraded, 1 newly installed, 0 to remove and 17 not upgraded.
Need to get 11.5 MB/11.6 MB of archives.
After this operation, 526 kB of additional disk space will be used.
Title: Re: qt5-Transition
Post by: axt on 2018/12/27, 15:35:12
Quote from: tranquil
placing qt5-gtk-platformtheme temporarily on hold removes all of the above mess.

That alone changes almost nothing here (LXQt, several packages like krusader → Qt based).

If there is one thing you could reasonably set on hold: 

Code: [Select]
apt-mark hold libqt5core5a

But don't forget after the transition!
Title: Re: qt5-Transition
Post by: melmarker on 2018/12/27, 20:47:06
The answer is: Patience.
Title: Re: qt5-Transition
Post by: dibl on 2018/12/28, 23:13:25
Quote from: melmarker
The answer is: Patience.

Yes, it is.  Full-upgrade will now run successfully on KDE/Plasma and LXQt systems. (17:12 U.S. Eastern)
Title: Re: qt5-Transition
Post by: drb on 2018/12/29, 10:58:52
Everything looks good except akonadi-backend-sqlite wants to be removed? Any ideas why?
Title: Re: qt5-Transition
Post by: piper on 2018/12/29, 11:42:37
Quote from: drb
Everything looks good except akonadi-backend-sqlite wants to be removed? Any ideas why?

Because of qt transition (50% done)

which also involves



    akonadi-backend-mysql
    akonadi-backend-postgresql
    akonadi-backend-sqlite
    akonadi-server
    libkf5akonadi-data
    libkf5akonadi-dev
    libkf5akonadi-dev-bin
    libkf5akonadiagentbase5
    libkf5akonadicore5abi2
    libkf5akonadiprivate5abi2
    libkf5akonadiserver-dev
    libkf5akonadiwidgets5abi1
    libkf5akonadixml5

Title: Re: qt5-Transition
Post by: drb on 2018/12/29, 12:07:32
Thanks! I'll be patient . . .
Title: Re: qt5-Transition
Post by: CCarpenter on 2019/01/04, 03:07:22
Some updates?
Title: Re: qt5-Transition
Post by: drb on 2019/01/04, 10:17:34
Still waiting for akonadi-backend-sqlite update here.
Title: Re: qt5-Transition
Post by: CCarpenter on 2019/01/06, 02:58:36
Same here ...
Code: [Select]
Die folgenden Pakete werden ENTFERNT:
  akonadi-backend-sqlite libsensors4 libsensors4:i386 mysql-client-5.7
  mysql-client-core-5.7 sensord
Title: Re: qt5-Transition
Post by: vayu on 2019/01/07, 06:15:09
I'm still far from being able to upgrade.  I've had 40+ packages set for remove for a long time.

Code: [Select]
The following packages will be REMOVED:
  colord dbus-user-session gvfs gvfs-backends gvfs-daemons gvfs-fuse k3b k3b-i18n kde-plasma-desktop kde-standard kinfocenter
  libmedc1v5 libqapt3-runtime libsensors4 libsensors4:i386 libvirt-daemon-system mariadb-client-10.1 mariadb-client-core-10.1
  mariadb-server-10.1 mariadb-server-core-10.1 muon network-manager network-manager-openconnect network-manager-openvpn
  network-manager-pptp network-manager-vpnc packagekit packagekit-tools plasma-desktop plasma-discover plasma-mediacenter plasma-nm
  plasma-widgets-addons plasma-workspace plasma-workspace-dev policykit-1 polkit-kde-agent-1 rtkit sddm-theme-breeze synaptic
  udisks2
Title: Re: qt5-Transition
Post by: finotti on 2019/01/07, 11:39:11
FWIW, all my systems have been upgraded a while ago without removals....
Code: [Select]
$ apt policy akonadi-backend-sqlite
akonadi-backend-sqlite:
  Installed: 4:18.08.1-1+b2
  Candidate: 4:18.08.1-1+b2
  Version table:
 *** 4:18.08.1-1+b2 500
        500 http://httpredir.debian.org/debian sid/main amd64 Packages
        500 http://httpredir.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
I'm pretty sure the qt5 transition is done: https://release.debian.org/transitions/
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 14:13:47
Interesting. I get:
Code: [Select]
apt policy akonadi-backend-sqlite
akonadi-backend-sqlite:
  Installed: 4:18.08.1-1.1
  Candidate: 4:18.08.1-1.1
  Version table:
 *** 4:18.08.1-1.1 500
        500 http://packages.siduction.org/fixes unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     4:18.08.1-1+b2 500
        500 http://http.debian.net/debian unstable/main amd64 Packages
        500 http://http.debian.net/debian testing/main amd64 Packages
Title: Re: qt5-Transition
Post by: finotti on 2019/01/07, 15:52:31
What does
Code: [Select]
apt-get -o Debug::pkgProblemResolver=yes dist-upgradesay?
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 15:57:43
Code: [Select]
Investigating (0) akonadi-backend-sqlite:amd64 < 4:18.08.1-1.1 @ii mK Ib >
Broken akonadi-backend-sqlite:amd64 Depends on qtbase-abi-5-11-2:amd64 < none @un H >
  Considering libqt5core5a:amd64 6461 as a solution to akonadi-backend-sqlite:amd64 5
  Removing akonadi-backend-sqlite:amd64 rather than change qtbase-abi-5-11-2:amd64
Title: Re: qt5-Transition
Post by: finotti on 2019/01/07, 16:05:44
Code: [Select]
Investigating (0) akonadi-backend-sqlite:amd64 < 4:18.08.1-1.1 @ii mK Ib >
Broken akonadi-backend-sqlite:amd64 Depends on qtbase-abi-5-11-2:amd64 < none @un H >
  Considering libqt5core5a:amd64 6461 as a solution to akonadi-backend-sqlite:amd64 5
  Removing akonadi-backend-sqlite:amd64 rather than change qtbase-abi-5-11-2:amd64
I wonder which package contains  qtbase-abi-5-11-2?  qt5-default?   qtbase-dev? qtbase5-dev-tools?  Maybe do an apt policy to these?  I do not have the latter two installed...  But both can be installed without problems:
Code: [Select]
# apt -s install qtbase5-dev-tools qtbase5-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libdrm-dev libgl1-mesa-dev libgles1 libglu1-mesa-dev libglvnd-core-dev libglvnd-dev libopengl0 libvulkan-dev libx11-xcb-dev
  libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev
  libxcb-sync-dev libxcb-xfixes0-dev libxdamage-dev libxfixes-dev libxshmfence-dev libxxf86vm-dev mesa-common-dev qt5-qmake
  qt5-qmake-bin x11proto-damage-dev x11proto-fixes-dev x11proto-xf86vidmode-dev
Suggested packages:
  default-libmysqlclient-dev firebird-dev libegl1-mesa-dev libpq-dev unixodbc-dev
Recommended packages:
  libqt5opengl5-dev
The following NEW packages will be installed:
  libdrm-dev libgl1-mesa-dev libgles1 libglu1-mesa-dev libglvnd-core-dev libglvnd-dev libopengl0 libvulkan-dev libx11-xcb-dev
  libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev
  libxcb-sync-dev libxcb-xfixes0-dev libxdamage-dev libxfixes-dev libxshmfence-dev libxxf86vm-dev mesa-common-dev qt5-qmake
  qt5-qmake-bin qtbase5-dev qtbase5-dev-tools x11proto-damage-dev x11proto-fixes-dev x11proto-xf86vidmode-dev
0 upgraded, 30 newly installed, 0 to remove and 0 not upgraded.
Inst libdrm-dev (2.4.95-1 Debian:unstable, Debian:testing [amd64])
Inst mesa-common-dev (18.2.8-2 Debian:unstable, Debian:testing [amd64])
Inst libglvnd-core-dev (1.1.0-1 Debian:unstable, Debian:testing [amd64])
Inst libgles1 (1.1.0-1 Debian:unstable, Debian:testing [amd64])
Inst libopengl0 (1.1.0-1 Debian:unstable, Debian:testing [amd64])
Inst libglvnd-dev (1.1.0-1 Debian:unstable, Debian:testing [amd64])
Inst libx11-xcb-dev (2:1.6.7-1 Debian:unstable, Debian:testing [amd64])
Inst libxcb-dri3-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Inst libxcb-render0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Inst libxcb-randr0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Inst libxcb-shape0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Inst libxcb-xfixes0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Inst libxcb-sync-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Inst libxcb-present-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Inst libxshmfence-dev (1.3-1 Debian:unstable, Debian:testing [amd64])
Inst libxcb-dri2-0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Inst libxcb-glx0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Inst x11proto-fixes-dev (1:2018.4-4 Debian:unstable, Debian:testing [all])
Inst libxfixes-dev (1:5.0.3-1 Debian:unstable, Debian:testing [amd64])
Inst x11proto-damage-dev (1:2018.4-4 Debian:unstable, Debian:testing [all])
Inst libxdamage-dev (1:1.1.4-3 Debian:unstable, Debian:testing [amd64])
Inst x11proto-xf86vidmode-dev (2018.4-4 Debian:unstable, Debian:testing [all])
Inst libxxf86vm-dev (1:1.1.4-1+b2 Debian:unstable, Debian:testing [amd64])
Inst libgl1-mesa-dev (18.2.8-2 Debian:unstable, Debian:testing [amd64])
Inst libglu1-mesa-dev (9.0.0-2.1 Debian:unstable, Debian:testing [amd64])
Inst libvulkan-dev (1.1.73+dfsg-1 Debian:unstable, Debian:testing [amd64])
Inst qt5-qmake-bin (5.11.3+dfsg-2 Debian:unstable, Debian:testing [amd64])
Inst qt5-qmake (5.11.3+dfsg-2 Debian:unstable, Debian:testing [amd64])
Inst qtbase5-dev-tools (5.11.3+dfsg-2 Debian:unstable, Debian:testing [amd64])
Inst qtbase5-dev (5.11.3+dfsg-2 Debian:unstable, Debian:testing [amd64])
Conf libdrm-dev (2.4.95-1 Debian:unstable, Debian:testing [amd64])
Conf mesa-common-dev (18.2.8-2 Debian:unstable, Debian:testing [amd64])
Conf libglvnd-core-dev (1.1.0-1 Debian:unstable, Debian:testing [amd64])
Conf libgles1 (1.1.0-1 Debian:unstable, Debian:testing [amd64])
Conf libopengl0 (1.1.0-1 Debian:unstable, Debian:testing [amd64])
Conf libglvnd-dev (1.1.0-1 Debian:unstable, Debian:testing [amd64])
Conf libx11-xcb-dev (2:1.6.7-1 Debian:unstable, Debian:testing [amd64])
Conf libxcb-dri3-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Conf libxcb-render0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Conf libxcb-randr0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Conf libxcb-shape0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Conf libxcb-xfixes0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Conf libxcb-sync-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Conf libxcb-present-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Conf libxshmfence-dev (1.3-1 Debian:unstable, Debian:testing [amd64])
Conf libxcb-dri2-0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Conf libxcb-glx0-dev (1.13.1-2 Debian:unstable, Debian:testing [amd64])
Conf x11proto-fixes-dev (1:2018.4-4 Debian:unstable, Debian:testing [all])
Conf libxfixes-dev (1:5.0.3-1 Debian:unstable, Debian:testing [amd64])
Conf x11proto-damage-dev (1:2018.4-4 Debian:unstable, Debian:testing [all])
Conf libxdamage-dev (1:1.1.4-3 Debian:unstable, Debian:testing [amd64])
Conf x11proto-xf86vidmode-dev (2018.4-4 Debian:unstable, Debian:testing [all])
Conf libxxf86vm-dev (1:1.1.4-1+b2 Debian:unstable, Debian:testing [amd64])
Conf libgl1-mesa-dev (18.2.8-2 Debian:unstable, Debian:testing [amd64])
Conf libglu1-mesa-dev (9.0.0-2.1 Debian:unstable, Debian:testing [amd64])
Conf libvulkan-dev (1.1.73+dfsg-1 Debian:unstable, Debian:testing [amd64])
Conf qt5-qmake-bin (5.11.3+dfsg-2 Debian:unstable, Debian:testing [amd64])
Conf qt5-qmake (5.11.3+dfsg-2 Debian:unstable, Debian:testing [amd64])
Conf qtbase5-dev-tools (5.11.3+dfsg-2 Debian:unstable, Debian:testing [amd64])
Conf qtbase5-dev (5.11.3+dfsg-2 Debian:unstable, Debian:testing [amd64])
If one of them is the problem, you can try to uninstall it, upgrade, and the reinstall it.  (Do simulations first!)
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 16:10:22
libqt5core5a (https://packages.debian.org/sid/libqt5core5a) provides qtbase-abi-5-11-2
https://packages.debian.org/sid/qtbase-abi-5-11-2 (https://packages.debian.org/sid/qtbase-abi-5-11-2)
Title: Re: qt5-Transition
Post by: finotti on 2019/01/07, 16:12:30
I have:
Code: [Select]
  Installed: 5.11.3+dfsg-2
  Candidate: 5.11.3+dfsg-2
  Version table:
 *** 5.11.3+dfsg-2 500
        500 http://httpredir.debian.org/debian sid/main amd64 Packages
        500 http://httpredir.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
You can try:
Code: [Select]
apt -s install libqt5core5a and see what happens...  (The "-s" is to only simulate.)
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 16:15:30
Code: [Select]
The following packages will be REMOVED:
  akonadi-backend-sqlite akonadi-kde-resource-googledata akregator kde-baseapps kde-plasma-desktop kde-standard kdepim-runtime kmail knotes konq-plugins
  konqueror kontact korganizer libkf5akonadicalendar5abi1 libkf5calendarsupport5abi1 libkf5eventviews5abi1 libkf5incidenceeditor5abi1 libkf5ksieveui5
  libkf5mailcommon5abi2 libkf5mailtransport5 libkf5mailtransportakonadi5 libkf5messagecomposer5abi1 libkf5messageviewer5abi1 libkf5templateparser5
  libkf5webengineviewer5abi1 libkpeople4 libkpimgapicalendar5 libkpimgapicontacts5 libkpimgapicore5abi1 libkpimgapitasks5 libktpcommoninternalsprivate8
  libktpmodelsprivate8 libktpwidgetsprivate8 libqt5webengine5 libqt5webenginecore5 libqt5webenginewidgets5 plasma-widgets-addons
Title: Re: qt5-Transition
Post by: finotti on 2019/01/07, 16:19:38
Weird...  Was the qtbase-abi-5-11-2 the only complain from "apt-get -o Debug::pkgProblemResolver=yes dist-upgrade"?  If so, I'm out of ideas...
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 16:24:36
Whole output:
Code: [Select]
apt-get -o Debug::pkgProblemResolver=yes dist-upgrade -dV
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 10
Starting 2 pkgProblemResolver with broken count: 10
Investigating (0) akonadi-backend-sqlite:amd64 < 4:18.08.1-1.1 @ii mK Ib >
Broken akonadi-backend-sqlite:amd64 Depends on qtbase-abi-5-11-2:amd64 < none @un H >
  Considering libqt5core5a:amd64 6461 as a solution to akonadi-backend-sqlite:amd64 5
  Removing akonadi-backend-sqlite:amd64 rather than change qtbase-abi-5-11-2:amd64
Investigating (0) libsensors-config:amd64 < none -> 1:3.5.0-3 @un uN Ib >
Broken libsensors-config:amd64 Breaks on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
  Considering libsensors4:amd64 -1 as a solution to libsensors-config:amd64 3
  Added libsensors4:amd64 to the remove list
  Fixing libsensors-config:amd64 via remove of libsensors4:amd64
Investigating (0) mariadb-client-10.3:amd64 < none -> 1:10.3.11-3 @un uN Ib >
Broken mariadb-client-10.3:amd64 Conflicts on virtual-mysql-client:amd64 < none @un H >
  Conflicts//Breaks against version 5.7.24-2 for mysql-client-5.7 but that is not InstVer, ignoring
  Considering mariadb-client-10.1:amd64 -1 as a solution to mariadb-client-10.3:amd64 2
  Added mariadb-client-10.1:amd64 to the remove list
Broken mariadb-client-10.3:amd64 Breaks on mariadb-client-10.1:amd64 < 1:10.1.37-3 @ii mK Ib >
  Considering mariadb-client-10.1:amd64 -1 as a solution to mariadb-client-10.3:amd64 2
  Added mariadb-client-10.1:amd64 to the remove list
  Fixing mariadb-client-10.3:amd64 via remove of mariadb-client-10.1:amd64
  Fixing mariadb-client-10.3:amd64 via remove of mariadb-client-10.1:amd64
Investigating (0) mariadb-server-10.3:amd64 < none -> 1:10.3.11-3 @un uN Ib >
Broken mariadb-server-10.3:amd64 Conflicts on virtual-mysql-server:amd64 < none @un H >
  Conflicts//Breaks against version 5.7.24-2 for mysql-server-5.7 but that is not InstVer, ignoring
  Considering mariadb-server-10.1:amd64 -2 as a solution to mariadb-server-10.3:amd64 1
  Added mariadb-server-10.1:amd64 to the remove list
Broken mariadb-server-10.3:amd64 Breaks on mariadb-server-10.1:amd64 < 1:10.1.37-3 @ii mK Ib >
  Considering mariadb-server-10.1:amd64 -2 as a solution to mariadb-server-10.3:amd64 1
  Added mariadb-server-10.1:amd64 to the remove list
  Fixing mariadb-server-10.3:amd64 via remove of mariadb-server-10.1:amd64
  Fixing mariadb-server-10.3:amd64 via remove of mariadb-server-10.1:amd64
Investigating (0) mariadb-client-core-10.3:amd64 < none -> 1:10.3.11-3 @un uN Ib >
Broken mariadb-client-core-10.3:amd64 Conflicts on virtual-mysql-client-core:amd64 < none @un H >
  Conflicts//Breaks against version 5.7.24-2 for mysql-client-core-5.7 but that is not InstVer, ignoring
  Considering mariadb-client-core-10.1:amd64 0 as a solution to mariadb-client-core-10.3:amd64 1
  Added mariadb-client-core-10.1:amd64 to the remove list
Broken mariadb-client-core-10.3:amd64 Breaks on mariadb-client-core-10.1:amd64 < 1:10.1.37-3 @ii mK Ib >
  Considering mariadb-client-core-10.1:amd64 0 as a solution to mariadb-client-core-10.3:amd64 1
  Added mariadb-client-core-10.1:amd64 to the remove list
  Fixing mariadb-client-core-10.3:amd64 via remove of mariadb-client-core-10.1:amd64
  Fixing mariadb-client-core-10.3:amd64 via remove of mariadb-client-core-10.1:amd64
Investigating (0) mariadb-server-core-10.3:amd64 < none -> 1:10.3.11-3 @un uN Ib >
Broken mariadb-server-core-10.3:amd64 Conflicts on virtual-mysql-server-core:amd64 < none @un H >
  Conflicts//Breaks against version 5.7.24-2 for mysql-server-core-5.7 but that is not InstVer, ignoring
  Considering mariadb-server-core-10.1:amd64 0 as a solution to mariadb-server-core-10.3:amd64 0
  Holding Back mariadb-server-core-10.3:amd64 rather than change virtual-mysql-server-core:amd64
Investigating (1) mariadb-server-10.3:amd64 < none -> 1:10.3.11-3 @un uN Ib >
Broken mariadb-server-10.3:amd64 Depends on mariadb-server-core-10.3:amd64 < none | 1:10.3.11-3 @un uH > (>= 1:10.3.11-3)
  Considering mariadb-server-core-10.3:amd64 0 as a solution to mariadb-server-10.3:amd64 1
  Holding Back mariadb-server-10.3:amd64 rather than change mariadb-server-core-10.3:amd64
Investigating (2) default-mysql-server:amd64 < 1.0.4 -> 1.0.5 @ii umU Ib >
Broken default-mysql-server:amd64 Depends on mariadb-server-10.3:amd64 < none | 1:10.3.11-3 @un uH >
  Considering mariadb-server-10.3:amd64 1 as a solution to default-mysql-server:amd64 2
  Removing default-mysql-server:amd64 rather than change mariadb-server-10.3:amd64
Investigating (3) akonadi-backend-mysql:amd64 < 4:18.08.1-1.1 @ii mK Ib >
Broken akonadi-backend-mysql:amd64 Depends on default-mysql-server:amd64 < 1.0.4 | 1.0.5 @ii umR >
  Considering default-mysql-server:amd64 2 as a solution to akonadi-backend-mysql:amd64 5
  Added default-mysql-server:amd64 to the remove list
Broken akonadi-backend-mysql:amd64 Depends on virtual-mysql-server:amd64 < none @un H >
  Considering mysql-server-5.7:amd64 -4 as a solution to akonadi-backend-mysql:amd64 5
  Added mysql-server-5.7:amd64 to the remove list
  Fixing akonadi-backend-mysql:amd64 via keep of default-mysql-server:amd64
  Fixing akonadi-backend-mysql:amd64 via keep of mysql-server-5.7:amd64
 Try to Re-Instate (3) default-mysql-server:amd64
Investigating (3) default-mysql-server:amd64 < 1.0.4 | 1.0.5 @ii umH Ib >
Broken default-mysql-server:amd64 Depends on mariadb-server-10.1:amd64 < 1:10.1.37-3 @ii mR >
  Considering mariadb-server-10.1:amd64 -2 as a solution to default-mysql-server:amd64 5
  Added mariadb-server-10.1:amd64 to the remove list
  Fixing default-mysql-server:amd64 via keep of mariadb-server-10.1:amd64
Investigating (3) mariadb-server-10.1:amd64 < 1:10.1.37-3 @ii mK Ib >
Broken mariadb-server-10.1:amd64 Depends on mariadb-client-10.1:amd64 < 1:10.1.37-3 @ii mR > (>= 1:10.1.37-3)
  Considering mariadb-client-10.1:amd64 -1 as a solution to mariadb-server-10.1:amd64 5
  Added mariadb-client-10.1:amd64 to the remove list
  Fixing mariadb-server-10.1:amd64 via keep of mariadb-client-10.1:amd64
Investigating (4) mariadb-client-10.3:amd64 < none -> 1:10.3.11-3 @un uN Ib >
Broken mariadb-client-10.3:amd64 Conflicts on virtual-mysql-client:amd64 < none @un H >
  Conflicts//Breaks against version 5.7.24-2 for mysql-client-5.7 but that is not InstVer, ignoring
  Considering mariadb-client-10.1:amd64 5 as a solution to mariadb-client-10.3:amd64 2
  Holding Back mariadb-client-10.3:amd64 rather than change virtual-mysql-client:amd64
Investigating (4) mariadb-client-10.1:amd64 < 1:10.1.37-3 @ii mK Ib >
Broken mariadb-client-10.1:amd64 Depends on mariadb-client-core-10.1:amd64 < 1:10.1.37-3 @ii mR > (>= 1:10.1.37-3)
  Considering mariadb-client-core-10.1:amd64 0 as a solution to mariadb-client-10.1:amd64 5
  Added mariadb-client-core-10.1:amd64 to the remove list
  Fixing mariadb-client-10.1:amd64 via keep of mariadb-client-core-10.1:amd64
Investigating (5) default-mysql-client:amd64 < 1.0.4 -> 1.0.5 @ii umU Ib >
Broken default-mysql-client:amd64 Depends on mariadb-client-10.3:amd64 < none | 1:10.3.11-3 @un uH >
  Considering mariadb-client-10.3:amd64 2 as a solution to default-mysql-client:amd64 2
  Holding Back default-mysql-client:amd64 rather than change mariadb-client-10.3:amd64
Investigating (5) mariadb-client-core-10.3:amd64 < none -> 1:10.3.11-3 @un uN Ib >
Broken mariadb-client-core-10.3:amd64 Conflicts on virtual-mysql-client-core:amd64 < none @un H >
  Conflicts//Breaks against version 5.7.24-2 for mysql-client-core-5.7 but that is not InstVer, ignoring
  Considering mariadb-client-core-10.1:amd64 5 as a solution to mariadb-client-core-10.3:amd64 1
  Holding Back mariadb-client-core-10.3:amd64 rather than change virtual-mysql-client-core:amd64
 Try to Re-Instate (6) default-mysql-client:amd64
Title: Re: qt5-Transition
Post by: finotti on 2019/01/07, 16:29:39
I am not sure, but it might be mysql-client:
Code: [Select]
apt policy mysql-client
mysql-client:
  Installed: (none)
  Candidate: 5.7.24-2
  Version table:
     5.7.24-2 500
        500 http://httpredir.debian.org/debian sid/main amd64 Packages
Code: [Select]
# apt -s install mysql-client
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mysql-client : Depends: mysql-client-5.7 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 16:31:57
Not installed here either:
Code: [Select]
apt policy mysql-client
mysql-client:
  Installed: (none)
  Candidate: 5.7.24-2
  Version table:
     5.7.24-2 500
        500 http://http.debian.net/debian unstable/main amd64 Packages
Title: Re: qt5-Transition
Post by: finotti on 2019/01/07, 16:33:27
Do you know which package provides virtual-mysql-client?
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 16:37:37
virtual-mysql-client is provided by mariadb-client-10.1 (I don't have mariadb-client-10.3 installed)
Is it possible to simulate the installation of a package using dpkg? I could download akonadi-backend-sqlite 4:18.08.1-1+b2
Title: Re: qt5-Transition
Post by: finotti on 2019/01/07, 16:47:08
What does
Code: [Select]
apt -s install mariadb-client-10.3say?

Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 16:58:30
apt -s install mariadb-client-10.3
Code: [Select]
The following packages will be REMOVED:
  akonadi-backend-mysql default-mysql-server mariadb-client-10.1 mariadb-client-core-10.1 mariadb-server-10.1
apt -s install mariadb-client-10.3 libqt5core5a gives:
Code: [Select]
The following packages will be REMOVED:
  akonadi-backend-mysql akonadi-backend-sqlite akonadi-kde-resource-googledata akregator default-mysql-server kde-baseapps kde-plasma-desktop kde-standard
  kdepim-runtime kmail knotes konq-plugins konqueror kontact korganizer libkf5akonadicalendar5abi1 libkf5calendarsupport5abi1 libkf5eventviews5abi1
  libkf5incidenceeditor5abi1 libkf5ksieveui5 libkf5mailcommon5abi2 libkf5mailtransport5 libkf5mailtransportakonadi5 libkf5messagecomposer5abi1
  libkf5messageviewer5abi1 libkf5templateparser5 libkf5webengineviewer5abi1 libkpeople4 libkpimgapicalendar5 libkpimgapicontacts5 libkpimgapicore5abi1
  libkpimgapitasks5 libktpcommoninternalsprivate8 libktpmodelsprivate8 libktpwidgetsprivate8 libqt5webengine5 libqt5webenginecore5 libqt5webenginewidgets5
  mariadb-client-10.1 mariadb-client-core-10.1 mariadb-server-10.1 plasma-widgets-addons
Title: Re: qt5-Transition
Post by: finotti on 2019/01/07, 17:04:45
That doesn't seem bad.  I do have akonadi-backend-mysql installed, so probably you can reinstall it later...  I do not have  mariadb-client-10.3 installed, though...  (I can install it, though.)

Now, you can try that and see if you can DU...  But it might be dangerous, and I'm not an expert, so I am not sure if it is really a good idea...  It'd be more an experiment.
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 17:15:30
The problem appears to be that I need akonadi-backend-sqlite 4:18.08.1-1+b2 but apt can't find it in sid, although it is the only package apparently available!
Title: Re: qt5-Transition
Post by: vayu on 2019/01/07, 17:18:05
FWIW, all my systems have been upgraded a while ago without removals....

I'm pretty sure the qt5 transition is done: https://release.debian.org/transitions/ (https://release.debian.org/transitions/)
finotti, thanks for letting me know.
Knowing that plus this very cool command I've never seen before helped me get my system all up to date.
Code: [Select]
apt-get -o Debug::pkgProblemResolver=yes dist-upgrade
Title: Re: qt5-Transition
Post by: finotti on 2019/01/07, 17:24:14
The problem appears to be that I need akonadi-backend-sqlite 4:18.08.1-1+b2 but apt can't find it in sid, although it is the only package apparently available!
I just noticed that in your output of apt policy...  (I had missed it before.)  The obvious: did you run "apt update"?  If so, maybe change your repository, as it does show up as available to me:
Code: [Select]
# apt policy akonadi-backend-sqlite
akonadi-backend-sqlite:
  Installed: 4:18.08.1-1+b2
  Candidate: 4:18.08.1-1+b2
  Version table:
 *** 4:18.08.1-1+b2 500
        500 http://httpredir.debian.org/debian sid/main amd64 Packages
        500 http://httpredir.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 17:27:15
Isn't the version I have 4:18.08.1-1.1 later than 4:18.08.1-1+b2? Even though only 4:18.08.1-1+b2 is downloadable from debian sid.
Title: Re: qt5-Transition
Post by: jure on 2019/01/07, 17:28:12
Quote
The problem appears to be that I need akonadi-backend-sqlite 4:18.08.1-1+b2 but apt can't find it in sid, although it is the only package apparently available!

try to disable "http://packages.siduction.org/fixes unstable/main amd64 Packages" in /etc/apt/sources.list.d....

than the debian version 4:18.08.1-1+b2  should be installed
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 17:32:18
Thanks. I have already tried that earlier but still have a problem that b2 isn't found.
Title: Re: qt5-Transition
Post by: jure on 2019/01/07, 17:35:59
hmm - I did it just 15min before and reinstalled akonadi-backend-sqlite here

now it is
Code: [Select]
apt policy akonadi-backend-sqlite
akonadi-backend-sqlite:
  Installiert:           4:18.08.1-1+b2
  Installationskandidat: 4:18.08.1-1+b2
  Versionstabelle:
 *** 4:18.08.1-1+b2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 17:39:10
Did you let it go then reinstall it?
Also, what is your debian sources list?
Title: Re: qt5-Transition
Post by: jure on 2019/01/07, 17:40:40
yes I let it go 29.12.2018 and now reinstalled it

Code: [Select]
cat /etc/apt/sources.list.d/debian.list
# debian loadbalancer
deb http://httpredir.debian.org/debian/ unstable main contrib non-free
#deb-src http://http.debian.net/debian/ unstable main contrib non-free

#testing
#deb http://httpredir.debian.org/debian/ testing main contrib non-free

# Experimental
#deb http://ftp.us.debian.org/debian/ experimental main contrib non-free
#deb-src http://ftp.us.debian.org/debian/ experimental main contrib non-free

# stable
#deb http://ftp.nl.debian.org/debian/ stable main contrib non-free
Title: Re: qt5-Transition
Post by: drb on 2019/01/07, 17:43:48
It looks like I've got to let  4:18.08.1-1.1 go then reinstall 4:18.08.1-1+b2 after disabling siduction/fixes.
PS Removal of akonadi-backend-sqlite, two dist-upgrades and reinstallation of akonadi-backend-sqlite got there!