Siduction Forum

Siduction Forum => Installation - Support => Installation Support (EN) => Topic started by: clubex on 2019/01/23, 12:06:52

Title: Install failure
Post by: clubex on 2019/01/23, 12:06:52
I'm trying to reinstall my / partition using siduction-18.3.0-patience-kde-amd64-201805132121 without successs. The checksum is correct.

The installation seems to hang at 32% (clearing fll-install leftovers) although there is still HD activity. I know sometimes an install can take a lon time so I let it continue for 1 1/2 hours. But no success.

I tried serveral different DVDs (no USB sticks available) all with the same effect.

Is there a way that I cam run the install from the CLI so I can see what is happening?

Code: [Select]
$ inxi -b
System:    Host: keith-westield Kernel: 4.10.0-38-generic x86_64 (64 bit)
           Desktop: KDE Plasma 5.8.9 Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASRock model: N68C-GS FX Bios: American Megatrends v: P1.40 date: 10/31/2012
CPU:       Quad core AMD Phenom II X4 945 (-MCP-) speed/max: 800/3000 MHz
Graphics:  Card: NVIDIA GM107 [GeForce GTX 750 Ti]
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1680x1050@59.88hz
           GLX Renderer: NVCF GLX Version: 3.0 Mesa 18.0.5
Network:   Card: NVIDIA MCP61 Ethernet driver: forcedeth
Drives:    HDD Total Size: 500.1GB (50.2% used)
Info:      Processes: 197 Uptime: 58 min Memory: 1222.9/7981.2MB Client: Shell (bash) inxi: 2.2.35
Title: Re: Install failure
Post by: devil on 2019/01/23, 12:20:56
You can try cli-installer. If that does not work either, please catch us on IRC
Title: Re: Install failure
Post by: piper on 2019/01/23, 12:24:54
cli-installer will probably fail on that version (201805132121)  iirc, I could be wrong, so your best bet is IRC.
Title: Re: Install failure
Post by: clubex on 2019/01/23, 14:43:32
Decided a clean install prove more effective.
After a backup and a change of HD I tried tried a clean install which failed at 53% see attached screenshot.
Title: Re: Install failure
Post by: axt on 2019/01/23, 15:58:12
Did you use a currently created image?

Quote from: devil
please catch us on IRC
Title: Re: Install failure
Post by: clubex on 2019/01/23, 16:39:26
Downloaded on 22 Jan at 11:11 GMT.
Apologies I can't do anything for the next 4-6 hours.
 
Title: Re: Install failure
Post by: piper on 2019/01/23, 16:50:55
What did you download on 22 Jan at 11:11 GMT ?

Is it a fresh iso from IRC ?

Because that is the only way to get a new iso
Title: Re: Install failure
Post by: axt on 2019/01/23, 16:58:15
It's not a question of when it was downloaded, but of when it was created. So it's an up to date build via IRC (agaida/devil/piper)?

Btw., with this error output I would first install and then distupgrade.
Title: Re: Install failure
Post by: devil on 2019/01/23, 21:26:01
cli-installer will just work
Title: Re: Install failure
Post by: clubex on 2019/01/23, 22:51:48
I been thinking of this for some time. I've decided I'm too old and ill to be faffing about with debian sid anyore.

I've just installed Mint 18.3 with no problems. I feel slightly soiled but I just can't be bothered anymore. My apologies for raising this thread.
 
I've stayed with debian sid since the sidux days and enjoyed every minute of it. Many, many thanks to all who have helped me and I hope I have helped some along the way. I wish siduction and all those involved all the best success for the future. Ta Ta.

 
Title: Re: Install failure
Post by: dibl on 2019/01/23, 23:27:39
Thanks for your contributions over these years -- I understand and respect your decision.  Be well!
Title: Re: Install failure
Post by: piper on 2019/01/24, 00:08:01
IIRC all you had to do to fix that error (screenshot) was

Code: [Select]
apt update; apt install apt dpkg perl calamares calamares-settings-siduction 

for live dvd/stick before install (while in live mode)
Title: Re: Install failure
Post by: clubex on 2019/01/24, 18:37:32
dibl: thanks pal. Much appreciated

piper: Well I gave your suggestion a go to no avail. apt dpkgr and perl upgraded Ok but calamares failed because of missing deps.

So I started to kludge. Installing kio solved the deps.

Couldn't find calamares-settings nor calamares-settings-siduction-(apt policy reported no candidates). So continued to kludge it. Tried calamares-branding-siductions and calamares-settings-debian (did I? not sure now). Installation ran until it hung with a cursor on a black screen.

Something needs to be done to fix this installer.

devil: cli-install did work when installing both / and /home. Wow!. But I couldn't find a way to install / while keeping /home intact (admittingly I didn't give it much attention).
 
I hope this is some help to you all.

That's it. Ta Ta.
Title: Re: Install failure
Post by: hendrikL on 2019/01/24, 19:02:21
i can be totally wrong but  it could be worth a try,
an
Code: [Select]
apt purge appstream
before installation could help,  or be offline while installation
Title: Re: Install failure
Post by: melmarker on 2019/01/25, 09:52:31
Please don't do upgrades for calamares on live isos - never.
Title: Re: Install failure
Post by: piper on 2019/01/25, 17:27:37
I had to do it once, yes, it was awhile ago, I had no problem at that time.
Thanks for saying not to do it again if the situation ever comes up again ;)

Now calamares just works out of the box  :)

Code: [Select]
System:    Host: x1 Kernel: 4.20.4-towo.1-siduction-amd64 x86_64 bits: 64 compiler: gcc v: 8.2.0 Desktop: KDE Plasma 5.14.5
           tk: Qt 5.11.3 wm: kwin_x11 dm: SDDM Distro: siduction 18.3.0 Paint It Black - kde - (201901241146)
           base: Debian GNU/Linux buster/sid
Machine:   Type: Desktop System: Gigabyte product: GA-970A-UD3 v: N/A serial: <root required> Chassis: type: 3
           serial: <root required>
           Mobo: Gigabyte model: GA-970A-UD3 v: x.x serial: <root required> BIOS: Award v: F7 date: 10/22/2012
Battery:   Device-1: hidpp_battery_0 model: Logitech Performance MX serial: 101a-e9-77-6f-11 charge: 70% (should be ignored)
           status: Discharging
Memory:    RAM: total: 15.65 GiB used: 4.38 GiB (28.0%)
           RAM Report: permissions: Unable to run dmidecode. Are you root?
CPU:       Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP arch: Bulldozer L2 cache: 2048 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 42283
           Speed: 1735 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1409 2: 1408 3: 1409 4: 1522 5: 1672 6: 1393
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: eVga.com. driver: nvidia v: 415.25 bus ID: 01:00.0
           chip ID: 10de:13c2
           Display: x11 server: X.Org 1.20.3 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa alternate: nv
           compositor: kwin_x11 resolution: 1920x1080~60Hz
           OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 415.25 direct render: Yes
Title: Re: Install failure
Post by: Mte90 on 2019/01/26, 16:01:42
I can confirm that a purge of appstream fix the problems during the install.If you take the 2018.3 patience calamares crash about issues with apt.Just to avoid any other errors I did also an apt update before tu run calamers because after the 10th test i was quite annoyed of the issue.Anyway this 2 commands let me to finish the distro installation.
Title: Re: Install failure
Post by: sunrat on 2019/04/12, 04:22:48
I just did 2 installs from the original 2018.3.0, one on bare metal and one in KVM/QEMU and both times hit this problem with appstream. Both times purging it from live allowed the installer to complete happily. Hopefully this is addressed before the next release.

 I was most impressed that doing d-u of over 1900 packages worked without a hitch! I will remember to ask on IRC for a more recent image next time if it's a long time since release, which may be soon as I have one more install to do soon.

Like the other poster here, I was also tempted to change to Debian stable and installed Buster with the intention of tracking it to release and then sticking with it. siduction is just better though so Buster hasn't won me over!  ;) 8) The only issue I've had with upgrades for a very, very long time is with Nvidia driver for the new 5.0 kernel and even that was easy to fix with the nvidia-driver package from experimental.
Title: Re: Install failure
Post by: LRC1962 on 2019/06/20, 23:28:47
I ran into the same issue on more then one distro variant. The one that I did find to work, after being very patient was using Netrunner debian which is stable. By this I do mean it got stuck for a while between 20-40% before it continued with the full install.
ake sure you add the neccessary sources to do the upgrades.
Using smxi you can then add siduction stuff. I then set upgrading to testing and then go to unstable. Might not be the best way, but I am now up and running without formating my home partition.