Siduction Forum

Siduction Forum => Siduction News => Siduction News (DE) => Topic started by: devil on 2020/07/15, 20:59:37

Title: Frische Abbilder
Post by: devil on 2020/07/15, 20:59:37
Ich habe heute alle siduction Abbilder auf https://isobuilds.siduction.org/ neu gebaut. Bitte beachtet, dass der Calamares-Installer noch kaputt ist und ihr deshalb den cli-installer verwenden müsst. Die Abbilder sind in VirtualBox einmal erfolgreich gebooted und installiert worden. Weitere Tests fanden nicht statt.

Update: towo hat Calamares repariert und ich habe alle ISOs nochmals neu gebaut. Bei den aktuellen Abbildern auf https://isobuilds.siduction.org/  funktioniert der grafische Installer wieder.
Title: Re: Frische Abbilder
Post by: ReinerS on 2020/07/15, 22:54:36
Hmm, sehe nur die XFCE Isos. Ist zwar genau das was ich brauche, aber Andere sind vielleicht nicht so ganz glücklich damit. Ist der Rest noch im Enstehen?

Grüße
Reiner

Ooops, ich bin ein Dussel, einfach zu schnell gedankenlos geklickt. Sorry!  :(
Title: Re: Frische Abbilder
Post by: toga on 2020/07/17, 08:55:40
Sehr cool!
Immer praktisch ein aktuelles ISO bereit zu haben.

Danke Devil, danke Towo!!

Natürlich auch Danke an alle anderen Siduction-Arbeiter für die diversen Flavours ;-) (eben erst gesehen)

Gruß,
toga
Title: Re: Frische Abbilder
Post by: charlyheinz on 2020/07/18, 11:49:13
Auch von hier ein herzliches Dankeschön an euch! Ich hatte ja Probleme mit libc6 auf einem frischen System. Diese sind Vergangenheit.Bezüglich Calamaris: Was haben denn die PC-Linuxer für einen Installer. Der ist ja man auch ganz nett, gerade in Bezug zu dem Einhängen von Partitionen und deren fstab- Einträgen während des Installierens?!
Nochmals besten Dank allerseits- es ist immer wieder ein schönes Gefühl eine Distribution mit deutschem Backround verwenden zu können (Vertrauenssache)!!
Title: Re: Frische Abbilder
Post by: glimfindel on 2020/07/18, 23:23:47
Vielen Dank, dieses Image kam für mich gerade zur richtigen Zeit, weil ich mir meine KDE-Umgebung durch das letzte d-u zersemmelt hatte. Irgendwas im pulseaudio hat sich da zerlegt, ich hatte erst auch das policykit im Verdacht, hat sich aber nicht bestätigt. Ich habe mir mal die Fehlersuche erspart, das KDE-Image genommen, und die Installation problemlos durchführen können.

Super Arbeit! 8) ;D
Title: Re: Frische Abbilder
Post by: Lanzi on 2020/07/27, 13:24:56
top!Dank Euch!

Title: Re: Frische Abbilder
Post by: ReinerS on 2020/10/05, 23:22:00
Hmm,ist es denkbar dass das XFCE-Image nicht soo gesund ist?
Wollte mein Frankensid neu (auch wieder verschlüsselt) aufsetzen, habe es auch soweit geschafft dass calamares brav anfing zu entpacken bis bei etwa 30% Rsync Fehler (10) auftraten.
Habe dann das Image neu gezogen und auf nen andere USB-Stick gepackt, gleicher Fehler.

Versuche es jetzt mal noch mit ner DVD, wenn das auch nicht klappt probiere ich morgen ein anderes Image (Kde (?)) aus.
Grüße
Reiner
Nachtrag: Auch von DVD Rsync Fehker 10, konnte noch kurz sehen dass er wohl bis 42% gekommen ist.
Ziehe mir mal für Morgen schon das frische KDE-Image,
Title: Re: Frische Abbilder
Post by: hendrikL on 2020/10/06, 07:54:42
Probiere bitte den cli-installer aus.
 
Title: Re: Frische Abbilder
Post by: ReinerS on 2020/10/06, 09:18:53
Habe ich auch schon probiert, Installation wurde fertiggestellt, war aber nicht bootbar.
Im cli-installer wird auch nicht angeboten ne EFI-Partition (/boot/efi) einzubinden.
Interessanterweise auch beim calamares nicht jedesmal. Wird die nicht mehr gebraucht?

Auch beim KDE Image war die calamares-installation mit nem Rsync Error abgeschmiert,
 lag also wohl nicht am XFCE-Image.

Ich starte mal nochn neuen Versuch mit dem CLI-Installer.
Klappt das auch nicht nehme ich das "aktuelle" offizielle Release für XFCE, tut das auch nicht
werde ich mal überlegen ob ich über den Umweg Debian-testing was tricksen kann.
Grüße
Reiner
Title: Re: Frische Abbilder
Post by: hendrikL on 2020/10/06, 09:53:31
Paste doch bitte die gesamte Fehlerausgabe.
Zu efi kann ich leider nichts sagen, habe kein System mit efi.
Title: Re: Frische Abbilder
Post by: ReinerS on 2020/10/06, 10:06:35
Welche, die vom cli-installer wenn der Boot nicht mehr gehen sollte?
Werde ein Foto davon machen.
Grüße
Reiner
Title: Re: Frische Abbilder
Post by: unklarer on 2020/10/06, 10:23:06
Ich habe auch kein System mit der "Efi".  ;D

Mit dem cli-Installer habe ich jedoch in der letzten Zeit ein paar Installationen gemacht (siduction / plasma, wegen dem Repo von Norbert Preining und mehrere bunsen-labs).
Dabei habe ich jedesmal was von der Efi gesehen.

Reiner, kann es sein, dass der cli-Installer hier ebenso "blöd" handelt, wie, wenn man auf die (Neu)-Einrichtung einer swap verzichten will? Also, man muß erst zwingend den Punkt auswählen, um ihn dann wieder abwählen zu können, damit die vorhandene swap nicht angefasst wird.
Title: Re: Frische Abbilder
Post by: hendrikL on 2020/10/06, 10:58:45
@Reiners

Beim calamares-installer die ansage/ausgabe mit dem "rsync Fehler" oder wie auch immer!?

Edit: https://forum.siduction.org/index.php?topic=8044.msg65213#msg65213
Title: Re: Frische Abbilder
Post by: ReinerS on 2020/10/06, 12:05:37
@unklarer: Muß ich mal ausprobieren

@hendrikl: Hmm da gibts nicht soo viel zu sehen, es gibt das Fortschrittsfenster beim Entpacken, dann poppt ein Unterfenster darüber und meldet nen RSync Error/Fehler 10 oder 11. Installation wird abgebrochen  und das wars dann auch schon. Sollte ich nochmal den calamares probieren mache ich nen Screenshot oder Foto.
Eigentlich habe ich es damit aufgegeben.
Davor ging alles "normal" bis etwa 30% bzw. bei KDE habe ich kurz noch 42 gesehen.

Den anderen Post den du angegeben hast, hatte ich schon probiert, klappte aber bei mir nicht.

Grüße
Reiner
Title: Re: Frische Abbilder
Post by: hendrikL on 2020/10/06, 13:22:18
Bitte von der Kommandozeile aus starten.
Title: Re: Frische Abbilder
Post by: ReinerS on 2020/10/06, 17:54:49
So, bin jetzt ein paar Schritte weiter

Habe dem cli-installer noch ne EFI-Partion untergejubelt und zum
Abschluß der Installation noch dazu gemounted.

Hat er auch brav genommen, allerdings ist der EFI-Aufbau von HP bei dem Laptop (HP8470p)
in der Struktur wohl anders.

Konnte erst booten nachdem ich beim Systemstart die siduction-efi-Datei manuell ausgewählt habe.
Der Rest sollte jetzt aber kein Problem sein,habe die alten EFI-Verzeichnisse gesichert und packe die,soweit sie fehlen, wieder zurück.
Grüße
Reiner

Title: Re: Frische Abbilder
Post by: axt on 2020/10/06, 22:32:45
Komisches Gebastel.

Wie auch immer, 7 Images sind heute aktualisiert worden.
Title: Re: Frische Abbilder
Post by: ReinerS on 2020/10/07, 13:58:29
Hab's mit dem "neuen" frischen Abbbild nochmal mit calamares versucht.
Leider gleiches Problem (Siehe Screengrabs).
Das angemeckerte Drive /dev/sdc war der frisch mit dd erstellte USB-Stick.
Danach waren die geöffneten LUKS/LVM Partionen für / und /home wieder geschlossen.

Grüße
Reiner
Title: Re: Frische Abbilder
Post by: hendrikL on 2020/10/07, 15:55:30
Ich glaube, dass der calamares-siduction nicht mit verschlüsselten Umgebungen umgehen kann, es wird zumindest nicht aktiv gefördert, da uns einfach die Ressourcen und das Wissen fehlt verschlüsselte Systeme zu debuggen bzw. zu supporten.

In jenem Falle, möchte man partout das gesamte System verschlüsseln und installieren, ist der cli-installer die erste wahl, so man siduction nutzen möchte.
Title: Re: Frische Abbilder
Post by: ReinerS on 2020/10/07, 17:00:27
@hendrikL; ja, "von Hause aus" kann der calamares es nicht, aber beim letztenmal (auch schon ewig her) konnte er soweit ich mich erinnere, die schon geöffneten verschlüsselten Container erkennen und dann auch richtig benutzen.
Ging ja diesmal auch erstmal soweit. Wieso er dann beim Entpacken nach etwa nem Drittel Probleme bekommt und dann anscheinend den Usb-Stick anmeckert ist mir allerdings schleierhaft.

Wie auch immer, ich habs mit demselben USB-Stick und dem "Unterjubeln" der EFI-Partition hingekriegt.
Vielleicht kann der grap. Installer (welcher immer das dann ist) das beim nächstenMal (in ein paar Jahren) dann ja endlich auch.  :D

Grüße
Reiner

Nachtrag: Jetzt ist mir auch aufgefallen warum der im Parallelthread beschriebene Workaround von MisterX bei mir nicht funktioniert hat; Im Gegensatz zu ihm verwende ich noch ne seperate /boot Partition die unverschlüsselt bleibt.
Nur EDI unverschlüsselt wollte ich (noch) nicht wagen. Vielleicht beim nächsten Mal. ;)

Sieht im Aufbau so aus:

/dev/sda1 ---> /boot/edi
/dev/sda2 ---> /boot
/dev/sda3 ---> LUKS/LVM Crypto Volume/Container mit /, /home und Swap Partitionen.
Dazu kommt noch beim Booten ein 2. LUKS/LVM Crypto Volume/Container als 'Archiv' der beim Booten über die crypttab und ein keyfile gemounted wird nachdem der 1. Container geöffnet ist.