Siduction Forum

Siduction Forum => Upgrade Warnings (DE / EN) => Topic started by: dpanter on 2020/12/20, 20:21:49

Title: KDE Spectacle breaks with libkimageannotator0 0.4.0-1
Post by: dpanter on 2020/12/20, 20:21:49
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=977649
TLDR: workaround with a symlink for now, quick oneliner for convenience:
Code: [Select]
sudo ln -s /usr/lib/x86_64-linux-gnu/libkImageAnnotator.so.0.4.0 /usr/lib/x86_64-linux-gnu/libkImageAnnotator.so.0.3.2
Bug report: the new version of kimageannotator bumps the SONAME of the shared library from libkImageAnnotator.so.0.3.2 to libkImageAnnotator.so.0.4.0, which is a big no-no. This also means that
kimageannotator sets the SONAME of its shared library to the full version number, basically breaking compatibility even in patch releases; this is _bad_...

Oof.

For reference:

Code: [Select]
$ spectacle
spectacle: error while loading shared libraries: libkImageAnnotator.so.0.3.2: cannot open shared object file: No such file or directory


Code: [Select]
$ locate libkImageAnnotator.so
/usr/lib/x86_64-linux-gnu/libkImageAnnotator.so.0.4.0


Code: [Select]
$ apt-file search libkImageAnnotator.so
libkimageannotator0: /usr/lib/x86_64-linux-gnu/libkImageAnnotator.so.0.3.2
libkimageannotator0: /usr/lib/x86_64-linux-gnu/libkImageAnnotator.so.0.4.0


Code: [Select]
$ apt list -a libkimageannotator0
libkimageannotator0/unstable,now 0.4.0-1 amd64 [installed,automatic]
libkimageannotator0/testing 0.3.2-2 amd64
Title: Re: KDE Spectacle breaks with libkimageannotator0 0.4.0-1
Post by: unklarer on 2020/12/21, 12:08:53
Thanks!   :)

(https://i.imgur.com/TLkEbsQt.png) (https://i.imgur.com/TLkEbsQ.png)
Title: Re: KDE Spectacle breaks with libkimageannotator0 0.4.0-1
Post by: dpanter on 2021/01/08, 22:52:55
Fixed with libkimageannotator0 0.4.0-2

Changelog:
Code: [Select]
kimageannotator (0.4.0-2) unstable; urgency=high

  * debian/patches: Add patch 0001 from upstream to properly
    handle library SONAME. (Closes: #977649)
  * debian/control: Bump libkcolorpicker version requirement
    to 0.1.5 to properly handle SONAME issue.

 -- Boyuan Yang <byang@debian.org>  Sat, 26 Dec 2020 22:29:08 -0500