Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] slrn läßt sich nach D-U nicht mehr installieren  (Read 3349 times)

apto-user-23

  • Guest
[DE] slrn läßt sich nach D-U nicht mehr installieren
« on: 2011/08/07, 13:56:35 »
Habe ein gestern ein D-U gemacht (64-bit), dabei wurde slrn entfernt.
Und jetzt läßt er sich nicht mehr installieren:

Code: [Select]

# apt-get install slrn
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut      
Statusinformationen werden eingelesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libgtk2.0-0 : Hängt ab von: libcups2 (>= 1.4.0) soll aber nicht installiert werden
               Hängt ab von: libgnutls26 (>= 2.9.11-0) soll aber nicht installiert werden
 slrn : Hängt ab von: libgnutls26 (>= 2.7.14-0) soll aber nicht installiert werden
 xemacs21 : Hängt ab von: xemacs21-mule (>= 21.4.22-3.1) soll aber nicht installiert werden oder
                           xemacs21-mule-canna-wnn (>= 21.4.22-3.1) soll aber nicht installiert werden oder
                           xemacs21-nomule (>= 21.4.22-3.1) soll aber nicht installiert werden

Er soll also aus unstable installiert werden.


Meine sources.list-Dateien sehen so aus:
aptosid.list:
Code: [Select]

deb http://aptosid.com/debian/ sid main fix.main    
deb-src http://aptosid.com/debian/ sid main fix.main


debian.list:
Code: [Select]

deb http://ftp.debian.org/debian/ sid main fix.main    
deb-src http://ftp.debian.org/debian/ sid main


jitsu.list:
Code: [Select]

###
###
###
###
###
###
###
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://download.jitsi.org/deb/ sid


Wenn ich slrn downloade und per dpkg installiere:

Code: [Select]

# dpkg -i slrn_1.0.0~pre18-1.1_amd64.deb
Vormals abgewähltes Paket slrn wird gewählt.
(Lese Datenbank ... 410683 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacken von slrn (aus slrn_1.0.0~pre18-1.1_amd64.deb) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von slrn:
 libgnutls26 (2.12.7-3) beschädigt slrn (<= 1.0.0~pre18-1.1) und ist installiert.
  Zu konfigurierende Version von slrn auf dem System ist 1.0.0~pre18-1.1.
dpkg: Fehler beim Bearbeiten von slrn (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für man-db werden verarbeitet ...
Trigger für menu werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 slrn

Was kann man da tun?


EDIT von bluelupo (Moderator): Codeboxen gesetzt, wegen besserer Lesbarkeit. Bitte zukünftig beachten. Danke!

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
slrn läßt sich nach D-U nicht mehr installieren
« Reply #1 on: 2011/08/07, 14:17:12 »
Quote

debian.list:
deb http://ftp.debian.org/debian/ sid main fix.main

das fix.main ist an der stelle unfug. debian kennt das nicht.
also vermute ich, dsass schon ein
Code: [Select]
apt-get updatescheitert. also entferne das fix.main, führe
Code: [Select]
apt-get update && apt-get dist-upgrade durch und dann nochmal die install von slrn

greetz
devil

apto-user-23

  • Guest
Re: slrn läßt sich nach D-U nicht mehr installieren
« Reply #2 on: 2011/08/07, 14:42:34 »
Hallo devil,

Quote from: "devil"
Quote

debian.list:
deb http://ftp.debian.org/debian/ sid main fix.main

das fix.main ist an der stelle unfug. debian kennt das nicht.
also vermute ich, dsass schon ein
Code: [Select]
apt-get updatescheitert. also entferne das fix.main, führe
Code: [Select]
apt-get update && apt-get dist-upgrade durch


Hab ich gemacht. 1. gutes Ergebnis: vorher kam jedesmal eine Fehlermeldung beim apt-get update, die ist jetzt weg.
Die beiden Kommandos ergaben jedoch keine Downloads oder Installationen (0 Pakete installiert/aktualisiert).

Quote from: "devil"

und dann nochmal die install von slrn


Da tut sich leider dann nix Neues, die obig genannte Fehlermeldung ist dann immer noch da.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: slrn läßt sich nach D-U nicht mehr installieren
« Reply #3 on: 2011/08/07, 14:46:55 »
würde hier einwandfrei installieren:
Code: [Select]
root@aptosidbox:/home/devil# apt-get install slrn -s
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut      
Statusinformationen werden eingelesen... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libcanlock2 libuu0
Vorgeschlagene Pakete:
  slrnpull metamail
Die folgenden NEUEN Pakete werden installiert:
  libcanlock2 libuu0 slrn
0 aktualisiert, 3 neu installiert, 0 zu entfernen und 31 nicht aktualisiert.
Inst libcanlock2 (2b-6 Debian:unstable [amd64])
Inst libuu0 (0.5.20-3.2 Debian:unstable [amd64])
Inst slrn (1.0.0~pre18-1.1 Debian:unstable [amd64])
Conf libcanlock2 (2b-6 Debian:unstable [amd64])
Conf libuu0 (0.5.20-3.2 Debian:unstable [amd64])
Conf slrn (1.0.0~pre18-1.1 Debian:unstable [amd64])


greetz
devil

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: slrn läßt sich nach D-U nicht mehr installieren
« Reply #4 on: 2011/08/07, 15:19:42 »
was passiert denn, wenn du explizit libcups2 installieren willst?

greetz
devil

apto-user-23

  • Guest
Re: slrn läßt sich nach D-U nicht mehr installieren
« Reply #5 on: 2011/08/07, 16:18:12 »
# apt-get install libcups2
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut      
Statusinformationen werden eingelesen... Fertig
libcups2 ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: slrn läßt sich nach D-U nicht mehr installieren
« Reply #6 on: 2011/08/07, 16:31:11 »
dpkg -l | grep libcups2  sagt was?
und apt-get install libgnutls26
falls installiert:
dpkg -l | grep libgnutls26
und
dpkg --get-selections|grep hold

greetz
devil

apto-user-23

  • Guest
Re: slrn läßt sich nach D-U nicht mehr installieren
« Reply #7 on: 2011/08/07, 16:44:59 »
Quote from: "devil"
dpkg -l | grep libcups2  sagt was?


# dpkg -l | grep libcups2
ii  libcups2                                   1.4.8-2                          Common UNIX Printing System(tm) - Core library

Quote
und apt-get install libgnutls26


# apt-get install libgnutls26
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut      
Statusinformationen werden eingelesen... Fertig
libgnutls26 ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert

Quote
falls installiert:
dpkg -l | grep libgnutls26


# dpkg -l | grep libgnutls26
ii  libgnutls26                                2.12.7-3                         GNU TLS library - runtime library


Quote
und
dpkg --get-selections|grep hold


Sagt garnix. Also null Ausgabe.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
Re: slrn läßt sich nach D-U nicht mehr installieren
« Reply #8 on: 2011/08/07, 17:42:33 »
Quote

dpkg: Abhängigkeitsprobleme verhindern Konfiguration von slrn:
 libgnutls26 (2.12.7-3) beschädigt slrn (<= 1.0.0~pre18-1.1) und ist installiert.
  Zu konfigurierende Version von slrn auf dem System ist 1.0.0~pre18-1.1.

hab ich erst jetzt gesehen.
da ist wohl ein bugreport deinerseits gegen libgnutls26  angesagt.

greetz
devil

Mr.Klijn

  • Guest
Re: slrn läßt sich nach D-U nicht mehr installieren
« Reply #9 on: 2011/08/07, 18:16:33 »
oder die libgnutls26 aus sid installieren statt der Version aus experimental
Code: [Select]
# apt-cache policy libgnutls26
libgnutls26:
  Installiert: 2.10.5-3
  Kandidat:    2.10.5-3
  Versionstabelle:
     2.12.7-3 0
         99 http://ftp.de.debian.org/debian/ experimental/main i386 Packages
 *** 2.10.5-3 0
        990 http://ftp2.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status

apto-user-23

  • Guest
Re: slrn läßt sich nach D-U nicht mehr installieren
« Reply #10 on: 2011/08/07, 18:18:20 »
Quote from: devil
Quote
.
da ist wohl ein bugreport deinerseits gegen libgnutls26  angesagt.


Danke für die Geduld, devil.
Bugreport an Debian mittels "reportbug" ist gerade raus.

CU

apto-user-23

  • Guest
Re: slrn läßt sich nach D-U nicht mehr installieren
« Reply #11 on: 2011/08/07, 20:25:40 »
Quote from: "Mr.Klijn"
oder die libgnutls26 aus sid installieren statt der Version aus experimental


Funktioniert leider auch nicht: die libgnutls26 von sid hab ich runtergeladen von
http://packages.debian.org/de/sid/amd64/libgnutls26/download
und dann:

# dpkg -i libgnutls26_2.12.7-4_amd64.deb
(Lese Datenbank ... 410731 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Ersetzen von libgnutls26 2.12.7-3 (durch libgnutls26_2.12.7-4_amd64.deb) ...
Ersatz für libgnutls26 wird entpackt ...
libgnutls26 (2.12.7-4) wird eingerichtet ...
root@aptosid:/home/uwe/Downloads/aptosid# apt-get install slrn
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut      
Statusinformationen werden eingelesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libgtk2.0-0 : Hängt ab von: libcups2 (>= 1.4.0) soll aber nicht installiert werden
               Hängt ab von: libgnutls26 (>= 2.9.11-0) soll aber nicht installiert werden
 slrn : Hängt ab von: libgnutls26 (>= 2.7.14-0) soll aber nicht installiert werden
 xemacs21 : Hängt ab von: xemacs21-mule (>= 21.4.22-3.1) soll aber nicht installiert werden oder
                           xemacs21-mule-canna-wnn (>= 21.4.22-3.1) soll aber nicht installiert werden oder
                           xemacs21-nomule (>= 21.4.22-3.1) soll aber nicht installiert werden
E: Beschädigte Pakete[/url]