seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/12/01, 07:54:15


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [Erledigt] Evolution segfault  (Read 4815 times)

0 Members and 1 Guest are viewing this topic.

Offline OppaErich

  • OLE
  • User
  • Posts: 377
[Erledigt] Evolution segfault
« on: 2012/02/18, 11:33:29 »
Nach einem d-u vor etwa einer Stunde saugt Xorg mehr als 90% von der CPU und Evolution startet kurz und verabschiedet sich gleich wieder mit einem segfault.

Ausser einem neuem nvidia war nichts besonderes dabei.
Code: [Select]


oppa@oppa-mag:~$ infobash -v3
Host/Kernel/OS  "oppa-mag" running Linux 3.1-5.slh.1-aptosid-686 i686 [ sidux 2010-01 Ύπνος - kde-lite - (201006131622) ]
CPU Info        4x Intel Atom 330 @ 512 KB cache flags( sse3 ht nx lm ) clocked at [ 1600.168 MHz ]
Videocard       nVidia ION VGA  X.Org 1.11.3.901  [ 1920x1080@50.0hz ]
Network cards   nVidia MCP79
                Atheros AR9285 Wireless
Processes 153 | Uptime 59min | Memory 686.9/1771.1MB | HDD WDC WD5000BEVT-2 Size 500GB (0%used) | GLX Renderer ION/integrated/SSE2 | GLX Version 3.3.0 NVIDIA 295.20 | Client Shell | Infobash v3.37


Xorg war mein Fehler, ich hatte nvidia-glx nicht reinstalliert.

Das Problem mit Evolution bleibt bestehen.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.452
Evolution segfault
« Reply #1 on: 2012/02/18, 12:01:05 »

Offline OppaErich

  • OLE
  • User
  • Posts: 377
Evolution segfault
« Reply #2 on: 2012/02/18, 16:37:26 »
Ob das dasselbe ist ? Er bekommt ja noch ein paar Fehlermeldungen...
Code: [Select]


oppa@oppa-mag:~$ evolution
Speicherzugriffsfehler
oppa@oppa-mag:~$

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.452
Evolution segfault
« Reply #3 on: 2012/02/18, 18:46:07 »
Nichts genaues weiss man nicht. Die Version passt, das Datum passt. Ich benutze evolution nicht.

greetz
devil

Offline Zeitgeist

  • User
  • Posts: 54
[Erledigt] Evolution segfault
« Reply #4 on: 2012/02/18, 19:20:50 »
Was sagt

Code: [Select]
apt-cache policy evolution?

Ich nutze Evolution und habe heute noch keinen D-U gemacht.(Ich werde das mal beobachten).

Vielleicht bring auch ein Blick in .xsession-errors Aufschluss.

EDIT

Ich hab nachgesehen und ich habe die neuste Version. Den Fehler kann ich aber nicht bestätigen.

Code: [Select]
mkn@Mars:~$ apt-cache policy evolution
evolution:
  Installiert: 3.2.2-1
  Kandidat:    3.2.2-1
  Versionstabelle:
 *** 3.2.2-1 0
        500 http://ftp.de.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
Pipes sind wie eine Zahnpastatube:
Um den Inhalt zu untersuchen,
muss man ihn erst herausdrücken;
danach gibt es keine Möglichkeit,
ihn wieder hineinzubringen.

--Marc J. Rochkind in "UNIX   Programmierung für Fortgeschrittene"

Offline OppaErich

  • OLE
  • User
  • Posts: 377
[Erledigt] Evolution segfault
« Reply #5 on: 2012/02/19, 10:09:15 »
Code: [Select]

oppa@oppa-mag:~$ apt-cache policy evolution
evolution:
  Installiert: 3.2.2-1
  Kandidat:    3.2.2-1
  Versionstabelle:
 *** 3.2.2-1 0
        500 http://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status

Aber ich habe i386. .xsession-errors zeigt nichts neues wenn ich Evolution starte.

Offline ralfi

  • User
  • Posts: 383
[Erledigt] Evolution segfault
« Reply #6 on: 2012/02/21, 11:18:06 »
Hi OppaErich,

bitte mal evolution-dbg und gdb (Debugger) installieren. Dann - als Nutzer in der Konsole - gdb starten, evolution laden ("file evolution") und mit "run" Evolution im Debug-Modus starten.

Die Ausgabe sollte dann schon gesprächiger sein. Ist jetzt aber hier einfach so hingeschmurkst, bei Bedarf in der gdb Hilfe nachschauen.
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline OppaErich

  • OLE
  • User
  • Posts: 377
[Erledigt] Evolution segfault
« Reply #7 on: 2012/02/24, 17:22:18 »
LOL, ich habe gerade die Debug Symbole fuer Evolution installiert und dann mal 'gdb evolution' gestartet.

Erst ein Schock: Der Einrichtungsassistent startete. Sind die Mailboxen korrupt ? - ich war noch root :)
Dann als User: Spielt einwandfrei. Das ganze ohne gdb: Spielt auch.

Da kein Evolution Update reinkam vermute ich dass es irgendeine lib war.

Danke,
Stephan

Oh, die Freude kam zu frueh. Gerade ist es beim POPpen wieder abgeschmirgelt. - Im gdb geht's - timing Probleme ?

Offline ralfi

  • User
  • Posts: 383
[Erledigt] Evolution segfault
« Reply #8 on: 2012/02/25, 10:15:08 »
Mmmh, ich tippe da mal eher auf Netzwerkprobleme. Wirst Du wohl ohne ein gleichzeitiges wireshark / tcpdump nicht rausbekommen. Vielleicht auch nochmal ins syslog schauen und die Suchmaschine Deiner Wahl befragen.
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline OppaErich

  • OLE
  • User
  • Posts: 377
[Erledigt] Evolution segfault
« Reply #9 on: 2012/02/25, 11:41:44 »
Im syslog ist nichts wirklich aufregendes. Aber Netzwerkprobleme ? Mit dem Eisdoof funktioniert es doch. Aber egal, ich lass Evolution weiter im gdb laufen. Vielleicht kommt ja mal ein Update daher.

Danke

Offline ralfi

  • User
  • Posts: 383
[Erledigt] Evolution segfault
« Reply #10 on: 2012/02/27, 08:33:25 »
Da hast Du natürlich Recht, wenn es mit Icedoof funzjoniert. Und es ist auch wahr, dass es im Laufe der Entwicklung auf Grund der Komplexität vor allem der MSExch Module haufenweise Probleme mit Evolution gab/gibt.
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline OppaErich

  • OLE
  • User
  • Posts: 377
[Erledigt] Evolution segfault
« Reply #11 on: 2012/03/03, 17:27:08 »
Mittlerweile schmiert er auch im gdb ab, die ganze Gnome Shell auch gerne. Nun bin ich wieder in KDE und siehe da: Evolution läuft darunter ohne Probleme. :)

Leider deutlich mehr Hunger auf Speicher und traniger das KDE.

Offline ralul

  • User
  • Posts: 1.809
[Erledigt] Evolution segfault
« Reply #12 on: 2012/03/03, 19:26:43 »
@OppaErich, in den Kde systemsettings bitte abstellen
- strigi
- nepomuk
- jede Menge Effekte
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline OppaErich

  • OLE
  • User
  • Posts: 377
[Erledigt] Evolution segfault
« Reply #13 on: 2012/04/07, 10:01:05 »
Beim vorgestrigen d-u kamen ein paar evolution updates mit rein und nun tut er's wieder. :)