seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/09/16, 02:08:55


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Installation mit btrfs  (Read 5925 times)

0 Members and 1 Guest are viewing this topic.

Offline ReinerS

  • User
  • Posts: 941
Installation mit btrfs
« on: 2012/05/17, 16:56:25 »
Habe mal die aktuelle XFCE-64-Bit Version in ner vbox mit btrfs  in der root-Patition installiert.

Nach der Installation wird versucht einen automatischen (?)  fsck mit fsck.btrfs durchzuführen. Da es dieses Programm/Link nicht gibt kann man nur per root auf ne Maintenance-Shell.

Das eigentlich richtige btrfsck kann man aber nicht laufen lassen da die Partition gemounted ist und btrfsck anscheinend keine Optionen kennt um trotzdem laufen zu können.

Booten von DVD und dann btrfsck von da laufen zu lassen funktioniert zwar aber beim nächsten Booten kommt das Problem wieder.

Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline ReinerS

  • User
  • Posts: 941
Erfahrungen / Trouble mit 2012-1 LXDE 686
« Reply #1 on: 2012/05/23, 21:26:22 »
Habe 2012-1 LXDE 686 auf meinen alten Laptop installiert.
Bei Verwendung btrfs als einzige Linux-Partition kam gleich ein Grub Geom error.

Habe dann mit ner ext2 Boot-Partition und btrfs als Root-Partition installiert und dasselbe Problem bekommen wie zuvor bei RC.1 in der VBox.
Beim Start wird wohl ein "automatischer" fsck durchgeführt, fsck.btrfs gibts nicht und man landet in der Maintenance Shell. :(
Ich habe das für mich dahingehend gelöst dass ich nen Sym-Link von btrfsck nach fsck.btrfs gelegt habe. Dann mault btrfsck zwar beim Start dass es die Option 'a' nicht kennt aber es wird weitergebootet. Nicht elegant aber für mich erstmal ok bis es ne bessere Lösung gibt. :roll:

Allerdings mag dann später der Display-Manager dann später weder Tastatur noch Touchpad oder Maus. Einzig mit ALT-STRG-F1 bin ich letztendlich in ne Text-Konsole reingekommen. Da funktioniert jetzt wieder alles, nur X bzw. Display-Manager wollen nicht.:x
Ob das an ner fehlerhaften X-Konfiguration liegt werde ich noch untersuchen. Den Display-Manager werde ich wahrscheinlich sowieso austauschen da ich die Kiste auf xfce und razor erweitern will. 8)
 
Musste die Installation von LXDE starten weil der Lappy noch kein internes DVD-Laufwerk hat und auch noch nicht von USB booten kann  :(

Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline ab

  • User
  • Posts: 117
Erfahrungen / Trouble mit 2012-1 LXDE 686
« Reply #2 on: 2012/05/28, 12:21:14 »
@ReinerS

Bestätigt.

Probiere bitte mal, in /etc/fstab den Parameter "<pass=" auf den Wert 0 zu setzen, um den Filesystemcheck beim booten zu unterbinden.

ungefähr so:
Code: [Select]
root@rechner:/home/user# cat /etc/fstab
UUID=d179xxx     /           btrfs        defaults,relaxxx usw         0    0  
UUID=6c2axxx     /home       ext4         defaults,relaxxx usw         0    2


gruß ab

Offline ReinerS

  • User
  • Posts: 941
Installation mit btrfs
« Reply #3 on: 2012/05/28, 17:44:39 »
werde ich gleich mal probieren.

Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline ReinerS

  • User
  • Posts: 941
Installation mit btrfs
« Reply #4 on: 2012/05/29, 00:34:15 »
Habs probiert und siehe da es funktioniert   :P

Vielen Dank.


Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline ab

  • User
  • Posts: 117
Installation mit btrfs
« Reply #5 on: 2012/05/29, 19:49:09 »
@ReinerS

Danke fürs testen!

gruß ab