seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2021/01/26, 22:29:25


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Multiarch users -- Beware!  (Read 3802 times)

0 Members and 1 Guest are viewing this topic.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.070
    • Land of the Buckeye
Multiarch users -- Beware!
« on: 2012/10/27, 03:06:54 »
If you have configured multiarch on your 64-bit system, this is not the moment to d-u:

Code: [Select]
root@imerabox:/home/don# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  libasound2:i386 libaudio2:i386 libc6:i386 libc6-i686:i386 libcomerr2:i386 libdbus-1-3:i386 libdrm-intel1:i386
  libdrm-nouveau1a:i386 libdrm-radeon1:i386 libdrm2:i386 libexpat1:i386 libffi5:i386 libfontconfig1:i386 libfreetype6:i386
  libgcc1:i386 libgcrypt11:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libgl1-nvidia-glx:i386 libglapi-mesa:i386
  libglib2.0-0:i386 libglu1-mesa:i386 libgnutls26:i386 libgpg-error0:i386 libgpm2:i386 libgsm1:i386 libice6:i386 libjbig0:i386
  libjpeg8:i386 liblcms1:i386 libltdl7:i386 liblzma5:i386 libmng1:i386 libmpg123-0:i386 libncurses5:i386 libodbc1:i386
  libp11-kit0:i386 libpciaccess0:i386 libpcre3:i386 libpng12-0:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386
  libqtcore4:i386 libqtgui4:i386 libselinux1:i386 libsm6:i386 libssl1.0.0:i386 libstdc++6:i386 libtasn1-3:i386 libtiff4:i386
  libtinfo5:i386 libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386 libwine:i386 libwine-alsa:i386 libwine-bin:i386 libwine-gl:i386
  libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-glx0:i386 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386
  libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386 libxml2:i386 libxrandr2:i386 libxrender1:i386
  libxslt1.1:i386 libxss1:i386 libxt6:i386 libxv1:i386 libxxf86vm1:i386 skype:i386 teamviewer7:i386 wine wine-bin:i386
  zlib1g:i386
The following NEW packages will be installed:
  wine64-bin
The following packages will be upgraded:
  exim4 exim4-base exim4-config exim4-daemon-light libc-bin libc-dev-bin libc6 libc6-dev libc6-i386 libmozjs10d libpcsclite1
  libsasl2-2 libsasl2-modules libxnvctrl0 linux-headers-3.6-3.towo-siduction-amd64 linux-headers-siduction-amd64
  linux-image-3.6-3.towo-siduction-amd64 linux-image-siduction-amd64 locales multiarch-support nvidia-settings
21 upgraded, 1 newly installed, 85 to remove and 0 not upgraded.
Need to get 51.4 MB of archives.
After this operation, 415 MB disk space will be freed.
Do you want to continue [Y/n]?


I am not the expert to say what is happening with all the i386 packages -- just giving the warning to be careful.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.481
Multiarch users -- Beware!
« Reply #1 on: 2012/10/27, 09:07:22 »
My guess is, wine64-bin is causing this havoc.
But i neither have multiarch nor wine here, so I can't be sure.

greetz
devil

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.070
    • Land of the Buckeye
RE: Multiarch users -- Beware!
« Reply #2 on: 2012/10/27, 15:20:11 »
Whatever the issue was, is now cleared:

Code: [Select]
root@imerabox:/home/don# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  exim4 exim4-base exim4-config exim4-daemon-light iceweasel libc-bin libc-dev-bin libc6 libc6:i386 libc6-dev libc6-i386
  libc6-i686:i386 libmozjs10d libmozjs18d libpcsclite1 libsasl2-2 libsasl2-modules libxnvctrl0
  linux-headers-3.6-3.towo-siduction-amd64 linux-headers-siduction-amd64 linux-image-3.6-3.towo-siduction-amd64
  linux-image-siduction-amd64 locales multiarch-support nvidia-settings xulrunner-18.0
26 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 73.0 MB of archives.
After this operation, 152 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS