seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/09/21, 03:15:19


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: PXE boot problem  (Read 4805 times)

0 Members and 1 Guest are viewing this topic.

Offline hwgasdfasdf

  • User
  • Posts: 10
PXE boot problem
« on: 2012/11/13, 09:40:02 »
When PXE booting, /proc/mdstat doesn't exist, and the script in the initrd at /scripts/local-top/mdadm causes the boot to panic and fall to the initrd shell.

Removing /scripts/local-top/mdadm from the initrd (and it's reference in the ORDER file in the same directory), and re-making the initrd image allows successful PXE booting.

I don't know why /proc/mdstat doesn't exist when pxe booting, and I'm sure fixing that is the correct way to fix the problem, rather than my hacky "remove the mdadm" method above, and probably needs to be investigated by someone that understands the boot process more than I do.

Offline ralfi

  • User
  • Posts: 381
PXE boot problem
« Reply #1 on: 2012/11/14, 09:42:26 »
Mmmh i do not modify the initram init script but pxe booting works very well. Which siduction image do you use?
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline hwgasdfasdf

  • User
  • Posts: 10
RE: PXE boot problem
« Reply #2 on: 2012/11/15, 01:22:46 »
I downloaded all of them, except no-x. I'm assuming they all use the same kernel / initrd, so I only have one of those on my tftp server, and have multiple menu entries that point at different nbd mounts for the different isos. I took the kernel image and initrd from the KDE ISO (I still have the ISO loopback mounted on my storage box!)

Offline hwgasdfasdf

  • User
  • Posts: 10
RE: PXE boot problem
« Reply #3 on: 2012/11/15, 06:02:29 »
I just tried booting the original initrd (I also added firmware-linux-nonfree to mine) from the KDE iso on a virtual machine (VirtualBox) too, it also fails with the same message - cannot initialise MD subsystem (/proc/mdstat missing). Hunting around the initrd image, I see no 'md' in /conf/modules, and I also see MD_MODULES='' in /conf/conf.d/md, yet lots of md modules in /lib/modules/3.4.../kernel/drivers/md, so I'm pretty sure md is compiled as modules, not compiled into the kernel. lsmod at the busybox shell it drops too when it aborts the boot shows no md module loaded. And yeah, I dug through the init scripts quite a bit, and now have a modest understanding of what's calling what :)

Are you pxe booting the 32 bit ISOs by chance?? Maybe worth pointing out I'm using the 64 bit ISOs. I didn't download the 32 bit ones, but maybe that's why it works for you, but not for me?

Offline ralfi

  • User
  • Posts: 381
RE: PXE boot problem
« Reply #4 on: 2012/11/15, 09:11:59 »
Im using the 32 bit KDE iso image. Are you sure that your nbd-server works properly? I also have a boot message "canot init MD subsystem" but the next messages is

Code: [Select]

Probing devices (nbd0)
Detected live squashfs filesystem ...
copy filesystem from nbd0 to ram ...


mysterious
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline diensthunds

  • User
  • Posts: 18
RE: PXE boot problem
« Reply #5 on: 2012/11/16, 04:16:51 »
Same issue here, have you tried copying over an initrd from an installed system?

Offline hwgasdfasdf

  • User
  • Posts: 10
RE: PXE boot problem
« Reply #6 on: 2012/11/17, 13:34:24 »
Pretty sure my nbd server works - when I remove the script that tries to initialize md arrays from the initrd, it boots and works fine.

No, I haven't tried copying an initrd from a running system.

Offline diensthunds

  • User
  • Posts: 18
RE: PXE boot problem
« Reply #7 on: 2012/11/17, 16:32:22 »
I tried it, but unfortunately it's not working either. Did before though.

Managed to change the initrd, however now it's almost twice the size of the original one. Still loads but now I'm being dropped at the nbd client setting up.

//update  Forgot to change the nbd server back to using ports instead of named exports. Now it works for 64 bit.

Offline ralfi

  • User
  • Posts: 381
RE: PXE boot problem
« Reply #8 on: 2012/11/17, 20:58:09 »
The diff is that i use the original extracted initrd from the iso, vmlinuz ("ln" to the extracted vmlinuz.686 in the same directory, it doesnt work if i use vmlinuz.686 as native file, i dont know why...) and the nbd-mount to the iso-image.
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline diensthunds

  • User
  • Posts: 18
RE: PXE boot problem
« Reply #9 on: 2012/11/18, 02:21:49 »
Finally fixed it to where I can now boot either the 32bit or 64bit version. For some reason the 32 bit still drops into a broken init but ctrl-d breaks it out and continues the boot. ralfi I followed your work and still had an interrupt in the init boot. Don't know why but it works.