seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/29, 04:54:33


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [Solved] Critical Failure apt grub after d-u  (Read 2418 times)

0 Members and 1 Guest are viewing this topic.

Offline Gabriel_M

  • User
  • Posts: 33
[Solved] Critical Failure apt grub after d-u
« on: 2013/05/11, 15:46:48 »
Critical Failure packages
Package  grub2-common 2.00-13 -> 2.00-14
 grub2-common: After Grub 2.00-14 upgrade, system failed to boot (rescue, old grub 1.99 still in mbr)
Package  apt 0.9.7.8 -> 0.9.8  
 #707578 - apt: yields dependency problems with "apt-get install --purge libreoffice"

Offline ayla

  • User
  • Posts: 1.706
[Solved] Critical Failure apt grub after d-u
« Reply #1 on: 2013/05/11, 17:01:52 »
Hi,

d-u'd this minute, no problems here.

Code: [Select]
apt-cache policy grub2-common
grub2-common:
  Installiert:           2.00-14
  Installationskandidat: 2.00-14


Quote
old grub 1.99 still in mbr


So I would suggest to boot into your system if possible and run
Code: [Select]
grub-install /dev/sd(x) were the (x) needs to be replaced with the disks letter were you want to install to the mbr.

If you haven't a rescue system then you may use a live media and run the commands shown here insteed:
http://wiki.siduction.de/index.php?title=Wie_fixe_ich_mein_verhunztes_grub2%3F
 were "/dev/sda2" has to be replaced with your root partition.

Sorry, its the german wiki, but the commands are universal.

For the libreoffice problem the output of apt would be of interrest and maybe why you want to purge it.

greets
ayla
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline Gabriel_M

  • User
  • Posts: 33
solved
« Reply #2 on: 2013/05/11, 18:24:47 »
New d-u'd, problems solved.

Code: [Select]
apt-cache policy grub2-common
grub2-common:
  Instalados: 2.00-14
  Candidato:  2.00-14
  Tabla de versión:
 *** 2.00-14 0
        500 http://ftp.de.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status