seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/12/01, 10:21:54


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: (solved) nvidia (geforce 6xxx,7xxx)  (Read 2281 times)

0 Members and 1 Guest are viewing this topic.

Offline michaa7

  • User
  • Posts: 2.128
(solved) nvidia (geforce 6xxx,7xxx)
« on: 2013/05/14, 10:29:23 »
Edit://

Sorry for the noise. It was completely my misunderstanding of the situation. All is fine, libgl1-nvidia-alternatives, libglx-nvidia-alternatives have to go with nvidia v 304.88-3.

Ignore the following.


----------------------------------------

(I don't understand this situation but we should wait:)
Edit: we need to d-u manually the nvidia packages:

Quote
# apt-get update && apt-get dist-upgrade -d
...
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden ENTFERNT:
  libgl1-nvidia-alternatives libglx-nvidia-alternatives
Die folgenden Pakete werden aktualisiert (Upgrade):
 ... nvidia-alternative nvidia-glx nvidia-kernel-dkms ...


and
Quote
# apt-cache show nvidia-alternative
Package: nvidia-alternative
Source: nvidia-graphics-drivers
Version: 313.30-1
Installed-Size: 156
Maintainer: Debian NVIDIA Maintainers <pkg>
Architecture: i386
Depends: glx-alternative-nvidia (>= 0.2), libgl1-nvidia-alternatives (>= 275.09.07-4), libglx-nvidia-alternatives (>= 275.09.07-4)
Breaks: libgl1-nvidia-glx (<< 275.09.07-2), nvidia-glx (<< 275.09.07-2)

but version
Quote
# apt-cache policy libgl1-nvidia-alternatives
libgl1-nvidia-alternatives:
  Installiert:           304.88-2

is installed.

OTAH, there is this situation:
Quote
# apt-cache policy  nvidia-alternative
nvidia-alternative:
  Installiert:           304.88-2
  Installationskandidat: 304.88-3


Summery: the situation for nvidia geforce 6xxx/7xxx is a mess as nvidia does *not* care about the right dependencies for those chips. We have to install the needed packages *manually* and take care to *manually update* those packages and then mark them to be hold.

Any advice to automagically d-u those packages is welcome.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.417
RE: nvidia (geforce 6xxx,7xxx)
« Reply #1 on: 2013/05/14, 11:05:46 »
Nvidia has nothing to do with debian packaging, you have to poke the maintainer.
Tha package name for 304-series drivers schould include a "legacy", since those cards are legacy cards now.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline michaa7

  • User
  • Posts: 2.128
Re: RE: nvidia (geforce 6xxx,7xxx)
« Reply #2 on: 2013/05/14, 11:23:47 »
Quote from: "towo"
Nvidia has nothing to do with debian packaging ...
Thanks for this claification, I didn't know.
Quote
... you have to poke the maintainer.
...

I think I will.

EDIT://
I think I'll wait for a while because it seems as yet not all needed packages (v 304.88-3) are built which currently causes some other nvidia packages (libgl1-nvidia-alternatives libglx-nvidia-alternatives) to be removed.

EDIT://
Solved, see first post.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake