seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/12/05, 00:13:23


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Watch your apt messages today  (Read 9312 times)

0 Members and 1 Guest are viewing this topic.

Offline michaa7

  • User
  • Posts: 2.128
Re: RE: Re: Watch your apt messages today
« Reply #15 on: 2013/05/14, 21:16:38 »
Quote from: "dibl"
Quote from: "michaa7"
Maybe it depends where the packages come from, in my case two of them came from dmo:


PERFECT -- thank you very much michaa!  I had dmo commented out for all the time wheezy was in freeze, and I forgot to uncomment it.


Glad I could help you.

I only uncomment it in the rare case I need something from DMO. Actually I realized that your problem might be connected to DMO when the output of "apt-cache policy <the> on my computer didn't show a real repo for the installed *dmo*-files (because it shows only repos which are activated in sources.list*).
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline DeepDayze

  • User
  • Posts: 414
RE: Re: RE: Re: Watch your apt messages today
« Reply #16 on: 2013/05/15, 04:03:11 »
I have had used --force-overwrite which forcibly overwrites the existing changelog with the one from the new package. It works, but yes its brutal.

Hopefully there will be a fix for the differing changelogs brought about by binNMU's that are done just for one or 2 arches rather than all.

Offline jacmoe

  • User
  • Posts: 26
    • http://www.jacmoe.dk/
Watch your apt messages today
« Reply #17 on: 2013/05/15, 07:00:43 »
Quote from: "piper"

...
and do that for

libgl1-mesa-dri
libgl1-mesa-glx:i386
libglapi-mesa


and then do
Code: [Select]
apt-get -f install


Thanks!
It works. Steam runs. :)

However, now apt-get wants to remove a lot of i386 packages, again..
I will definitely hold off du'ing for a while.

I mean, Half-Life 2 just arrived to Linux as a beta. :D

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
Watch your apt messages today
« Reply #18 on: 2013/05/15, 16:22:04 »
Quote from: "jacmoe"
Quote from: "piper"

...
and do that for

libgl1-mesa-dri
libgl1-mesa-glx:i386
libglapi-mesa


and then do
Code: [Select]
apt-get -f install


Thanks!
It works. Steam runs. :)

However, now apt-get wants to remove a lot of i386 packages, again..
I will definitely hold off du'ing for a while.

I mean, Half-Life 2 just arrived to Linux as a beta. :D


I let them go,and reinstalled them (wine & steam) becareful if you need libxvmc1:i386 libxvmcnvidia1:i386 as it will remove
Code: [Select]
kaffeine libgl1-nvidia-glx libxine1-x libxvmc1 mplayer mplayerthumbs nvidia-glx xserver-xorg-video-nvidiaI have not had the time, er I should say too lazy to see if after removal if they can be reinstalled with no problems

but, at the moment I don't have steam installed, (I have a testing build installed right now) actually I haven't had the linux-steam installed yet, always used wine and steam to play hl-2, one of my favorites and I play skyrim (without steam)

wine reinstalled (after it removed things from a du sometime this week) fine
Code: [Select]
apt-get install wine winetricks libwine-openal:i386 libc6-i686:i386 libgpm2:i386 uuid-runtime:i386 libgsm1:i386 libv4l-0:i386 fonts-liberation libwine-gl:i386 libwine-alsa:i386 libgl1-mesa-dri:i386 -s
Reading package lists... Done
Building dependency tree      
Reading state information... Done
fonts-liberation is already the newest version.
wine is already the newest version.
winetricks is already the newest version.
The following extra packages will be installed:
  libasound2:i386 libc6:i386 libdbus-1-3:i386 libdrm-intel1:i386 libdrm-nouveau1a:i386 libdrm-radeon1:i386 libdrm2:i386
  libexpat1:i386 libffi6:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt11:i386 libgl1-mesa-glx:i386
  libglapi-mesa:i386 libglu1-mesa:i386 libgnutls26:i386 libgpg-error0:i386 libice6:i386 libjbig0:i386 libjpeg8:i386 libltdl7:i386
  liblzma5:i386 libmpg123-0:i386 libncurses5:i386 libodbc1:i386 libopenal1:i386 libp11-kit0:i386 libpciaccess0:i386
  libpng12-0:i386 libsm6:i386 libssl1.0.0:i386 libstdc++6:i386 libtasn1-6:i386 libtiff4:i386 libtinfo5:i386 libuuid1:i386
  libv4lconvert0:i386 libwine:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-glx0:i386 libxcb1:i386 libxcomposite1:i386
  libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386 libxml2:i386
  libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxxf86vm1:i386 zlib1g:i386
Suggested packages:
  libasound2-plugins:i386 glibc-doc:i386 locales:i386 rng-tools:i386 libglide3:i386 libmyodbc:i386 odbc-postgresql:i386
  tdsodbc:i386 unixodbc-bin:i386 libportaudio2:i386 libroar-compat2:i386 wine-doc:i386 libwine-cms:i386 libwine-sane:i386
  libwine-ldap:i386 libwine-print:i386 libwine-gphoto2:i386
Recommended packages:
  libpulse0:i386 ttf-liberation:i386 xml-core:i386
The following NEW packages will be installed:
  libasound2:i386 libc6:i386 libc6-i686:i386 libdbus-1-3:i386 libdrm-intel1:i386 libdrm-nouveau1a:i386 libdrm-radeon1:i386
  libdrm2:i386 libexpat1:i386 libffi6:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt11:i386
  libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libglu1-mesa:i386 libgnutls26:i386 libgpg-error0:i386 libgpm2:i386
  libgsm1:i386 libice6:i386 libjbig0:i386 libjpeg8:i386 libltdl7:i386 liblzma5:i386 libmpg123-0:i386 libncurses5:i386
  libodbc1:i386 libopenal1:i386 libp11-kit0:i386 libpciaccess0:i386 libpng12-0:i386 libsm6:i386 libssl1.0.0:i386 libstdc++6:i386
  libtasn1-6:i386 libtiff4:i386 libtinfo5:i386 libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386 libwine:i386 libwine-alsa:i386
  libwine-gl:i386 libwine-openal:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-glx0:i386 libxcb1:i386
  libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386
  libxinerama1:i386 libxml2:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxxf86vm1:i386 uuid-runtime:i386 zlib1g:i386
0 upgraded, 67 newly installed, 0 to remove and 5 not upgraded.
3 not fully installed or removed.
Inst libgcc1:i386 (1:4.8.0-7 Debian:unstable [i386]) []
Inst libc6:i386 (2.17-2 Debian:unstable [i386])
Inst zlib1g:i386 (1:1.2.8.dfsg-1 Debian:unstable [i386])
Inst libssl1.0.0:i386 (1.0.1e-2 Debian:unstable [i386])
Inst libstdc++6:i386 (4.8.0-7 Debian:unstable [i386])
Inst liblzma5:i386 (5.1.1alpha+20120614-2 Debian:unstable [i386])
Inst libtinfo5:i386 (5.9+20130504-1 Debian:unstable [i386])
Conf libgcc1:i386 (1:4.8.0-7 Debian:unstable [i386])
Conf libc6:i386 (2.17-2 Debian:unstable [i386])
Conf libtinfo5:i386 (5.9+20130504-1 Debian:unstable [i386])
Inst libncurses5:i386 (5.9+20130504-1 Debian:unstable [i386])
Inst libuuid1:i386 (2.20.1-5.4 Debian:unstable [i386])
Inst libgpg-error0:i386 (1.10-3.1 Debian:unstable [i386])
Inst libgcrypt11:i386 (1.5.0-5 Debian:unstable [i386])
Inst libp11-kit0:i386 (0.12-3 Debian:unstable [i386])
Inst libtasn1-6:i386 (3.3-1 Debian:unstable [i386])
Inst libgnutls26:i386 (2.12.23-3 Debian:unstable [i386])
Inst libgpm2:i386 (1.20.4-6 Debian:unstable [i386])
Inst libxml2:i386 (2.8.0+dfsg1-7+nmu1 Debian:unstable [i386])
Inst libasound2:i386 (1.0.27-3+siduction1 packages.siduction.org [i386])
Inst libdbus-1-3:i386 (1.6.10-1 Debian:unstable [i386])
Inst libdrm2:i386 (2.4.40-1~deb7u2 Debian:unstable [i386])
Inst libpciaccess0:i386 (0.13.1-2 Debian:unstable [i386])
Inst libdrm-intel1:i386 (2.4.40-1~deb7u2 Debian:unstable [i386])
Inst libdrm-nouveau1a:i386 (2.4.40-1~deb7u2 Debian:unstable [i386])
Inst libdrm-radeon1:i386 (2.4.40-1~deb7u2 Debian:unstable [i386])
Inst libexpat1:i386 (2.1.0-3 Debian:unstable [i386])
Inst libffi6:i386 (3.0.13-4 Debian:unstable [i386])
Inst libfreetype6:i386 (2.4.9-1.1 Debian:unstable [i386])
Inst libfontconfig1:i386 (2.9.0-7.1 Debian:unstable [i386])
Inst libglapi-mesa:i386 (8.0.5-4+b1+siduction1 unstable [i386])
Inst libxau6:i386 (1:1.0.7-1 Debian:unstable [i386])
Inst libxdmcp6:i386 (1:1.1.1-1 Debian:unstable [i386])
Inst libxcb1:i386 (1.8.1-2 Debian:unstable [i386])
Inst libx11-6:i386 (2:1.5.0-1 Debian:unstable [i386])
Inst libx11-xcb1:i386 (2:1.5.0-1 Debian:unstable [i386])
Inst libxcb-glx0:i386 (1.8.1-2 Debian:unstable [i386])
Inst libxfixes3:i386 (1:5.0-4 Debian:unstable [i386])
Inst libxdamage1:i386 (1:1.1.3-2 Debian:unstable [i386])
Inst libxext6:i386 (2:1.3.1-2 Debian:unstable [i386])
Inst libxxf86vm1:i386 (1:1.1.2-1 Debian:unstable [i386])
Inst libgl1-mesa-glx:i386 (8.0.5-4+b1+siduction1 unstable [i386])
Inst libglu1-mesa:i386 (8.0.5-4+b1+siduction1 unstable [i386])
Inst libgsm1:i386 (1.0.13-4 Debian:unstable [i386])
Inst libice6:i386 (2:1.0.8-2 Debian:unstable [i386])
Inst libjpeg8:i386 (8d-1 Debian:unstable [i386])
Inst libltdl7:i386 (2.4.2-1.2 Debian:unstable [i386])
Inst libmpg123-0:i386 (1.15.3-1 Debian:unstable [i386])
Inst libodbc1:i386 (2.2.14p2-5 Debian:unstable [i386])
Inst libopenal1:i386 (1:1.14-4 Debian:unstable [i386])
Inst libpng12-0:i386 (1.2.49-4 Debian:unstable [i386])
Inst libsm6:i386 (2:1.2.1-2 Debian:unstable [i386])
Inst libjbig0:i386 (2.0-2 Debian:unstable [i386])
Inst libtiff4:i386 (3.9.6-11 Debian:unstable [i386])
Inst libv4lconvert0:i386 (0.8.9-3 Debian:unstable [i386])
Inst libv4l-0:i386 (0.8.9-3 Debian:unstable [i386])
Inst libxcomposite1:i386 (1:0.4.3-2 Debian:unstable [i386])
Inst libxrender1:i386 (1:0.9.7-1 Debian:unstable [i386])
Inst libxcursor1:i386 (1:1.1.13-1 Debian:unstable [i386])
Inst libxi6:i386 (2:1.6.1-1 Debian:unstable [i386])
Inst libxinerama1:i386 (2:1.1.2-1 Debian:unstable [i386])
Inst libxrandr2:i386 (2:1.3.2-2 Debian:unstable [i386])
Inst libxslt1.1:i386 (1.1.26-14.1 Debian:unstable [i386])
Inst libwine:i386 (1.4.1-4 Debian:unstable [i386])
Inst libc6-i686:i386 (2.17-2 Debian:unstable [i386])
Inst libgl1-mesa-dri:i386 (8.0.5-4+b1+siduction1 unstable [i386])
Inst libwine-alsa:i386 (1.4.1-4 Debian:unstable [i386])
Inst libwine-gl:i386 (1.4.1-4 Debian:unstable [i386])
Inst libwine-openal:i386 (1.4.1-4 Debian:unstable [i386])
Inst uuid-runtime:i386 (2.20.1-5.4 Debian:unstable [i386])
Conf keyboard-configuration (1.93 Debian:unstable [all])
Conf console-setup-linux (1.93 Debian:unstable [all])
Conf console-setup (1.93 Debian:unstable [all])
Conf zlib1g:i386 (1:1.2.8.dfsg-1 Debian:unstable [i386])
Conf libssl1.0.0:i386 (1.0.1e-2 Debian:unstable [i386])
Conf libstdc++6:i386 (4.8.0-7 Debian:unstable [i386])
Conf liblzma5:i386 (5.1.1alpha+20120614-2 Debian:unstable [i386])
Conf libncurses5:i386 (5.9+20130504-1 Debian:unstable [i386])
Conf libuuid1:i386 (2.20.1-5.4 Debian:unstable [i386])
Conf libgpg-error0:i386 (1.10-3.1 Debian:unstable [i386])
Conf libgcrypt11:i386 (1.5.0-5 Debian:unstable [i386])
Conf libp11-kit0:i386 (0.12-3 Debian:unstable [i386])
Conf libtasn1-6:i386 (3.3-1 Debian:unstable [i386])
Conf libgnutls26:i386 (2.12.23-3 Debian:unstable [i386])
Conf libgpm2:i386 (1.20.4-6 Debian:unstable [i386])
Conf libxml2:i386 (2.8.0+dfsg1-7+nmu1 Debian:unstable [i386])
Conf libasound2:i386 (1.0.27-3+siduction1 packages.siduction.org [i386])
Conf libdbus-1-3:i386 (1.6.10-1 Debian:unstable [i386])
Conf libdrm2:i386 (2.4.40-1~deb7u2 Debian:unstable [i386])
Conf libpciaccess0:i386 (0.13.1-2 Debian:unstable [i386])
Conf libdrm-intel1:i386 (2.4.40-1~deb7u2 Debian:unstable [i386])
Conf libdrm-nouveau1a:i386 (2.4.40-1~deb7u2 Debian:unstable [i386])
Conf libdrm-radeon1:i386 (2.4.40-1~deb7u2 Debian:unstable [i386])
Conf libexpat1:i386 (2.1.0-3 Debian:unstable [i386])
Conf libffi6:i386 (3.0.13-4 Debian:unstable [i386])
Conf libfreetype6:i386 (2.4.9-1.1 Debian:unstable [i386])
Conf libfontconfig1:i386 (2.9.0-7.1 Debian:unstable [i386])
Conf libglapi-mesa:i386 (8.0.5-4+b1+siduction1 unstable [i386])
Conf libxau6:i386 (1:1.0.7-1 Debian:unstable [i386])
Conf libxdmcp6:i386 (1:1.1.1-1 Debian:unstable [i386])
Conf libxcb1:i386 (1.8.1-2 Debian:unstable [i386])
Conf libx11-6:i386 (2:1.5.0-1 Debian:unstable [i386])
Conf libx11-xcb1:i386 (2:1.5.0-1 Debian:unstable [i386])
Conf libxcb-glx0:i386 (1.8.1-2 Debian:unstable [i386])
Conf libxfixes3:i386 (1:5.0-4 Debian:unstable [i386])
Conf libxdamage1:i386 (1:1.1.3-2 Debian:unstable [i386])
Conf libxext6:i386 (2:1.3.1-2 Debian:unstable [i386])
Conf libxxf86vm1:i386 (1:1.1.2-1 Debian:unstable [i386])
Conf libgl1-mesa-glx:i386 (8.0.5-4+b1+siduction1 unstable [i386])
Conf libglu1-mesa:i386 (8.0.5-4+b1+siduction1 unstable [i386])
Conf libgsm1:i386 (1.0.13-4 Debian:unstable [i386])
Conf libice6:i386 (2:1.0.8-2 Debian:unstable [i386])
Conf libjpeg8:i386 (8d-1 Debian:unstable [i386])
Conf libltdl7:i386 (2.4.2-1.2 Debian:unstable [i386])
Conf libmpg123-0:i386 (1.15.3-1 Debian:unstable [i386])
Conf libodbc1:i386 (2.2.14p2-5 Debian:unstable [i386])
Conf libopenal1:i386 (1:1.14-4 Debian:unstable [i386])
Conf libpng12-0:i386 (1.2.49-4 Debian:unstable [i386])
Conf libsm6:i386 (2:1.2.1-2 Debian:unstable [i386])
Conf libjbig0:i386 (2.0-2 Debian:unstable [i386])
Conf libtiff4:i386 (3.9.6-11 Debian:unstable [i386])
Conf libv4lconvert0:i386 (0.8.9-3 Debian:unstable [i386])
Conf libv4l-0:i386 (0.8.9-3 Debian:unstable [i386])
Conf libxcomposite1:i386 (1:0.4.3-2 Debian:unstable [i386])
Conf libxrender1:i386 (1:0.9.7-1 Debian:unstable [i386])
Conf libxcursor1:i386 (1:1.1.13-1 Debian:unstable [i386])
Conf libxi6:i386 (2:1.6.1-1 Debian:unstable [i386])
Conf libxinerama1:i386 (2:1.1.2-1 Debian:unstable [i386])
Conf libxrandr2:i386 (2:1.3.2-2 Debian:unstable [i386])
Conf libxslt1.1:i386 (1.1.26-14.1 Debian:unstable [i386])
Conf libwine:i386 (1.4.1-4 Debian:unstable [i386])
Conf libc6-i686:i386 (2.17-2 Debian:unstable [i386])
Conf libgl1-mesa-dri:i386 (8.0.5-4+b1+siduction1 unstable [i386])
Conf libwine-alsa:i386 (1.4.1-4 Debian:unstable [i386])
Conf libwine-gl:i386 (1.4.1-4 Debian:unstable [i386])
Conf libwine-openal:i386 (1.4.1-4 Debian:unstable [i386])
Conf uuid-runtime:i386 (2.20.1-5.4 Debian:unstable [i386])
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline jacmoe

  • User
  • Posts: 26
    • http://www.jacmoe.dk/
Watch your apt messages today
« Reply #19 on: 2013/05/15, 20:04:22 »
I am running the official Steam client for Linux. There is no wine involved. ;)

Half-Life 2 beta for Linux was released 5 days ago:

http://steamcommunity.com/app/220/discussions/0/810924133983035694/



It doesn't look too bad today on the apt-get front, though.
But I suspect that removing gtk2-engines and libcurl3 for i386 will upset the Steam client.

I don't get why there should be such a conflict between 64 and 32 bit in this day and age.
It's ridiculous. :)


Edit:
Scrap that - nothing to remove now.

Thanks Siduction team!
Your fixes fixes things. :)