seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/11/19, 06:13:00


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: dependency errors with apache2  (Read 4730 times)

0 Members and 1 Guest are viewing this topic.

Offline michaa7

  • User
  • Posts: 2.126
dependency errors with apache2
« on: 2013/05/31, 15:20:53 »
After update apache2 remains not configured.

 
Quote
apache2 (2.4.4-4) wird eingerichtet ...
Directory /etc/apache2/conf.d is not empty - leaving as is
Please note, that directory is considered obsolete and not read anymore by default
apache2-doc  drupal6.conf  javascript-common.conf
ERROR: Module mpm_worker is enabled - cannot proceed due to conflicts. It needs to be disabled first!
dpkg: Fehler beim Bearbeiten von apache2 (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von apache2-mpm-worker:
 apache2-mpm-worker hängt ab von apache2 (= 2.4.4-4); aber:
  Paket apache2 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von apache2-mpm-worker (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von apache2.2-bin:
 apache2.2-bin hängt ab von apache2; aber:
  Paket apache2 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von apache2.2-bin (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 apache2
 apache2-mpm-worker
 apache2.2-bin
E: Sub-process /usr/bin/dpkg returned an error code (1)


de:
Abhängigkeitsprobleme
en: dependency problems

de:
unkonfiguriert
en:
not configured
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline ralfi

  • User
  • Posts: 383
dependency errors with apache2
« Reply #1 on: 2013/05/31, 15:29:56 »
de: Versuche zuerst die apache2.2 Pakete zu entfernen dann geht es auch (bei mir)
en: try purging apache2.2 packages first, then it works (for me)
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline michaa7

  • User
  • Posts: 2.126
dependency errors with apache2
« Reply #2 on: 2013/05/31, 15:38:03 »
*All* of them, that's quite a bunch ... and then I have to reconfigure all my virtual hosts (purge!)?
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline ralfi

  • User
  • Posts: 383
dependency errors with apache2
« Reply #3 on: 2013/05/31, 15:49:10 »
de: Bei mir wurden nur die 2.2 Pakete entfernt, die Konfiguration blieb erhalten. Das ist natürlich keine Gewähr dafür, dass sich das überall so verhält.
en: For me, only the 2.2 packages were removed, the configuration was retained. This is of course no guarantee that the same everywhere behaves.
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline michaa7

  • User
  • Posts: 2.126
dependency errors with apache2
« Reply #4 on: 2013/05/31, 15:56:58 »
purging is *not* entfernen!!!

purging is delete AND remove all config files (exept those in /home/<user>)

remove is delete but leave all configs untouched.

So you did not purge but only remove apache2*.

EDIT://
At least I can confirm that apt-get purge apache2.2* and then installing the formerly removed packages again avoids the dependency problems.
But now I have to configure my local apache2 environement again :-(

BTW: Could you tell me where the config of VirtualHosts is done? Here nothing works anymore.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline DeepDayze

  • User
  • Posts: 409
RE: dependency errors with apache2
« Reply #5 on: 2013/05/31, 16:23:18 »
Would taking a backup of all the config and data files before purging the apache2 packages help?

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
dependency errors with apache2
« Reply #6 on: 2013/06/02, 16:50:24 »
When I do a dist-upgrade it wants to remove apache2.2-common and php5-ffmpeg.
Does this resolve if I just wait for a couple of days or should I purge and reinstall apache?
Also, does anyone knows what's the problem with php5-ffmpeg?

Code: [Select]
$ apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden ENTFERNT:
  apache2.2-common libharfbuzz0 php5-ffmpeg
Die folgenden NEUEN Pakete werden installiert:
  apache2-bin apache2-data libfile-basedir-perl libgd3 libharfbuzz0a libio-html-perl libtext-levenshtein-perl libwebp4 t1utils
Die folgenden Pakete werden aktualisiert (Upgrade):
  apache2 apache2-mpm-prefork apache2-utils apache2.2-bin at-spi2-core autotools-dev cpio freespacenotifier gcc-4.8-base gcc-4.8-base:i386 gettext gettext-base inxi kde-style-oxygen
  kde-window-manager kde-workspace kde-workspace-bin kde-workspace-data kde-workspace-kgreet-plugins kdebase-workspace-bin kdm klipper kmenuedit ksysguard ksysguardd libapache2-mod-php5
  libasprintf-dev libasprintf0c2 libatk-bridge2.0-0 libatspi2.0-0 libcanberra-gtk0 libcanberra-gtk3-0 libcanberra0 libgcc1 libgcc1:i386 libgdbm3 libgettextpo-dev libgettextpo0 libgfortran3
  libgomp1 libgraphite2-3 libhttp-message-perl libio-socket-ssl-perl libitm1 libkdecorations4abi1 libkephal4abi1 libkscreensaver5 libksgrd4 libksignalplotter4 libkwineffects1abi4
  libkwinglutils1abi1 libkworkspace4abi2 libnettle4 libpango-1.0-0 libpango1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libplasma-geolocation-interface4 libplasmaclock4abi3
  libplasmagenericshell4 libprocesscore4abi1 libprocessui4a libquadmath0 libsolidcontrol4abi2 libsolidcontrolifaces4abi2 libstdc++6 libstdc++6:i386 libtaskmanager4abi3 libusb-0.1-4
  libweather-ion6 libwebp-dev libxalan2-java lintian mercurial mercurial-common nfs-common php-pear php5-cgi php5-cli php5-common php5-curl php5-gd php5-mcrypt php5-mysql php5-sqlite
  php5-xdebug plasma-dataengines-workspace plasma-desktop plasma-scriptengine-python plasma-widgets-workspace ppp systemsettings xterm
94 aktualisiert, 9 neu installiert, 3 zu entfernen und 0 nicht aktualisiert.
Es müssen 45,7 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 3.411 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]?

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.373
dependency errors with apache2
« Reply #7 on: 2013/06/02, 18:55:39 »
Apache as well as php are transitioning atm, just wait it out.
php: http://release.debian.org/transitions/html/php5.5.html
apache: http://bugs.debian.org/661958

greetz
devil

Offline michaa7

  • User
  • Posts: 2.126
dependency errors with apache2
« Reply #8 on: 2013/06/03, 01:11:04 »
apache2.2-common must go as it is replaced by one of the new apache packages. And it seems the currently shipped new built packages do not have the above mentioned dependency problems.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline DeepDayze

  • User
  • Posts: 409
dependency errors with apache2
« Reply #9 on: 2013/06/03, 01:34:03 »
For Gnome users this will remove:

gnome gnome-core gnome-user-share task-gnome-desktop

So if any of you are using Gnome 3 better wait further

EDIT: Think that's fixed now with updated gnome-user-share

Offline brummer

  • User
  • Posts: 270
    • http://guitarix.sourceforge.net/
dependency errors with apache2
« Reply #10 on: 2013/06/13, 14:31:10 »
trouble with apache2 seems still exist. dist-upgrade fails here, because apache2 fails to start, error in configuration file, and I need to remove apache2 and friends
Code: [Select]
apt-get remove --purge apache2* php5* siguibui sidu-disk-center
running several apt-get -f install then proceed the dist-upgrade
after-wards I reinstall  sidu-disk-center  php5-json
that ships apache2, but still apache2 fail to start, so configuration didn't get ready (E). I need to reboot and run again apt-get -f install, then apache starts finally.