Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] boot-repair requires a live-session when it already is in a live session  (Read 11587 times)


  • Guest
I am trying to dual boot Siduction 13.2.1 with Windows 8.1 (for the time being) on an HP Pavilion notebook.  When I run boot-repair in a live DVD or a live USB, I get the message, "Please use this software in a live-session (live-CD or live-USB). This will enable this feature." ???

I do not know how to address this.  Any suggestions?

P.S. I fixed the link to the notebook information.
« Last Edit: 2014/02/24, 06:01:12 by jjjrrr3 »

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.846
You should probably file a bug at https://bugs.launchpad.net/boot-repair


Offline der_bud

  • User
  • Posts: 1.077
  • member
Besides the tool  boot-repair  (which I don't know), I assume you got problems with proper boot management after installing windows? Then you can repair grub according to our manual: http://manual.siduction.org/sys-admin-grub2#mbr-over-grub2. Or what else are the concrete problems you're faceing?
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.


  • Guest
The computer came with Windows 8.1 pre-installed. I have installed Siduction 13.2.1 and would like the computer to boot up with grub2, but it always defaults to Windows instead. I ran the instruction "To only re-write grub2 to MBR from the hard drive", but it made no difference.

Offline sunrat

  • User
  • Posts: 406
A windows 8.1 computer will boot with UEFI, not GRUB in MBR.

Offline GoinEasy9

  • User
  • Posts: 564
I don't think any boot repair utility has been updated successfully to deal with UEFI yet (then again, I could be wrong).  First rule would be to ask here in the forum before using such a utility, even though it's a siduction utility (well, it's in the siduction extra repo) for boot repair. 

UEFI boot problems are actually easy to fix, provided that you installed siduction in UEFI mode, which I'm guessing you didn't, which is why you are having these problems.  If you can still boot Windows, it probably means that you didn't harm anything, but that's just a guess.  I would suggest reading over a how-to I made on how to install siduction on UEFI hardware here:

If I read this wrong, and you know you have a UEFI bios, and have deliberately installed siduction to the MBR, I'm sorry I  misunderstood.  Maybe some more info would help.
« Last Edit: 2014/02/26, 03:10:47 by GoinEasy9 »
Linux Counter number 348347


  • Guest
I'll take a look ay your how-to.  This is my first UEFI machine, and I'll confess that it is turning out to be [ahem] a learning experience.

Offline GoinEasy9

  • User
  • Posts: 564
When I first recieved my ASUS UEFI motherboard, I made many mistakes, including the trashing of a 1.5TB HD which I thought could be used with a rack mount like I did with my previous MBR installations.  While it didn't take long to understand how UEFI worked, it did take a while to get comfortable using it.

Think of UEFI as a replacement for Grub.  In dual boot situations, you choose your OS from UEFI and it points to a bootloader in /boot/efi.  That in turn points to another bootloader, in Linux case, Grub, which you use to start the OS you've chosen.  Fedora has been trying to put Grub into /boot/efi, but, their experiments still only work with their distro. 

When installing in UEFI, you must be able to boot the installation cd or usb stick in UEFI mode.  You also have to use the common /boot/efi partition, this is where the UEFI bootloader is installed.  Once those 2 requirements are met, it's just a regular install. 

 I have 4 distros at present on my UEFI machine.  Debian, Fedora, openSUSE and siduction.  All have their own separate grubs, so, no problems trying to maintain a single grub for all installs.  In fact, I've turned off the os-prober in each of their grubs, because trying to boot one distro from another distros grub in UEFI, is an experiment in terror.  Once resulting in the corruption of my NVRAM (the place where UEFI firmware stores info on the motherboard).

I first learned about UEFI from Rod Smith, who is active on the fedora forums, and is also the author of gdisk, link here:   
http://www.rodsbooks.com/efi-bootloaders/  (Which is more technical than easy reading)
I also use Rod's rEFInd as a UEFI rescue disk: http://www.rodsbooks.com/refind/
Then there's the Arch wiki which has a lot of good info: https://wiki.archlinux.org/index.php/Unified_Extensible_Firmware_Interface
Or the recently written blog by AdamW of Red Hat fame: https://www.happyassassin.net/2014/01/25/uefi-boot-how-does-that-actually-work-then/  (Easier to read)   
Then there's the original Tanguy Ortolo post that devil posted when I first started inquiring about UEFI: http://tanguy.ortolo.eu/blog/article51/debian-efi  (It's a bit dated, but, easy to understand, and, the comments to the post are also helpful).

After you become a little more familiar with UEFI, I'd say try the siduction install again, but, using the instructions I posted.  I'm really happy finally having siduction as the main distro on my newest machine.

BTW - The author of the siduction installer, hama, actually helped the most, by putting the EFI options into the installer.  I used the siduction wiki and his improved installer to make the how-to.
Linux Counter number 348347