seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/10/23, 15:01:17


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: apt-get dist-upgrade not possible  (Read 6051 times)

0 Members and 1 Guest are viewing this topic.

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
apt-get dist-upgrade not possible
« on: 2014/05/19, 10:57:38 »
Hi!

When I try to apt-get dist-upgrade I get the following output:

Code: [Select]
$ apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
 modemmanager : Breaks: network-manager (< 0.9.8.2-1) but 0.9.8.0-5 is to be installed
 plasma-nm : Depends: network-manager (>= 0.9.8.4) but 0.9.8.0-5 is to be installed
 ppp : Breaks: network-manager (< 0.9.8.8-7~) but 0.9.8.0-5 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Internal error, Upgrade broke stuff

Has anyone an idea how to fix this?
Thanks!

EDIT: replacing german output with english
« Last Edit: 2014/05/19, 12:01:31 by davidb »

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.304
Re: apt-get dist-upgrade not possible
« Reply #1 on: 2014/05/19, 10:59:01 »
apt-get update

before!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
Re: apt-get dist-upgrade not possible
« Reply #2 on: 2014/05/19, 11:04:41 »
I did update before. But now I noticed I get a:

Code: [Select]
Fehl http://ftp.debian.org experimental/non-free amd64 Packages
in the list

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.368
Re: apt-get dist-upgrade not possible
« Reply #3 on: 2014/05/19, 11:23:07 »
Just a remark: If posting in EN, please paste Your output in EN as well. Putting LANG=C in front of your commands outputs EN. Other than that your sources seem somehow broken . Please paste inxi -r


greetz
devil

Offline absolut

  • User
  • Posts: 421
Re: apt-get dist-upgrade not possible
« Reply #4 on: 2014/05/19, 11:37:16 »
I did update before. But now I noticed I get a:
Code: [Select]
Fehl http://ftp.debian.org experimental/non-free amd64 Packagesin the list

this is probably due to a mirror sync at around 11:00


check if you have siduction's kdenext repository enabled
check if you have any packages on hold
check if there are any packages not completely installed with apt-get install -f

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
Re: apt-get dist-upgrade not possible
« Reply #5 on: 2014/05/19, 11:59:53 »
Code: [Select]
inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/debian.list
           deb http://http.debian.net/debian/ unstable main contrib non-free
           deb http://ftp.de.debian.org/debian/ stable main contrib non-free
           deb http://security.debian.org/ stable/updates main contrib non-free
           deb http://ftp.de.debian.org/debian experimental main contrib non-free
           Active apt sources in file: /etc/apt/sources.list.d/misc.list
           deb http://www.charlesproxy.com/packages/apt/ charles-proxy main
           deb http://ppa.launchpad.net/webupd8team/java/ubuntu precise main
           deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/siduction.list
           deb http://ftp.spline.de/pub/siduction/base unstable main

kdenext repository is not enabled. Should I do that?
No package is on hold
apt-get isntall -f gives just:

Code: [Select]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 170 not upgraded.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.368
Re: apt-get dist-upgrade not possible
« Reply #6 on: 2014/05/19, 14:17:50 »
PPA in Debian is always a risk. Remove the ppa lines and the one for debian security. Then try again.


greetz
devil

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
Re: apt-get dist-upgrade not possible
« Reply #7 on: 2014/05/19, 15:40:34 »
An apt-get install network-manager also installed:
Code: [Select]
libmm-glib0 libpam-systemd ppp systemd-sysvremoved:
Code: [Select]
sysvinit-core

Now I get a huge list of packages to remove/upgrade/new install:

Code: [Select]
$apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  build-essential dkms g++ g++-4.8 gcc gcc-4.8 libboost-atomic1.54-dev
  libboost-chrono1.54-dev libboost-date-time1.54-dev
  libboost-serialization1.54-dev libboost-system1.54-dev libboost-thread-dev
  libboost-thread1.54-dev libboost1.54-dev libcogl-pango12 libcogl12
  libeventviews4 libgdata13 libgoa-1.0-0 libincidenceeditorsng4 libksieveui4
  libmailcommon4 libmailimporter4 libmessagecomposer4 libmessageviewer4
  libpimcommon4 libtemplateparser4 linux-headers-3.10-4.towo-siduction-amd64
  linux-headers-3.11-0.towo-siduction-amd64
  linux-headers-3.11-4.towo-siduction-amd64
  linux-headers-3.11-6.towo-siduction-amd64
  linux-headers-3.12-0.towo-siduction-amd64
  linux-headers-3.12-1.towo-siduction-amd64
  linux-headers-3.12-2.towo-siduction-amd64
  linux-headers-3.12-4.towo-siduction-amd64
  linux-headers-3.12-5.towo-siduction-amd64
  linux-headers-3.12-6.towo-siduction-amd64
  linux-headers-3.12-7.towo-siduction-amd64
  linux-headers-3.13-1.towo-siduction-amd64
  linux-headers-3.13-2.towo-siduction-amd64
  linux-headers-3.13-5.towo-siduction-amd64
  linux-headers-3.13-6.towo-siduction-amd64 linux-headers-siduction-amd64
  nvidia-driver nvidia-kernel-dkms
The following NEW packages will be installed:
  esound-common gcc-4.9-base kdepim-groupware kdepim-strigi-plugins
  kdepim-wizards libabw-0.0-0 libakonadi-xml4 libaudiofile1 libavcodec55
  libavdevice54 libavfilter4 libavformat55 libavutil53 libboost-atomic1.55-dev
  libboost-atomic1.55.0 libboost-date-time1.55-dev libboost-date-time1.55.0
  libboost-serialization1.55-dev libboost-serialization1.55.0
  libboost-system1.55-dev libboost-system1.55.0 libboost1.55-dev
  libcamel-1.2-49 libcmis-0.4-4 libcogl-pango20 libcogl-path20 libcogl20
  libdrm2:i386 libe-book-0.0-0 libebackend-1.2-7 libecal-1.2-16
  libedata-book-1.2-20 libedata-cal-1.2-23 libedataserver-1.2-18 libeot0
  libesd0 libetonyek-0.0-0 libexporter-tiny-perl libfreehand-0.0-0 libgdata19
  libgeocode-glib0 libgl1-mesa-glx:i386 libglapi-mesa:i386 libgoa-1.0-0b
  libgtkspell3-3-0 libident libiscsi2 libkdcraw23 libkomparediff2-4
  libmarblewidget17 libmbim-glib0 libmikmod3 libmodemmanagerqt1 libmwaw-0.2-2
  libnet-idn-encode-perl libnetworkmanagerqt1 libotr5 libplist2 libpoppler44
  libqmi-glib0 libqmobipocket1 libqt4-opengl:i386 libqt4-xmlpatterns:i386
  libraw10 libreoffice-avmedia-backend-gstreamer libreoffice-base-drivers
  librtmp1 libruby2.1 libsystemd-id128-0 libudev1:i386 libva-glx1
  libx11-xcb1:i386 libx264-142 libxatracker2 libxcb-dri2-0:i386
  libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386
  libxdamage1:i386 libxfixes3:i386 libxine2 libxine2-bin libxine2-ffmpeg
  libxine2-misc-plugins libxine2-plugins libxine2-x libxshmfence1:i386
  libxxf86vm1:i386 linux-image-3.14-4.towo-siduction-amd64 nvidia-modprobe
  opencv-data ruby2.1 sidu-base startpar
The following packages have been kept back:
  cpp-4.8 gcc-4.8-base gcc-4.8-base:i386 libasan0 libgcc-4.8-dev libgcc1
  libgcc1:i386 libstdc++-4.8-dev libstdc++6 libstdc++6:i386
The following packages will be upgraded:
  akonadiconsole akregator cups-filters cups-filters-core-drivers digikam
  digikam-data digikam-private-libs evolution evolution-common
  evolution-data-server evolution-data-server-common evolution-plugins
  gstreamer0.10-plugins-ugly gvfs gvfs-backends gvfs-bin gvfs-common
  gvfs-daemons gvfs-libs kaddressbook kaffeine kalarm kdepim kdepim-kresources
  kdepim-runtime kipi-plugins kipi-plugins-common kleopatra kmail knode knotes
  kompare kontact kopete korganizer ktimetracker libatomic1 libav-tools
  libavcodec54 libavformat54 libavresample1 libboost-dev libcalendarsupport4
  libchamplain-0.12-0 libchromaprint0 libclutter-1.0-0 libclutter-gtk-1.0-0
  libclutter-imcontext-0.1-0 libcluttergesture-0.0.2-0 libebook-1.2-14
  libebook-contacts-1.2-0 libevolution libfreerdp-plugins-standard
  libgfortran3 libgl1-nvidia-glx libgoa-1.0-common libgomp1 libgpod4
  libimobiledevice4 libitm1 libkdepim4 libkdepimdbusinterfaces4 libkdgantt2-0
  libkleo4 libkmanagesieve4 libkpgp4 libksieve4 libmediastreamer-base3
  libmessagecore4 libmessagelist4 libmx-1.0-2 libnepomukcore4 libokularcore3
  libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-video2.4 libpoppler-qt4-4 libpulse-dev
  libpulse-mainloop-glib0 libpulse0 libqtwebkit4 libqtwebkit4:i386
  libquadmath0 libreoffice libreoffice-base libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-impress libreoffice-math libreoffice-style-galaxy
  libreoffice-writer libsdl-mixer1.2 libsdl-mixer1.2-dev libsearchclient0
  libsendlater4 libstreamanalyzer0 libstreams0 libstrigihtmlgui0
  libstrigiqtdbusclient0 libswscale2 libtsan0 libtype-tiny-perl libusbmuxd2
  linux-image-siduction-amd64 modemmanager nepomuk-core-runtime ngircd
  nvidia-alternative nvidia-vdpau-driver okular okular-extra-backends
  plasma-nm plasma-widget-networkmanagement policykit-1 poppler-utils
  python3-uno pywwetha qemu-system-x86 qemu-utils ruby signing-party
  strigi-client strigi-daemon sysv-rc sysvinit-utils upower usbmuxd vlc
  vlc-nox weechat weechat-core weechat-curses weechat-plugins
  xserver-xorg-video-nvidia xserver-xorg-video-vmware
146 upgraded, 95 newly installed, 45 to remove and 10 not upgraded.
Need to get 266 MB of archives.
After this operation, 201 MB disk space will be freed.

Is there a transition going on and should I wait?

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
Re: apt-get dist-upgrade not possible
« Reply #8 on: 2014/05/19, 17:17:56 »
I just let it run and everything seems fine now.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.922
    • Land of the Buckeye
Re: apt-get dist-upgrade not possible
« Reply #9 on: 2014/05/19, 17:59:23 »
I saw some old linux-headers packages removed this morning, but had no other issues.  But I don't understand why it pulled your nvidia-driver and nvidia-kernel-dkms packages.  It did not pull mine, which are still installed.  You might want to take a look at that issue -- try reinstalling them and find out what is conflicting.


Code: [Select]
root@imerabox:/# apt-cache policy nvidia-kernel-dkms
nvidia-kernel-dkms:
  Installed: 337.12-0.siduction.1
  Candidate: 337.12-0.siduction.1
  Version table:
     337.19-1 0
          1 http://ftp.us.debian.org/debian/ experimental/non-free amd64 Packages
 *** 337.12-0.siduction.1 0
        500 http://packages.siduction.org/experimental/ unstable/non-free amd64 Packages
        100 /var/lib/dpkg/status
     331.67-2 0
        500 http://ftp.us.debian.org/debian/ unstable/non-free amd64 Packages
     331.67-1.siduction.1 0
        500 http://packages.siduction.org/fixes/ unstable/non-free amd64 Packages


Also, your siduction sources don't look like what is recommended.  Here is a better siduction.list, assuming you don't need source packages (you can comment out experimental if you don't want it):


Code: [Select]
root@imerabox:/etc/apt/sources.list.d# cat siduction.list
deb http://packages.siduction.org/base unstable main
#deb-src http://packages.siduction.org/base unstable main
deb http://packages.siduction.org/extra unstable main
#deb-src http://packages.siduction.org/extra unstable main
deb http://packages.siduction.org/fixes unstable main contrib non-free
#deb-src http://packages.siduction.org/fixes unstable main
deb http://packages.siduction.org/experimental unstable main contrib non-free
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline davidb

  • User
  • Posts: 29
    • http://brandesign.org
Re: apt-get dist-upgrade not possible
« Reply #10 on: 2014/05/19, 19:42:23 »
Indeed I needed to reinstall the nvidia drivers.
Also somehow pywwetha was running after the upgrade and didn't let me start nginx because it was binded to port 80. apt-get purge pywwetha fixed it.