seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/08/07, 11:47:15


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Latest version of libdlb1 makes d-u remove a lot of stuff  (Read 4033 times)

0 Members and 1 Guest are viewing this topic.

Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
Good morning, if you are having this problem you can workaround it putting libldb1on hold:


(sorry for the Spanish output)


Code: [Select]

# aptitude dist-upgrade
Se actualizarán los siguientes paquetes:         
  libdatetime-timezone-perl libldb1 libtalloc2 libtdb1 libtdb1:i386 libtyxml-ocaml libtyxml-ocaml-dev python-ldb python-talloc
  python-tdb tdb-tools
11 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 1 sin actualizar.
Necesito descargar 1.703 kB de ficheros. Después de desempaquetar se usarán 4.128 kB.
No se satisfacen las dependencias de los siguientes paquetes:
 libben-ocaml : Depende: libtyxml-ocaml-caro0 que es un paquete virtual.
 samba-libs : Depende: libldb1 (< 1:1.1.17~) pero se va a instalar 1:1.1.17-1.
 ben : Depende: libtyxml-ocaml-caro0 que es un paquete virtual.
abierto: 279; cerrado: 397; diferido: 272; conflicto: 379                                                                           .Las acciones siguientes resolverán estas dependencias


       Eliminar los paquetes siguientes:                                 
1)       akonadi-kde-resource-googledata                                 
2)       akonadiconsole                                                 
3)       akregator                                                       
4)       amarok                                                         
5)       amarok-dbg                                                     
6)       amor                                                           
7)       ark                                                             
       bangarang                                                       
9)       ben                                                             
10)      blinken                                                         
11)      blogilo                                                         
12)      bluedevil                                                       
13)      bomber                                                         
14)      bovo                                                           
15)      braindump                                                       
16)      calligra                                                       
17)      calligraauthor                                                 
18)      calligraflow                                                   
19)      calligraplan                                                   
20)      calligrasheets                                                 
21)      calligrastage                                                   
22)      calligrawords                                                   
23)      cantor                                                         
24)      cantor-backend-kalgebra                                         
25)      cantor-backend-maxima                                           
[snip]                                                     
330)     vlc                                                             
331)     vlc-nox                                                         
332)     vlc-plugin-notify                                               
333)     vlc-plugin-pulse                                               
334)     yakuake                                                         


       Dejar las siguientes dependencias sin resolver:                   
335)     amarok-common recomienda amarok (>= 2.8.0-2)                   
336)     digikam-doc recomienda digikam                                 
337)     kipi-plugins recomienda konqueror                               
338)     showfoto recomienda dolphin                                     
339)     showfoto recomienda kipi-plugins                               
340)     kscreensaver-xsavers recomienda kscreensaver (= 4:4.13.1-1)     
341)     kdenlive-data recomienda kdenlive                               
342)     kmymoney-common recomienda kmymoney                             
343)     konversation-data recomienda konversation (>= 1.5-1)           
344)     libkopete4 recomienda kopete (= 4:4.13.1-1)                     
345)     krecipes-doc recomienda krecipes (>= 2.0~beta2-3)               
346)     kde-config-telepathy-accounts recomienda kde-telepathy         
347)     kde-telepathy-approver recomienda kde-telepathy                 
348)     plasma-runner-telepathy-contact recomienda kde-telepathy       
349)     kde-telepathy-integration-module recomienda kde-telepathy       
350)     kvpnc-data recomienda kvpnc (>= 0.9.6a-2.1)                     
351)     samba-common recomienda samba-common-bin                       
352)     ssft recomienda zenity | kdebase-bin                           
353)     tellico-data recomienda tellico                                 
354)     tellico-doc recomienda tellico                                 
355)     tellico-scripts recomienda tellico                             
356)     winetricks recomienda zenity | kdebase-bin                     
357)     kde-standard recomienda plasma-widget-networkmanagement         
358)     kdegraphics-mobipocket recomienda okular                       
359)     kdelibs5-plugins recomienda kde-runtime                         
360)     kdenetwork recomienda kppp (>= 4:4.10.5)                       
361)     kdepim-groupware recomienda kdepim-wizards                     
362)     kdeutils recomienda print-manager (>= 4:4.10.5)                 
363)     konqueror recomienda dolphin                                   
364)     konqueror recomienda kfind                                     
365)     kontact recomienda kmail                                       
366)     kontact recomienda knotes                                       
367)     kontact recomienda akregator                                   
368)     kontact recomienda kaddressbook                                 
369)     ktorrent-data recomienda ktorrent (>= 4.3.1-90r0)               
370)     libktpcommoninternalsprivate7 recomienda kde-telepathy-kpeople 
371)     okular-extra-backends recomienda okular                         
372)     plasma-desktop recomienda kde-workspace                         
373)     plasma-netbook recomienda kde-workspace                         
374)     plasma-scriptengines recomienda plasma-scriptengine-superkaramba
375)     plasma-widgets-addons recomienda plasma-widget-lancelot         
376)     muon recomienda muon-updater                                   


P.S. while this wants to remove a lot of KDE stuff it doesn't matter if you have kdenext activated or not.
« Last Edit: 2014/06/06, 17:31:04 by Santa »
Sometimes standing for what you believe means standing alone.

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Latest version of libdlb1 makes d-u remove a lot of stuff
« Reply #1 on: 2014/06/02, 13:41:48 »
Hello Santa,

you are right, aptitude uses a more agressive resolver than apt-get.
Interestingly nothing else needs to be kept back.

Code: [Select]
root@sidbox:~# LANG=C apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libldb1
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
With today's dist-upgrade everything is fine again.
Sometimes standing for what you believe means standing alone.

Offline GoinEasy9

  • User
  • Posts: 467
Yes it is, confirmed.  Thanks Santa.
Linux Counter number 348347

Offline vilde

  • User
  • Posts: 672
With today's dist-upgrade everything is fine again.

That's not working here, still have to have libdlb1on hold. (32bit xfce)

Offline seasons

  • User
  • Posts: 252
You may have to wait a bit longer depending on your mirror. samba_4.1.7+dfsg-2+b1 package should solve it
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=750541

Offline vilde

  • User
  • Posts: 672
You may have to wait a bit longer depending on your mirror. samba_4.1.7+dfsg-2+b1 package should solve it
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=750541
Hmmm, I don't think I have samba installed, how shall that help me?
It look like this, sorry for the Swedish but hopefully you understand (TAS BORT=REMOVED)
Code: [Select]
root@T410:/home/vilde# apt-cache policy samba
samba:
  Installerad: (ingen)
  Kandidat:    2:4.1.7+dfsg-2
  Versionstabell:
     2:4.1.7+dfsg-2 0
        500 http://debian.lth.se/debian/ unstable/main i386 Packages

Code: [Select]
root@T410:/home/vilde# apt-get dist-upgrade -d
Läser paketlistor... Färdig
Bygger beroendeträd         
Läser tillståndsinformation... Färdig
Beräknar uppgradering... Färdig
Följande paket kommer att TAS BORT:
  gvfs-backends libsmbclient mplayer2 samba-libs vlc vlc-nox
Följande paket kommer att uppgraderas:
  libldb1
1 att uppgradera, 0 att nyinstallera, 6 att ta bort och 0 att inte uppgradera.
Behöver hämta 109 kB arkiv.
Efter denna åtgärd kommer 34,7 MB att frigöras på disken.
Vill du fortsätta? [J/n]

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Hello vilde,

your mirror is really stuck and out of sync - or did you forget to run "apt-get update"?

Code: [Select]
$ LANG=C apt-cache policy samba
samba:
  Installed: (none)
  Candidate: 2:4.1.7+dfsg-2+b1
  Version table:
     2:4.1.7+dfsg-2+b1 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages

Fact is that i see a newer candidate.

greetings
musca

„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline seasons

  • User
  • Posts: 252
Even if you don't have samba installed, you probably have samba-libs installed.(especially if you're using KDE or VLC).

Offline vilde

  • User
  • Posts: 672
Hello vilde,

your mirror is really stuck and out of sync - or did you forget to run "apt-get update"?

Code: [Select]
$ LANG=C apt-cache policy samba
samba:
  Installed: (none)
  Candidate: 2:4.1.7+dfsg-2+b1
  Version table:
     2:4.1.7+dfsg-2+b1 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages

Fact is that i see a newer candidate.
greetings
musca
That is because you have 64 bit, on 32 bit it's the one I have. So I probably have to wait and hope.....

Offline axt

  • User
  • Posts: 409
    • axebase.net
Re: Latest version of libdlb1 makes d-u remove a lot of stuff
« Reply #10 on: 2014/06/06, 13:38:03 »
I can acknowledge this. Unfortunately. The issue persits.

Siduction/LXDE/32 bit freshly installed yesterday - no chance to install kde-runtime and thus install any KDE/Qt applications (depends on >> libldb1 (< 1:1.1.17~).

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=750541


Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
Re: Latest version of libdlb1 makes d-u remove a lot of stuff
« Reply #11 on: 2014/06/06, 17:30:46 »
I can acknowledge this. Unfortunately. The issue persits.

Siduction/LXDE/32 bit freshly installed yesterday - no chance to install kde-runtime and thus install any KDE/Qt applications (depends on >> libldb1 (< 1:1.1.17~).

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=750541


If I'm understanding the problem correctly, it remains unfixed for i386 but not amd64, where the problem is gone. Thanks for notcing, changing the topic subject.
Sometimes standing for what you believe means standing alone.

Offline axt

  • User
  • Posts: 409
    • axebase.net
Re: Latest version of libdlb1 makes d-u remove a lot of stuff
« Reply #12 on: 2014/06/06, 20:31:29 »
Right. I have solved it for me temporarily, as I have downloaded and installed previous versions of certain packages manually. Not pretty, but possible.

libldb1_1.1.16-1_i386.deb
libtdb1_1.2.13-4_i386.deb
python-crypto_2.6.1-5_i386.deb
python-ldb_1.1.16-1_i386.deb
python-samba_4.1.7+dfsg-2_i386.deb
python-tdb_1.2.13-4_i386.deb
samba-libs_4.1.7+dfsg-2_i386.deb
samba_4.1.7+dfsg-2_i386.deb

Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
Re: Latest version of libdlb1 makes d-u remove a lot of stuff
« Reply #13 on: 2014/06/09, 20:46:06 »
This problem was workarounded in fixes/, there is also a new version of samba in debian which has a similar workaround, so everything should work fine now in i386, please let us know if it doesn't.
Sometimes standing for what you believe means standing alone.

Offline vilde

  • User
  • Posts: 672
Re: Latest version of libdlb1 makes d-u remove a lot of stuff
« Reply #14 on: 2014/06/14, 17:33:15 »
This problem was workarounded in fixes/, there is also a new version of samba in debian which has a similar workaround, so everything should work fine now in i386, please let us know if it doesn't.
Been away some days, doing d-u now and it looks like the problem is gone for me. Thanks :)