Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] Siduction 2013.2, Xfce, Radeon: Closing laptop lid always suspends, can't wake!  (Read 5032 times)


  • Guest
I'm having a power management problem that started with a clean install of Siduction 2013.2 (AMD64) with Xfce.  I'm currently using the open source radeon driver, in case it matters.  My system is up-to-date and running the 3.14-2 kernel.

No matter what settings I set in the Xfce power manager GUI, the laptop will always go into a suspend or hibernate mode (not sure which) whenever I close the lid.  Even if I tell it to do nothing when the lid closes, it suspends anyway.  Once it suspends, nothing will wake it: It's totally unresponsive to the keyboard, and hitting the power button tries to wake it, but the screen just flashes gray every once in a while.  Even Alt+SysReq+RSEIUB doesn't work, and I have to physically power down the machine and reboot to get back to work.  This is time-consuming and annoying for obvious reasons, and it's also probably bad for my hard drive.

I don't think it's a Linux hardware compatibility problem:
I previously used [an up-to-date] Siduction 2012.2 install with the MATE desktop (from the MATE developers' repositories), and the power management worked fine.  The power manager obeyed the settings in the MATE GUI, and suspend/resume worked as expected.  I ran into some unrelated problems a month ago that convinced me to do a clean install and give Xfce a chance, and that's when my power management problems started.

My Xfce power manager GUI settings are apparently being ignored, so that seems to indicate there might be a disconnect between the GUI and the actual system settings, but it still wouldn't explain why the machine won't wake.  The problem might also have something to do with systemd, because I don't think my 2012.2 install ever used it (I could be wrong though).  I've tried searching the forums and the Internet in general for Xfce power management problems, but I haven't found anything quite like this.

Does anyone else have this problem?  If so, has anyone solved it?  I can't imagine I'm the only one, but I haven't seen anyone here talking about it.  Thanks for any insights! :)

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.842
You could try to add
Code: [Select]
HandleLidSwitch=ignore to /etc/systemd/logind.conf or play with the other options there that pertain to lid or suspend. Let us know how that goes.



  • Guest
Thanks devil!  That solved half of the problem: If I set HandleLidSwitch=ignore, I can close the lid without suspending.  I guess systemd has taken over handle button functions, and xfce4-power-manager just isn't systemd-aware yet, so it's changing settings in the wrong place?  I wonder if the Xfce developers are aware or even care, considering how controversial systemd has been.

Unfortunately, that still doesn't explain why suspending the machine sends it into a coma it can't wake from, and /etc/systemd/logind.conf doesn't seem to have any options relevant to this.  I can live with it like it is, but this thing gets really hot, so it would be nice to suspend/resume at will from time to time.  Since resume worked okay with 2012.2 and MATE, any idea what change may have broken this?

EDIT: I just read that some people have fixed suspend/resume problems by adding acpi_sleep=nonvs to GRUB_CMDLINE_LINUX in /etc/default/grub, but that's not working for me.  I've also tried different search terms and stumbled across a few other resources, like this one.  Running pm-suspend throws the machine into a coma too, so I'll start looking into the diagnostic steps here.
EDIT2: That looks like a dead-end, because the kernel wasn't compiled with CONFIG_PM_DEBUG set.
« Last Edit: 2014/05/05, 03:57:34 by SuspiciousLizard »


  • Guest
I had the same problems like SuspiciousLizard (thanks for reporting!) and the workaround by devil solved it perfectly as far as I can see.

"Unfortunately" I don't have the same issues with the suspend mode, it's working - just like before.