Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [solved] Installing to a "securely" erased HD?  (Read 3022 times)

jjjrrr3

  • Guest
[EN] [solved] Installing to a "securely" erased HD?
« on: 2014/05/13, 07:47:52 »
Someone ran dd if=/dev/zero of=/dev/sda to delete a HD securely. I ran the Siduction installer without error, but the machine still will not boot up.  I get nothing but a blinking cursor in text mode.

I assume that running dd on the disk instead of the partitions overwrote something important that the installer doesn't cover, but I have no idea what or how to repair it.  Any suggestions?
« Last Edit: 2014/05/14, 21:13:27 by jjjrrr3 »

Offline ReinerS

  • User
  • Posts: 1.075
Re: Installing to a "securely" erased HD?
« Reply #1 on: 2014/05/13, 08:14:33 »
I am not sure but it could be a missing Master Boot Record (MBR) or the partition table is missing or corrupt.

I would advice to use gparted manually from a live-dvd, create a partition table and then the partitions.
After that, I would repeat the installation.
Make sure that grub uses the Master Boot Record of the first (in case there are more than one harddisks installed) hdd and not the first sector of an partition (i.e. /dev/sda and not /dev/sda1).


Regards

Reiner

slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline musca

  • User
  • Posts: 725
  • sid, fly high!
Re: Installing to a "securely" erased HD?
« Reply #2 on: 2014/05/13, 09:43:24 »
Hello jjjrrr3,

wiping a disk is perfectly okay and you get the same clean state as if the disk just came from the factory. So any computer and any operatingsystem must be able to handle this situation.
Please remove any USB devices like cameras, printers, dvb receivers and any removable storage media and try again.

Now we need more details:
What kind of hardware do you use (vendor/model of system and grapic card)? What capacity does your disk provide?

Does your system not boot at all or does it boot and only hangs before starting the graphical user interface (gui)?
Do you see anything before the blinking cursor appears?


Using the siduction live media (DVD or usbstick) you can run siduction-irc or connect to irc://irc.oft.net/#siduction to be supported by the siduction community in an interactive chat.

greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.846
Re: Installing to a "securely" erased HD?
« Reply #3 on: 2014/05/13, 10:12:55 »
And also let us know what partitions you wrote with what tool onto the disk. The output of fdisk -l would be interesting, if you can get to init 1.


greetz
devil

jjjrrr3

  • Guest
Re: Installing to a "securely" erased HD?
« Reply #4 on: 2014/05/14, 14:40:21 »
Thanks for your replies, everyone.  It turns out that there was a partition error, but I got the same result when I re-partitioned and re-installed.
________________________________

Lenovo G510 laptop
Intel® HD Graphics 4600
1 Tbyte HDD
http://shop.lenovo.com/us/en/laptops/lenovo/g-series/g510/

The system boots up enough to display the Lenovo logo, but then it displays a blinking cursor in text mode and does not respond.
________________________________

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00056ed7

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048    35653631    17825792   82  Linux swap / Solaris
/dev/sda2        35653632    77596671    20971520   83  Linux
/dev/sda3        77596672  1953523711   937963520   83  Linux

Offline GoinEasy9

  • User
  • Posts: 564
Re: Installing to a "securely" erased HD?
« Reply #5 on: 2014/05/14, 19:09:05 »
Your laptop uses UEFI.  To use UEFI you need a dedicated partition formatted in fat32 that's at least 200MB for the ESP.  This partition will be your /boot/efi partition.  I wrote up a howto here:

http://forum.siduction.org/index.php?topic=4254.0

You can however reset the firmware to use Legacy BIOS.  This is from your laptops user manual:

There are two boot modes: UEFI and Legacy Support
. To change the boot mode, start the BIOS setup utility and set boot mode to UEFI or Legacy support on the boot menu.

I'm using UEFI on my ASUS mobo, and, prefer it to Legacy BIOS.  With it, one doesn't need to use grub when dual booting, since you choose the OS you want to boot, from the UEFI menu instead of grub.  If you only intend on using siduction as the sole OS on the laptop, mbr will work just fine, but, you have to have the firmware set to use legacy bios, which, could very well be your problem.

Edit:  This is the link to your laptops user manual.  Info on how to change the bios settings are on page 23. http://www.lenovo.com/shop/americas/content/user_guides/g410_g510_ug_en.pdf
« Last Edit: 2014/05/14, 19:16:54 by GoinEasy9 »
Linux Counter number 348347

jjjrrr3

  • Guest
Re: Installing to a "securely" erased HD?
« Reply #6 on: 2014/05/14, 21:12:09 »
The (lack of) /boot/efi seems to have been the problem.  Thank you!