seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/13, 09:04:44


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] No mount from KDE Desktop  (Read 1439 times)

0 Members and 1 Guest are viewing this topic.

Offline orinoco

  • User
  • Posts: 170
[solved] No mount from KDE Desktop
« on: 2014/05/22, 01:55:46 »
Hi,

since last d-u I can't mount external drives from "DeviceNotifier".

seit dem letzten d-u kann ich keine externen Laufwerke mit  der Geräteüberwachung mounten.

"Ein nicht genauer angegebener Fehler ist aufgetreten: Not authorized"

Any ideas/Lösungsvorschläge?
« Last Edit: 2014/05/26, 12:06:39 by musca »

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.377
Re: No mount from KDE Desktop
« Reply #1 on: 2014/05/22, 02:18:20 »
What file system?




Offline orinoco

  • User
  • Posts: 170
Re: No mount from KDE Desktop
« Reply #2 on: 2014/05/22, 02:34:34 »
The first message I received with a NTFS-Partition. With a FAT32 partition I get

Method FilesystemMount" with signature "sas" on interface "org.freedesktop.UDisks.Device" doesn't exist

Last but not least wth ext4 again "Not authrized"

I crosschecked with a new installed siduction on my notebook and everything seems to be fine. I love it...



Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: No mount from KDE Desktop
« Reply #3 on: 2014/05/22, 11:12:06 »
hello orinoco,

I suspect you may have old mountpoints in the /media directory that have wrong owner + group (root root).
I suggest you remove them.

Before i plug in my USB stick  my /media is empty:
Code: [Select]
musca@sidbox:~$ ls -l /media
total 0

After plugging in and selecting open with filemanager there is a mountpoint that belongs to the user musca:
Code: [Select]
musca@sidbox:~$ ls -l /media
total 8
drwx------ 7 musca musca 8192 Jan  1  1970 Spaceloop

After removing from "device notifier" /media is clean again:
Code: [Select]
musca@sidbox:~$ ls -l /media
total 0

Authorization is done via policykit-1, and the package usbmount is not needed (i removed it recently).
Please check theese packages:
Code: [Select]
chilan@sidbox:~$ dpkg -l | grep -e 'policykit-1' -e 'usbmount'
ii  policykit-1  0.105-5  amd64   framework for managing administrative policies and privileges
rc  usbmount     0.0.22     all   automatically mount and unmount USB mass storage devices

greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline orinoco

  • User
  • Posts: 170
Re: No mount from KDE Desktop
« Reply #4 on: 2014/05/26, 01:34:22 »
Hi,

this weekend I had more time to investigate the problem. The few weeks old siduction installation on my notebook helped me a lot. I compared journald output and came to the conclusion that on my notebook a process called usbmount seems to do the mounting. On my desktop I can't see this. I checked if a package like usbmount is installed. It wasn't. After installing and a reboot I thought I made it. My external device gets mounted. But my two external hdds gets mounted automatically. I looked into /media and found lots of usb mountpoints numbered form 0 to 7 and a symlink from usb to usb0. I removed them and rebooted the computer again. Now I seems that mounting devices from the notifier is working fine again.

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: No mount from KDE Desktop
« Reply #5 on: 2014/05/26, 12:04:58 »
Hello orinoco,

in my opinion usbmount is not needed and only removing the mountpoints solved it. But I guess we will never know ...
This thread will be marked as [solved] though.

greetings
musca
« Last Edit: 2014/05/27, 07:33:56 by musca »
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)