seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/06, 18:37:29


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: cups error after d-u  (Read 4148 times)

0 Members and 1 Guest are viewing this topic.

Offline rueX

  • User
  • Posts: 121
Re: cups error after d-u
« Reply #15 on: 2014/07/18, 14:41:20 »
dpkg -l |grep cups
iU  cups-client                                      1.7.4-1                           amd64        Common UNIX Printing System(tm) - client programs (SysV)
iU  cups-common                                      1.7.4-1                           all          Common UNIX Printing System(tm) - common files
iFR cups-daemon                                      1.7.3-3                           amd64        Common UNIX Printing System(tm) - daemon
ii  cups-filters                                     1.0.54-3+b1                       amd64        OpenPrinting CUPS Filters - Main Package
ii  cups-filters-core-drivers                        1.0.54-3+b1                       amd64        OpenPrinting CUPS Filters - PPD-less printing
ii  cups-ppdc                                        1.7.3-6                           amd64        Common UNIX Printing System(tm) - PPD manipulation utilities
ii  cups-server-common                               1.7.3-6                           all          Common UNIX Printing System(tm) - server common files
iU  libcups2:amd64                                   1.7.4-1                           amd64        Common UNIX Printing System(tm) - Core library
iU  libcupscgi1:amd64                                1.7.4-1                           amd64        Common UNIX Printing System(tm) - CGI library
ii  libcupsdriver1:amd64                             1.5.3-1                           amd64        Common UNIX Printing System(tm) - Driver library
ii  libcupsfilters1:amd64                            1.0.54-3+b1                       amd64        OpenPrinting CUPS Filters - Shared library
iU  libcupsimage2:amd64                              1.7.4-1                           amd64        Common UNIX Printing System(tm) - Raster image library
iU  libcupsmime1:amd64                               1.7.4-1                           amd64        Common UNIX Printing System(tm) - MIME library
iU  libcupsppdc1:amd64                               1.7.4-1                           amd64        Common UNIX Printing System(tm) - PPD manipulation library



/etc/systemd/system/printer.target.wants/cups.service
bash: /etc/systemd/system/printer.target.wants/cups.service: Datei oder Verzeichnis nicht gefunden


/lib/systemd/system/cups.service
bash: /lib/systemd/system/cups.service: Keine Berechtigung

root@siductionbox:/home/linux# /var/lib/systemd/deb-systemd-helper-enabled/cups.service.dsh-also
bash: /var/lib/systemd/deb-systemd-helper-enabled/cups.service.dsh-also: Keine Berechtigung

root@siductionbox:/home/linux# /var/lib/systemd/deb-systemd-helper-enabled/printer.target.wants/cups.service
bash: /var/lib/systemd/deb-systemd-helper-enabled/printer.target.wants/cups.service: Keine Berechtigung



(mmh, by the way : i have no printer - and i need no printer ...) and: ...lines with "no found=nicht gefunden" should i make a file ?



Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.779
    • g-com.eu
Re: cups error after d-u
« Reply #16 on: 2014/07/19, 01:08:20 »
can you purge cups completely?
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline rueX

  • User
  • Posts: 121
SOLVED: cups error after d-u
« Reply #17 on: 2014/07/24, 01:14:08 »
no, dear alf ...
nothing helped:
dpkg -P --force-all cups-daemon
apt-get purge cups-daemon
dpkg -i --force-all --no-triggers /var/cache/apt/archives/cups_daemon_1.7.3-6_amd64.deb

so i decided to check:

/var/lib/dpkg/status (alles mit cups-daemon)

und hab einfach alles mit cups-daemon dort herausgenommen :)

danach ein :
apt-get -f install

und jetzt läuft der d-u durch !!!

...bin mal gespannt, wo er hängen bleibt ...

« Last Edit: 2014/07/24, 02:22:16 by rueX »

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.779
    • g-com.eu
Re: cups error after d-u
« Reply #18 on: 2014/07/24, 01:42:33 »
nu ja - bei mir sähe das mit dem deinstallieren so aus:

Code: [Select]
agaida@razorbox:~$ sudo apt-get purge cups-d*
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Note, selecting 'cups-core-drivers' for regex 'cups-d*'
Note, selecting 'cups-server-common' for regex 'cups-d*'
Note, selecting 'cups-daemon' for regex 'cups-d*'
Note, selecting 'cups-client' for regex 'cups-d*'
Note, selecting 'cups-backend-bjnp' for regex 'cups-d*'
Note, selecting 'cups-pk-helper' for regex 'cups-d*'
Note, selecting 'cups-driver-gutenprint' for regex 'cups-d*'
Note, selecting 'cups-browsed' for regex 'cups-d*'
Note, selecting 'cups-pdf' for regex 'cups-d*'
Note, selecting 'cups-filters-core-drivers' for regex 'cups-d*'
Note, selecting 'cups-bsd' for regex 'cups-d*'
Note, selecting 'cups-filters' for regex 'cups-d*'
Note, selecting 'cups-tea4cups' for regex 'cups-d*'
Note, selecting 'cups-common' for regex 'cups-d*'
Note, selecting 'libnet-cups-perl' for regex 'cups-d*'
Note, selecting 'hal-cups-utils' for regex 'cups-d*'
Note, selecting 'cups-dbg' for regex 'cups-d*'
Note, selecting 'cups-ppdc' for regex 'cups-d*'
Paket »hal-cups-utils« ist nicht installiert, wird also auch nicht entfernt.
Paket »cups-dbg« ist nicht installiert, wird also auch nicht entfernt.
Paket »cups-backend-bjnp« ist nicht installiert, wird also auch nicht entfernt.
Paket »cups-driver-gutenprint« ist nicht installiert, wird also auch nicht entfernt.
Paket »libnet-cups-perl« ist nicht installiert, wird also auch nicht entfernt.
Paket »cups-tea4cups« ist nicht installiert, wird also auch nicht entfernt.
Die folgenden zusätzlichen Pakete werden installiert:
  foomatic-filters lprng
Vorgeschlagene Pakete:
  magicfilter lprng-doc
Empfohlene Pakete:
  colord
Die folgenden Pakete werden ENTFERNT:
  cups* cups-browsed* cups-bsd* cups-client* cups-common* cups-core-drivers* cups-daemon* cups-filters* cups-filters-core-drivers* cups-pdf* cups-pk-helper*
  cups-ppdc* cups-server-common* cupsddk* foomatic-db-engine*
Die folgenden NEUEN Pakete werden installiert:
  foomatic-filters lprng
0 aktualisiert, 2 neu installiert, 15 zu entfernen und 8 nicht aktualisiert.
0 aktualisiert, 2 neu installiert, 15 zu entfernen und 8 nicht aktualisiert.
Es müssen 1.404 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 7.404 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]
nöö - mach ich mal lieber nich

und das Zeug - oder Teile davon wieder ins System geworfen und alles wäre gut gewesen :)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline rueX

  • User
  • Posts: 121
SOLVED : cups error after d-u
« Reply #19 on: 2014/07/24, 02:21:35 »
sudo apt-get purge cups-d*
...
Entfernen von cups-daemon (1.7.3-3) ...
Failed to open /dev/tty: Kein passendes Gerät bzw. keine passende Adresse gefunden
Failed to issue method call: Unit cups.service not loaded.
invoke-rc.d: initscript cups, action "stop" failed.
dpkg: Fehler beim Bearbeiten des Paketes cups-daemon (--purge):
 Unterprozess installiertes pre-removal-Skript gab den Fehlerwert 5 zurück
Failed to issue method call: Unit cups.service failed to load: Invalid argument. See system logs and 'systemctl status cups.service' for details.
invoke-rc.d: initscript cups, action "start" failed.
dpkg: Fehler beim Aufräumen:
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 6 zurück
Fehler traten auf beim Bearbeiten von:
 cups-daemon


Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.779
    • g-com.eu
Re: cups error after d-u
« Reply #20 on: 2014/07/24, 09:26:37 »
apt-get -f install
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline reinob

  • User
  • Posts: 62
Re: cups error after d-u
« Reply #21 on: 2014/07/24, 10:32:21 »
Quote
Failed to issue method call: Unit cups.service not loaded.
invoke-rc.d: initscript cups, action "stop" failed.
dpkg: Warnung: Unterprozess altes pre-removal-Skript gab den Fehlerwert 5 zurück

Nothing you do with dpkg or apt-get will fix this problem. The problem is the pre-removal script is failing, something that should never happen.

Since dpkg cannot be forced to ignore the maintainer scripts, you have to either delete or fix the script yourself.
Edit /var/lib/dpkg/cups-daemon.prerm

somewhere it probably says "invoke-rc.d stop cups-daemon". This is what fails. Either cups is not actually running or systemd had broken yet-another-thing. Since *supposedly* the pre-removal script only wants to (unnecessarily) stop the service so that it can then be restarted, you can "safely" (but I cannot tell you for sure) delete the script (unless you know how to fix it), i.e.

# rm /var/lib/dpkg/cups-daemon.prerm

then do "dpkg -P cups-daemon" and hope for the best. Then apt-get -f install and then apt-get upgrade.

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.723
  • we are the priests ... of the temples of syrinx
Re: cups error after d-u
« Reply #22 on: 2014/07/24, 13:14:22 »
If systemd had broken yet-another-thing, many more users here would be posting about broken cups, I on the other hand am using my printer as we speak (work) , my wife has to use it all day, every day.

I du 3-4 times a day, unless on holiday, then, it's up to the cat, that lazy no good moth%^ &^@#!* !, so it ends up done when I get home ;)

I can't remember the last time I had an issue with cups, hmm, kanotix, knoppix days, many years ago


You would also be seeing this (failing) at #debian-systemd and I haven't unless I missed something
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear