seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/09, 04:03:55


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Solved: Times are rough tonight  (Read 6592 times)

0 Members and 1 Guest are viewing this topic.

Offline seasons

  • User
  • Posts: 239

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: Solved: Times are rough tonight
« Reply #16 on: 2014/07/15, 21:39:19 »
Code: [Select]
cp -p $(find /«PKGBUILDDIR»/build -mindepth 3 -name '*.sum' ! -name libgo.sum) \
debian/g++-4.9/usr/share/doc/gcc-4.9-base/test-summaries/
cp: will not overwrite just-created 'debian/g++-4.9/usr/share/doc/gcc-4.9-base/test-summaries/gfortran.sum' with '/«PKGBUILDDIR»/build/gcc/testsuite/gfortran2/gfortran.sum'
cp: will not overwrite just-created 'debian/g++-4.9/usr/share/doc/gcc-4.9-base/test-summaries/gfortran.sum' with '/«PKGBUILDDIR»/build/gcc/testsuite/gfortran5/gfortran.sum'
cp: will not overwrite just-created 'debian/g++-4.9/usr/share/doc/gcc-4.9-base/test-summaries/gfortran.sum' with '/«PKGBUILDDIR»/build/gcc/testsuite/gfortran/gfortran.sum'

so let them fix this mess and it will be built - /me don't change makefiles in other projects
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline terroreek

  • User
  • Posts: 169
Re: Solved: Times are rough tonight
« Reply #17 on: 2014/07/15, 22:11:46 »
This is what I am seeing today.  I know I can let go of libgjs0c and libmutter0b as they are being replaced, the dev packages I am not so worried about but, I think the siduction-settings-gnome-december package should not be uninstalled. 

Code: [Select]
The following packages will be REMOVED:
  libgjs0c libglib2.0-dev libmutter0b libpcre3-dev
  siduction-settings-gnome-december
The following NEW packages will be installed:
  gir1.2-atspi-2.0 grub-theme-siduction-december libgjs0e libgnome-bluetooth13
  libgnome-desktop-3-10 libmozjs-24-0 libmutter0d libupower-glib2
The following packages have been kept back:
  cpp-4.9 g++-4.9 gcc-4.9 gcc-4.9-base libasan1 libatomic1 libcilkrts5
  libgcc-4.9-dev libgcc1 libgfortran3 libgomp1 libitm1 liblsan0 libpcre3
  libquadmath0 libstdc++-4.9-dev libstdc++6 libtsan0 libubsan0
The following packages will be upgraded:
  accountsservice acpid apt apt-utils bluetooth bluez cheese cheese-common
  chrome-remote-desktop cups cups-bsd cups-client cups-common
  cups-core-drivers cups-daemon cups-ppdc cups-server-common e2fslibs
  e2fsprogs eog extlinux four-in-a-row gambas3-gb-form gambas3-gb-gtk
  gambas3-gb-gui gambas3-gb-image gambas3-gb-qt4 gambas3-gb-settings
  gambas3-runtime gdm3 gengetopt gimp gimp-data gir1.2-accountsservice-1.0
  gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-gdesktopenums-3.0 gir1.2-gdm3
  gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-json-1.0
  gir1.2-mutter-3.0 gir1.2-nautilus-3.0 gir1.2-upowerglib-1.0 gjs
  gnome-bluetooth gnome-control-center gnome-control-center-data
  gnome-desktop3-data gnome-power-manager gnome-session gnome-session-bin
  gnome-session-common gnome-settings-daemon gnome-shell gnome-shell-common
  gnome-shell-extensions gsettings-desktop-schemas gstreamer1.0-clutter
  hexchat hexchat-common iperf libaccountsservice0 libapt-inst1.5
  libapt-pkg4.12 libbluetooth3 libc-bin libc-dev-bin libc6 libc6:i386
  libc6-dev libcap2 libcap2:i386 libcap2-bin libcheese-gtk23 libcheese7
  libclutter-gst-2.0-0 libcogl-pango20 libcogl-path20 libcogl20 libcomerr2
  libcomerr2:i386 libcups2 libcups2:i386 libcupscgi1 libcupsimage2
  libcupsmime1 libcupsppdc1 libdebian-installer-extra4 libdebian-installer4
  libdlrestrictions1 libfs6 libgdm1 libgimp2.0 libgl1-nvidia-glx
  libgnutls-deb0-28 libgnutls-deb0-28:i386 libgnutls-openssl27
  libgssapi-krb5-2 libgssapi-krb5-2:i386 libgssdp-1.0-3 libgtkglext1
  libgweather-3-6 libgweather-common libice6 libice6:i386 libimport-into-perl
  libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libjson-glib-1.0-0
  libjson-glib-1.0-common libk5crypto3 libk5crypto3:i386 libkrb5-3
  libkrb5-3:i386 libkrb5support0 libkrb5support0:i386
  liblwp-protocol-https-perl liblzo2-2 libmono-cairo4.0-cil
  libmono-corlib4.0-cil libmono-corlib4.5-cil libmono-data-tds4.0-cil
  libmono-posix4.0-cil libmono-security4.0-cil libmono-sharpzip4.84-cil
  libmono-sqlite4.0-cil libmono-system-configuration4.0-cil
  libmono-system-core4.0-cil libmono-system-data4.0-cil
  libmono-system-drawing4.0-cil libmono-system-enterpriseservices4.0-cil
  libmono-system-runtime-serialization-formatters-soap4.0-cil
  libmono-system-runtime4.0-cil libmono-system-security4.0-cil
  libmono-system-transactions4.0-cil
  libmono-system-web-applicationservices4.0-cil
  libmono-system-web-services4.0-cil libmono-system-web4.0-cil
  libmono-system-xml-linq4.0-cil libmono-system-xml4.0-cil
  libmono-system4.0-cil libmono-web4.0-cil libmpc3 libmtp-common
  libmtp-runtime libmtp9 libnautilus-extension1a libnss3 libnvidia-ml1
  libpciaccess0 libpcrecpp0 libperl5.18 libpixman-1-0 libpixman-1-0:i386
  libplank-common libplank0 libprocps3 libpython-stdlib libquvi-scripts
  librlog5 librtmp1 libsasl2-2 libsasl2-modules-db libsm6 libsm6:i386 libss2
  libsub-name-perl libtracker-control-1.0-0 libtracker-sparql-1.0-0
  liburi-perl libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwebkitgtk-3.0-0
  libwebkitgtk-3.0-common libx264-142 libxaw7 libxdamage1 libxdamage1:i386
  libxfixes3 libxfixes3:i386 libxfont1 libxft2 libxft2:i386 libxpm4 libxvmc1
  linux-libc-dev locales manpages-de mono-4.0-gac mono-gac mono-runtime
  mono-runtime-common mono-runtime-sgen multiarch-support mutter-common nano
  nautilus nautilus-data ntfs-config nvidia-alternative nvidia-driver
  nvidia-kernel-dkms nvidia-vdpau-driver openjdk-7-jre openjdk-7-jre-headless
  perl perl-base perl-doc perl-modules plank pm-utils procps python
  python-minimal rsync siduction-art-gnome-december
  siduction-art-wallpaper-december strace syslinux syslinux-common tracker
  tracker-gui upower virtualbox virtualbox-dkms virtualbox-qt x11-apps
  x11-utils x11-xserver-utils xauth xfonts-encodings xfonts-utils
  xserver-xorg-input-synaptics xserver-xorg-video-nvidia

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: Solved: Times are rough tonight
« Reply #18 on: 2014/07/15, 22:13:20 »
aptitude why-not siduction-settings-gnome-december
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline seasons

  • User
  • Posts: 239
Re: Solved: Times are rough tonight
« Reply #19 on: 2014/07/15, 22:32:33 »
siduction-settings-gnome depends on libglib2.0-dev which is being removed.

The solution is simply to wait for gcc team to fix the i386 build (not to hack around and "let packages go"). I know that's tough for a lot of sid users, but the system will not explode if it's not dist-upgrade'd on a daily basis.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: Solved: Times are rough tonight
« Reply #20 on: 2014/07/16, 01:31:27 »
hopefully fixed gcc - build is ok, but the tests are fucking slow (approx 2-3 h on a decent machine). will see if it work tomorrow and prepare a patch for debian.

And i will have a look at the settings package - imho it should not depend on a dev package on runtime.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline terroreek

  • User
  • Posts: 169
Re: Solved: Times are rough tonight
« Reply #21 on: 2014/07/16, 15:19:05 »
Hmm ... this is strange so my work laptop is not complaining about the linux-headers-siduction-amd64 package but below is the DU from my desktop.  It wants to remove it. 

the output from aptitude why-not linux-headers-siduction-amd64 is this;

Code: [Select]
Unable to find a reason to remove linux-headers-siduction-amd64.

the full d-u output

Code: [Select]
The following packages will be REMOVED:
  libgjs0c libmetacity-private0a libmutter0b
  linux-headers-3.15-0.towo.3-siduction-amd64
  linux-headers-3.15-1.towo-siduction-amd64
  linux-headers-3.15-2.towo-siduction-amd64
  linux-headers-3.15-3.towo.2-siduction-amd64
  linux-headers-3.15-4.towo-siduction-amd64
  linux-headers-3.15-5.towo-siduction-amd64 linux-headers-siduction-amd64
The following NEW packages will be installed:
  gir1.2-atspi-2.0 hoichess libboost-filesystem1.55.0 libgjs0e
  libgnome-bluetooth13 libgnome-desktop-3-10 libmetacity-private1
  libmozjs-24-0 libmutter0d libswresample0:i386 libupower-glib2
  linux-image-3.15-5.towo.2-siduction-amd64
The following packages have been kept back:
  cpp-4.9 g++-4.9 gcc-4.9 gcc-4.9-base libasan1 libatomic1 libcilkrts5
  libgcc-4.9-dev libgcc1 libgfortran3 libgomp1 libitm1 liblsan0 libpcre3
  libpcre3-dev libpcrecpp0 libquadmath0 libstdc++-4.9-dev libstdc++6 libtsan0
  libubsan0
The following packages will be upgraded:
  bluetooth bluez cheese-common chrome-remote-desktop comerr-dev cups cups-bsd
  cups-client cups-common cups-core-drivers cups-daemon cups-ppdc
  cups-server-common e2fslibs e2fsprogs encfs eog evolution five-or-more gdm3
  gimp-data gir1.2-gdesktopenums-3.0 gir1.2-gdm3 gir1.2-gnomebluetooth-1.0
  gir1.2-gnomedesktop-3.0 gir1.2-json-1.0 gir1.2-mutter-3.0
  gir1.2-nautilus-3.0 gir1.2-nmgtk-1.0 gir1.2-upowerglib-1.0 gjs
  gnome-bluetooth gnome-chess gnome-control-center gnome-control-center-data
  gnome-desktop3-data gnome-power-manager gnome-screensaver gnome-session
  gnome-session-bin gnome-session-common gnome-settings-daemon gnome-shell
  gnome-shell-common gnome-shell-extensions gnome-user-guide gnome-user-share
  gsettings-desktop-schemas inkscape krb5-locales krb5-multidev libavcodec55
  libavcodec55:i386 libavfilter4 libavformat55 libavresample1
  libavresample1:i386 libavutil52 libavutil52:i386 libbasicusageenvironment0
  libbluetooth-dev libbluetooth3 libc-bin libc-dev-bin libc6 libc6:i386
  libc6-dev libc6-i386 libcap2 libcap2:i386 libcap2-bin libcheese-gtk23
  libcheese7 libcomerr2 libcomerr2:i386 libcups2 libcups2:i386 libcupscgi1
  libcupsimage2 libcupsmime1 libcupsppdc1 libdebian-installer-extra4
  libdebian-installer4 libdlrestrictions1 libevolution libfs6 libgdm1
  libgimp2.0 libgroupsock1 libgssapi-krb5-2 libgssapi-krb5-2:i386
  libgssdp-1.0-3 libgssrpc4 libgudev-1.0-0 libice-dev libice6 libice6:i386
  libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libjson-glib-1.0-0
  libjson-glib-1.0-common libk5crypto3 libk5crypto3:i386 libkadm5clnt-mit9
  libkadm5srv-mit9 libkdb5-7 libkrb5-3 libkrb5-3:i386 libkrb5-dev
  libkrb5support0 libkrb5support0:i386 liblivemedia33
  liblwp-protocol-https-perl liblzo2-2 liblzo2-dev libnautilus-extension1a
  libnm-gtk-common libnm-gtk0 libnss3 libopenal-data libopenal1
  libopenal1:i386 libpam-systemd libpciaccess0 libpciaccess0:i386 libperl5.18
  libpixman-1-0 libpixman-1-0:i386 libpostproc52 libprocps3 libsm-dev libsm6
  libsm6:i386 libss2 libsub-name-perl libswresample0 libswscale2
  libsystemd-daemon0 libsystemd-id128-0 libsystemd-id128-0:i386
  libsystemd-journal0 libsystemd-journal0:i386 libsystemd-login0
  libtracker-control-1.0-0 libtracker-sparql-1.0-0 libudev-dev libudev1
  libudev1:i386 libusageenvironment2 libvlc5 libvlccore7 libwebkitgtk-1.0-0
  libwebkitgtk-1.0-common libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libxaw7
  libxdamage-dev libxdamage1 libxdamage1:i386 libxfixes-dev libxfixes3
  libxfixes3:i386 libxfont1 libxft2 libxft2:i386 libxpm4 libxpm4:i386 libxvmc1
  linux-image-siduction-amd64 linux-libc-dev locales manpages-de metacity
  metacity-common multiarch-support mutter-common nano nautilus nautilus-data
  network-manager-gnome ntfs-config perl perl-base perl-modules procps rpcbind
  strace systemd systemd-sysv tracker tracker-gui transmission-gtk udev upower
  virtualbox virtualbox-dkms virtualbox-qt vlc vlc-data vlc-nox x11-apps
  x11-utils x11-xserver-utils x11proto-input-dev xauth xbmc xbmc-bin xbmc-data
  xbmc-skin-confluence xfonts-encodings xfonts-utils
  xserver-xorg-input-synaptics

I am going to leave it alone today and see if the d-u changes tomorrow. 

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: Solved: Times are rough tonight
« Reply #22 on: 2014/07/16, 17:08:53 »
it will not change and this will last for one week or so - and i'm not longer willing to fix the debian compiler crap - just wait and eventually Mr. Klose make his homeworks and solve the mess he introduced. Not my business anymore.

Die Multiarch-Kacke wird noch länger am Dampfen bleiben - und zwar genau so lange, bis Herr Klose seinen selbst angerührten Mist in Ordnung bringt. Ich hab da keinerlei Böcke mehr drauf. Ich habe bessere Sachen mit meiner Restlebenszeit anzufangen.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline seasons

  • User
  • Posts: 239
Re: Solved: Times are rough tonight
« Reply #23 on: 2014/07/16, 17:11:22 »
Hmm ... this is strange so my work laptop is not complaining about the linux-headers-siduction-amd64 package but below is the DU from my desktop.  It wants to remove it.

Is your laptop running 64-bit siduction with multiarch (32-bit packages) enabled? If not, then it's not strange that the laptop doesn't have the issue.

Offline terroreek

  • User
  • Posts: 169
Re: Solved: Times are rough tonight
« Reply #24 on: 2014/07/16, 20:20:04 »
Hmm ... this is strange so my work laptop is not complaining about the linux-headers-siduction-amd64 package but below is the DU from my desktop.  It wants to remove it.

Is your laptop running 64-bit siduction with multiarch (32-bit packages) enabled? If not, then it's not strange that the laptop doesn't have the issue.

I thought that too, when I first noticed but I enabled multi-arch because I needed it to install the VMWare view client on my laptop.  If I cat /var/lib/dpkg/arch I have amd64 and i386, listed on both the desktop and laptop.  Weird right ... meuh I'm just going to hold off for now. 

Offline OppaErich

  • OLE
  • User
  • Posts: 375
Re: Solved: Times are rough tonight
« Reply #25 on: 2014/07/17, 18:33:18 »

Code: [Select]
The following packages will be REMOVED:
  gdm3 gnome gnome-bluetooth gnome-core gnome-session gnome-shell gnome-shell-extensions gnome-user-share libmetacity-private0a linux-headers-3.15-0.towo-siduction-amd64 linux-headers-3.15-0.towo.2-siduction-amd64
  linux-headers-3.15-1.towo-siduction-amd64 linux-headers-3.15-1.towo.2-siduction-amd64 linux-headers-3.15-3.towo.2-siduction-amd64 linux-headers-3.15-5.towo-siduction-amd64 linux-headers-siduction-amd64
I keep waiting.

Offline seasons

  • User
  • Posts: 239
Re: Solved: Times are rough tonight
« Reply #26 on: 2014/07/18, 02:10:21 »
So gcc 4.9.1 was fixed and has propagated through my mirror, but still, issues remained. It looks like the latest problem is mismatching versions of libpcre3 and libpcre:i386
https://buildd.debian.org/status/package.php?p=pcre3&suite=unstable

The libpcre3:i386 package is needed for 32-bit wine, so that may explain why only certain multiarch users are seeing the issue(s).

Should I file a bug, or would a maintainer automatically know about a build error through automatic notification?

Offline terroreek

  • User
  • Posts: 169
Re: Solved: Times are rough tonight
« Reply #27 on: 2014/07/18, 07:32:25 »
Desktop is good on my side.  :)   Laptop still has an issue with the siduction-settings-gnome-december package

Offline seasons

  • User
  • Posts: 239
Re: Solved: Times are rough tonight
« Reply #28 on: 2014/07/18, 14:19:59 »
Laptop still has an issue with the siduction-settings-gnome-december package

That's caused by the gcc bug I linked to. It should resolve itself very soon depending on what mirror you're using (I use U.S. mirror and it cleared up for me).

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: Solved: Times are rough tonight
« Reply #29 on: 2014/07/18, 20:51:55 »
siduction-settings-gnome depends on libglib2.0-dev which is being removed.
http://bugs.siduction.org/issues/1623

Thanks seasons
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)