seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/15, 18:47:41


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Time problem after update (Solved)  (Read 2811 times)

0 Members and 1 Guest are viewing this topic.

Offline GoinEasy9

  • User
  • Posts: 461
Time problem after update (Solved)
« on: 2014/07/24, 05:50:24 »
Ever since tonight’s update, every time I boot up, the desktop clock is 4 hours ahead.  I corrected the time, then, rebooted, and, it was again 4 hours ahead.  This time, I didn't change the time, and rebooted, checked the time on the motherboard, and it was correct.  Then, continued to boot into siduction, and, again, it was 4 hours ahead.  Corrected time, and rebooted, and, again it was 4 hours ahead.

So, I guess it's not going away.  Any ideas?  Time is set to local, New York time.  The ntp service is disabled.  This happens occasionally when locales is updated, but, it always goes away after I reset the time.

BTW - the first time I corrected the time, my HD went into overdrive, and, I had to kill gvfsd-metadata.  I saw it running on after running top, and, killing it put the brakes on the hard disk. 

Anyone else seeing the date problem? 

Edit: journalctl shows this:
Code: [Select]
Jul 23 23:55:11 siduction64kdefx kbd[700]: Setting console screen modes.
Jul 23 23:54:56 siduction64kdefx ntpdate[900]: Can't find host 0.debian.pool.ntp.org: Name or service not known (-2)
Jul 23 23:54:56 siduction64kdefx ntpdate[900]: Can't find host 1.debian.pool.ntp.org: Name or service not known (-2)
Jul 23 23:54:56 siduction64kdefx ntpdate[900]: Can't find host 2.debian.pool.ntp.org: Name or service not known (-2)
Jul 23 23:54:56 siduction64kdefx ntpdate[900]: Can't find host 3.debian.pool.ntp.org: Name or service not known (-2)
Jul 23 23:54:56 siduction64kdefx ntpdate[900]: no servers can be used, exiting
Jul 23 23:54:57 siduction64kdefx rpc.statd[917]: ^[[1;39mVersion 1.2.8 starting

Then a little farther down:
Code: [Select]
Jul 23 23:55:35 siduction64kdefx dbus[1018]: ^[[1;39m[system] Successfully activated service 'org.freedesktop.UDisks'
Jul 23 23:55:36 siduction64kdefx dbus[1018]: ^[[1;39m[system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Jul 23 23:55:36 siduction64kdefx org.kde.powerdevil.backlighthelper[3503]: ^[[1;39mQDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.
Jul 23 23:55:36 siduction64kdefx dbus[1018]: ^[[1;39m[system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Jul 24 03:55:47 siduction64kdefx ntpdate[3258]: ^[[1;39mstep time server 209.114.111.1 offset 14407.393619 sec
Jul 24 03:55:47 siduction64kdefx systemd[3319]: Time has been changed
Jul 24 03:55:47 siduction64kdefx systemd[1245]: Time has been changed
Jul 24 03:55:47 siduction64kdefx systemd[1]: Time has been changed
Jul 24 03:55:50 siduction64kdefx dbus[1018]: ^[[1;39m[system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service'
Jul 24 03:55:50 siduction64kdefx systemd[1]: Starting Bluetooth service...

Seems like ntpdate is the cause.  It was updated tonight.  I'll look at it further when I get home from work tomorrow night.  I'm hoping it's because debian.pool.ntp.org is down, although, why is it looking since I have ntp service disabled?
« Last Edit: 2014/07/25, 03:45:49 by GoinEasy9 »
Linux Counter number 348347

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Time problem after update
« Reply #1 on: 2014/07/24, 09:56:56 »
Hello Goineays9,

you safely can remove ntpdate. See issue #1631 in the siduction bugtracker.

timely greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline GoinEasy9

  • User
  • Posts: 461
Re: Time problem after update
« Reply #2 on: 2014/07/24, 18:12:04 »
Thanks Musca, that makes things easier.  We'll see tonight.

Edit:  That did it, purging ntpdate fixed the problem.

Thanks again.
« Last Edit: 2014/07/25, 03:45:27 by GoinEasy9 »
Linux Counter number 348347

Offline DeepDayze

  • User
  • Posts: 410
Re: Time problem after update
« Reply #3 on: 2014/07/27, 23:16:44 »
Thanks Musca, that makes things easier.  We'll see tonight.

Edit:  That did it, purging ntpdate fixed the problem.

Thanks again.

Same here...dumping ntpdate worked for me too