seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2021/01/26, 23:20:46


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: (solved) unmet dependencies for kate and kate-part  (Read 2953 times)

0 Members and 1 Guest are viewing this topic.

Offline Jörg

  • User
  • Posts: 95
After DU of this morning I get:

Code: [Select]
Reading package lists... Done                                                                                                                   
[09:02:45] root@thinkpad-s540:/home/jorg# apt-get dist-upgrade -dV
Reading package lists... Done                                                                                                                   
Building dependency tree                                                                                                                       
Reading state information... Done                                                                                                               
You might want to run 'apt-get -f install' to correct these.                                                                                   
The following packages have unmet dependencies:                                                                                                 
 kate : Depends: katepart (= 4:4.14.1-90r2) but 4:4.14.2-1 is installed                                                                         
        Depends: libkateinterfaces4 (= 4:4.14.1-90r2) but 4:4.14.2-1 is installed                                                               
 katepart : Depends: kate-data (>= 4:4.14.2-1) but 4:4.14.1-90r2 is installed                                                                   
E: Unmet dependencies. Try using -f.                                                                                                           
[09:02:54] root@thinkpad-s540:/home/jorg# apt-get -f install                                                                                   
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  kate kate-data
The following packages will be upgraded:
  kate kate-data
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
113 not fully installed or removed.
Need to get 0 B/2,095 kB of archives.
After this operation, 151 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Reading changelogs... Done
(Reading database ... 195102 files and directories currently installed.)
Preparing to unpack .../kate-data_4%3a4.14.2-1_all.deb ...
Unpacking kate-data (4:4.14.2-1) over (4:4.14.1-90r2) ...
dpkg: error processing archive /var/cache/apt/archives/kate-data_4%3a4.14.2-1_all.deb (--unpack):
 trying to overwrite '/usr/share/kde4/apps/kate/plugins/project/ui.rc', which is also in package kate 4:4.14.1-90r2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../kate_4%3a4.14.2-1_amd64.deb ...
Unpacking kate (4:4.14.2-1) over (4:4.14.1-90r2) ...
dpkg: error processing archive /var/cache/apt/archives/kate_4%3a4.14.2-1_amd64.deb (--unpack):
 trying to overwrite '/usr/share/kde4/services/katereplicodeplugin.desktop', which is also in package kate-data 4:4.14.1-90r2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/kate-data_4%3a4.14.2-1_all.deb
 /var/cache/apt/archives/kate_4%3a4.14.2-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


I tried to use -f, but without result. Any help will be appreciated.

Greetings,
Jörg
« Last Edit: 2014/10/22, 10:43:03 by piper »

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.481
Re: unmet dependencies for kate and kate-part
« Reply #1 on: 2014/10/21, 13:20:57 »
The debian-kde-maintainer made a mistake, should be fixed with next mirror sync.


greetz
devil

Offline vayu

  • User
  • Posts: 222
Re: unmet dependencies for kate and kate-part
« Reply #2 on: 2014/10/21, 17:32:54 »
Is there any kind of workaround we can do?

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.070
    • Land of the Buckeye
Re: unmet dependencies for kate and kate-part
« Reply #3 on: 2014/10/21, 20:19:23 »
This issue has been fixed -- I have run a successful d-u on two siduction/KDE systems in the past hour here in U.S. Eastern time zone.  It does take an "apt-get -f install" to get past the the error, and then run d-u again to get the rest of the updates.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline vayu

  • User
  • Posts: 222
Re: unmet dependencies for kate and kate-part
« Reply #4 on: 2014/10/22, 00:30:35 »
This issue has been fixed -- I have run a successful d-u on two siduction/KDE systems in the past hour here in U.S. Eastern time zone.  It does take an "apt-get -f install" to get past the the error, and then run d-u again to get the rest of the updates.
Thanks, now I can use apt again, which I need to figure out my nvidia problem.

Offline GoinEasy9

  • User
  • Posts: 477
Re: unmet dependencies for kate and kate-part
« Reply #5 on: 2014/10/22, 04:01:48 »
Linux Counter number 348347

Offline vayu

  • User
  • Posts: 222
Re: unmet dependencies for kate and kate-part
« Reply #6 on: 2014/10/22, 04:08:51 »
Someone say Nvidia problem? http://forum.siduction.org/index.php?topic=5076.0
Thanks, yes, that thread solved the problem.

Offline Jörg

  • User
  • Posts: 95
Re: unmet dependencies for kate and kate-part
« Reply #7 on: 2014/10/22, 09:04:22 »
Thanks devil and dibl for your hints!  After this morning's DU the problem with kate is solved.

Greetings,
Jörg