seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/10/25, 23:48:01


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: vgaarb: this pci device is not a vga device  (Read 7518 times)

0 Members and 1 Guest are viewing this topic.

Offline Mte90

  • User
  • Posts: 149
  • KDE & Debian lover
    • http://www.mte90.net
vgaarb: this pci device is not a vga device
« on: 2014/10/28, 16:08:49 »
Bug reference: https://github.com/Bumblebee-Project/Bumblebee/issues/159

Little explanation.
On notebook with dual card the intel integrated in the motherboard is detected as a Vga card, the nvidia as 3d controller.

With this little patch the bug is fixed: http://pastebin.com/wpmFi38k
There is a recent discussion on the kernel mailing list about this: https://www.mail-archive.com/linux-kernel@vger.kernel.org/msg730468.html
Ticket reference: https://bugzilla.kernel.org/show_bug.cgi?id=63641
Ubuntu ticket reference: https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1381175

I think that this patch will be fix all of my problem with my laptop and the nvidia card.
Is possible add this very little patch to the kernel?
« Last Edit: 2014/10/28, 16:13:54 by Mte90 »

Offline Mte90

  • User
  • Posts: 149
  • KDE & Debian lover
    • http://www.mte90.net
Re: vgaarb: this pci device is not a vga device
« Reply #1 on: 2014/10/29, 20:07:42 »
The patch is working now bumblebee/optirun work without problems!

Thank you very much!!!!!

now i need to config the system of use the nvidia card and not the intel  :P