seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/06, 18:41:03


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: libexpat1 kaputt?  (Read 4396 times)

0 Members and 1 Guest are viewing this topic.

Offline ayla

  • User
  • Posts: 1.697
libexpat1 kaputt?
« on: 2014/11/29, 11:01:02 »
Quote
Start-Date: 2014-11-29  10:27:16
Commandline: apt-get dist-upgrade
Install: linux-image-3.17-4.towo-siduction-amd64:amd64 (3.17-12), libmusicbrainz5-1:amd64 (5.1.0-2, automatic), linux-headers-3.17-4.towo-siduction-amd64:amd64 (3.17-12)
Upgrade: initscripts:amd64 (2.88dsf-57, 2.88dsf-58), libdebian-installer-extra4:amd64 (0.97, 0.98), libio-socket-ssl-perl:amd64 (2.002-1, 2.002-2), libgpgme++2:amd64 (4.14.2-1, 4.14.2-2), libtaskmanager4abi4:amd64 (4.11.13-1, 4.11.13-2.1), libkblog4:amd64 (4.14.2-1, 4.14.2-2), libchm1:amd64 (0.40a-3, 0.40a-3+b1), libstdc++-4.8-dev:amd64 (4.8.3-13, 4.8.3-14), libkimap4:amd64 (4.14.2-1, 4.14.2-2), whiptail:amd64 (0.52.17-1, 0.52.17-1+b1), libreoffice-base-core:amd64 (4.3.3~rc2-1, 4.3.3-1), libreoffice:amd64 (4.3.3~rc2-1, 4.3.3-1), hplip:amd64 (3.14.6-1+b1, 3.14.6-1+b2), sysvinit:amd64 (2.88dsf-57, 2.88dsf-58), libfontembed1:amd64 (1.0.61-2, 1.0.61-4), libefivar0:amd64 (0.15-1, 0.15-2), libasan0:amd64 (4.8.3-13, 4.8.3-14), libasan1:amd64 (4.9.1-19, 4.9.2-4), libsystemd-login0:amd64 (215-5+b1, 215-7), debianutils:amd64 (4.4, 4.4+b1), libgnutls-openssl27:amd64 (3.3.8-3, 3.3.8-5), libxcb-dri2-0:amd64 (1.10-3, 1.10-3+b1), libquadmath0:amd64 (4.9.1-19, 4.9.2-4), liblcms2-2:amd64 (2.6-3+b2, 2.6-3+b3), libakonadi-kcal4:amd64 (4.14.2-1, 4.14.2-2), gcc-4.8-base:amd64 (4.8.3-13, 4.8.3-14), grub-efi-amd64-bin:amd64 (2.02~beta2-15, 2.02~beta2-16), libwmf0.2-7:amd64 (0.2.8.4-10.3+b1, 0.2.8.4-10.3+b2), ark:amd64 (4.14.2-1, 4.14.2-2), libvorbisfile3:amd64 (1.3.4-1, 1.3.4-2), libpangoxft-1.0-0:amd64 (1.36.8-2, 1.36.8-3), libpython2.7-stdlib:amd64 (2.7.8-11, 2.7.9~rc1-1), libxfixes3:amd64 (5.0.1-2, 5.0.1-2+b1), multiarch-support:amd64 (2.19-12, 2.19-13), cups-core-drivers:amd64 (1.7.5-7, 1.7.5-9), perl:amd64 (5.20.1-2, 5.20.1-3),

 ...............

 libitm1:amd64 (4.9.1-19, 4.9.2-4), locales:amd64 (2.19-12, 2.19-13), net-tools:amd64 (1.60-26, 1.60-26+b1), libxrandr2:amd64 (1.4.2-1, 1.4.2-1+b1), libpython2.7-minimal:amd64 (2.7.8-11, 2.7.9~rc1-1), libreoffice-math:amd64 (4.3.3~rc2-1, 4.3.3-1), init:amd64 (1.21, 1.22), libvorbisenc2:amd64 (1.3.4-1, 1.3.4-2), libvncclient0:amd64 (0.9.9+dfsg-6+b2, 0.9.9+dfsg-6.1), vlc-plugin-pulse:amd64 (2.2.0~pre4-2, 2.2.0~rc2-1), libkrb5support0:amd64 (1.12.1+dfsg-11, 1.12.1+dfsg-15), libk5crypto3:amd64 (1.12.1+dfsg-11, 1.12.1+dfsg-15), libfs6:amd64 (1.0.6-1, 1.0.6-1+b1), libxxf86dga1:amd64 (1.1.4-1, 1.1.4-1+b1), libc6-dev:amd64 (2.19-12, 2.19-13), vim-runtime:amd64 (7.4.488-1, 7.4.488-2), libreoffice-calc:amd64 (4.3.3~rc2-1, 4.3.3-1), gcc-4.9-base:amd64 (4.9.1-19, 4.9.2-4), kwrite:amd64 (4.14.2-2, 4.14.2-siduction1.1), libcurl3-gnutls:amd64 (7.38.0-2, 7.38.0-3), libxvmc1:amd64 (1.0.8-2, 1.0.8-2+b1), tar:amd64 (1.27.1-2, 1.27.1-2+b1), libcupsfilters1:amd64 (1.0.61-2, 1.0.61-4), libtbb2:amd64 (4.2~20140122-3, 4.2~20140122-4)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2014-11-29  10:28:49

Start-Date: 2014-11-29  10:30:05
Commandline: apt-get -f install
Upgrade: libpam-systemd:amd64 (215-5+b1, 215-7)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2014-11-29  10:30:05

Start-Date: 2014-11-29  10:33:47
Commandline: apt-get -f install
Upgrade: libpam-systemd:amd64 (215-5+b1, 215-7)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2014-11-29  10:33:47
Quote
apt-get -f install                                                               
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libpam-systemd
Die folgenden Pakete werden aktualisiert (Upgrade):
  libpam-systemd
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 386 nicht aktualisiert.
27 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 119 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 47,1 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]
Lese Changelogs... Fertig
dpkg: Abhängigkeitsprobleme verhindern Triggerverarbeitung für dbus:
 dbus hängt ab von libexpat1 (>= 2.0.1); aber:
  Paket libexpat1:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes dbus (--configure):
 Abhängigkeitsprobleme - Trigger bleiben unverarbeitet
dpkg: Abhängigkeitsprobleme verhindern Triggerverarbeitung für dbus:
 dbus hängt ab von libexpat1 (>= 2.0.1); aber:
  Paket libexpat1:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes dbus (--configure):
 Abhängigkeitsprobleme - Trigger bleiben unverarbeitet
dpkg: Abhängigkeitsprobleme verhindern Triggerverarbeitung für dbus:
 dbus hängt ab von libexpat1 (>= 2.0.1); aber:
  Paket libexpat1:amd64 ist noch nicht konfiguriert.
............
Quote
dpkg-reconfigure libexpat1
/usr/sbin/dpkg-reconfigure: libexpat1 ist kaputt oder nicht komplett installiert

I do not know whether this is a current warning, because this happened to my laptop which gets not frequently updatet.

But as I cant finish the update process...

greets
ayla
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
Re: libexpat1 kaputt?
« Reply #1 on: 2014/11/29, 14:11:56 »
I checked a fully updated 64-bit system and also a 32-bit system, and they both show this:


Code: [Select]
root@imerabox:/# apt-cache policy libexpat1
libexpat1:
  Installed: 2.1.0-6+b3
  Candidate: 2.1.0-6+b3
  Version table:
 *** 2.1.0-6+b3 0
        500 http://ftp.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status


So, unless there is bad news coming in the next debian mirror sync for the U.S., I think the breakage is within your system.    :'(


I looked at
Code: [Select]
apt-cache rdepends libexpat1 and it is obviously a very important package on the system.  I think you have to fix it.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline ayla

  • User
  • Posts: 1.697
Re: libexpat1 kaputt?
« Reply #2 on: 2014/11/29, 14:38:24 »
Quote
...and it is obviously a very important package on the system.  I think you have to fix it.

Yupp :(

As I have the same version installed and the same version available it is most likely within my system (64bit).

 I'm wondering it boots up... Will have a look tonight whether I can fix it.


greets
ayla
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline convbsd

  • User
  • Posts: 92
Re: libexpat1 kaputt?
« Reply #3 on: 2014/11/29, 17:24:03 »
Hi,

I have the same probem here.
It seems it's a dbus problem. I have downgraded dbus and libdbus and seems to be ok.

Greetings
ConvBSD

Online vilde

  • User
  • Posts: 657
Re: libexpat1 kaputt?
« Reply #4 on: 2014/11/29, 17:53:41 »
Hi,

I have the same probem here.
It seems it's a dbus problem. I have downgraded dbus and libdbus and seems to be ok.

Greetings
ConvBSD
Same problem here, and @convbsd, please tell us how do downgrade dbus


Online vilde

  • User
  • Posts: 657
Re: libexpat1 kaputt?
« Reply #6 on: 2014/11/29, 19:20:23 »
I have downgraded dbus and libdbus using:
http://snapshot.debian.org/archive/debian/20141110T222123Z/pool/main/d/dbus/libdbus-1-3_1.8.10-1_amd64.deb
http://snapshot.debian.org/archive/debian/20141110T222123Z/pool/main/d/dbus/dbus_1.8.10-1_amd64.deb
After that I have done a apt-get install -f.
That worked. I have done d-u on three laptops today, all 64 bit but this problem only occurred on one of them.

Offline ayla

  • User
  • Posts: 1.697
Re: libexpat1 kaputt?
« Reply #7 on: 2014/11/29, 19:26:35 »
Thanks convbsd, that did it.

After that I set both packages on hold, then d-u-ed.

Set both packages on unhold and d-u-ed again.

Evrything's fine here again. :)

greets
ayla
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline sunrat

  • User
  • Posts: 310
Re: libexpat1 kaputt?
« Reply #8 on: 2014/12/04, 08:55:14 »
I am still having a problem with libexpat1. I tried to manually install dbus and libdbus-1-3 as suggested although my versions were lower due to several weeks since last d-u. I tried both with dbus and libdbus-1-3 on hold and not held.
Code: [Select]
root@brain:/home/roger/Desktop# dpkg -i libdbus-1-3_1.8.10-1_amd64.deb dbus_1.8.10-1_amd64.deb
(Reading database ... 200304 files and directories currently installed.)
Preparing to unpack libdbus-1-3_1.8.10-1_amd64.deb ...
Unpacking libdbus-1-3:amd64 (1.8.10-1) over (1.8.8-2) ...
Preparing to unpack dbus_1.8.10-1_amd64.deb ...
Unpacking dbus (1.8.10-1) over (1.8.8-2) ...
Setting up libdbus-1-3:amd64 (1.8.10-1) ...
dpkg: dependency problems prevent configuration of dbus:
 dbus depends on libexpat1 (>= 2.0.1); however:
  Package libexpat1:amd64 is not configured yet.

dpkg: error processing package dbus (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.0.2-3) ...
Processing triggers for siduction-dynamic-dms (2014.08.13) ...
Processing triggers for libc-bin (2.19-13) ...
Errors were encountered while processing:
 dbus
root@brain:/home/roger/Desktop# dpkg-reconfigure libexpat1
/usr/sbin/dpkg-reconfigure: libexpat1 is broken or not fully installed
root@brain:/home/roger/Desktop# apt-cache policy libexpat1
libexpat1:
  Installed: 2.1.0-6+b3
  Candidate: 2.1.0-6+b3
  Version table:
 *** 2.1.0-6+b3 0
        500 http://ftp.au.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Offline kalimero

  • User
  • Posts: 45
Re: libexpat1 kaputt?
« Reply #9 on: 2014/12/05, 19:32:59 »
I have the same problem on my Laptop (amd64, multiarch)

I think I have to install libdbus-1-3:i386 Vers. 1.8.10-1 besides  the mentioned  libdbus:amd64 and dbus :

root@siductionbox:/home/heinz/Downloads# dpkg -i libdbus*
dpkg: Warnung: Version 1.8.12-1 des Paketes libdbus-1-3:amd64 wird durch ältere Version 1.8.10-1 ersetzt
(Lese Datenbank ... 303951 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von libdbus-1-3_1.8.10-1_amd64.deb ...
Entpacken von libdbus-1-3:amd64 (1.8.10-1) über (1.8.12-1) ...
dpkg: Fehler beim Bearbeiten des Paketes libdbus-1-3:amd64 (--install):
 Paket libdbus-1-3:amd64 1.8.10-1 kann nicht konfiguriert werden, da libdbus-1-3:i386 in einer anderen Version vorliegt (1.8.12-1)
Fehler traten auf beim Bearbeiten von:
 libdbus-1-3:amd64

But I dont find the old Version. Can anyone tell me where to find the nesseray version?

Thank you.

Kalimero

Offline Santa

  • User
  • Posts: 261
  • siduction's KDE packager
Re: libexpat1 kaputt?
« Reply #10 on: 2014/12/05, 20:22:31 »
But I dont find the old Version. Can anyone tell me where to find the nesseray version?


Enter http://snapshot.debian.org/ and search by binary package name.
Sometimes standing for what you believe means standing alone.

Offline kalimero

  • User
  • Posts: 45
Re: libexpat1 kaputt?
« Reply #11 on: 2014/12/05, 23:14:06 »
I have found the version  libdbus-1-3_1.8.10-1i386.deb on

 http://snapshot.debian.org/archive/debian/20141110T222123Z/pool/main/d/dbus/

and now it seems all ok.

Thanks

Kalimero

Offline sunrat

  • User
  • Posts: 310
Re: libexpat1 kaputt?
« Reply #12 on: 2014/12/05, 23:43:26 »
d-u yesterday seemed to fix this. dbus is now 1.8.12-1. But boot was glacially slow with the same apparent issue as in another thread.