seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/12, 01:35:30


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [fixed] Chromium won't start after upgrade  (Read 2724 times)

0 Members and 1 Guest are viewing this topic.

Offline Millie

  • User
  • Posts: 40
[fixed] Chromium won't start after upgrade
« on: 2015/03/04, 15:45:04 »
I upgraded my LXDE this morning, and afterword, Chromium won't start at all.

I tried from the terminal and got:
Code: [Select]
[0304/073715:FATAL:isolate_holder.cc(70)] Couldn't mmap v8 natives data file
Aborted

Upgraded the following packages:
chromium (40.0.2214.111-1) to 41.0.2272.76-1
gtk2-engines-pixbuf (2.24.25-2) to 2.24.25-3
libgtk2.0-0 (2.24.25-2) to 2.24.25-3
libgtk2.0-common (2.24.25-2) to 2.24.25-3
linux-headers-siduction-686 (3.19-2) to 3.19-3
linux-image-siduction-686 (3.19-2) to 3.19-3
« Last Edit: 2015/03/07, 15:45:26 by musca »

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
Re: Chromium won't start after upgrade
« Reply #1 on: 2015/03/04, 16:39:03 »
Google tells me that error has been seen before.


Not an official siduction recommendation, but FYI I switched from chromium to SRWare Iron some months ago and it is working great.  But enabling pepperflash is a special kubuki dance that you have to do.  Those instructions are here.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline Millie

  • User
  • Posts: 40
Re: Chromium won't start after upgrade
« Reply #2 on: 2015/03/04, 21:19:51 »
Thanks for the info, dibl. It looks like this problem has been around for a while now.

But enabling pepperflash is a special kubuki dance that you have to do.
I don't think I want to put on all that makeup just to install pepperflash. ;D    


I've used Iron on Linux in the past, but I can't remember why I stopped using it. I think I'll take this opportunity and try out the Linux version of Slimjet.


Offline seasons

  • User
  • Posts: 241
Re: Chromium won't start after upgrade
« Reply #4 on: 2015/03/05, 06:26:10 »
I also had Google Chrome installed, so I copied two files from Chrome (natives_blob.bin and snapshot_blob.bin) to /usr/lib/chromium and now it starts.

I don't know exactly what those files are for and whether they could/should be included with chromium
https://chromium.googlesource.com/chromium/src/+/dd97f2b5ff8cbdab0bb9c0fec87d07f2fe2a3b50%5E!/#F0.

Offline Millie

  • User
  • Posts: 40
Re: Chromium won't start after upgrade
« Reply #5 on: 2015/03/05, 15:24:08 »
Well, for now I'm going to avoid upgrading Chromium on my Xfce. I did  install Slimjet on my LXDE and it runs great. Flash is supported without any extra effort. It is, however, based on 40, so I'll have to wait and see what happens when it's updated to base 41.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
Re: Chromium won't start after upgrade
« Reply #6 on: 2015/03/05, 17:05:16 »
Iron seems to lag Chrome development a bit -- it is presently at Ver. 39.0.2100.  And of course there's no package in Debian, although they do package a .deb for downloading from their site.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: Chromium won't start after upgrade
« Reply #7 on: 2015/03/05, 18:22:21 »
hmm - this is sid, a bugreport for it is there, with a possible fix - so just wait and/or use chromium from testing should be sufficient.  Hey, it's sid, things break from time to time, but nothing to see here, move along :D

EDIT: FTBFS (fail to build from source) after 1h build time on a decent buildmachine - bug in debian packaging, the sources are ok - so i lost the interest to fix this.
« Last Edit: 2015/03/05, 19:54:47 by melmarker »
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline Millie

  • User
  • Posts: 40
Re: Chromium won't start after upgrade
« Reply #8 on: 2015/03/06, 00:08:04 »
Iron seems to lag Chrome development a bit -- it is presently at Ver. 39.0.2100.  And of course there's no package in Debian, although they do package a .deb for downloading from their site.

I did go look at the Iron website, but found they don't support 32bit for Linux any more, and I run 32bit.

This is on their "New Iron-Version: 39.0.2100.0 Stable for Linux" page posted back in January:
"We create no 32-Bit Versions due to the marginal usage. The downloads link to an older version."

So that means at best 38 for Linux 32bit. Debian stable is still 37 and probably not going to change until Jessie goes stable.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: Chromium won't start after upgrade
« Reply #9 on: 2015/03/06, 00:16:07 »
Suggestion: Wait for a fixed build - use chromium from testing until available :)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Chromium won't start after upgrade
« Reply #10 on: 2015/03/06, 13:03:03 »
Hello,

fixed chromium 41.0.2272.76-2 is in incoming and will enter the debian repo with next sync (around 16:30h UTC, i think).

greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline ajavibp

  • User
  • Posts: 86
    • The website of the association where I collaborate.
Re: Chromium won't start after upgrade
« Reply #11 on: 2015/03/06, 17:05:32 »
It's finally fixed!  ;D

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.781
    • g-com.eu
Re: Chromium won't start after upgrade
« Reply #12 on: 2015/03/06, 17:43:33 »
HURRA! Das Internet geht wieder 8)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.931
    • Land of the Buckeye
Re: Chromium won't start after upgrade
« Reply #13 on: 2015/03/06, 19:29:07 »
HURRA! Das Internet geht wieder 8)


Wie wunderbar!  Das Internet hat die chromium-software repariert!   :o
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline Millie

  • User
  • Posts: 40
Re: Chromium won't start after upgrade
« Reply #14 on: 2015/03/06, 20:03:52 »
Thanks musca! :)  I just installed and it runs perfectly.