seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/28, 08:28:40


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] dependencies problem with xserver-xorg  (Read 19644 times)

0 Members and 1 Guest are viewing this topic.

Offline ayla

  • User
  • Posts: 1.700
Re: dependencies problem with xserver-xorg
« Reply #45 on: 2015/05/09, 17:08:57 »
Here on my system (see below) it's safe, as long as the xserver is meant.

But there is another problem at the moment, one should read this thread also:

http://forum.siduction.org/index.php?topic=5513.msg45032#msg45032
« Last Edit: 2015/05/09, 17:12:26 by ayla »
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline Lanzi

  • User
  • Posts: 1.622
Re: dependencies problem with xserver-xorg
« Reply #46 on: 2015/05/09, 17:37:11 »
thanks to you both... I think I will wait :-)
 ;D ;D ;D

Offline vayu

  • User
  • Posts: 204
Re: dependencies problem with xserver-xorg
« Reply #47 on: 2015/05/09, 19:04:06 »
is du possible today for intel-graphics users? is it safe?

I did one about four hours ago.  du broke with what I imagine are unrelated libsane problems. It completed with no problems after I removed those and some of their librares.

Offline drb

  • User
  • Posts: 160
Re: dependencies problem with xserver-xorg
« Reply #48 on: 2015/05/09, 22:52:27 »
intel was fine yesterday and it looks like there's a libsane-common update but will wait for report that it's OK

Offline vayu

  • User
  • Posts: 204
Re: dependencies problem with xserver-xorg
« Reply #49 on: 2015/05/09, 23:41:30 »
intel was fine yesterday and it looks like there's a libsane-common update but will wait for report that it's OK

I went after and reinstalled all the sane xsane libsane stuff I had uninstalled and they are now installed fine. My du is currently up to date with no known problems.
« Last Edit: 2015/05/09, 23:47:59 by vayu »

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
[solved: no more] dependencies problem with xserver-xorg
« Reply #50 on: 2015/05/10, 02:37:26 »

yes, xorg transition ist done, mostly.

The package xserver-xorg-video-modesetting is obsolete and now part of the xserver-xorg-core, which replaces it.

Don't forget to reinstall any lost drivers, all of them should be installable again.

greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline wannek3

  • User
  • Posts: 53
Re: [solved] dependencies problem with xserver-xorg
« Reply #51 on: 2015/05/11, 10:48:59 »
Hi all,

since i went into trouble before knowing from this thread here last week, i tried to resolve the broken intel server today.

After a complete d-u from console, and also fetching fbdev and vesa, startx complained about missing /usr/bin/X. Which is correct, it's missing there. But there is a /usr/bin/Xorg. After appropriately changing the startx-script, kdm came back. I'm fine now.

Wanted to let you know, in case this issue arises for anybody else.

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.331
Re: [solved] dependencies problem with xserver-xorg
« Reply #52 on: 2015/05/11, 10:51:45 »
apt-get install xserver-xorg


then you have /usr/bin/X


And btw, for intel, you need xserver-xorg-video-inel.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline wannek3

  • User
  • Posts: 53
Re: [solved] dependencies problem with xserver-xorg
« Reply #53 on: 2015/05/11, 17:34:26 »
Thanks, Towo, that with the intel i knew; the xserver-xorg got me indeed now the missing X :-)