seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/12, 01:53:37


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [workaround] hpaio and sane not working after d-u  (Read 1131 times)

0 Members and 1 Guest are viewing this topic.

Offline glimfindel

  • User
  • Posts: 5
After the last dist-upgrade of my 64Bit system this week I encountered that my HP 5520 was no longer supported by sane.
Versions:

libsane-hpaio 3.14.6-1+b3    amd64
sane  1.0.14-11   amd64

While printing was no problem I guessed this would not be a hardware or a connection problem (USB).
A "scanimage -L" told me that there were no devices found, so did xsane.
Using strace while starting scanimage I found those line:

open("/usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)

The libsane-hpaio package places the libs only in  /usr/lib/sane/libsane-hpaio.so.1.0.0, so sane is not able to find it.
Workaround here is to place a symlink in usr/lib/x86_64-linux-gnu/sane/

ln -s /usr/lib/sane/libsane-hpaio.so.1.0.0 /usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1

Afterwards sanning worked again perfectly.

Best regards

Burkhard
« Last Edit: 2015/11/08, 14:39:02 by glimfindel »

Offline harley-peter

  • User
  • Posts: 798
Re: [workaround] hpaio and sane not working after d-u
« Reply #1 on: 2015/11/11, 17:58:39 »
Same problem here after du.
Thank's for the workaround.

Offline jure

  • User
  • Posts: 520
Gruss Juergen

Offline CCarpenter

  • User
  • Posts: 195
    • http://www.greenvalleyranchschwand.de
Re: [workaround] hpaio and sane not working after d-u
« Reply #3 on: 2015/11/14, 19:40:15 »
Kann bug nicht bestätigen!

Nach DU von gerade eben:

Code: [Select]
cc@ccsboch:~$ scanimage -L
device `hpaio:/net/HP_LaserJet_Professional_M1217nfw_MFP?ip=192.168.0.29' is a Hewlett-Packard HP_LaserJet_Professional_M1217nfw_MFP all-in-one

Und ist funktional.

libsane-hpaio:
  Installiert:           3.14.6-1+b3
  Installationskandidat: 3.14.6-1+b3
  Versionstabelle:
 *** 3.14.6-1+b3 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
        500 http://ftp.fr.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status

sane:
  Installiert:           1.0.14-11
  Installationskandidat: 1.0.14-11
  Versionstabelle:
 *** 1.0.14-11 0
        500 http://http.debian.net/debian/ unstable/main amd64 Packages
        500 http://ftp.fr.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Offline jure

  • User
  • Posts: 520
Re: [workaround] hpaio and sane not working after d-u
« Reply #4 on: 2015/11/14, 19:43:30 »
for me solved with the the latest du
Code: [Select]
apt-cache policy libsane
libsane:
  Installiert:           1.0.25-2
  Installationskandidat: 1.0.25-2

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804240
« Last Edit: 2015/11/14, 19:47:25 by jure »
Gruss Juergen