seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/21, 02:24:26


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] du fails - qml-module-org-kde-extensionplugin_5.16.0-1  (Read 8273 times)

0 Members and 1 Guest are viewing this topic.

Offline jure

  • User
  • Posts: 520
I try to dist-upgrade for my kdenext system, but it fails with ..

Code: [Select]
apt-get dist-upgrade
Die folgenden Pakete werden ENTFERNT(removed):
   libkactivities-bin (5.15.0-siduction1)
   libkf5baloo1 (5.9.2-siduction1)
   libkf5balooxapian1 (5.9.2-siduction1)
   libkpeople3 (0.2.2-2)
   libktpcommoninternalsprivate7 (0.8.1-90r1)
   libktpmodelsprivate7 (0.8.1-90r1)
   libktpwidgetsprivate7 (0.8.1-90r1)
   qml-module-org-kde-activities (5.15.0-siduction1)
Die folgenden NEUEN Pakete werden installiert (installed):
   catdoc (0.94.4-1.1)
   fonts-noto-hinted (20151116~dfsg-1)
   libkf5gpgmepp5 (15.08.1-1)
Die folgenden Pakete sind zurückgehalten worden (hold):
   libgnutls-deb0-28:i386 (3.3.18-1 => 3.3.19-1)
   libgraphicsmagick3 (1.3.20-3+deb8u1 => 1.3.21-3)
Die folgenden Pakete werden aktualisiert (Upgrade):
   apt (1.1.2 => 1.1.3)
   apt-utils (1.1.2 => 1.1.3)
   baloo (5.15.0+-siduction1 => 5.16.0-1)
   baloo-kf5 (5.15.0+-siduction1 => 5.16.0-1)
   binutils (2.25.90.20151125-1 => 2.25.90.20151125-2)
   cpp (5.2.1-6 => 5.2.1-8)
   cpp-5 (5.2.1-26 => 5.2.1-27)
   cups (2.1.0-6 => 2.1.0-7)
   cups-bsd (2.1.0-6 => 2.1.0-7)
   cups-client (2.1.0-6 => 2.1.0-7)
   cups-common (2.1.0-6 => 2.1.0-7)
   cups-core-drivers (2.1.0-6 => 2.1.0-7)
   cups-daemon (2.1.0-6 => 2.1.0-7)
   cups-filters (1.1.0-1+b1 => 1.2.0-1)
   cups-filters-core-drivers (1.1.0-1+b1 => 1.2.0-1)
   cups-ppdc (2.1.0-6 => 2.1.0-7)
   cups-server-common (2.1.0-6 => 2.1.0-7)
   debian-keyring (2015.08.13 => 2015.11.30)
   frameworkintegration (5.15.0-siduction1.1 => 5.16.0-1)
   g++ (5.2.1-6 => 5.2.1-8)
   g++-5 (5.2.1-26 => 5.2.1-27)
   gcc (5.2.1-6 => 5.2.1-8)
   gcc-5 (5.2.1-26 => 5.2.1-27)
   gcc-5-base (5.2.1-26 => 5.2.1-27)
   gcc-5-base:i386 (5.2.1-26 => 5.2.1-27)
   kactivities (5.15.0-siduction1 => 5.16.0-1)
   kded5 (5.15.0-siduction1 => 5.16.0-1)
   kdoctools5 (5.15.0-siduction1 => 5.16.0-1)
   kinit (5.15.0-siduction1 => 5.16.0-1)
   kio (5.15.0-siduction1.1 => 5.16.0-1)
   kpackagetool5 (5.15.0-siduction1 => 5.16.0-1)
   kross (5.15.0-siduction1 => 5.16.0-1)
   ktexteditor-data (5.15.0-siduction1 => 5.16.0-1)
   ktexteditor-katepart (5.15.0-siduction1 => 5.16.0-1)
   lame (3.99.5+repack1-9 => 3.99.5+repack1-9+b1)
   less (458-3 => 458-3+b1)
   libapt-inst2.0 (1.1.2 => 1.1.3)
   libapt-pkg5.0 (1.1.2 => 1.1.3)
   libasan2 (5.2.1-26 => 5.2.1-27)
   libatomic1 (5.2.1-26 => 5.2.1-27)
   libcaca0 (0.99.beta19-2 => 0.99.beta19-2+b1)
   libcc1-0 (5.2.1-26 => 5.2.1-27)
   libcdio-cdda1 (0.83-4.2 => 0.83-4.2+b1)
   libcdio-paranoia1 (0.83-4.2 => 0.83-4.2+b1)
   libcdio13 (0.83-4.2 => 0.83-4.2+b1)
   libcilkrts5 (5.2.1-26 => 5.2.1-27)
   libcups2 (2.1.0-6 => 2.1.0-7)
   libcupscgi1 (2.1.0-6 => 2.1.0-7)
   libcupsfilters1 (1.1.0-1+b1 => 1.2.0-1)
   libcupsimage2 (2.1.0-6 => 2.1.0-7)
   libcupsmime1 (2.1.0-6 => 2.1.0-7)
   libcupsppdc1 (2.1.0-6 => 2.1.0-7)
   libcwidget3v5 (0.5.17-4 => 0.5.17-4+b1)
   libdebconfclient0 (0.198 => 0.199)
   libfontembed1 (1.1.0-1+b1 => 1.2.0-1)
   libgcc-5-dev (5.2.1-26 => 5.2.1-27)
   libgcc1 (5.2.1-26 => 5.2.1-27)
   libgcc1:i386 (5.2.1-26 => 5.2.1-27)
   libgcj-common (4.9.3-6 => 4.9.3-8)
   libgfortran3 (5.2.1-26 => 5.2.1-27)
   libgomp1 (5.2.1-26 => 5.2.1-27)
   libimage-exiftool-perl (10.05-1 => 10.07-1)
   libiso9660-8 (0.83-4.2 => 0.83-4.2+b1)
   libitm1 (5.2.1-26 => 5.2.1-27)
   libjs-sphinxdoc (1.3.1-8 => 1.3.2-1)
   libkf5activities5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5archive5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5attica5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5auth-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5auth5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5baloo5 (5.15.0+-siduction1 => 5.16.0-1)
   libkf5balooengine5 (5.15.0+-siduction1 => 5.16.0-1)
   libkf5bookmarks-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5bookmarks5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5codecs-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5codecs5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5completion-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5completion5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5config-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5config-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5configcore5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5configgui5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5configwidgets-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5configwidgets5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5coreaddons-bin-dev (5.15.0-siduction1 => 5.16.0-1)
   libkf5coreaddons-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5coreaddons5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5crash5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5dbusaddons-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5dbusaddons-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5dbusaddons5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5declarative-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5declarative5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5dnssd-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5dnssd5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5emoticons-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5emoticons-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5emoticons5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5filemetadata-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5filemetadata-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5filemetadata3 (5.15.0-siduction1 => 5.16.0-1)
   libkf5globalaccel-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5globalaccel-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5globalaccel5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5globalaccelprivate5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5guiaddons5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5i18n-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5i18n5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5iconthemes-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5iconthemes-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5iconthemes5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5idletime5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5itemmodels5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5itemviews-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5itemviews5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5jobwidgets-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5jobwidgets5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5js5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5jsembed-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5jsembed5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5kcmutils-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5kcmutils5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5kdelibs4support-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5kdelibs4support5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5kdelibs4support5-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5khtml-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5khtml-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5khtml5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5kiocore5 (5.15.0-siduction1.1 => 5.16.0-1)
   libkf5kiofilewidgets5 (5.15.0-siduction1.1 => 5.16.0-1)
   libkf5kiontlm5 (5.15.0-siduction1.1 => 5.16.0-1)
   libkf5kiowidgets5 (5.15.0-siduction1.1 => 5.16.0-1)
   libkf5krosscore5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5krossui5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5modemmanagerqt6 (5.15.0-siduction1 => 5.16.0-1)
   libkf5networkmanagerqt6 (5.15.0-siduction1 => 5.16.0-1)
   libkf5newstuff-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5newstuff5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5notifications-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5notifications5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5notifyconfig-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5notifyconfig5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5package-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5package5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5parts-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5parts5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5people-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5people5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5peoplebackend5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5peoplewidgets5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5plasma5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5plasmaquick5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5plotting5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5pty-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5pty5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5quickaddons5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5runner5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5service-bin (5.15.0+-siduction1 => 5.16.0-1)
   libkf5service-data (5.15.0+-siduction1 => 5.16.0-1)
   libkf5service5 (5.15.0+-siduction1 => 5.16.0-1)
   libkf5solid-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5solid5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5solid5-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5sonnet5-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5sonnetcore5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5sonnetui5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5style5 (5.15.0-siduction1.1 => 5.16.0-1)
   libkf5su-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5su-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5su5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5texteditor5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5textwidgets-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5textwidgets5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5threadweaver5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5unitconversion-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5unitconversion5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5wallet-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5wallet-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5wallet5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5webkit5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5widgetsaddons-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5widgetsaddons5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5windowsystem-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5windowsystem5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5xmlgui-bin (5.15.0-siduction1 => 5.16.0-1)
   libkf5xmlgui-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5xmlgui5 (5.15.0-siduction1 => 5.16.0-1)
   libkf5xmlrpcclient-data (5.15.0-siduction1 => 5.16.0-1)
   libkf5xmlrpcclient5 (5.15.0-siduction1 => 5.16.0-1)
   libkwalletbackend5-5 (5.15.0-siduction1 => 5.16.0-1)
   liblsan0 (5.2.1-26 => 5.2.1-27)
   libmpx0 (5.2.1-26 => 5.2.1-27)
   libpdf-api2-perl (2.023-1 => 2.025-1)
   libqt4-dbus (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-declarative (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-designer (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-help (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-network (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-opengl (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-qt3support (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-script (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-scripttools (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-sql (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-sql-mysql (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-sql-sqlite (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-svg (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-test (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-xml (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqt4-xmlpatterns (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqtcore4 (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqtdbus4 (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libqtgui4 (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   libquadmath0 (5.2.1-26 => 5.2.1-27)
   libstdc++-5-dev (5.2.1-26 => 5.2.1-27)
   libstdc++6 (5.2.1-26 => 5.2.1-27)
   libstdc++6:i386 (5.2.1-26 => 5.2.1-27)
   libtsan0 (5.2.1-26 => 5.2.1-27)
   libubsan0 (5.2.1-26 => 5.2.1-27)
   libwine:i386 (1.8~rc1-1 => 1.8~rc2-1)
   nano (2.4.2-1 => 2.4.2-1+b1)
   plasma-framework (5.15.0-siduction1 => 5.16.0-1)
   python-imaging (2.9.0-1 => 3.0.0-1)
   python-pil (2.9.0-1+b1 => 3.0.0-1)
   qdbus (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   qml-module-org-kde-draganddrop (5.15.0-siduction1 => 5.16.0-1)
   qml-module-org-kde-extensionplugin (5.15.0-siduction1 => 5.16.0-1)
   qml-module-org-kde-kcoreaddons (5.15.0-siduction1 => 5.16.0-1)
   qml-module-org-kde-kio (5.15.0-siduction1 => 5.16.0-1)
   qml-module-org-kde-kquickcontrols (5.15.0-siduction1 => 5.16.0-1)
   qml-module-org-kde-kquickcontrolsaddons (5.15.0-siduction1 => 5.16.0-1)
   qml-module-org-kde-kwindowsystem (5.15.0-siduction1 => 5.16.0-1)
   qml-module-org-kde-solid (5.15.0-siduction1 => 5.16.0-1)
   qtcore4-l10n (4.8.7+dfsg-4 => 4.8.7+dfsg-5)
   qtdeclarative5-kf5declarative (5.15.0-siduction1 => 5.16.0-1)
   qtdeclarative5-kf5solid (5.15.0-siduction1 => 5.16.0-1)
   wine (1.8~rc1-1 => 1.8~rc2-1)
   wine32:i386 (1.8~rc1-1 => 1.8~rc2-1)
237 aktualisiert, 3 neu installiert, 8 zu entfernen und 2 nicht aktualisiert.

Code: [Select]
Vorbereitung zum Entpacken von .../qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb ...
Entpacken von qml-module-org-kde-extensionplugin:amd64 (5.16.0-1) über (5.15.0-siduction1) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb (--unpack):
 Versuch, »/usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/activities/libkactivitiesextensionplugin.so« zu überschreiben, welches auch in Paket qml-module-org-kde-activities:amd64 5.15.0-siduction1 ist
Vorbereitung zum Entpacken von .../kactivities_5.16.0-1_amd64.deb ...
Entpacken von kactivities (5.16.0-1) über (5.15.0-siduction1) ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb
Log ended: 2015-12-01  10:17:19

Code: [Select]
LANG=C apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libkf5activities5 qml-module-org-kde-extensionplugin
The following packages will be REMOVED:
  qml-module-org-kde-activities
The following packages will be upgraded:
  libkf5activities5 qml-module-org-kde-extensionplugin
2 upgraded, 0 newly installed, 1 to remove and 210 not upgraded.
19 not fully installed or removed.
Need to get 0 B/119 kB of archives.
After this operation, 3072 B disk space will be freed.
Do you want to continue? [Y/n] y
Lese Changelogs... Fertig
apt-extracttemplates: relocation error: apt-extracttemplates: symbol _Z16ParseCommandLineR11CommandLine7APT_CMDPKP13ConfigurationPP9pkgSystemiPPKc, version APTPRIVATE_0.0 not defined in file libapt-private.so.0.0 with link time reference
debconf: apt-extracttemplates failed: No such file or directory
(Reading database ... 275631 files and directories currently installed.)
Preparing to unpack .../qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb ...
Unpacking qml-module-org-kde-extensionplugin:amd64 (5.16.0-1) over (5.15.0-siduction1) ...
dpkg: error processing archive /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/activities/libkactivitiesextensionplugin.so', which is also in package qml-module-org-kde-activities:amd64 5.15.0-siduction1
Errors were encountered while processing:
 /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Last Edit: 2015/12/06, 17:45:36 by jure »
Gruss Juergen

Offline hendrikL

  • User
  • Posts: 342
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #1 on: 2015/12/01, 11:17:38 »
did you tried "aptitude dist-upgrade" ?
IIRC that worked for me.

Offline clubex

  • User
  • Posts: 265
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #2 on: 2015/12/01, 12:34:12 »
jure:
Same for me
Code: [Select]
The following packages have unmet dependencies:
kactivities: Dependa: libkf5activities (>+5.16.0) but 5.15.0-siduction1 is to be installed
qml-module-org-kde-extensionplugin: Depends: libkf5activities (=5.16.0-1) but 5.15.0-siduction1 is to be installed.

Neither apt-get nor aptitude dist-upgrade will fix it.



Offline hendrikL

  • User
  • Posts: 342
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #3 on: 2015/12/01, 12:48:43 »
So you have the option:
1) to wait, till santa has the time to update all things
2) did you chosse in aptitude to downgrade that package?
sorry wrong.
did aptitude offer some other way to upgrade?

I took a look to the apt history and term log and it works with aptitude on my system.
« Last Edit: 2015/12/01, 12:52:57 by hendrikL »

Offline jure

  • User
  • Posts: 520
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #4 on: 2015/12/01, 15:55:08 »
I am at work now, so I will check it in the evening and I never used aptitude .....
Gruss Juergen

Offline jure

  • User
  • Posts: 520
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #5 on: 2015/12/01, 19:39:31 »
jure:
Same for me
Code: [Select]
The following packages have unmet dependencies:
kactivities: Dependa: libkf5activities (>+5.16.0) but 5.15.0-siduction1 is to be installed
qml-module-org-kde-extensionplugin: Depends: libkf5activities (=5.16.0-1) but 5.15.0-siduction1 is to be installed.

Neither apt-get nor aptitude dist-upgrade will fix it.

yes and Santa is the maintainer of the package and should/will fix it - please ;-)
Code: [Select]
apt-cache show qml-module-org-kde-activities
Package: qml-module-org-kde-activities
Source: kactivities-kf5
Version: 5.15.0-siduction1
Architecture: amd64
Maintainer: José Manuel Santamaría Lema <panfaust@gmail.com>
Gruss Juergen

Offline mylo

  • User
  • Posts: 921
Broken packages
« Reply #6 on: 2015/12/02, 21:11:04 »
I have some unfulfilled depends, which I experienced last time many years ago:

Code: [Select]
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 kactivities : Hängt ab von: libkf5activities5 (>= 5.16.0) aber 5.15.0-siduction1 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
root@tuap:~# apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
The following additional packages will be installed:
  libkf5activities5 qml-module-org-kde-extensionplugin
Die folgenden Pakete werden ENTFERNT:
  qml-module-org-kde-activities
Die folgenden Pakete werden aktualisiert (Upgrade):
  libkf5activities5 qml-module-org-kde-extensionplugin
2 aktualisiert, 0 neu installiert, 1 zu entfernen und 192 nicht aktualisiert.
6 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 119 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 3.072 B Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] j
Lese Changelogs... Fertig
(Lese Datenbank ... 249516 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb ...
Entpacken von qml-module-org-kde-extensionplugin:amd64 (5.16.0-1) über (5.15.0-siduction1) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb (--unpack):
 Versuch, »/usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/activities/libkactivitiesextensionplugin.so« zu überschreiben, welches auch in Paket qml-module-org-kde-activities:amd64 5.15.0-siduction1 ist
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/qml-module-org-kde-extensionplugin_5.16.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@

apt-get -f did not help. So is waiting just the right way to become consistent again?
Or can I do something else?
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline jure

  • User
  • Posts: 520
Re: Broken packages
« Reply #7 on: 2015/12/02, 21:27:30 »
Hi mylo,

same her ->  http://forum.siduction.org/index.php?topic=5920.0 -  but not solved until now ...
Gruss Juergen

Offline mylo

  • User
  • Posts: 921
Re: Broken packages
« Reply #8 on: 2015/12/02, 21:33:59 »
Oh yes sorry. Did not see that. Forum Admin, can you please merge threads or close mine?
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.394
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #9 on: 2015/12/02, 22:32:23 »
merged




Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.954
    • Land of the Buckeye
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #10 on: 2015/12/02, 22:38:10 »
I got impatient and tried a d-u before this was resolved.  If you follow the apt dependency errors, and use

Code: [Select]
dpkg -r xxxpackage
you can get back to a fully upgraded and usable system in about 10 minutes.  Basically you remove plasma-desktop, plasma-workspace kde-standard (if you have it), kinfocenter, sddm-theme-breeze (if you have it) and remove the two qml-module-org-kde-xxx packages from the /var/apt archives, and then you can run the d-u on what is left and it will go through with one

Code: [Select]
apt-get -f install

Then you can install plasma-desktop and the others and get back to a fully functional Kf5 desktop.
« Last Edit: 2015/12/02, 23:00:18 by dibl »
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline mylo

  • User
  • Posts: 921
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #11 on: 2015/12/02, 23:47:01 »
thanks for that procedure. Other opinions? Is waiting an alternative?
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline clubex

  • User
  • Posts: 265
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #12 on: 2015/12/02, 23:53:45 »
dibl:
I've just got fed up waiting and did the same. After the du I reinstalled plasma-desktop, plasma-workspace and sddm-theme-breeze. Everything seems OK at the moment and even seems to be a lot more stable than before.

Offline jure

  • User
  • Posts: 520
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #13 on: 2015/12/03, 10:06:41 »
I think a new version (5.16.0-1)  of "qml-module-org-kde-activities" is still missing, most the other packages are upgradable from 5.15.0-siduction1 to 5.16.0-1 (with kdenext)

Quote
LANG=C apt-cache policy qml-module-org-kde-activities   libkf5activities5   qml-module-org-kde-extensionplugin
qml-module-org-kde-activities:
  Installed: 5.15.0-siduction1
  Candidate: 5.15.0-siduction1

  Version table:
 *** 5.15.0-siduction1 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libkf5activities5:
  Installed: 5.15.0-siduction1
  Candidate: 5.16.0-1

  Version table:
     5.16.0-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 5.15.0-siduction1 500
        500 http://packages.siduction.org/kdenext unstable/main amd64 Packages
        100 /var/lib/dpkg/status
qml-module-org-kde-extensionplugin:
  Installed: 5.15.0-siduction1
  Candidate: 5.16.0-1

  Version table:
     5.16.0-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
 *** 5.15.0-siduction1 500
Gruss Juergen

Offline drb

  • User
  • Posts: 160
Re: du fails - qml-module-org-kde-extensionplugin_5.16.0-1
« Reply #14 on: 2015/12/03, 10:54:11 »
I got impatient and tried a d-u before this was resolved.  If you follow the apt dependency errors, and use

Code: [Select]
dpkg -r xxxpackage
you can get back to a fully upgraded and usable system in about 10 minutes.  Basically you remove plasma-desktop, plasma-workspace kde-standard (if you have it), kinfocenter, sddm-theme-breeze (if you have it) and remove the two qml-module-org-kde-xxx packages from the /var/apt archives, and then you can run the d-u on what is left and it will go through with one

Code: [Select]
apt-get -f install

Then you can install plasma-desktop and the others and get back to a fully functional Kf5 desktop.

@dibl - are you still using kdenext after these actions?

My current (kdenext) remove list is :

Code: [Select]
The following packages will be REMOVED:
   kde-full (92+siduction1.7)
   kde-plasma-desktop (92+siduction1.7)
   kde-plasma-netbook (92+siduction1.7)
   kde-standard (92+siduction1.7)
   kde-workspace (5.4.2-siduction2)
   kde-workspace-bin (5.4.2-siduction1)                                                                                                                                                       
   kde-workspace-data (5.4.2-siduction2)                                                                                                                                                     
   kdebase-workspace-bin (4.11.22-3)                                                                                                                                                         
   klipper (5.4.2-siduction2)                                                                                                                                                                 
   libkactivities-bin (5.15.0-siduction1)                                                                                                                                                     
   libkf5baloo1 (5.9.2-siduction1)                                                                                                                                                           
   libkf5balooxapian1 (5.9.2-siduction1)                                                                                                                                                     
   plasma-desktopthemes-artwork (15.04.0-siduction0.4)